bluetooth

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
luzzo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 508
Iscrizione: giovedì 3 marzo 2005, 9:41

bluetooth

Messaggio da luzzo » sabato 10 dicembre 2005, 15:35

Mi è sempre funzionato perfettamente il collegamento gprs tramite rfcomm modificando semplicemente il file /etc/bluetooth/rfcomm.conf e inserendo l'indirizzo del cellulare (trovato con hcitool) e mettendolo sul canale 1.
Ieri ho dovuto usarlo anche nella partizione windows e dopo qualche peripezia sono riuscito a configurarlo anche li.
Tornando in ubuntu e dando il classico pon gprs sul monitor del telefono appare di sfuggita che si sta collegando e poi niente...
A questo punto rfcomm mi da come risposta rfcomm0: indirizzo del cel e channel 1 closed
Non riesco a capire cosa possa essere successo perchè i parametri del cellulare non li ho toccati nel configurarlo per windows...

Avatar utente
LinuxCore
Prode Principiante
Messaggi: 76
Iscrizione: giovedì 26 gennaio 2006, 21:59

Re: bluetooth

Messaggio da LinuxCore » lunedì 30 gennaio 2006, 2:51

ciao luzzo :)

io ho lo stesso identico problema, con l'unica differenza che te sei riuscito già a collegarti io ancora no, e non iresco a capire il perchè, nonostante abbia fatto tutta la configurazione per bene, non c'è modo di far partire il collegamento.
E' capitato anche a me di imbattermi in
Luzzo ha scritto ha scritto:... appare di sfuggita che si sta collegando e poi niente...
A questo punto rfcomm mi da come risposta rfcomm0: indirizzo del cel e channel 1 closed
per liberare il canale basta riavviare il bluez con il commando =>

Codice: Seleziona tutto

sudo /etc/init.d/bluez-utils restart
per poi rieffettura la connessione al canale 0 con => sudo rfcomm 0 adress 1

spero di esser stato utile

ciao
Powered by Sony Vaio Fe28H + Ubuntu Gutsy + Compiz Fusion 6

Avatar utente
luzzo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 508
Iscrizione: giovedì 3 marzo 2005, 9:41

Re: bluetooth

Messaggio da luzzo » lunedì 30 gennaio 2006, 23:15

A me ora va tutto bene! Io ho fatto semplicemente così:
- hcitool scan (e trovi l'indirizzo del tuo telefono)
- sudo gedit /etc/bluetooth/rfcomm.conf e aggiungi o decommenti (togli #) alle righe:

rfcomm0 {
bind yes;
device xx:xx:xx:xx:xx:xx; (qui copi l'indirizzo del tuo telefono)
channel 1;
}

- sudo pppconfig e crei una nuova connessione con utente e pass vuoti o quello che vuoi, numero di telefono *99#
- pon nome_connessione per avviare e poff nome_connessione per sconnettere

P.S. prima di fare l'effettiva connessione la prima volta ho dovuto associare il computer dal telefono altrimenti dava il permesso alla connessione

Ciao

Avatar utente
LinuxCore
Prode Principiante
Messaggi: 76
Iscrizione: giovedì 26 gennaio 2006, 21:59

Re: bluetooth

Messaggio da LinuxCore » martedì 31 gennaio 2006, 1:02

solo oggi ho provato ad usare pppconfig, ora vedo se riesco a risolvere!!!

Mi stai dicendo che quindi se non fai rilevare al cell il pc ti nega la connessione? strano però, perchè io l'ho fatto...

vabbè farò avere novità.
Powered by Sony Vaio Fe28H + Ubuntu Gutsy + Compiz Fusion 6

Avatar utente
LinuxCore
Prode Principiante
Messaggi: 76
Iscrizione: giovedì 26 gennaio 2006, 21:59

Re: bluetooth

Messaggio da LinuxCore » martedì 31 gennaio 2006, 14:34

niente da fare, continuo ad avere risultati negativi, ogni volta che tento di connettermi sia con pppd che con wmdial (anche usando gnome-ppp come gui) niente da fare.. sempre solito msg => " Connessione rifiutata" e da quanto ho capito linux con tutta la config che è stata fatta per il bt e gprs, rileva il cell, ma non riesce a vederlo come modem.

vi prego qualcuno mi aiuti perchè non riesco a capire..

Ho postato pure qui il problema ma ancora nessuna risposta :( => http://forum.ubuntu-it.org/viewtopic.ph ... 3#msg40003
Powered by Sony Vaio Fe28H + Ubuntu Gutsy + Compiz Fusion 6

Avatar utente
luzzo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 508
Iscrizione: giovedì 3 marzo 2005, 9:41

Re: bluetooth

Messaggio da luzzo » martedì 31 gennaio 2006, 15:21

Il numero *99# è per i nokia se non sbaglio... magari è per quello che non va. Prova a cercare il numero giusto per il tuo telefono

Avatar utente
LinuxCore
Prode Principiante
Messaggi: 76
Iscrizione: giovedì 26 gennaio 2006, 21:59

Re: bluetooth

Messaggio da LinuxCore » mercoledì 1 febbraio 2006, 14:12

mmm non è un problema di numero, ma del canale rfcomm, appena risolvo farò sapere qualcosa..  ;)
Powered by Sony Vaio Fe28H + Ubuntu Gutsy + Compiz Fusion 6

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: domes, liviux00 e 9 ospiti