problemi con la connessione alice adsl

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
barbablu
Prode Principiante
Messaggi: 12
Iscrizione: giovedì 26 gennaio 2006, 11:00
Località: san giovanni in persiceto BO

problemi con la connessione alice adsl

Messaggio da barbablu » lunedì 30 gennaio 2006, 9:13

salve a tutti,
premetto che sono un novizio di ubuntu e che arrivo da windowsXP perciò la mia esperienza con la riga di comando è limitata.
Ho qualche reminiscenza di ms-dos 6 nonchè di comandi con i mitici commodore vic 20 e 64, ma in generale avendo sempre utilizzato le finestre attualmente ho "perso la manualità" che spero, con l'andare del tempo, mi ritorni e mi faccia tornare l'elasticità di una volta.

problema:
ho un modem adsl usb trust 235A speedlink che sono riuscito a far funzionare grazie alla guida di Dany e spulciando tra il forum: ora le lucine sono accese!

ho configurato i files pap-secrets, chap secrets e resolv.conf con i DNS che mi ha dato l'assistenza tecnica di alice: 212.216.112.112 e 212.216.172.62.

giuro che sono rimasto ore sul forum e le ho provate tutte pur di cavarmela da solo, ma sono veramente esausto.

quando do il comando pppd, ubuntu mi dice che il file pppoatm.so è caricato, ma se avvio firefox col ca**o che si collega.
ho provato decine di combinazioni con vari DNS di Alice che ho trovato in giro su internet ma il risultato è sempre lo stesso.

la versione di ubuntu che ho installato è la 5.10 del sito in italiano.

vi ringrazio se mi vorrete aiutare e anche se non....
ciao!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

barbablu
Prode Principiante
Messaggi: 12
Iscrizione: giovedì 26 gennaio 2006, 11:00
Località: san giovanni in persiceto BO

Re: problemi con la connessione alice adsl

Messaggio da barbablu » lunedì 30 gennaio 2006, 9:41

...ho configurato anche il file options...naturalmente...

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 10:55

http://forum.ubuntu-it.org/viewtopic.ph ... msg38161ci sono riuscito
ho messo ip statico
via http nelle impostazioni del router ho dato il permesso al pc (ho permesso ip computer) nella pagina lan client
ho editato il file /etc/resolv.conf e ho dato l'ip del pc e ho messo l'ip del pc e i DNS 212.216.112.112 e 212.216.172.62 e funziona
e vai di ubuntu

sto scrivendo da ubuntu
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

barbablu
Prode Principiante
Messaggi: 12
Iscrizione: giovedì 26 gennaio 2006, 11:00
Località: san giovanni in persiceto BO

Re: problemi con la connessione alice adsl

Messaggio da barbablu » lunedì 30 gennaio 2006, 11:27

dove trovo l'IP del mio PC?
e poi lo aggiungo in resolv.conf come nameserver "IP computer"?
come faccio a mettere l'IP statico?
scusa e grazie

Avatar utente
Automa
Prode Principiante
Messaggi: 173
Iscrizione: giovedì 26 gennaio 2006, 11:59

Re: problemi con la connessione alice adsl

Messaggio da Automa » lunedì 30 gennaio 2006, 11:52

prova dalla consol ping localhost cosi trovi lì'ip del tuo pc

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 12:04

oppure ifconfig da terminale
oppure sotto winzoz ipconfig/all
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 12:09

barbablu ha scritto: dove trovo l'IP del mio PC?
e poi lo aggiungo in resolv.conf come nameserver "IP computer"?
come faccio a mettere l'IP statico?
scusa e grazie
nameserver (es)192.168.1.1
x aprire il file sudo gedit(vim,nano,ecc.............) /etc/resolv.conf
e lo modifichi
comunque prova a leggere le varie discussioni postate
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

barbablu
Prode Principiante
Messaggi: 12
Iscrizione: giovedì 26 gennaio 2006, 11:00
Località: san giovanni in persiceto BO

Re: problemi con la connessione alice adsl

Messaggio da barbablu » lunedì 30 gennaio 2006, 18:59

niente da fare... :'(

sentite un po' non è che  c'è qualcuno che utilizzi Alice flat?

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 19:04

posta il file resolv.conf
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 19:24

come hai settato il router ppoa o ppoe?
prova ppoa non ppoe
lo hai interrogato ti risponde
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

barbablu
Prode Principiante
Messaggi: 12
Iscrizione: giovedì 26 gennaio 2006, 11:00
Località: san giovanni in persiceto BO

Re: problemi con la connessione alice adsl

Messaggio da barbablu » lunedì 30 gennaio 2006, 19:29

resolv.conf

nameserver 210.17.17.1 (questo dovrebbe essere l'IP del mio computer)
nameserver 212.216.112.112
nameserver 212.216.172.62

questo invece è il risultato di ipconfig/all in XP


Configurazione IP di Windows

       Nome host . . . . . . . . . . . . . . : xxxxxx-sh3x65m1
       Suffisso DNS primario  . . . . . . .  :
       Tipo nodo . . . . . . . . .  : Sconosciuto
       Routing IP abilitato. . . . . . . . . : No
       Proxy WINS abilitato . . . . . . . .  : No

Scheda Ethernet Connessione alla rete locale (LAN):

       Stato supporto . . . . . . . . . . . : Supporto disconnesso
       Descrizione . . . . . . . . . . . . . : Scheda Fast Ethernet PCI SiS 900

       Indirizzo fisico. . . . . . . . . . . : 00-0A-E6-36-56-6D

Scheda PPP TRUST 235A SPEEDLINK ADSL WEB MODEM:

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : WAN (PPP/SLIP) Interface
       Indirizzo fisico. . . . . . . . . . . : 00-53-45-00-00-00
       DHCP abilitato. . . . . . . . . . . . : No
       Indirizzo IP. . . . . . . . . . . . . : 82.54.80.191
       Subnet mask . . . . . . . . . . . . . : 255.255.255.255
       Gateway predefinito . . . . . . . . . : 82.54.80.191
       Server DNS . . . . . . . . . . . . .  : 85.37.17.52
                                           85.38.28.92o...................:82.54.80.191

...mi viene il dubbio che i DNS giusti siano quelli indicati nell'ipconfig di XP (visto che sono diversi), ma è un dubbio amletico!!!!

ricordo che il modem è usb...

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 21:34

prova a digitare 64.233.183.147 se compare la pagina di google e' un problema di DNS
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 21:37

poi hai la possibilita' di usarlo via ethernet
poi hai messo PPoA nella proprieta' di connessione
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 21:49

prova cosi'

installare il modulo ppp (puoi usare Sistema->Amministrazione->Synaptic)
e quando dai il comando per ricompilare il kernel usa anche il comando --initrd

ma forse lo hai gia' fatto

Impostazione della connessione

L'ultimo passo per la connessione ad internet è l'impostazione della connessione. Nel terminale digitiamo

cd /etc/ppp
sudo gedit options

e scriviamo queste righe in fondo al file:

noipdefault
noauth
persist
lcp-max-configure 50
-pap
usepeerdns
name any
user "latuapassword@qualcosa"
defaultroute
plugin /usr/lib/pppd/2.4.3/pppoatm.so
8.35

Ora prestiamo attenzione alla riga user, dopo la quali dobbiamo scrivere il nostro username che usiamo per la connessione (completo di dominio se necessario, ad esempio per gli utenti Libero 4 Megabit flat sarà del tipo user@adslfast). Dopo la riga plugin dobbiamo inserire il percorso del plugin pppoatm.so, se non siamo sicuri della sua locazione digitiamo locate pppoatm.so nel terminale. Nell'ultima riga il numero prima del punto indica il VPI e il numero dopo il punto indica il VCI della nostra connessione; questi valori spesso coincidono con quelli nell'esempio qui sopra, comunque vi consiglio di fare una breve ricerca in internet che vi fornirà subito questi dati.

Dopo aver salvato il file diamo il comando

sudo gedit chap-secrets

e scriviamo questa riga in fondo al file

vostrousername@vostrodominioseserve  *  vostrapassword

cambiando i dati nell'esempio con i nostri username e password di connessione, stando attenti a lasciare degli spazi, poi un asterisco, e poi altri spazi fra i due dati.

La stessa riga va ora scritta in fondo ad un altro file, che apriamo col comando

sudo gedit pap-secrets

Dopo aver modificato e salvato anche questo file diamo il comando

sudo gedit resolv.conf

e scriviamo le seguenti righe

nameserver 193.70.152.15
nameserver 193.70.152.25

A fianco alla parola nameserver nella prima riga dobbiamo indicare il DNS primario del nostro provider; nella seconda riga mettiamo invece il DNS secondario. L'esempio si riferisce alle impostazioni valide per Libero, in ogni caso con una veloce ricerca in internet saremo in grado di trovare i dati che fanno al caso nostro.
Connessione

Finalmente abbiamo sistemato tutto quello che c'era da sistemare per creare un'efficace connessione ad internet col nostro modem; ora non ci resta nient'altro da fare che riavviare il pc e far partire il sistema operativo col kernel modificato, e avviare la connessione. Vi consiglio di verificare che all'avvio il led rosso del modem lampeggi e poi rimanga stabilmente acceso: questo significa che il modem s'è agganciato alla portante ed è sincronizzato con la centrale telefonica; in altre parole significa che è pronto per la connessione, e questo lo si può verificare anche col comando cat /proc/net/atm/cxacru\:0 da dare una volta che il led è fisso e che deve restituire qualcosa del tipo

ADSL USB MODEM (usb-0000:00:07.2-2)
MAC: 00:06:4f:17:1c:7a
AAL5: tx 3865 ( 0 err ), rx 4467 ( 1 err, 0 drop )
Line up

A questo punto avviamo la connessione col comando pppd nel terminale e... SIAMO IN RETE! Per terminare la connessione dovrebbe bastare il comando killall pppd  ma consiglio di verificare l'effettiva disconnessione a chi non ha una connessione flat ma a pagamento.

Infine, ecco un pratico script che fa tutto questo per noi, con simpatici messaggi. Dovrebbe dirvi anche il tempo di connessione :)

#!/bin/bash

# CONNESSIONE CON ZENITY BY NoWhereMan :)

pppd
disc=1
start=`date +%s`
while [[ $disc != 0 ]]; do
        zenity --notification --text "Connesso."
        end=`date +%s`
        elapsed=`expr $end - $start`
        mins=`expr $elapsed / 60`
        secs=`expr $elapsed % 60`
        zenity --question --text "Connesso da $mins Minuti e $secs Secondi. Disconnettere ? ";
        disc=$?
done;
killall pppd

Copiate il testo, salvatelo in un file, per esempio "connect". Dategli permessi di esecuzione con

chmod +x connect

ora potete per esempio creare un'icona di avvio per il desktop. Fate doppio clic su questo script, e apparirà una piccola "(i)" accanto all'orologio: siete connessi. Un clic su di essa, e un messaggio vi chiederà se volete disconnettervi, informandovi di quanto tempo è passato da quando vi siete connessi.

Il consiglio di verificare la disconnesione rimane. Se ciò non fosse avvenuto, al solito, "killall pppd"
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

morfeo68
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1240
Iscrizione: domenica 30 ottobre 2005, 21:41

Re: problemi con la connessione alice adsl

Messaggio da morfeo68 » lunedì 30 gennaio 2006, 21:50

[quote="barbablu"]
resolv.conf
da togliere in rosso
nameserver 210.17.17.1 (questo dovrebbe essere l'IP del mio computer)
da tenere in nero
nameserver 212.216.112.112
nameserver 212.216.172.62

prova a togliere la riga che ho marcato

poi leggi qua dovrebbe essere quella giusta

http://forum.ubuntu-it.org/viewtopic.php?t=14137
Ultima modifica di morfeo68 il lunedì 30 gennaio 2006, 21:59, modificato 1 volta in totale.
asus p4c800dlx, p4 2.4 800 mhz, 1,5 gb ram, ati 9600 pro, ubuntu 9.10 Karmic Koala

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: ralf9000 e 15 ospiti