[Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribaltata

Riconoscimento, installazione e configurazione delle periferiche.

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda ugaciaka » martedì 24 giugno 2008, 19:01

arjos85 ha scritto:
ugaciaka ha scritto: (ot) Bella guida, la segnalo sul mio blog! Certo che questa storia delle webcam capovolte è spassosa. Però grazie a te, al creatore dei driver, alla comunità l'opensource mostra quelle marce in più che il closedsource non avrà mai!


Grazie a te!!;)
infatti come avrai visto nella guida ho citato un articolo presente sul tuo blog!!! ;)

Grazie  (b2b)

infatti lo ho fatto dove ho spiegato come, in Italiano, ricompilare i driver per *buntu  (good)
non ho mai comprato su ebay, i macbook non mi piacciono, non ho bisogno di facebook né myspace né secondlife
non sono un nerd né lamer né troll né geek né cracker né hacker
Avatar utente
ugaciaka
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1960
Iscrizione: ottobre 2006
Località: Belluno

Re: [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribaltata

Messaggioda lynux » martedì 24 giugno 2008, 20:43

arjos85 ha scritto:
cRoW2k ha scritto:arjos85, mi hai reso una persona felice  Funziona alla grande (Soluzione 1). Direi che sta guida è un MUST da indicizzare SUBITO


WOW....  (b2b)
sono contento che anche a te funzioni....
hai provato anche la seconda soluzione???  :P
Dai provala e fammi sapere quale credi sia quella migliore!!!  8)

A proposito di "indicizzare"...
sei la seconda persona che prova la mia patch e la seconda a cui funziona!!  (good)

WOWOWOWOWOWWWWWWWWWWWWWWW  (rotfl)


Bel lavoro arjos85, complimenti !

Ho provato le 4 versioni della patch:

- la prima soluzione nella versione specchiata ,e non, funzionano abbastanza bene, c'è un minimo di ritardo tra i frame, ma nulla di eccezionale;

- la seconda soluzione nella versione non specchiata, sembra rendere il funzionamento della cam, un po' più fluido delle precedenti;

- infine, la seconda soluzione, specchiata, manda in blocco l'intero sistema, lampeggiano anche i vari caps look, scroll look, etc... sembra essere un kernel-panic.

Con la seconda versione, sono riuscito , finalmente, a far partire cheese, ma è troppo lento il funzionamento del programma.

Con mplayer ottengo questo risultato:

MPlayer dev-SVN-r26300-4.1.3 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU    T7500  @ 2.20GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski
comment: first try, more to come ;-)
v4l2: ioctl get standard failed: Invalid argument
Selected device: USB 2.0 Camera
Capabilites:  video capture  streaming
supported norms:
inputs: 0 = Camera 1;
Current input: 0
Current format: YUYV
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
Error opening/initializing the selected video_out (-vo) device.

v4l2: ioctl set mute failed: Invalid argument
v4l2: 0 frames successfully processed, 0 frames dropped.

Exiting... (End of file)


e come al solito, camorama non funziona...

Complimenti, ancora per il lavoro svolto.


Ciao
lynux
Prode Principiante
 
Messaggi: 195
Iscrizione: febbraio 2008

Re: [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribaltata

Messaggioda arjos85 » martedì 24 giugno 2008, 21:27

lynux ha scritto:Bel lavoro arjos85, complimenti !
Ho provato le 4 versioni della patch:

Fantastico ........ sei un grande!!!!  (b2b)
- la prima soluzione nella versione specchiata ,e non, funzionano abbastanza bene, c'è un minimo di ritardo tra i frame, ma nulla di eccezionale;

che webcam hai? che risoluzione ha?
in che modo hai testato le varie soluzioni? Con mplayer?
questo ritardo potrebbe dipendere dal "fps"... prova ad usare anche skype e/o amsn, kopete....  ;)
- la seconda soluzione nella versione non specchiata, sembra rendere il funzionamento della cam, un po' più fluido delle precedenti;

perfetto...  (good)
- infine, la seconda soluzione, specchiata, manda in blocco l'intero sistema, lampeggiano anche i vari caps look, scroll look, etc... sembra essere un kernel-panic.

molto strano...  >:(
potrebbe essere un bug della mia patch!!!
in che modo hai testato questa soluzione? Potresti postarmi il comando completo che hai usato? ;)
Con la seconda versione, sono riuscito , finalmente, a far partire cheese, ma è troppo lento il funzionamento del programma.

Con la prima soluzione (speculare e non) non ti partiva cheese?
Se ho capito bene...invece ti parte con la seconda versione, ma solo la variante con le immagini speculari. Giusto?

Con mplayer ottengo questo risultato:

MPlayer dev-SVN-r26300-4.1.3 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU    T7500  @ 2.20GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski
comment: first try, more to come ;-)
v4l2: ioctl get standard failed: Invalid argument
Selected device: USB 2.0 Camera
Capabilites:  video capture  streaming
supported norms:
inputs: 0 = Camera 1;
Current input: 0
Current format: YUYV
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
Error opening/initializing the selected video_out (-vo) device.

v4l2: ioctl set mute failed: Invalid argument
v4l2: 0 frames successfully processed, 0 frames dropped.

Exiting... (End of file)

potresti postarmi il comando che hai usato per ottenere questo output?
Io uso mplayer con nel seguente modo:
Codice: Seleziona tutto
mplayer tv:// -tv driver=v4l2:device=/dev/video0:outfmt=yuy2:width=640:height=480:fps=50 -vo x11

a quanto pare il tuo problema è riconducibile al fatto che o non hai messo l'opzione "-vo video_output_driver" oppure che hai segnalato un "video_output_driver" errato.
Per sapere quali sono i "video_output_driver" per mplayer:
Codice: Seleziona tutto
mplayer -vo help


e come al solito, camorama non funziona...

purtroppo camorama non funziona nemmeno a me....e sinceramente non ho tempo per preoccuparmene...
io cmq per fare i test ho usato i seguenti programmi:
kopete, amsn, skype, mplayer, luvcview, cheese e per alcuni test ho usato anche "motion"

in particolare "luvcview" è molto carino e semplice da usare:
se non erro dovrebrebbe bastare il seguente comando per installarlo:
Codice: Seleziona tutto
sudo apt-get install luvcview

e per usarlo usa questo:
Codice: Seleziona tutto
luvcview -f yuv -s 640x480


Fammi sapere  ...
ciao

e grazie per aver testato tutte e 4 le soluzioni...
ora cerco di capire cos è che non va nella variante 2 della seconda soluzione.

arjos85
Ultima modifica di arjos85 il martedì 24 giugno 2008, 21:39, modificato 1 volta in totale.
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribaltata

Messaggioda Tizianub » martedì 24 giugno 2008, 23:06

Ciao sono di nuovo io  (yes)

ho provato le quattro soluzioni, e vanno tutte bene da tutti i punti di vista, forse un po' più fluide le prime due ma davvero poco.

Grazie di nuovo, volevo solo testimoniare che avevo provato tutte le soluzioni.
Avatar utente
Tizianub
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2923
Iscrizione: aprile 2007
Località: Jesi (AN)

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » martedì 24 giugno 2008, 23:20

Tizianub ha scritto:Ciao sono di nuovo io  (yes)

ho provato le quattro soluzioni, e vanno tutte bene da tutti i punti di vista, forse un po' più fluide le prime due ma davvero poco.

Grazie di nuovo, volevo solo testimoniare che avevo provato tutte le soluzioni.

wow...
Perfetto ti ringrazio tantissimo per il tuo prezioso contributo...  (b2b)
ti avviso che man mano farò altri aggiornamenti!!!
quindi rimani sintonizzato...  ;)

ciao  (good)
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribaltata

Messaggioda Tizianub » martedì 24 giugno 2008, 23:26

Sicuro e grazie a te  (b2b)
Avatar utente
Tizianub
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2923
Iscrizione: aprile 2007
Località: Jesi (AN)

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda lynux » mercoledì 25 giugno 2008, 9:47

Ciao,

Ti confermo  il problema riscontrato con l'ultima versione della patch, n°2 specchiata.

Ti riporto alcune informazioni, sul mio sistema, spero possano esserti d'aiuto:

Kubuntu 7.10 kernel 2.6.22-14-generic t7500 2gb ram

che webcam hai?
Bus 006 Device 002: ID 174f:5a35 Syntek 1.3MPixel Web Cam - Asus G1s
che risoluzione ha?
1280x1024
in che modo hai testato le varie soluzioni?

Kopete    : OK
Amsn      : OK
camorama : NO, non riconosce la cam
Cheese    : Ok, solo con la seconda versione, lento, non specchiata, con le altre non funziona.
Ekiga        : NO, non riconosce la cam
lucview*    : OK, lento
mplayer** : OK
skype        : NO, non ho trovato la versione a 64bit, con la funzione videochat
ffmpeg***  : OK

*Per installare lucview:
sudo apt-get install libsdl1.2-dev, il file da http://openfacts.berlios.de/index-en.ph ... =Linux+UVC, make , ed infine luvcview -f yuv -s 640x480

**Con mplayer ho provato con questi comandi, trovati in questo sito http://doc.ubuntu-fr.org/syntek:

mplayer tv:// -tv driver=v4l:width=640:height=480
mplayer tv:// -tv driver=v4l2:width=320:height=240:fps=25:outfmt=rgb24:device=/dev/video0
mplayer tv:// -tv driver=v4l2:width=320:height=240:fps=25:outfmt=yuy2:device=/dev/video0
mplayer tv:// -tv driver=v4l2:width=320:height=240:fps=25:outfmt=uyvy:device=/dev/video0
---------------------^^^NON FUNZIONANO^^^-----------------------------------------------------------
mencoder tv:// -tv driver=v4l:width=640:height=480:outfmt=rgb24:device=/dev/video0 -nosound -ovc lavc -o out.avi

Solo con l'ultima è stato possibile registrare l'output video in un file

Questo è l'output del comando
$ mplayer -vo help

MPlayer dev-SVN-r26300-4.1.3 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU    T7500  @ 2.20GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Available video output drivers:
        fbdev  Framebuffer Device
        fbdev2  Framebuffer Device
        v4l2    V4L2 MPEG Video Decoder Output
        cvidix  console VIDIX
        null    Null video output
        mpegpes Mpeg-PES to DVB card
        yuv4mpeg        yuv4mpeg output for mjpegtools
        tga    Targa output
        pnm    PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame

Se dò il comando: mplayer tv:// -tv driver=v4l2:device=/dev/video0:outfmt=yuy2:width=640:height=480:fps=50 -vo x11
ottengo lo stesso errore che ti ho segnalato nel precedente post.

***Brevi flash tra i frames

Se hai la possibilità, prova questo:
http://www.openwengo.org/ , la versione a 64bit non è ancora perfetta, così non la posso testare sul mio sistema, non appena avrò del tempo disponibile, la compilerò dai sorgenti.

Grazie  (b2b)

Ciao


PS: Un piccolo script per semplificare le varie operazioni:

#Salvare il file , esempio StartCam, impostare i permessi di esecuzione
#!/bin/bash
make clean
make all
sudo modprobe -r uvcvideo
sudo make install
# Aggiunto per la precedente versione del make install
sudo cp uvcvideo.ko /lib/modules/2.6.22-14-generic/ubuntu/media/usbvideo/
sudo modprobe uvcvideo
Ultima modifica di lynux il mercoledì 25 giugno 2008, 10:41, modificato 1 volta in totale.
lynux
Prode Principiante
 
Messaggi: 195
Iscrizione: febbraio 2008

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » mercoledì 25 giugno 2008, 10:19

ti consiglio di leggere la mia risposta al tuo messaggio precedente : http://forum.ubuntu-it.org/viewtopic.ph ... 7#p1330577
lynux ha scritto:Ti confermo  il problema riscontrato con l'ultima versione della patch, n°2 specchiata.
Ti riporto alcune informazioni, sul mio sistema, spero possano esserti d'aiuto:
che webcam hai?

Bus 006 Device 002: ID 174f:5a35 Syntek 1.3MPixel Web Cam - Asus G1s
che risoluzione ha?
1280x800

tra l'altro hai la mia stessa webcam: 174f:5a35
e la tua risoluzione massima non dovrebbe essere quella...
per sapere quali sono le risoluzioni supportate dalla tua webcam lancia questo comando:
Codice: Seleziona tutto
sudo lsusb -vv -d 174f:5a35

Da qualche parte nell'output dovresti trovare questo:
Codice: Seleziona tutto
        wWidth( 0)                       1280
        wHeight( 0)                      1024
        wWidth( 1)                       1280
        wHeight( 1)                       960
        wWidth( 2)                        640
        wHeight( 2)                       480
        wWidth( 3)                        352
        wHeight( 3)                       288
        wWidth( 4)                        320
        wHeight( 4)                       240
        wWidth( 5)                        176
        wHeight( 5)                       144
        wWidth( 6)                        160
        wHeight( 6)                       120


Fammi sapere,
soprattutto in riferimento alla mia risposta al tuo messaggio precedente.
ciao
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » mercoledì 25 giugno 2008, 10:20

scusami...ma sto ancora dormendo...
non avevo letto la parte successiva del tuo messaggio!!!  :-[
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda lynux » mercoledì 25 giugno 2008, 10:26

arjos85 ha scritto:ti consiglio di leggere la mia risposta al tuo messaggio precedente : http://forum.ubuntu-it.org/viewtopic.ph ... 7#p1330577
lynux ha scritto:Ti confermo  il problema riscontrato con l'ultima versione della patch, n°2 specchiata.
Ti riporto alcune informazioni, sul mio sistema, spero possano esserti d'aiuto:
che webcam hai?

Bus 006 Device 002: ID 174f:5a35 Syntek 1.3MPixel Web Cam - Asus G1s
che risoluzione ha?
1280x800

tra l'altro hai la mia stessa webcam: 174f:5a35
e la tua risoluzione massima non dovrebbe essere quella...
per sapere quali sono le risoluzioni supportate dalla tua webcam lancia questo comando:
Codice: Seleziona tutto
sudo lsusb -vv -d 174f:5a35

Da qualche parte nell'output dovresti trovare questo:
Codice: Seleziona tutto
        wWidth( 0)                       1280
        wHeight( 0)                      1024
        wWidth( 1)                       1280
        wHeight( 1)                       960
        wWidth( 2)                        640
        wHeight( 2)                       480
        wWidth( 3)                        352
        wHeight( 3)                       288
        wWidth( 4)                        320
        wHeight( 4)                       240
        wWidth( 5)                        176
        wHeight( 5)                       144
        wWidth( 6)                        160
        wHeight( 6)                       120


Fammi sapere,
soprattutto in riferimento alla mia risposta al tuo messaggio precedente.
ciao


Risoluzione Schermo: 1280x800
Risoluzione Cam    :  1280x1024

Leggi con calma, fammi sapere se hai novità.

Ciao
lynux
Prode Principiante
 
Messaggi: 195
Iscrizione: febbraio 2008

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » mercoledì 25 giugno 2008, 10:57

lynux ha scritto:Ciao,

Ti confermo  il problema riscontrato con l'ultima versione della patch, n°2 specchiata.

Mah...non saprei, a me non da problemi e nemmeno ad altri 2 ragazzi.
In genere succede qualcosa del genere quando si cerca di "scrivere" dove non si può!!! Ma allora questo problema dovremmo averlo tutti!!

Ti riporto alcune informazioni, sul mio sistema, spero possano esserti d'aiuto:

Kubuntu 7.10 kernel 2.6.22-14-generic t7500 2gb ram
Bus 006 Device 002: ID 174f:5a35 Syntek 1.3MPixel Web Cam - Asus G1s

Ha la mia stessa configurazione hardware...cpu, ram e webcam sono le stesse.
Io ho un Asus F3SR.
Però io ho kubuntu 8.04...prova ad aggiornare kubuntu alla 8.04...non si sa mai!!
in che modo hai testato le varie soluzioni?

Kopete    : OK
Amsn      : OK
camorama : NO, non riconosce la cam
Cheese    : Ok, solo con la seconda versione, lento, non specchiata, con le altre non funziona.
Ekiga        : NO, non riconosce la cam
lucview*    : OK, lento
mplayer** : OK
skype        : NO, non ho trovato la versione a 64bit, con la funzione videochat
ffmpeg***  : OK


Anch'io con ekiga ogni tanto ho questo problema, ma mi basta uscire dal programma e riavviarlo e tutto funziona: la webcam è riconosciuta perfettamente!!!
Le mie impostazioni sono:
Codice: Seleziona tutto
Video Plugin: V4L2
Inpute Devices : <nome della webcam>
Format : (PAL Europe)
Channel: 0

Questo è l'output del comando
$ mplayer -vo help

MPlayer dev-SVN-r26300-4.1.3 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU    T7500  @ 2.20GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Available video output drivers:
        fbdev  Framebuffer Device
        fbdev2  Framebuffer Device
        v4l2    V4L2 MPEG Video Decoder Output
        cvidix  console VIDIX
        null    Null video output
        mpegpes Mpeg-PES to DVB card
        yuv4mpeg        yuv4mpeg output for mjpegtools
        tga    Targa output
        pnm    PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame

Se dò il comando: mplayer tv:// -tv driver=v4l2:device=/dev/video0:outfmt=yuy2:width=640:height=480:fps=50 -vo x11
ottengo lo stesso errore che ti ho segnalato nel precedente post.

certo, perchè x11 non è nella tua lista degli "Available video output drivers"!! al posto di x11 prova uno ad uno quelli elencati sopra: "yuv4mpeg" suona bene, prova quello per esempio!!
Se non va, prova anche tutti gli altri!!!
Se hai la possibilità, prova questo:
http://www.openwengo.org/ , la versione a 64bit non è ancora perfetta, così non la posso testare sul mio sistema, non appena avrò del tempo disponibile, la compilerò dai sorgenti.

ma tu hai installato kubuntu-64bit?
potrebbe essere anche quello il problema con una delle mie patch....ora controllo!!!
PS: Un piccolo script per semplificare le varie operazioni:

#Salvare il file , esempio StartCam, impostare i permessi di esecuzione
#!/bin/bash
make clean
make all
sudo modprobe -r uvcvideo
sudo make install
# Aggiunto per la precedente versione del make install
sudo cp uvcvideo.ko /lib/modules/2.6.22-14-generic/ubuntu/media/usbvideo/
sudo modprobe uvcvideo

perchè nello script hai messo :
sudo cp uvcvideo.ko /lib/modules/2.6.22-14-generic/ubuntu/media/usbvideo/
non hai modificato il makefile come ho scritto nell HOW-TO?

fammi sapere...
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » giovedì 26 giugno 2008, 13:16

Ragazzi vi volevo informare che ho nuovamente aggiornato l'HOW-TO:
ho sostituito il codice delle funzioni modificate con le corrispondenti patch.

Queste patch sono comunque il risultato di nuove modifiche ai sorgenti: ho cercato di snellire ancora un po' il lavoro che devono svolgere.

Fatemi sapere cosa ne pensate!!

ciao  ;)
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda lynux » giovedì 26 giugno 2008, 15:01

arjos85 ha scritto:Ragazzi vi volevo informare che ho nuovamente aggiornato l'HOW-TO:
ho sostituito il codice delle funzioni modificate con le corrispondenti patch.

Queste patch sono comunque il risultato di nuove modifiche ai sorgenti: ho cercato di snellire ancora un po' il lavoro che devono svolgere.

Fatemi sapere cosa ne pensate!!

ciao  ;)


Aggiornamenti:

Skype: OK, provata versione 32bit con videochat  (good)

EKiga: OK, canale va settato a zero  (good)


Wengophone (OpenWengo): non si vede nulla nè nell'anteprima, nè durante la videochat, ho trovato una versione a 64 bit nel repositary, si accende la luce della cam, forse un bug nel programma, se ti va di provarlo, basta modificare il file /etc/apt/sources.list, aggiungedo queste righe:

#[LaunchPad Gutsy]
deb http://ppa.launchpad.net/cavedon/ubuntu gutsy main
deb-src http://ppa.launchpad.net/cavedon/ubuntu gutsy main


oppure

#[LaunchPad Hardy]
deb http://ppa.launchpad.net/cavedon/ubuntu hardy main
deb-src http://ppa.launchpad.net/cavedon/ubuntu hardy main

$ sudo apt-get update
$ sudo apt-get install wengophone

E' un progetto interessante, adesso ha cambiato nome,funziona egregiamente.
http://forum.ubuntu-it.org/viewtopic.php?t=172141

Consiglio dopo l'installazione del programma, di commentare le due linee di questi repositary, poichè contengono altro software , ancora in versione troppo sperimentale.

perchè nello script hai messo :
sudo cp uvcvideo.ko /lib/modules/2.6.22-14-generic/ubuntu/media/usbvideo/
non hai modificato il makefile come ho scritto nell HOW-TO?


Ogni volta che scarichi i sorgenti, il makefile ritorno al suo stato originale, senza le tue modifiche.

Altra buona notizia, il problema della 2 versione della seconda patch sembra essere risolto.

Ho riscontrato ancora lentezza nell'uso di Cheese, e problemi con kernel headers diversi dal 2.6.22-14, nel mio caso 2.6.22-15 , il modulo uvcvideo, quando esegui il comando
$ sudo modprobe -r uvcvideo
$ sudo modprobe uvcvideo

sembra non venire sovrascritto.  :o

Adesso provo le patch, e ti dò nuove notizie, spero positive.
Mi hai bruciato sul tempo, avevo in mente di proporti i file patch , invece delle funzioni modificate.

Ciao (b2b)
Ultima modifica di lynux il venerdì 27 giugno 2008, 8:54, modificato 1 volta in totale.
lynux
Prode Principiante
 
Messaggi: 195
Iscrizione: febbraio 2008

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » giovedì 26 giugno 2008, 15:10

ti ringrazio,...
nn appena ho un attimino di tempo provo il programma che mi hai consigliato.

Come hai fatto a risolvere il problema della versione 2 della seconda soluzione?
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda lynux » giovedì 26 giugno 2008, 19:06

arjos85 ha scritto:ti ringrazio,...
nn appena ho un attimino di tempo provo il programma che mi hai consigliato.

Come hai fatto a risolvere il problema della versione 2 della seconda soluzione?


Il comando

$ patch < Versione1.patch  da il seguente errore :

patching file uvc_video.c
patch unexpectedly ends in middle of line
Hunk #1 succeeded at 371 with fuzz 1. :-\


Capita solo a me ?


Ciao  (b2b)
lynux
Prode Principiante
 
Messaggi: 195
Iscrizione: febbraio 2008

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » giovedì 26 giugno 2008, 19:27

Ciao,
io ottengo il seguente output:
Codice: Seleziona tutto
patching file uvc_video.c


E il file uvc_video.c viene patchato in modo corretto!!

Vediamo un po quali potrebbero essere i tuoi problemi:
1) sei sicuro di aver scaricato l ultima versione del driver?
Il comando è il seguente:
Codice: Seleziona tutto
svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk

2) hai copiato la patch nella cartella contenente i sorgenti?
3) sei sicuro che il file "uvc_video.c" sia quello originale? O magari l'hai già pacioccato in qlk modo?
4) hai copiato anche l ultima riga della patch (è una riga vuota)?
5) quando esegui il comando "patch < nome.patch" sei dentro il path della cartella "Trunk"?

Fammi sapere,
ciao
Ultima modifica di arjos85 il giovedì 26 giugno 2008, 19:29, modificato 1 volta in totale.
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda lynux » venerdì 27 giugno 2008, 8:54

Ho risolto il problema delle patch (good), si trattava di un banale errore di terminatore di riga, nell'editor di testi era impostata l'opzione "Fine Riga Windows", ed era presente una riga in più, risultato dall'operazione di copia-incolla.

Le impressioni provando le 4 versioni, sono più o meno le stesse delle precedenti, la prima versione risulta leggermente più fluida, ma la seconda resta ancora la migliore. (good)

Cheese ha un andamento fluido, ma con il trascorrere dei secondi, il suo funzionamento risulta lento, e si blocca dopo qualche minuto, credo che richieda troppe risorse in termini di memoria e cpu. Non sono ancora riuscito ad impostare la risoluzione. :-\

Per applicare le varie patch ho scritto questo script, per uso personale, non badare tanto all'estetica ::) del codice, spero possa essere utile:

#!/bin/bash
# APPLICA LA PATCH SELEZIONATA
# MODIFICARE IL VALORE DI N_PATCH
#COME SEGUE
# I FILE DELLE VARIE PATCH DOVRANNO AVERE I NOMI SOTTO ELENCATI,
#ED ESSERE PRESENTI NELLA DIR trunk
# SE NON GRADITE LE SIGLE CAMBIATE PURE IL NOME DELLE VARIABILI
#
#          1S  : Prima    Versione della Patch , con effetto specchio (mirror)
#          1NS : Prima    Versione della Patch , senza l'effetto specchio (Normale)
#          2S  : Seconda Versione della Patch , con effetto specchio (mirror)
#          2NS : Seconda  Versione della Patch , senza l'effetto specchio (Normale)
#

N_PATCH=2S



# SE DESIDERATE SCARICARE L'ULTIMA VERSIONE DAL REPOSITARY
#ELIMINATE IL SIMBOLO '#' DALLE RIGHE SUCCESSIVE

#INIZIO DOWNLOAD
# svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk
#cp trunk/uvc_video.c ../
#FINE DOWLOAD COMMENTARLE NUOVAMENTE, PER APPLICARE UNA ULTERIORE PATCH

#Copiare questo file nella directory trunk
#RIPRISTINA COPIA ORIGINALE UVC_VIDEO.C, il file deve trovarsi nella cartella superiore a quella attuale
# es /home/utente/cam/trunk , copiate il file in /home/utente/cam, prima di iniziare il processo


#RIPRISTINO DA BACKUP

echo -e "Ripristino il file originale...\n"
cp ../uvc_video.c .


#APPLICA PATCH

echo -e "\nSto Applicando la patch: $N_PATCH...\n"
patch < $N_PATCH

#RIMUOVE COMPILA ED INSTALLA IL NUOVO MODULO

echo -e "\nElimino i file compilati in precedenza...\n"
make clean

echo -e "\nRimuovo il modulo uvcvideo...\n"
sudo modprobe -r uvcvideo

echo -e "\nCompilo i sorgenti del modulo...\n"
make all

echo -e "\nCopio i file del modulo uvcvideo compilato prima...\n"
sudo make install
sudo cp uvcvideo.ko /lib/modules/$(uname -r)/ubuntu/media/usbvideo/

echo -e "\nAttivo il modulo appena installato...\n"
sudo modprobe uvcvideo

echo -e "Fine.\n"

Grazie,

Ciao  (b2b)
Ultima modifica di lynux il sabato 28 giugno 2008, 7:44, modificato 1 volta in totale.
lynux
Prode Principiante
 
Messaggi: 195
Iscrizione: febbraio 2008

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribaltata

Messaggioda Tizianub » domenica 29 giugno 2008, 9:58

Ciao Arjos85

ho provato tutte le soluzioni con il metodo da te aggiornato delle patch, tutto ok con le 4 soluzioni.

Solo con la soluzione 1 not mirrored c'è cheese che non carica l'immagine e rimane bloccata, mentre se provo con mplayer e lucvideo vanno.

Per il resto tutto a posto
Avatar utente
Tizianub
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2923
Iscrizione: aprile 2007
Località: Jesi (AN)

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » domenica 29 giugno 2008, 10:16

Tizianub ha scritto:Ciao Arjos85

ho provato tutte le soluzioni con il metodo da te aggiornato delle patch, tutto ok con le 4 soluzioni.

Solo con la soluzione 1 not mirrored c'è cheese che non carica l'immagine e rimane bloccata, mentre se provo con mplayer e lucvideo vanno.

Per il resto tutto a posto


Grazie Tizianub per i tuoi preziosissimi test!!  (b2b)

hai ragione...
non so perchè ma con la soluzione 1 not mirrored ottengo i seguenti messaggi da "cheese":
(cheese:30574): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
(cheese:30574): GStreamer-CRITICAL **: gst_object_unref: assertion `object != NULL' failed
(cheese:30574): GStreamer-CRITICAL **: gst_object_unref: assertion `object != NULL' failed


Sembrerebbe comunque essere un bug di cheese, dato che tutti gli altri programmi funzionano correttamente!!

se qualcuno ne sa qualcosa...
grazie ;)
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

Re: [Driver] [HOW TO] UVCVIDEO : come risolvere il problema della webcam ribalta

Messaggioda arjos85 » domenica 29 giugno 2008, 10:30

[lost]-Divilinux ha scritto:@ugaciaka
Bella guida, la segnalo sul mio blog!

ok allora e' inutile che la segnalo io..pazienza


Grazie Divilinux per aver segnalato questo HOW-TO sul tuo blog: http://divilinux.netsons.org/index.php/archives/812

ps.
tra l'altro sono anch'io uno sfegatato di Lost....dalla seconda serie fino alla quarta ho visto tutte le puntate con i sottotitoli pur di vederle il prima possibile!! ;)
Arjos85
Avatar utente
arjos85
Prode Principiante
 
Messaggi: 54
Iscrizione: giugno 2008
Località: Vicinissimo Torino

PrecedenteSuccessiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 9 ospiti