[RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
gazzellone
Prode Principiante
Messaggi: 104
Iscrizione: sabato 31 gennaio 2009, 6:45

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da gazzellone » sabato 4 aprile 2009, 15:03

Anche io possessore di una MX 440 devo ringraziare l'autore del post per la risoluzione di innumerevoli problemi (su indicazioni di francesco bat), Grazie  ;D

Avatar utente
fiero_alleaten
Prode Principiante
Messaggi: 176
Iscrizione: sabato 20 settembre 2008, 0:52
Località: Ancona
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da fiero_alleaten » domenica 5 aprile 2009, 18:31

Vedo che qualcuno c'è allora :P

In riferimento al mio vecchio post:
fiero_alleaten ha scritto: Dato che qua passano molti della vecchia scuola, per caso siete riusciti ad abilitare effetti come le finestre sfocate (blur), oltre alla trasparenza, in compiz? Perchè credo che le nostre schede non possano :(
Non sono ancora riuscito a risolvere il problema, ma ancora non ho capito se è per un bug di Compiz o un problema con la scheda grafica. Qualcuno ha trovato quel plugin un po' buggato, a volte funziona a volte no.

Se qualcuno sa qualcosa mi avverta :)

Avatar utente
francesco bat
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1136
Iscrizione: giovedì 3 luglio 2008, 3:08
Desktop: KDE o IceWM
Distribuzione: PCLinuxOS
Località: Roma
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da francesco bat » domenica 5 aprile 2009, 19:31

Guarda, ti posso dire che Compiz non c'entra niente !
A me lo faceva anche senza Compiz !
Lo provai con compiz disattivato e senza effetti, con fusion Icon che impostavo Metacity, persino con la rimozione completa di Compiz, avevo sempre i stessi problemi.
È proprio una caratteristica di questo driver che non è impostato bene.
Ora l'ho sperimentato sia senza Compiz che con Compiz e va una favola.
Ora ho Compiz attivo con i massimi effetti (mi devo rifare  ;D ) e va benissimo.
Ciao
Francesco bat
Software Linux
Il forum dei programmi per Linux
http://softwarelinux.italiaforum.net/

Avatar utente
luchino
Prode Principiante
Messaggi: 244
Iscrizione: domenica 25 febbraio 2007, 14:20

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da luchino » martedì 14 aprile 2009, 23:13

Ragazzi,
scusate...ma io non ho capito il modo di risolvere il problema di wine...qualcuno me lo potrebbe rispiegare?!
cmq gli altri problemi risolti alla grande!!
grazie!! ;)

Avatar utente
Lord T
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 583
Iscrizione: mercoledì 4 aprile 2007, 15:04
Località: Quartucciu

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da Lord T » mercoledì 15 aprile 2009, 0:27

luchino ha scritto: Ragazzi,
scusate...ma io non ho capito il modo di risolvere il problema di wine...qualcuno me lo potrebbe rispiegare?!
cmq gli altri problemi risolti alla grande!!
grazie!! ;)
vai in applicazini→accessori→editor di testo
e incolli

[HKEY_CURRENT_USER\Software\wine\X11 driver]
"ClientSideWithRender"="N"

salvi il file  nominandolo setting.txt nella scrivania
apri il terminale e digiti

regedit /home/NOMEUTENTE/Scrivania/setting.txt
Importantissimo!!!blocchiamo la censura  di internet

http://sitononraggiungibile.e-policy.it/
(b2b)

Avatar utente
fiero_alleaten
Prode Principiante
Messaggi: 176
Iscrizione: sabato 20 settembre 2008, 0:52
Località: Ancona
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da fiero_alleaten » mercoledì 15 aprile 2009, 12:23

francesco bat ha scritto: È proprio una caratteristica di questo driver che non è impostato bene.
Ora l'ho sperimentato sia senza Compiz che con Compiz e va una favola.
Ora ho Compiz attivo con i massimi effetti (mi devo rifare  ;D ) e va benissimo.
Mi sa che questa era una risposta per me e la leggo solo ora :D. Ma adesso hai cambiato scheda o sei sempre con la geforce4?

Avatar utente
francesco bat
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1136
Iscrizione: giovedì 3 luglio 2008, 3:08
Desktop: KDE o IceWM
Distribuzione: PCLinuxOS
Località: Roma
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da francesco bat » mercoledì 15 aprile 2009, 13:10

Io ho la Geforce FX 5500 !
Il problema è che la mia CPU non supporta le istruzioni SSE e gli ultimi driver della Nvidia (173 in poi) funzionano solo se tu hai gli SSE.
Infatti per questo l'unico driver funzionante è il driver 96 x me, l'importante è giusto cambiare i settaggi x farlo funzionare bene senza problemi con gli altri programmi.
Ciao
Francesco bat
Software Linux
Il forum dei programmi per Linux
http://softwarelinux.italiaforum.net/

Avatar utente
fiero_alleaten
Prode Principiante
Messaggi: 176
Iscrizione: sabato 20 settembre 2008, 0:52
Località: Ancona
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da fiero_alleaten » mercoledì 15 aprile 2009, 16:59

Capito :). Di questi tempi ho un po' da fare, credo che per settare a dovere i driver serva tempo... magari quando avrò un po' più di tempo libero. Hai smanettato sullo xorg.conf?

Avatar utente
francesco bat
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1136
Iscrizione: giovedì 3 luglio 2008, 3:08
Desktop: KDE o IceWM
Distribuzione: PCLinuxOS
Località: Roma
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da francesco bat » mercoledì 15 aprile 2009, 20:05

In verità su Xorg non ho messo mano xchè è stata l'unica cosa che mi ha funzionato senza problemi  :P
Infatti non mi sono capitate sparizioni di tasti delle finestre.
Mi capita solo di rado nel momento che attivo Compiz (se lo tenevo disattivato) che mi sparisce tutta la barra con i tasti sopra a tutto le finestre.
Succede raramente e basta comunque fare un termina sessione e ritorna tutto funzionante.  ;)
Ciao
Francesco bat
Software Linux
Il forum dei programmi per Linux
http://softwarelinux.italiaforum.net/

giannir1988
Prode Principiante
Messaggi: 148
Iscrizione: mercoledì 17 dicembre 2008, 20:31

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da giannir1988 » mercoledì 15 aprile 2009, 20:37

francesco bat ha scritto: In verità su Xorg non ho messo mano xchè è stata l'unica cosa che mi ha funzionato senza problemi  :P
Infatti non mi sono capitate sparizioni di tasti delle finestre.
Mi capita solo di rado nel momento che attivo Compiz (se lo tenevo disattivato) che mi sparisce tutta la barra con i tasti sopra a tutto le finestre.
Succede raramente e basta comunque fare un termina sessione e ritorna tutto funzionante.  ;)
Ciao
Francesco bat
Bhe se hai il Compiz disattivato è ovvio che questi problemi non ne hai  :P
Questo POST è proprio per chi ha una GeForce Legacy e vuole utilizzare il Compiz senza problemi.
Sono ormai mesi che pur avendo una GeForce 440MX il Compiz mi va una favola e non mi scompare più niente!
Tutto grazie a questi interventi.
Bye

Avatar utente
fiero_alleaten
Prode Principiante
Messaggi: 176
Iscrizione: sabato 20 settembre 2008, 0:52
Località: Ancona
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da fiero_alleaten » mercoledì 15 aprile 2009, 21:50

Okok :) Beh, quel livello di disfunzione (sparizione pezzi di finestre) l'ho superato molto tempo fa, di guide ce ne sono, e chi passerà per questo forum grazie a questo thread non avrà mai problemi del genere. Ma tu con i driver legacy riesci a far partire il blur? A me si attiva la spunta, ma nulla ha il blur :s. Altri plugin (sempre minori) crashano e perdono la spunta. Ma si tratta di davvero poca roba. Mi è capitato ad esempio quando ho attivato le finestre 3D per prova il crash dell'applicazione. Per il resto, il 99% dei plugin di compiz va :)

Avatar utente
francesco bat
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1136
Iscrizione: giovedì 3 luglio 2008, 3:08
Desktop: KDE o IceWM
Distribuzione: PCLinuxOS
Località: Roma
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da francesco bat » mercoledì 15 aprile 2009, 22:50

No, no !
Io non ho Compiz disattivato !!!
Diciamo che alterno l'utilizzo e a volte lo uso e a volte no per prestazioni migliori di velocità.
Io x quando lo uso non ho alcun minimo problema riscontrato e lo uso anche con i massimi effetti senza problemi (tranne un pò più lento a caricarsi all'avvio).
Ciao
Francesco bat
Software Linux
Il forum dei programmi per Linux
http://softwarelinux.italiaforum.net/

giannir1988
Prode Principiante
Messaggi: 148
Iscrizione: mercoledì 17 dicembre 2008, 20:31

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da giannir1988 » giovedì 16 aprile 2009, 8:58

Come detto prima il Compiz mi funziona bene..
Tutti gli effetti partono e non crasciano...compreso finestre 3D...
Comunque c'è poco da fare...tutto dipende da che tipo di scheda video abbiamo...già se si ha una GeForce 440MX o una GeForce 440MX AGP8X cambia tutto...
Io avevo aperto questo post non per mettermi in competizione con altre guide...sò che ci sono molte guide...il mio scopo era quello di raccogliere le suddette guide per facilitare i nuovi utenti che sono costretti a maneggiare questi driver..

Avatar utente
fiero_alleaten
Prode Principiante
Messaggi: 176
Iscrizione: sabato 20 settembre 2008, 0:52
Località: Ancona
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da fiero_alleaten » giovedì 16 aprile 2009, 14:09

Grazie framcesco bat :)

@giannir1988: Beh a me questa guida è stata utile comunque :) Come dicevo nella precedente pagina di post, mi ha risolto il problema con wine. Sui vari modelli di schede non sono esperto, a dir la verità. Io comunque ho una mx440-se

Avatar utente
francesco bat
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1136
Iscrizione: giovedì 3 luglio 2008, 3:08
Desktop: KDE o IceWM
Distribuzione: PCLinuxOS
Località: Roma
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da francesco bat » venerdì 24 aprile 2009, 14:38

Ragazzi, sapete se tutto questo funziona anche con la versione Jaunty Jackalope (Ubuntu 9.04) ?
Io ora ho scaricato la iso ma non l'ho ancora installata xchè ho molto timore di questo problema  ???
L'ho provata da Live e mi funziona bene, ma i driver Nvidia si possono installare solo sulla versione installata.
Qualcuno di voi lo ha già testato ?
Ciao
Francesco bat
Software Linux
Il forum dei programmi per Linux
http://softwarelinux.italiaforum.net/

DaviDM
Prode Principiante
Messaggi: 53
Iscrizione: giovedì 2 agosto 2007, 11:37

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da DaviDM » venerdì 24 aprile 2009, 15:53

ciao a tutti, anche aggiungendo

Codice: Seleziona tutto

Option	"metamodes"	"1024x768	+0+0"
non cambia niente: ogni volta che abilito compiz spariscono i bordi della finestre (quelli con la X per chiudere). E adesso di punto in bianco il terminale non solo non ha i bordi, ma adesso è un rettangolo, bianco; stessa cosa per le notifiche
Io ho una Geforce 2 MX

giannir1988
Prode Principiante
Messaggi: 148
Iscrizione: mercoledì 17 dicembre 2008, 20:31

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da giannir1988 » domenica 26 aprile 2009, 13:53

DaviDM ha scritto: ciao a tutti, anche aggiungendo

Codice: Seleziona tutto

Option	"metamodes"	"1024x768	+0+0"
non cambia niente: ogni volta che abilito compiz spariscono i bordi della finestre (quelli con la X per chiudere). E adesso di punto in bianco il terminale non solo non ha i bordi, ma adesso è un rettangolo, bianco; stessa cosa per le notifiche
Io ho una Geforce 2 MX
Bhe è strano...
Ma mica hai eseguito "nvidia-settings" ? ed hai salvato il file xorg.conf?
Perchè il file deve essere vergine...
Facciamo così...
Prova in questo modo:
esegui il comando :

Codice: Seleziona tutto

 sudo gedit /etc/X11/xorg.conf 
e confronta il contenuto con il mio file xorg:

Codice: Seleziona tutto

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	24
	Option	"AddARGBGLXVisuals"	"True"
	Option	"metamodes"	"1024x768	+0+0"
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection
già se hai qualche riga in pù al 99% il problema è proprio lì...
Al massimo prova a copiarti il mio e vedi se funziona...
Spero di esserti stato utile...ciao

DaviDM
Prode Principiante
Messaggi: 53
Iscrizione: giovedì 2 agosto 2007, 11:37

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da DaviDM » domenica 26 aprile 2009, 15:11

Ho risolto, mancava la riga

Codice: Seleziona tutto

Option	"AddARGBGLXVisuals"	"True"
grazie

DaviDM
Prode Principiante
Messaggi: 53
Iscrizione: giovedì 2 agosto 2007, 11:37

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da DaviDM » lunedì 27 aprile 2009, 11:35

Ho visto sul sito di Nvidia che ci sono i 96.43.11
http://www.nvidia.com/object/linux_disp ... 43.11.html . Io ho i 96.43.10; ho provato ad installare quelli più aggiornati ma non ci sono riuscito
Qualcuno li ha installati? Ha notato qualche differenza con i 96.43.10?

Avatar utente
francesco bat
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1136
Iscrizione: giovedì 3 luglio 2008, 3:08
Desktop: KDE o IceWM
Distribuzione: PCLinuxOS
Località: Roma
Contatti:

Re: [RISOLTO] Soluzione ad alcuni problemi grafici NVIDIA (driver versione 96)

Messaggio da francesco bat » lunedì 27 aprile 2009, 12:53

Ragazzi, volevo aggiungere che installando Jaunty Jackalope funziona tutto benissimo e non c'è stato bisogno di riconfigurare niente  ;D
Evviva il leprotto  ;D
Ciao
Francesco bat
Software Linux
Il forum dei programmi per Linux
http://softwarelinux.italiaforum.net/

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 5 ospiti