[Internet] Internet Key USB HSPA One Touch X060S (RISOLTO)

Riconoscimento, installazione e configurazione delle periferiche.

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » martedì 21 luglio 2009, 7:13

Appena provato...
ridato il comando sudo usb_modeswitch ed ho riottenuto lo stesso messaggio postatoti ieri.
Poi con tasto dx su Applet NetworkManager (versione 0.7.0.100) => nuova connessione a banda larga => nuova configurazione con H3G ricaricabile e... NIENTE  >:(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » martedì 21 luglio 2009, 10:14

fà niente eventualmente usiamo wvdial, te lo mando configurato qual'è il tuo provider internet? comunque quando clicchi "aggiungi" dovresti avere in basso una finestrella con il nome del tuo modem o qualcosa altro scritto dentro, cosa vedi?
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » martedì 21 luglio 2009, 12:42

Il mio provider internet è 3 ricaricabile. Ho riprovato a creare una connessione con la configurazione di applet NetworkManager ma nn si apre alcuna finestra che riporti il nome del modem. Ho provato anche a guardare le proprietà della connessione a banda larga creata ma nn c'è nulla che faccia riferimento al modem!!
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » martedì 21 luglio 2009, 14:25

con tre ricaricabile intendi naviga tre? è importante.
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » martedì 21 luglio 2009, 14:53

si naviga tre. Quando connettevo il cellulare l'APN usato era tre.it  :)
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » martedì 21 luglio 2009, 15:00

strano il naviga tre di solito usa naviga.tre.it ma credo vada bene anche tre.it, ti allego il file wvdial.conf, cambia l'estensione da .txt a .conf e mettilo in /etc, dopo inserisci la chiavetta dai i comandi per caricarla e dopo digita

sudo wvdial

se alla fine ti appaiono i dns sei connesso, apri firefox e spunta "non in linea" se è selezionato dopo dovresti navigare
Allegati
wvdial.txt
(572 Byte) Scaricato 24 volte
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » martedì 21 luglio 2009, 17:13

Nisba Danex..

Ti posto quanto ho fatto e i risultati.

salvo@shadow-laptop:~$ sudo usb_modeswitch
[sudo] password for salvo:

* usb_modeswitch: tool for controlling "flip flop" mode USB devices
* Version 0.9.7beta (C) Josua Dietze 2009
* Works with libusb 0.1.12 and probably other versions

Looking for target devices ...
Found devices in target mode or class (1)
Looking for default devices ...
Found default devices (1)
Prepare switching, accessing device 002 on bus 002 ...
Looking for active driver ...
OK, driver found ("usb-storage")
OK, driver "usb-storage" detached

Setting up communication with interface 0 ...
Trying to send the message to endpoint 0x01 ...

OK, message successfully sent

-> Run lsusb to note any changes. Bye


salvo@shadow-laptop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
salvo@shadow-laptop:~$


salvo@shadow-laptop:~$ lsusb
Bus 002 Device 003: ID 1bbb:0000 T & A Mobile Phones
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 0d7d:0150 Phison Electronics Corp.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 04f2:b008 Chicony Electronics Co., Ltd
salvo@shadow-laptop:~$

:(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » martedì 21 luglio 2009, 17:23

dopo usb_modeswitch devi caricare il modulo modem con

sudo modprobe usbserial vendor=0x1bbb product=0x0000

aspetti 5 sec

poi

sudo wvdial
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

Re: [Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda swn » martedì 21 luglio 2009, 18:14

CaioGiulioCesare ha scritto:Nisba Danex..

Ti posto quanto ho fatto e i risultati.

salvo@shadow-laptop:~$ sudo usb_modeswitch
[sudo] password for salvo:

* usb_modeswitch: tool for controlling "flip flop" mode USB devices
* Version 0.9.7beta (C) Josua Dietze 2009
* Works with libusb 0.1.12 and probably other versions

Looking for target devices ...
Found devices in target mode or class (1)
Looking for default devices ...
Found default devices (1)
Prepare switching, accessing device 002 on bus 002 ...
Looking for active driver ...
OK, driver found ("usb-storage")
OK, driver "usb-storage" detached

Setting up communication with interface 0 ...
Trying to send the message to endpoint 0x01 ...

OK, message successfully sent

-> Run lsusb to note any changes. Bye


salvo@shadow-laptop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
salvo@shadow-laptop:~$


salvo@shadow-laptop:~$ lsusb
Bus 002 Device 003: ID 1bbb:0000 T & A Mobile Phones
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 0d7d:0150 Phison Electronics Corp.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 04f2:b008 Chicony Electronics Co., Ltd
salvo@shadow-laptop:~$

:(




per sicurezza, quando hai switchato da memoria di massa a modem e caricato i vid e pid corretti con modprobe  , prova a dare  :

dmesg | grep tty

e vedere se ti compaiono le  ttyUSB*   relative al modem..

Potrebbe anche essere necessario modificare il file wvdial postato da Danx , modificando la porta dati..
magari non è  la /dev/ttyUSB0

e per lanciare la connessione  usa  :    sudo wvdial
Ultima modifica di swn il martedì 21 luglio 2009, 18:42, modificato 1 volta in totale.
swn
Prode Principiante
 
Messaggi: 48
Iscrizione: luglio 2007

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » mercoledì 22 luglio 2009, 18:26

Ciao Danx, ho dato le linee di codice da te indicate e precisamente:

sudo usb_modeswitch
sudo modprobe usbserial vendor=0x1bbb product=0x0000

Dopo qualche secondo ho dato

sudo wvdial

e il risultato è il seguente:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
--> Sending: ATQ0
--> Re-Sending: ATX3
--> Modem not responding.

Suggerimenti?
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » mercoledì 22 luglio 2009, 18:34

Ciao swn,
ho seguito anche il tuo suggerimento. il comando dmesg | grep tty mi restituisce quanto riporto:

[    0.004000] console [tty0] enabled
[  238.432104] usb 2-5: generic converter now attached to ttyUSB0
[  238.432367] usb 2-5: generic converter now attached to ttyUSB1
[  238.432625] usb 2-5: generic converter now attached to ttyUSB2

Ho provato anche a modificare in wvdial.conf  /dev/ttyUSB0 con USB1 e 2 ma in entrambi i csi l'output reso è:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
+CME ERROR: SIM not inserted
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.

--> Sending: ATX3
ATX3
+CME ERROR: SIM not inserted
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.

--> Sending: ATX3
ATX3
+CME ERROR: SIM not inserted
--> Bad init string.

Una domanda: come fai a riportare il post di altri soggetti? Grazie  :(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » mercoledì 22 luglio 2009, 19:00

questo messaggio "SIM not inserted", controlla di aver inserito bene la sim e che non ci sia il blocco pin, provala su un telefonino, adesso wvdial rileva il modem quindi ci siamo quasi "Initializing modem"
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » mercoledì 22 luglio 2009, 20:03

Allora Danx, ho seguito il tuo consiglio. Ho disabilitato il PIN della scheda, anche se tuttavia preciso che con altra internet key nn mi fa problemi.
Ho dato di seguito i comandi (tralasciando gli output):

sudo usb_modeswitch
sudo modprobe usbserial vendor=0x1bbb product=0x0000
sudo wvdial (preciso che in esso /tty/USB era con lo zero finale quindi /tty(USB0)

ottenendo:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
--> Sending: ATQ0
--> Re-Sending: ATX3
--> Modem not responding.

Poi con sudo gedit /etc/wvdial.conf ho cambiato USB0 in USB1 (come suggerito da swn) e il successivo sudo wvdial ha reso:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK

--> Sending: AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK

--> Sending: at+cgdcont=1,"IP","naviga.tre.it",,0,0
at+cgdcont=1,"IP","naviga.tre.it",,0,0
OK

--> Modem initialized.
--> Sending: ATM1L3DT*99***1#
--> Waiting for carrier.
ATM1L3DT*99***1#
--> Disconnecting at Wed Jul 22 20:22:59 2009

Ho ridato sudo wvdial e l'output è cambiato in:

--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB1: No such file or directory
--> Cannot open /dev/ttyUSB1: No such file or directory
--> Cannot open /dev/ttyUSB1: No such file or directory

Ti posto anche l'output di dmesg | grep tty  se può esser di aiuto:

[    0.004000] console [tty0] enabled
[    4.143667] tty tty29: hash matches
[  319.573495] usb 2-5: generic converter now attached to ttyUSB0
[  319.573749] usb 2-5: generic converter now attached to ttyUSB1
[  319.574069] usb 2-5: generic converter now attached to ttyUSB2
[  477.001987] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[  477.003186] generic ttyUSB2: generic converter now disconnected from ttyUSB2
[  477.011661] generic ttyUSB1: generic converter now disconnected from ttyUSB1
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda swn » mercoledì 22 luglio 2009, 20:32

quale versione di ubuntu hai ? la 9.04 ??  Mi  pare che nel kernel originale ci siano dei problemi con il modulo usbserial...

prova a riavviare il PC.

Fai la procedura suggerita da Danx.

Nel file /etc/wvdial.conf      prova a settare anche la /dev/ttyUSB2  ...

molte volte alcune porte sono dedicate per la comunicazione dati , per gli SMS ,per il GPS, per comandi propietari....

io ho una chiavetta che dovrebbe essere simile alla tua , quella nuova della Digicom... e seguendo le loro FAQ per la compatibilità con Linux   riesco ad utilizzarla correttamente ...

le stesse istruzioni mi sono state utili per altre chiavette che necessitano dell'  switching da memoria di massa a modm.

prova a darci un'occhiata ed a prenderne uno spunto ...

http://www.digicom.it/digisit/faq2.nsf/ ... enDocument

http://www.digicom.it/digisit/faq2.nsf/ ... enDocument
swn
Prode Principiante
 
Messaggi: 48
Iscrizione: luglio 2007

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » mercoledì 22 luglio 2009, 21:45

però se ci fossero problemi di kernel non la riconoscerebbe e basta, io invece direi che ci siamo è solo questione di configurare bene wvdial.conf,
prova a cambiare nel file wvdial.conf questo dato
*99***1#
con questo
*99#
altrimenti se ancora non va copiati il file wvdial.conf attuale sul desktop poi cancella il contenuto di quello in /etc lasciando solo la prima riga poi nel terminale digita

sudo wvdialconf

che andrà a creare un wvdial.conf su misura per la tua chiavetta, dopo lo devi editare aggiungendo le righe relative alla tua connessione, eventualmente postamelo così come è stato creato e te lo configuro
Ultima modifica di Danx il mercoledì 22 luglio 2009, 21:48, modificato 1 volta in totale.
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » mercoledì 22 luglio 2009, 21:54

swn ho guardato quelle guide e devo dire che sono molto interessanti, grazie
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » giovedì 23 luglio 2009, 14:04

Ciao Danx,
ho cambiato il numero in *99# ma nulla... il post è il segunte..

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK
--> Sending: AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: at+cgdcont=1,"IP","naviga.tre.it",,0,0
at+cgdcont=1,"IP","naviga.tre.it",,0,0
OK
--> Modem initialized.
--> Sending: ATM1L3DT*99#
--> Waiting for carrier.
ATM1L3DT*99#
--> Disconnecting at Thu Jul 23 14:39:29 2009

Ho provato a copiare il wvdial su desktop e ho cancellato tutte le righe presenti in /etc/wvdial.conf lasciando solo quella [Dialer Defaults]. Dato il comando sudo wvdialconf ma  >:(.. ti posto l'output di errore:


Editing `/etc/wvdial.conf'.
Scanning your serial ports for a modem.
Modem Port Scan<*1>: S0  S1  S2  S3 

Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?
Please read the FAQ at http://open.nit.ca/wiki/?WvDial
If you still have problems, send mail to .
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » giovedì 23 luglio 2009, 14:09

Ciao swn,
la versione di ubuntu è la 9.04. La marca esatta della chiavetta che stiamo cercando di configurare è ALCATEL One Touch X060S - HSDPA USB Modem. Se metti marca e modello in google come chiave di ricerca si trova il mondo dal punto di vista delle opinioni ma nulla per quanto concerne la configurazione in linux.. data tra l'altro come automatica.

Mi suggerisci di inserire anche /dev/ttyUSB2 ... va aggiunta a quella già presente o devo cambiare solo il numero indicato nella riga presente in wvdial? Se devo cambiare il numero, l'ho fatto ieri con esito negativo. >:(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu


Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » giovedì 23 luglio 2009, 18:46

prova a seguire il punto 3 della guida
http://www.tuxmind.org/2009/04/16/alcat ... -un-pirla/
perchè, a quanto dice, jaunty non permette l'utilizzo di usbserial come modulo da linea di comando, quindi dovresti editare questo file

/boot/grub/menu.lst

aggiungendo alla riga iniziante con

root=etc,etc,etc

relativa al kernel che avvii di solito che dovrebbe essere quello più in alto nel file

la seguente stringa

usbserial.vendor=0x1bbb usbserial.product=0x000

lasciando uno spazio dopo l'ultima opzione

dopo devi riavviare con la chiavetta inserita e dare solo il comando usb_modeswitch seguito da sudo wvdial, (che devi riconfigurare come prima)

come vedi nella stringa ci sono dei punti . non sò esattamente se siano da inserire, comunque ho copiato la stringa esattamente come è nella guida
Ultima modifica di Danx il giovedì 23 luglio 2009, 19:30, modificato 1 volta in totale.
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

PrecedenteSuccessiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 14 ospiti