[Risolto]Scheda WiFi Mediatek MT7630 non funzionante su asus

Riconoscimento, installazione e configurazione delle periferiche.

[Risolto]Scheda WiFi Mediatek MT7630 non funzionante su asus

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 17:08

Ciao , finalmente ho compratoun nuovo notebook , dopo aver sudato 7 camice x installare ubuntu 12.04 ed aver perso irrimediabilmente windows 8 , quindi la garanzia , mi accorgo che vario hardware in ubuntu non funziona , il wi fi e la sheda video Nvidia , leggendo su alcune discussioni si diceva che aggiornarndo il kernel (ho messo il 3.12) potesse risolvere i problemi , così nn è stato , la grafiche è sempre in "low mode" e il wi fi continua a non fuzionare , ecco l'output :
Codice: Seleziona tutto
fabio@fabio-X550CC:~$     lspci -vnn | grep -i net
03:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7630]
04:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 0a)
fabio@fabio-X550CC:~$     sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
[sudo] password for fabio:
E: Impossibile impostare il blocco /var/lib/dpkg/lock - open (11: Risorsa temporaneamente non disponibile)
E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). Un altro processo potrebbe tenerla occupata.
fabio@fabio-X550CC:~$ lsb_release -r; lspci -v; ifconfig; iwconfig
Release:   12.04
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, fast devsel, latency 0
   Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
   I/O behind bridge: 0000e000-0000efff
   Memory behind bridge: f6000000-f70fffff
   Prefetchable memory behind bridge: 00000000e0000000-00000000f1ffffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, fast devsel, latency 0, IRQ 49
   Memory at f7400000 (64-bit, non-prefetchable) [size=4M]
   Memory at d0000000 (64-bit, prefetchable) [size=256M]
   I/O ports at f000 [size=64]
   Expansion ROM at <unassigned> [disabled]
   Capabilities: <access denied>
   Kernel driver in use: i915
   Kernel modules: i915

00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04) (prog-if 30 [XHCI])
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, medium devsel, latency 0, IRQ 43
   Memory at f7a00000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: <access denied>
   Kernel driver in use: xhci_hcd

00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, fast devsel, latency 0, IRQ 47
   Memory at f7a1a000 (64-bit, non-prefetchable) [size=16]
   Capabilities: <access denied>
   Kernel driver in use: mei_me
   Kernel modules: mei-me

00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04) (prog-if 20 [EHCI])
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, medium devsel, latency 0, IRQ 16
   Memory at f7a18000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci-pci

00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
   Subsystem: ASUSTeK Computer Inc. Device 118f
   Flags: bus master, fast devsel, latency 0, IRQ 48
   Memory at f7a10000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
   Memory behind bridge: f7900000-f79fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
   I/O behind bridge: 0000d000-0000dfff
   Memory behind bridge: f7800000-f78fffff
   Prefetchable memory behind bridge: 00000000f2100000-00000000f21fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04) (prog-if 20 [EHCI])
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, medium devsel, latency 0, IRQ 23
   Memory at f7a17000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci-pci

00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, medium devsel, latency 0
   Capabilities: <access denied>
   Kernel driver in use: lpc_ich
   Kernel modules: lpc_ich

00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04) (prog-if 01 [AHCI 1.0])
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 45
   I/O ports at f0b0 [size=8]
   I/O ports at f0a0 [size=4]
   I/O ports at f090 [size=8]
   I/O ports at f080 [size=4]
   I/O ports at f060 [size=32]
   Memory at f7a16000 (32-bit, non-prefetchable) [size=2K]
   Capabilities: <access denied>
   Kernel driver in use: ahci
   Kernel modules: ahci

00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: medium devsel, IRQ 255
   Memory at f7a15000 (64-bit, non-prefetchable) [size=256]
   I/O ports at f040 [size=32]
   Kernel modules: i2c-i801

01:00.0 3D controller: NVIDIA Corporation Device 1298 (rev a1)
   Subsystem: ASUSTeK Computer Inc. Device 124d
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
   Memory at e0000000 (64-bit, prefetchable) [size=256M]
   Memory at f0000000 (64-bit, prefetchable) [size=32M]
   I/O ports at e000 [size=128]
   Expansion ROM at f7000000 [disabled] [size=512K]
   Capabilities: <access denied>
   Kernel driver in use: nvidia
   Kernel modules: nvidia_331, nouveau, nvidiafb

03:00.0 Network controller: MEDIATEK Corp. Device 7630
   Subsystem: Foxconn International, Inc. Device e074
   Flags: bus master, fast devsel, latency 0, IRQ 255
   Memory at f7900000 (32-bit, non-prefetchable) [size=1M]
   Capabilities: <access denied>

04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
   Subsystem: ASUSTeK Computer Inc. Device 202f
   Flags: bus master, fast devsel, latency 0, IRQ 46
   Memory at f7800000 (32-bit, non-prefetchable) [size=64K]
   Capabilities: <access denied>
   Kernel driver in use: rtsx_pci
   Kernel modules: rtsx_pci

04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 0a)
   Subsystem: ASUSTeK Computer Inc. Device 200f
   Flags: bus master, fast devsel, latency 0, IRQ 44
   I/O ports at d000 [size=256]
   Memory at f2104000 (64-bit, prefetchable) [size=4K]
   Memory at f2100000 (64-bit, prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: r8169
   Kernel modules: r8169

eth0      Link encap:Ethernet  IndirizzoHW bc:ee:7b:29:02:46 
          indirizzo inet:192.168.1.3  Bcast:192.168.1.127  Maschera:255.255.255.128
          indirizzo inet6: fe80::beee:7bff:fe29:246/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21659 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16159 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:28902021 (28.9 MB)  Byte TX:1425271 (1.4 MB)

lo        Link encap:Loopback locale 
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:447 errors:0 dropped:0 overruns:0 frame:0
          TX packets:447 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:39988 (39.9 KB)  Byte TX:39988 (39.9 KB)

eth0      no wireless extensions.

lo        no wireless extensions.

fabio@fabio-X550CC:~$     lspci -vnn | grep -i net
03:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7630]
04:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 0a)
fabio@fabio-X550CC:~$

Qualcuno mi può aiutare ?
Ultima modifica di CuOrEnErO il venerdì 11 luglio 2014, 21:52, modificato 3 volte in totale.
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda Pike » domenica 9 febbraio 2014, 17:19

Codice: Seleziona tutto
uname -r
?
Non capisco però perchè dai
Codice: Seleziona tutto
sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

quando la tua wifi è una Ralink/mediatek...
Ultima modifica di Pike il domenica 9 febbraio 2014, 17:23, modificato 1 volta in totale.
Incivile e maleducato. Come certificato dalla moderazione. You have been warned
Pigroidiorazione. Non fallisce MAI. Anche a 134 giorni di distanza ha l'utilità di un cucchiaio per aprire una lattina.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2932
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Xenial Xerus i686 (16.04.1)

Re: Vario Hardware non funzionante su asus f550c

Messaggioda dataghoul » domenica 9 febbraio 2014, 17:22

ho un F550CC, che è stretto parente del tuo, e per il WiFi ho risolto con le istruzioni che seguono:

ho trovato sul forum inglese la soluzione:
http://askubuntu.com/questions/351594/w ... re-switch/

in pratica bisogna controllare l'output del comando:

lsmod | grep asus

e poi si prova a cambiare il parametro indicato a partire da 0 fino ad arrivare a 4, dando questa serie di comandi:

sudo -i
echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf
exitsudo

al riavvio Fn+F2 dovrebbe permettere di avviare subito la wifi.

A me ha funzionato al primo colpo con il parametro wapf=1
"Before you diagnose yourself with depression or low self-esteem, first make sure that you are not, in fact, simply surrounded by assholes."
(William Gibson)
Avatar utente
dataghoul
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 288
Iscrizione: maggio 2009
Località: fluttuante nella rete
Desktop: Gnome
Distribuzione: Ubuntu 17.10
Sesso: Maschile

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 17:24

@pike
Codice: Seleziona tutto
fabio@fabio-X550CC:~$     uname -r
3.12.0-031200-generic
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 17:30

@ data , quale di questi parametri ? mi sembrano già ad 1
Codice: Seleziona tutto
fabio@fabio-X550CC:~$ lsmod | grep asus
asus_nb_wmi            16990  0
asus_wmi               24794  1 asus_nb_wmi
sparse_keymap          13890  1 asus_wmi
wmi                    19363  2 asus_wmi,mxm_wmi
video                  19574  2 i915,asus_wmi
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 17:36

l'ho fatto ma mi sembra ancora ad 1 ora provo a riavviare ...
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 18:43

Sono arrivato fino a 4 ma nn funziona , l'unica differenza è che al passo il led del wifi è già spento e rimane spento ... in tutti gli altri casi è già acceso ma anche con fn+f2 noncambia nulla ... in nessun caso ....
Sembrerebbe che il mio hw wifi non è supportato in ubuntu ... possibile ?
Codice: Seleziona tutto
03:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7630]

ora che si fa ? non c resta che piangere
:cry:
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda Pike » domenica 9 febbraio 2014, 18:55

O andare sul sito di Mediatek e scaricare il driver??? :D
Incivile e maleducato. Come certificato dalla moderazione. You have been warned
Pigroidiorazione. Non fallisce MAI. Anche a 134 giorni di distanza ha l'utilità di un cucchiaio per aprire una lattina.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2932
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Xenial Xerus i686 (16.04.1)

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 20:04

sembra che ancora nn c sia una soluzione ....
bug
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda rocco basco » domenica 9 febbraio 2014, 20:12

Anche io ho lo stesso identico problema, ho guardato tutti i forum e ho provato a fare quello che suggeriscono: installare i driver backports-3.11.6-1, modificare la blacklist.conf, modificare il valore di asus_nb_wmi wapf da 1 a 4, installare i driver di windows tramite Ndiswrapper; ma niente non funziona!! il led della scheda wirless è sempre acceso (tranne se si imposta il valore 4 o si modifica la blacklist.conf, allora si spegne) ma non da segni di vita.
La scheda è una Mediatek MT7630E 802.11bgn Wi-Fi Adapter, sul sito di Mediatek non esistono drivers per linux e comunque non è permesso il download, ma è necessario contattarli per mail.
Vi prego aiutatemi a risolvere il problema: tornare a windows dopo anni di ubuntu sarebbe davvero un trauma!

Grazie
rocco basco
Prode Principiante
 
Messaggi: 8
Iscrizione: febbraio 2014
Desktop: Unity
Distribuzione: Ubuntu 14.04.1 LTS x86_64

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » domenica 9 febbraio 2014, 20:22

Anche io ho lo stesso identico problema, ho guardato tutti i forum e ho provato a fare quello che suggeriscono: installare i driver backports-3.11.6-1, modificare la blacklist.conf, modificare il valore di asus_nb_wmi wapf da 1 a 4, installare i driver di windows tramite Ndiswrapper; ma niente non funziona!! il led della scheda wirless è sempre acceso (tranne se si imposta il valore 4 o si modifica la blacklist.conf, allora si spegne) ma non da segni di vita.
La scheda è una Mediatek MT7630E 802.11bgn Wi-Fi Adapter, sul sito di Mediatek non esistono drivers per linux e comunque non è permesso il download, ma è necessario contattarli per mail.
Vi prego aiutatemi a risolvere il problema: tornare a windows dopo anni di ubuntu sarebbe davvero un trauma!

Grazie

Mi Associo .... , oltretutto nn posso tornare a windows
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda Pike » domenica 9 febbraio 2014, 20:43

rocco basco Immagine ha scritto:La scheda è una Mediatek MT7630E 802.11bgn Wi-Fi Adapter, sul sito di Mediatek non esistono drivers per linux

http://www.mediatek.com/_en/07_downloads/01_windows.php?sn=501

rocco basco Immagine ha scritto:e comunque non è permesso il download, ma è necessario contattarli per mail.

Mica sempre....
ftp://ftp.hp.com/pub/softpaq/sp63501-64000/sp63656.tar
sono per SLES e sono in RPM... ma sai mai che dentro ci sia una soluzione al problema...

Qualcuno sostiene
http://h30434.www3.hp.com/t5/Wireless-Internet-Home-Networking/ProBook-400-series-Mediatek-MT7630e-linux-driver/td-p/3486695
che non ci sia troppa differenza tra la MT7360 e le rt2800...

Ma in ogni caso mi domando:
E allora quanto vale questa informazione?
http://www.ubuntu.com/certification/catalog/component/pci/14c3:7630/
Incivile e maleducato. Come certificato dalla moderazione. You have been warned
Pigroidiorazione. Non fallisce MAI. Anche a 134 giorni di distanza ha l'utilità di un cucchiaio per aprire una lattina.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2932
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Xenial Xerus i686 (16.04.1)

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » lunedì 10 febbraio 2014, 0:13

ciao pike , allora cosa ci consigli di fare ?
Il wi fi nob va , mediatek nn rilascia drivers linux per questa scheda e nemmeno x la 28xx e quei files non si possono usare x ubuntu ....
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » lunedì 10 febbraio 2014, 8:46

Se qualcuno mi spiega come provare ad adattare questi driver , io c posso provare ...

Mica sempre....
ftp://ftp.hp.com/pub/softpaq/sp63501-64000/sp63656.tar
sono per SLES e sono in RPM... ma sai mai che dentro ci sia una soluzione al problema...
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda rocco basco » lunedì 10 febbraio 2014, 12:49

CuOrEnErO Immagine ha scritto:Se qualcuno mi spiega come provare ad adattare questi driver , io c posso provare ...

Mica sempre....
ftp://ftp.hp.com/pub/softpaq/sp63501-64000/sp63656.tar
sono per SLES e sono in RPM... ma sai mai che dentro ci sia una soluzione al problema...


Premetto che io non ne capisco molto di ubuntu e dei comandi da terminale, pertanto quando faccio qualcosa non so mai cosa sto facendo e se quello che faccio ha senso o meno.
Io ho provato a convertire quei file rpm in deb ed installarli, ma così non funziona.
Io non so che pesci prendere, per il momento l'unica soluzione che mi viene in mente è quella di comprare una pendrive wirless per connettermi da Ubuntu, in attesa che si risolva il problema con la scheda di rete.
Se c'è qualche anima buona che avesse la competenze (che io non ho) e la pazienza di aiutarci gli erigo un monumento.

Saluti
rocco basco
Prode Principiante
 
Messaggi: 8
Iscrizione: febbraio 2014
Desktop: Unity
Distribuzione: Ubuntu 14.04.1 LTS x86_64

Re: Vario Hardware non funzionante su asus f550c

Messaggioda CuOrEnErO » lunedì 10 febbraio 2014, 13:59

per il momento l'unica soluzione che mi viene in mente è quella di comprare una pendrive wirless per connettermi da Ubuntu

Per fortuna io avevo già una pennetta usb wifi d-link e sto usando quella nell'attesa di risolvere ....
Nel frattempo io provo a mandare una mail x richiedere i drivers x linux a Mediatek (ho poche speranze che lo facciano ) , comunque se anche tu rocco li rihiedi , potremmo avere qualche possibilità in più .
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Vario Hardware non funzionante su asus f550c

Messaggioda rocco basco » lunedì 10 febbraio 2014, 16:41

CuOrEnErO Immagine ha scritto:
Nel frattempo io provo a mandare una mail x richiedere i drivers x linux a Mediatek (ho poche speranze che lo facciano ) , comunque se anche tu rocco li rihiedi , potremmo avere qualche possibilità in più .


Certo, scriverò una mail anche io a Mediatek e speriamo bene.
rocco basco
Prode Principiante
 
Messaggi: 8
Iscrizione: febbraio 2014
Desktop: Unity
Distribuzione: Ubuntu 14.04.1 LTS x86_64

Re: Scheda WiFi Mediatek non funzionante su asus f550c

Messaggioda CuOrEnErO » lunedì 10 febbraio 2014, 20:01

Sembra che la soluzione di adattare i drivers mt 2800 non funzioni .... :
qui
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: Scheda WiFi Mediatek non funzionante su asus f550c

Messaggioda Pike » lunedì 10 febbraio 2014, 23:22

A questo punto, nell'attesa che Mediatek faccia qualcosa, si possono percorrere 3 strade:
strada 1: trasformazione dell'RPM con alien in .deb.
strada 2: estrazione della roba presente nell'RPM per analizzarla meglio
strada 3: ndiswrapper e driver Windows, che è disponibile per quella scheda.
Incivile e maleducato. Come certificato dalla moderazione. You have been warned
Pigroidiorazione. Non fallisce MAI. Anche a 134 giorni di distanza ha l'utilità di un cucchiaio per aprire una lattina.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2932
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Xenial Xerus i686 (16.04.1)

Re: Scheda WiFi Mediatek non funzionante su asus f550c

Messaggioda CuOrEnErO » lunedì 10 febbraio 2014, 23:42

Per la strada 2 mi sto attrezzando (ora che ho scoperto l'esistenza di alien ) , mentre nel passo 1 avevo già visto che all'nterno dell'archivio ci sono 2 files rpm , il secondo dei 2 contiene dei files .ko che se non ricordo male servono per compilare il kerne?? , pike , devi capire che nn siamo informatici e non arriviamo a risolvere tutto ...
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: chaoz4ngel, Google [Bot], Majestic-12 [Bot] e 22 ospiti