[Risolto]Scheda WiFi Mediatek MT7630 non funzionante su asus

Riconoscimento, installazione e configurazione delle periferiche.

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda amivaleo » giovedì 10 marzo 2016, 20:18

CuOrEnErO Immagine ha scritto:Finalmente è arrivata ed ho montato la Intel Centrino 2230 , tutto ha funzionato perfettamente da subito .... penso d'aver definitivamente risolto i problemi con mediatek sia per quanto riguarda WI-FI che BT . Posso consigliare a tutti di fare questa operazione ed anche di NON ACQUISTARE pc con componenti MEDIATEK , soprattutto se poi avete intenzione di usare un OS linux .

:)
Vedi? Quel sito funzia bene! Impiega solo un sacco di tempo per farti arrivare gli acquisti.
:ciao:
Avatar utente
amivaleo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 512
Iscrizione: maggio 2010
Desktop: Gnome-Shell
Distribuzione: Gnome-Ubuntu 16.04 64bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda CuOrEnErO » giovedì 10 marzo 2016, 20:28

Ziel van Brand Immagine ha scritto:
CuOrEnErO Immagine ha scritto:Finalmente è arrivata ed ho montato la Intel Centrino 2230 , tutto ha funzionato perfettamente da subito .... penso d'aver definitivamente risolto i problemi con mediatek sia per quanto riguarda WI-FI che BT . Posso consigliare a tutti di fare questa operazione ed anche di NON ACQUISTARE pc con componenti MEDIATEK , soprattutto se poi avete intenzione di usare un OS linux .

:)
Vedi? Quel sito funzia bene! Impiega solo un sacco di tempo per farti arrivare gli acquisti.

Ottimo , ho già comprato molti altri oggetti ...
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda trekfan1 » venerdì 11 marzo 2016, 10:19

Anche io ho mandato a prendere la scheda INTEL centrino 2230, arrivata, montata, tutto ok
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16321
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 17.10 e 18.04 (dev) 64 bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda amivaleo » venerdì 11 marzo 2016, 10:30

:D
Il mio endorsement su questa schedina Intel ha dato ottimi frutti! :)
:ciao:
Avatar utente
amivaleo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 512
Iscrizione: maggio 2010
Desktop: Gnome-Shell
Distribuzione: Gnome-Ubuntu 16.04 64bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda dubjules » venerdì 20 maggio 2016, 14:08

Ziel van Brand Immagine ha scritto:Tra i nuovi aggiornamenti di oggi c'era il nuovo kernel 4.4 che sarà di default su Ubuntu 16.04.
I driver che ho linkato di questa maledetta scheda di rete non funzionano più. Tuttavia qualche buona persona li ha già modificati per renderli compatibili ( https://github.com/benjarobin/MT7630E ).
Con un buon copia-incolla sono quindi riuscito anche stavolta ad ottenere dei driver funzionanti. Potete scaricarli da qui: https://drive.google.com/open?id=0By0xI ... 1h0RnUybTA
Le istruzioni per l'installazione sono ancora una volta contenute dentro il file LEGGIMI. Sono rimaste le stesse.

Inutile dirlo: anche stavolta il bluetooth non funziona.
Spero comunque che questi driver possano tornarvi utili, magari in attesa di un'altra scheda di rete, come è il caso del sottoscritto. :devilmad:



Con ubuntu 14.04 utilizzavo anche io questa procedura sul mio ASUS, ora che sono passata ad ubuntu 16 invece, neanche questi driver mi fanno avere internet.. uffi!! come posso fare?
dubjules
Prode Principiante
 
Messaggi: 57
Iscrizione: maggio 2014
Distribuzione: Ubuntu 16.4

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda CuOrEnErO » venerdì 20 maggio 2016, 14:54

dubjules Immagine ha scritto:
Ziel van Brand Immagine ha scritto:Tra i nuovi aggiornamenti di oggi c'era il nuovo kernel 4.4 che sarà di default su Ubuntu 16.04.
I driver che ho linkato di questa maledetta scheda di rete non funzionano più. Tuttavia qualche buona persona li ha già modificati per renderli compatibili ( https://github.com/benjarobin/MT7630E ).
Con un buon copia-incolla sono quindi riuscito anche stavolta ad ottenere dei driver funzionanti. Potete scaricarli da qui: https://drive.google.com/open?id=0By0xI ... 1h0RnUybTA
Le istruzioni per l'installazione sono ancora una volta contenute dentro il file LEGGIMI. Sono rimaste le stesse.

Inutile dirlo: anche stavolta il bluetooth non funziona.
Spero comunque che questi driver possano tornarvi utili, magari in attesa di un'altra scheda di rete, come è il caso del sottoscritto. :devilmad:



Con ubuntu 14.04 utilizzavo anche io questa procedura sul mio ASUS, ora che sono passata ad ubuntu 16 invece, neanche questi driver mi fanno avere internet.. uffi!! come posso fare?

Sostituisci la scheda ;)
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda dubjules » venerdì 20 maggio 2016, 18:05

=_=
dubjules
Prode Principiante
 
Messaggi: 57
Iscrizione: maggio 2014
Distribuzione: Ubuntu 16.4

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda CuOrEnErO » venerdì 20 maggio 2016, 18:18

dubjules Immagine ha scritto:=_=

Altrimenti non ne esci piu..... se guardi qualche post precedente trovi anche un modello di scheda che funziona perfettamente
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda amivaleo » venerdì 20 maggio 2016, 18:41

Condivido il consiglio di cambiare scheda.
Non è la soluzione al problema, ma un modo per aggirarlo, me ne rendo conto. Credimi però, non ne esci avvero altrimenti.
:ciao:
Avatar utente
amivaleo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 512
Iscrizione: maggio 2010
Desktop: Gnome-Shell
Distribuzione: Gnome-Ubuntu 16.04 64bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda CuOrEnErO » sabato 21 maggio 2016, 21:47

dubjules Immagine ha scritto:
Ziel van Brand Immagine ha scritto:Tra i nuovi aggiornamenti di oggi c'era il nuovo kernel 4.4 che sarà di default su Ubuntu 16.04.
I driver che ho linkato di [url=http://ubuntuforums.org/showthread.php?t=2300107&page=2&s=44e67eee9d96684c8e55f1df45484392][url=http://ubuntuforums.org/showthread.php?t=2300107&page=2&s=44e67eee9d96684c8e55f1df45484392]questa[/url][/url] maledetta scheda di rete non funzionano più. Tuttavia qualche buona persona li ha già modificati per renderli compatibili ( https://github.com/benjarobin/MT7630E ).
Con un buon copia-incolla sono quindi riuscito anche stavolta ad ottenere dei driver funzionanti. Potete scaricarli da qui: https://drive.google.com/open?id=0By0xI ... 1h0RnUybTA
Le istruzioni per l'installazione sono ancora una volta contenute dentro il file LEGGIMI. Sono rimaste le stesse.

Inutile dirlo: anche stavolta il bluetooth non funziona.
Spero comunque che questi driver possano tornarvi utili, magari in attesa di un'altra scheda di rete, come è il caso del sottoscritto. :devilmad:



Con ubuntu 14.04 utilizzavo anche io questa procedura sul mio ASUS, ora che sono passata ad ubuntu 16 invece, neanche questi driver mi fanno avere internet.. uffi!! come posso fare?


Comunque se vuoi farti del male , ho trovato questa guida che funziona col kernel 4.4.0-22-generic :
Devi dare questi comandi da terminale , 1 alla volta .. con me ha funzionato , ogni aggiornamento del kernel devi ripetere le ultime 3 righe ....ora posso togliere nuovamente la scheda e rimmetterne una decente ;) .
Codice: Seleziona tutto
sudo apt-get install --reinstall git linux-headers-$(uname -r) build-essential dkms
git clone https://github.com/neurobin/MT7630E/
cd MT7630E/
make
sudo make install


Il bluetooth non funziona .
Da qualche parte ho letto : Hai mac ? ->Hai soldi da buttare! , Hai Linux ? ->Hai tempo da buttare , Hai Windows ? -> Hai soldi e tempo da Buttare ----- Calzante no ???
Avatar utente
CuOrEnErO
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1248
Iscrizione: settembre 2009
Desktop: Ubuntu16.04 Xubuntu16.04

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda dubjules » domenica 22 maggio 2016, 8:34

niente da fare.. in realtà credo che non sia solo un problema di mediatek, ma anche sistema operativo, perchè mi dice che i pacchetti non hanno le giuste dipendenze e non riesce ad aggiornarsi.
dubjules
Prode Principiante
 
Messaggi: 57
Iscrizione: maggio 2014
Distribuzione: Ubuntu 16.4

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda trekfan1 » domenica 22 maggio 2016, 9:30

@dubjules come ti ha già suggerito cuorenero cambia la schedina wifi (costa pochi euro) e tieni la mediatek da parte in caso di problemi hardware (se il pc è ancora in garanzia). Anche io ho dovuto fare così sul mio portatile HP Probook 450G1 (ovviamente ho rimesso dentro al G1 la mediatek e mi sono tenuto la INTEL), ora sono passato al 450G2 e per fortuna c'è un'altra schedina wifi che con ubuntu funziona.
Codice: Seleziona tutto
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp8s0 state: down mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16321
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 17.10 e 18.04 (dev) 64 bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda vetto-91 » venerdì 3 giugno 2016, 22:48

Ciao ragazzi! Io sono riuscito a risolvere in questo modo, spero possa servire a qualcuno!

Codice: Seleziona tutto
cd
sudo apt-get install --reinstall git linux-headers-$(uname -r) build-essential dkms
git clone https://github.com/neurobin/MT7630E/
cd MT7630E/
make
sudo make install
sudo reboot


Non sono molto esperto ma queste istruzione installano i pacchetti necessari alla compilazione, per il vostro kernel (3,13 & 3.16 funzionano a me), dopo di che scarica il driver e lo compila poi riavvia! In questo modo al login funziona la scheda wifi. L'unica pecca è che ogni volta che il sistema aggiorna il kernel, perde il driver (penso sia sotto forma di modulo) e quindi va rinstallato. Io per velocità ho creato un piccolo script eseguibile sulla scrivania per installare il driver, in questo caso:
Codice: Seleziona tutto
#!/bin/bash

cd ~/MT7630E
make
sudo make install
sudo reboot


Ora mi chiedo, anche se è un modo semplice e veloce per installare i driver, c'è qualcuno che riuscirebbe ad avviare questa script ad ogni avvio, di modo che i driver vengano caricati nel kernel nuovo, qualora venga aggiornato?

Spero di essere stato d'aiuto per il momento, e cito la fonte che mi è stata utilissima, e ringrazio il forum di ubuntu inglese:
http://ubuntuforums.org/showthread.php? ... eb01a32566

Saluti! :ciao:
vetto-91
Prode Principiante
 
Messaggi: 2
Iscrizione: febbraio 2013
Desktop: Unity & Gnome
Distribuzione: Ubunut Desktop 12.04 LTS x64

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda steff » venerdì 3 giugno 2016, 23:05

Per lo script dovresti aprire una discussione in programmazione, sarebbe meglio.
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36643
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda vetto-91 » venerdì 3 giugno 2016, 23:56

steff Immagine ha scritto:Per lo script dovresti aprire una discussione in programmazione, sarebbe meglio.


Potrei aprire una nuova discussione in programmazione e fare riferimento a questa? Potrebbe andare?
vetto-91
Prode Principiante
 
Messaggi: 2
Iscrizione: febbraio 2013
Desktop: Unity & Gnome
Distribuzione: Ubunut Desktop 12.04 LTS x64

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda steff » sabato 4 giugno 2016, 8:21

Sì, come no.
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36643
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda Random95 » sabato 12 novembre 2016, 16:25

Anche se la conversazione è molto vecchia, vorrei chiedervi come siete riusciti a risolvere il problema. Mi trovo nella stessa vostra stessa situazione e non riesco proprio a far funzionare il wifi
Random95
Prode Principiante
 
Messaggi: 9
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.1 LTS
Sesso: Femminile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda amivaleo » sabato 12 novembre 2016, 16:25

Ho cambiato scheda...
:ciao:
Avatar utente
amivaleo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 512
Iscrizione: maggio 2010
Desktop: Gnome-Shell
Distribuzione: Gnome-Ubuntu 16.04 64bit
Sesso: Maschile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda Random95 » sabato 12 novembre 2016, 16:38

Ziel van Brand Immagine ha scritto:Ho cambiato scheda...


Quindi se non cambio scheda non avrò la possibilità di risolvere il problema?
Random95
Prode Principiante
 
Messaggi: 9
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.1 LTS
Sesso: Femminile

Re: [Risolto]Scheda WiFi Mediatek MT7630 non funzionante su

Messaggioda amivaleo » sabato 12 novembre 2016, 16:39

Non so. Da quando ho cambiato scheda, non mi sono più interessato a questa.
:ciao:
Avatar utente
amivaleo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 512
Iscrizione: maggio 2010
Desktop: Gnome-Shell
Distribuzione: Gnome-Ubuntu 16.04 64bit
Sesso: Maschile

PrecedenteSuccessiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 7 ospiti