[Risolto]Ubuntu 14.04 LTS - Parallels - Problema Risoluzione

Riconoscimento, installazione e configurazione delle periferiche.

[Risolto]Ubuntu 14.04 LTS - Parallels - Problema Risoluzione

Messaggioda TriderG7 » martedì 22 aprile 2014, 22:04

Ciao a tutti,
sto utilizzando un macbook pro 13" mid2010 7.1 con 16GB di RAM, ed ho installato 2 macchine virtuali su Parallels Desktop 9.0.23350 una con windows XP SP3 ed una con Win7 Ultimate, perfettamente funzionanti.

Aspettavo da tempo l'uscita della versione stabile di Ubuntu 14.04 LTS per poterlo installare come macchina virtuale (e tornare a smanettare su Ubuntu Linux), così ho scaricato la iso a 64bit e l'ho installata senza problemi.

L'unico problema riscontrato è relativo alla risoluzione video, bloccata a 800x600.
Spero di trovare una soluzione al problema e che possa essere d'aiuto a chi sta cercando di far funzionare a perfezione Ubuntu su macchina virtuale sotto Mac OS X 10.9.2.

EDIT: PROBLEMA RISOLTO, ANDATE DIRETTAMENTE IN FONDO ALLA DISCUSSIONE, ALL'ULTIMO THREAD
INOLTRE HO TROVATO LA RISOLUZIONE AL PROBLEMA DI UNITY E LA BARRA DEI MENU SCOMPARSI DOPO L'INSTALLAZIONE DI PARALLELS TOOLS


:D :D :D :D :D


Vi elenco quello che ho fatto fin'ora:

Per prima cosa ho installato Parallels Tools, ma montando l'unità virtuale e installando riscontro un problema non meglio identificato.
Scopro che per la versione in uso di Parallels Desktop 9.0.23350 esiste una patch da installare. Ho seguito senza problemi
questa guida, e sembra che si installi alla perfezione -> http://forum.parallels.com/showthread.p ... u-14-04%29

Riavviando, non trovo però nuove risoluzioni video disponibili.

Adesso sto tentando di aggiungere nuove modalità video con il comando xrandr ma mi viene restituito un errore: "Failed to get size of gamma for output default". Una cosa che mi è parsa strana (avendo usato Ubuntu in passato) è stata non trovare in /etc/X11 il file xorg.conf. Ho provato a lanciare il comando "sudo dpkg-reconfigure xserver-xorg", non viene restituito alcun output e torno rapidamente al prompt senza errori

Dicevo che ho provato ad aggiungere nuove risoluzioni video con i comandi:
cvt 1280 800
poi copio l'output
ed uso il comando "sudo xrandr --newmode "1280x800_60.00" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +VSync

e di nuovo l'errore "Failed to get size of gamma for output default"

Qualcuno sa come fare?

Edit:
Output del comando "lspci | grep VGA"
Codice: Seleziona tutto
samfisher@ubuntu:/etc/X11$ lspci |grep VGA
01:00.0 VGA compatible controller: Parallels, Inc. Accelerated Virtual Video Adapter


Output del comando "xrandr" (n.b. la seconda risoluzione di 1280x800 sarebbe quella nativa del monitor, l'ho aggiunta ma non funziona). Dal pannello monitor di impostazioni di sistema, posso selezionare due risoluzioni (dopo smanettamenti), oltre alla 800x600 4:3 anche 1280x800 16:10. Ma se seleziono la seconda ottengo l'errore: "Non è possibile applicare la configurazione selezionata per i display. la dimensione virtuale richiesta non è adatta per la dimensione disponibile: richiesta=(1280, 800), minima=(800, 600), massima=(800, 600)"

Codice: Seleziona tutto
samfisher@ubuntu:/etc/X11$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 1280 x 800
default connected primary 800x600+0+0 0mm x 0mm
   800x600        75.0*
   1280x800_60.00   60.0 


Output del comando "cvt 1280 800":
Codice: Seleziona tutto
samfisher@ubuntu:/etc/X11$ cvt 1280 800
# 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync


Il comando "sudo dpkg-reconfigure xserver-xorg" non fa nulla, non viene creato in /etc/X11 il file xorg.conf e non restituisce alcun output.
Ultima modifica di TriderG7 il venerdì 25 aprile 2014, 2:45, modificato 8 volte in totale.
TriderG7
Prode Principiante
 
Messaggi: 3
Iscrizione: aprile 2014

Re: Ubuntu 14.04 LTS - Parallels - Problema Risoluzione

Messaggioda maxbigsi » martedì 22 aprile 2014, 22:25

il file xorg.conf non esiste più già da parecchio, nonostante questo in alcune rare situazioni ho creato io stesso uno xorg.conf per sistemare la risoluzione su qualche macchina virtuale in passato, ma su virtualbox... prova a crearlo manualmente ispirandoti al wiki e mettendo la risoluzione ideale del tuo monitor... Hardware/Video/Xorg ... (è un tentativo) ;)
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16557
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

Re: Ubuntu 14.04 LTS - Parallels - Problema Risoluzione

Messaggioda TriderG7 » martedì 22 aprile 2014, 22:31

grazie per la gentilissima risposta, non lo sapevo :P Ho usato Ubuntu anni fa.
Non capisco la causa dell'errore che mi appare in continuazione. Provo a seguire i tuoi consigli.
Edit:
Il comando xrandr --newmode (come da wiki) mi restituisce sempre questo errore (provato anche con "sudo" davanti):
Codice: Seleziona tutto
samfisher@ubuntu:/etc/X11$ xrandr --newmode "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19


Dal comando "xrandr | grep connected" ottengo il nome dell'uscita video, nel mio caso "default".
Codice: Seleziona tutto
samfisher@ubuntu:/etc/X11$ xrandr|grep connected
xrandr: Failed to get size of gamma for output default
default connected primary 800x600+0+0 0mm x 0mm


Sulla base di uno xorg.conf trovato qui: http://forum.parallels.com/showthread.p ... g-ABI-tips
ho creato in /etc/X11 il file xorg.conf in questo modo, adesso in impostazioni->monitor l'unica risoluzione
selezionabile è 800x600 4:3 (è scomparsa la 1280x800 16:10 risultata da smanettamenti, ma comunque non funzionante):

Codice: Seleziona tutto
# X.Org server configuration file generated by Parallels Guest Tools.
#

# Parallels Video section
Section "Device"
   Identifier   "Parallels Video"
   Driver   "prlvideo"
EndSection

# Parallels Monitor section
Section "Monitor"
   Identifier   "Parallels Monitor"
   VendorName   "Parallels Inc."
   ModelName   "Parallels Monitor"
#questa l'ho editata con l'output del comando cvt 1280 800 60
        Modeline "1280x800_60.00" 83.50 1280 1352 1480 1680 800 803 809 831 -hsync +vsync
EndSection

# Parallels Screen section
Section "Screen"
   Identifier   "Parallels Screen"
   Device   "Parallels Video"
   Monitor   "Parallels Monitor"
   Option   "NoMTRR"
   SubSection   "Display"
      Depth   24
      Modes   "1280x800_60.00" "800x600"
   EndSubSection
EndSection

# DefaultFlags section
Section "ServerFlags"
   Option   "AllowEmptyInput"   "yes"
   Option   "AutoAddDevices"   "yes"
EndSection

# DefaultLayout section
Section "ServerLayout"
   Identifier   "DefaultLayout"
   Screen   "Parallels Screen"
EndSection


Non ho ancora capito se i Parallels Tools sono perfettamente installati (l'installazione dopo l'applicazione della patch va a buon fine), non viene creato in automatico il file xorg.conf (quello qui sopra l'ho creato io e messo su /etc/X11)
TriderG7
Prode Principiante
 
Messaggi: 3
Iscrizione: aprile 2014

Re: Ubuntu 14.04 LTS - Parallels - Problema Risoluzione

Messaggioda TriderG7 » mercoledì 23 aprile 2014, 3:28

Ho quasi risolto installando una versione più recente di parallels desktop 9.0.24229.
In realtà funzionava tutto, la risoluzione adesso è corretta (dopo aver reinstallato i Parallels Tools)...
...poi per cercare di capire se il file xorg.conf servisse o meno l'ho rinominato in xorg.conf.old
da allora non vedo più la barra laterale di Unity, vedo solo le poche icone che erano presenti sul desktop.
La cosa assurda è che riposizionando il file xorg.conf al suo posto continua a non funzionare!!!!!
Non vorrei reinstallare avete idee?

ATTENZIONE: chi dovesse riscontrare problemi di risoluzione dopo l'installazione di Ubuntu 14.04 su Parallels Desktop per Mac OS X: ho risolto aggiornando Parallels Desktop all'ultima versione e reinstallando Parallels Tools.

RISOLUZIONE DEL PROBLEMA DELLA BARRA DEI MENU E DI UNITY SCOMPARSI:


Press Ctrl+Alt+T to open a terminal window.
At the terminal prompt, type ccsm. If the CompizConfig Settings Manager window appears, skip to step 5. If not, continue with step 3.
Type sudo apt-get install compizconfig-settings-manager. Type your password when prompted.
At the next terminal prompt, type ccsm.
In CompizConfig Settings Manager, select the check box for the OpenGL plugin if it isn't already selected.
Click the Ubuntu Unity Plugin item.
Select the Enable Ubuntu Unity Plugin check box, if it isn't already selected. If it is already selected then uncheck this and again select it.
Exit from the CompizConfig Settings Manager.
Press Ctrl+Alt+Delete. When asked, confirm that you want to log out.
I did a cold reboot at this point. I'm not sure it's necessary, but I'm a bit paranoid.
After this, Unity came up as it's supposed to for me.

da questa discussione: http://askubuntu.com/questions/285779/a ... ot-showing

ADESSO FUNZIONA TUTTO :)
TriderG7
Prode Principiante
 
Messaggi: 3
Iscrizione: aprile 2014


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti