[Risolto] Error mounting /dev/sdc1

Riconoscimento, installazione e configurazione delle periferiche.

[Risolto] Error mounting /dev/sdc1

Messaggioda ghiltanas » sabato 7 giugno 2014, 14:50

Ho un grosso problema, che spero (e devo) risolvere in fretta

Error mounting /dev/sdc1 at /media/marco/Dati Linux: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdc1" "/media/marco/Dati Linux"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

il pc era sospeso, io non me lo sono ricordato e ho staccato la spina.
Adesso non posso più accedere a questo hd che è quello dati (l'os, ubuntu 14.04 adesso, lo tengo su un hd a se).
Come risolvo?
Ultima modifica di ghiltanas il sabato 7 giugno 2014, 22:24, modificato 1 volta in totale.
ghiltanas
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2013
Distribuzione: Ubuntu 14.04 x86_64

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda daigo » sabato 7 giugno 2014, 15:23

Codice: Seleziona tutto
sudo e2fsck -f /dev/sdc1

Codice: Seleziona tutto
sudo resize2fs /dev/sdc1
?
daigo
 

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda ghiltanas » sabato 7 giugno 2014, 15:43

ora provo. Non tocca i dati vero?
ghiltanas
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2013
Distribuzione: Ubuntu 14.04 x86_64

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda daigo » sabato 7 giugno 2014, 15:45

Che io sappia no
daigo
 

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda ghiltanas » sabato 7 giugno 2014, 16:08

allora, il check me l'ha fatto, ma il resize no:

[code2=shell]e2fsck 1.42.9 (4-Feb-2014)
ext2fs_open2: Bad magic number in super-block
e2fsck: Superblock invalid, trying backup blocks...
Superblocco needs_recovery flag is clear, but journal has data.
Flag di recupero non impostato nel superblocco di backup, eseguo journal comunque.
Dati_Linux: ripristino del journal
Superblocco needs_recovery flag is clear, but journal has data.
Flag di recupero non impostato nel superblocco di backup, eseguo journal comunque.
Superblocco needs_recovery flag is clear, but journal has data.
Flag di recupero non impostato nel superblocco di backup, eseguo journal comunque.
e2fsck: impossibile impostarei i flag del superblocco a Dati_Linux[/code2]


Dati_Linux: ***** IL FILESYSTEM E' STATO MODIFICATO *****

Dati_Linux: ********** ATTENZIONE: Il filesystem contiene ancora errori ************

marco@marco-GA-MA790XT-UD4P:~$ man resize2fs
marco@marco-GA-MA790XT-UD4P:~$ sudo resize2fs /dev/sdc1
resize2fs 1.42.9 (4-Feb-2014)
resize2fs: Bad magic number in super-block durante l'apertura di /dev/sdc1
Impossibile trovare un valido superblocco per il filesystem.
ghiltanas
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2013
Distribuzione: Ubuntu 14.04 x86_64

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda ghiltanas » sabato 7 giugno 2014, 16:18

pensi questa guida faccia al caso mio:
http://linuxexpresso.wordpress.com/2010 ... in-ubuntu/ ?
ghiltanas
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2013
Distribuzione: Ubuntu 14.04 x86_64

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda daigo » sabato 7 giugno 2014, 16:47

Questo che dice?
Codice: Seleziona tutto
sudo mke2fs -n /dev/sdc1


Edit: non avevo visto il link,è la stessa cosa che avevo in mente
daigo
 

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda ghiltanas » sabato 7 giugno 2014, 17:00

perfetto, allora procedo cosi e vedo come va (grazie per ora comunque)
ghiltanas
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2013
Distribuzione: Ubuntu 14.04 x86_64

Re: Error mounting /dev/sdc1 at /media/marco/Dati Linux:

Messaggioda ghiltanas » sabato 7 giugno 2014, 22:23

Risolto! Col primo codice di backup non ha funzionato, col secondo si ;)

Ora mi resta da capire perchè il radeon dpm non funziona (almeno credo dato che la gpu è a 60° fissi), con il kernel 3.13 dovrebbe essere attivo di default
ghiltanas
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2013
Distribuzione: Ubuntu 14.04 x86_64

Re: Error mounting /dev/sdc1 [Risolto]

Messaggioda daigo » sabato 7 giugno 2014, 22:36

ghiltanas ha scritto:Risolto! Col primo codice di backup non ha funzionato, col secondo si ;)

bene :ciao:
daigo
 


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: cccp-annarella e 13 ospiti