Problemi driver nvidia con Ubuntu

Riconoscimento, installazione e configurazione delle periferiche.

Problemi driver nvidia con Ubuntu

Messaggioda Splugen96 » sabato 21 ottobre 2017, 12:27

Scusate,sono nuovo,spero di non star sbagliando lo spazio in cui sto pubblicando.
Scrivo perchè ho parecchi problemi con ubuntu dalla sua prima installazione.Putroppo ,già nelle prime installazioni ho avuto parecchi problemi(ho un ASUS Rog gl552vw),poi ho seguito questa guida https://www.google.it/amp/s/jeremymdyso ... l552v/amp/ .Ora ,finita l installazione , faccio per disinstallare e reinstallare i driver nvidia (come fa a fine guida), e di fatto il problema è che se provavo a switchare dalla scheda esterna a quella integrata mi veniva segnalato un problema dal sistema e al seguente riavvio la shell non si avviava (quindi dovevo rientrare in modalità recovery,disinstallare e reinstallare i driver nvidia in modo da impostare la nvidia come scheda principale,in quanto in recovery non è possibile switchare semplicemente).Punto del discorso devo tenere la Gtx 960 come scheda impostata,e la batteria mi dura 2 ore se non faccio nulla.Oltretutto la situazione è peggiorata ora che ho aggiornato a Ubuntu 17.10,in quanto non mi fa aprire/disinstallare/reinstallare alcune applicazioni quali quella del pannello di Controllo Nvidia (quindi non posso proprio più neanche switchare scheda),o il Monitor delle risorse.

Dinenticavo di dire che l os è installato in dual boot con windows 10
Ultima modifica di giulux il mercoledì 1 novembre 2017, 6:04, modificato 2 volte in totale.
Motivazione: precisato il titolo
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda giulux » sabato 21 ottobre 2017, 13:41

E si, hai sbagliato sezione: la descrizione di "Consiglio della Comunità" è Comunicazioni con il Consiglio della Comunità italiana di Ubuntu: Il Consiglio risponderà a suggerimenti, critiche, discussioni riguardanti tutta la comunità.
Ti pare che il tuo problema riguardi tutta la comunità? ;)

Sposto in driver e periferiche.

Ciao.

Dimenticavo: Benvenuto!
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 20107
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda Splugen96 » sabato 21 ottobre 2017, 14:48

Grazie mille,scusate ma sono da mobile e faccio fatica a orientarmi 😅
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda wilecoyote » sabato 21 ottobre 2017, 15:17

ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 6351
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda Roberto Pontecorvi » sabato 21 ottobre 2017, 17:30

La guida che hai postato parla dei drive 361... quando la tua scheda usa i 384.... Non ti conviene aggiungere il ppa per la scheda grafica in modo che i drive nvidia si aggiornano in automatico????
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate

Re: Problemi con Ubuntu

Messaggioda Splugen96 » sabato 21 ottobre 2017, 23:14

Grazie per le guide proverò a vedere😁,mentre per quanto riguarda il fatto del 384 mi pare che le avessi già installato sia i driver corretti della nvidia che della intel ma ugualmente non riuscivo a switchare
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda Roberto Pontecorvi » domenica 22 ottobre 2017, 9:31

Nvidia prime è installato??? Se non vado errato e abbia capto bene il tuo problema, questo è inserito nel tuo grub??:
Find the line that reads
‘GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”‘
and change it to read
‘GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=Linux i915.preliminary_hw_support=1 idle=nomwait”‘

se si leggi questo -> https://wiki.ubuntu-it.org/Installazione/ParametriAvvio (già segnalato da @Will.........)
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate

Re: Problemi con Ubuntu

Messaggioda Splugen96 » martedì 24 ottobre 2017, 21:26

Certo,ho installato nvidia prime e il codice da inserire nel Grub lo inserisco già all installazione,credetemi ho chiesto al tecnico informatico della mia università ,professori,chiunque abbia qualche competenza e non riesco ad uscirne.Avrò installato ubuntu una 50ina di volte e in neanche una di esse sono riuscito a far impostare la scheda integrata.Se ci provo (con tutti i driver installati) la shell non vuole più avviarsi,sono costretto a entrare in recovery e reinstallare e reimpostare la nvidia
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda Roberto Pontecorvi » mercoledì 25 ottobre 2017, 21:20

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=Linux i915.preliminary_hw_support=1 idle=nomwait”‘

Se metti queste istruzioni il SO funziona con i soli drive generici (I915). In poche parole elimina tutta la parte nvidia.
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate

Re: Problemi con Ubuntu

Messaggioda Splugen96 » lunedì 30 ottobre 2017, 13:31

e quindi cosa dovrei fare?Se provo a impostare la scheda intel attraverso PRIME e faccio log out o provo a riavviare ottengo schermata nera con scritte due righette.Poi devo rientrare in reovery,fare purge dei driver nvidia,e reinstallarli in modo tale che siano impostati(perchè PRIME non funziona in recovery)
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi con Ubuntu

Messaggioda Roberto Pontecorvi » martedì 31 ottobre 2017, 22:51

Non vorrei che sia un bug della 17.10. Scusa se te lo domando, ma se la riga -> GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash " -fosse solo così non fumziona????
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate

Re: Problemi driver nvidia con Ubuntu

Messaggioda giulux » mercoledì 1 novembre 2017, 6:05

Ho precisato il titolo
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 20107
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problemi driver nvidia con Ubuntu

Messaggioda Splugen96 » mercoledì 1 novembre 2017, 14:02

Purtroppo non è solo ubuntu 17.10 a darmi il problema dello Switch tra schede,ma c è l ho dalla prima versione che ho utilizzato di ubuntu(16.04).Il grub l'ho aggiornato così perchè diceva di farlo sulla guida,ma non ho mai provato a lasciarlo invariato.
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi driver nvidia con Ubuntu

Messaggioda wilecoyote » mercoledì 1 novembre 2017, 15:33

ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 6351
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: Problemi driver nvidia con Ubuntu

Messaggioda Roberto Pontecorvi » domenica 26 novembre 2017, 10:40

Se nella distribuzione hai scelto di usare come gestore grafico "wayland", i drive nvidia (proprieari) non funzionano. Scegli di usare "Xorg".
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate

Re: Problemi driver nvidia con Ubuntu

Messaggioda Splugen96 » sabato 23 dicembre 2017, 20:15

Scusate il mio ritardo nel rispondere, ma ho avuto da fare sempre con questo problema quindi avevo il computer inagibile.Purtroppo,ho reinstallato ancora ubuntu, e non sembra accettare in alcun caso l'uso di ulteriori driver se non quelli nouveau di xorg,i quali pero' implicano che io usi continuamente la gtx 960,durandomi quindi un ora e mezza la batteria a piena carica(2 se disattivo il wi-fi).Ho provato a seguire le guide per le grafiche ibride già tempo addietro e non funzionano.Non so più che fare,anche perche' non penso che sia limitata la mia batteria in quanto con windows dura parecchio di piu e un mio amico con un asus strix(con specifiche praticamente identiche alle mie) ha una durata di 6/7 ore.
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi driver nvidia con Ubuntu

Messaggioda Roberto Pontecorvi » domenica 24 dicembre 2017, 10:49

Posta il risultato dei seguenti comandi:
Codice: Seleziona tutto
echo $XDG_SESSION_TYPE
lspci -vnn | grep VGA -A 12
dkms status
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate

Re: Problemi driver nvidia con Ubuntu

Messaggioda Splugen96 » lunedì 15 gennaio 2018, 19:58

Preciso una cosa, recentemente ho installato Pop!_os, che è una distro modificata di Ubuntu, e per installarla sono disponibili due iso (trovi tutto qui https://system76.com/pop), quella per intel/AMD o per Nvidia, e io ho provato l'installazione di entrambe.Nel caso della intel mi restituiva il seguente messaggio al tentativo di boot da una chiavetta : "A start job is running for Detect the available GPUs and deal with any system changes.", mentre l'installazione della iso nvidia è andata a buon fine.Il problema è che essendo appunto una distro di ubuntu 17.10, difatto presenta lo stesso problema che avevo con Ubuntu.Ho riportato il messaggio comunque nel caso che possa aiutare a capire il problema.
Ecco qui i risultati dei comandi


1)echo $XDG_SESSION_TYPE -----> X11


2)lspci -vnn | grep VGA -A 12 ------->

00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 530 [8086:191b] (rev 06) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. HD Graphics 530 [1043:1c5d]
Flags: bus master, fast devsel, latency 0, IRQ 129
Memory at dd000000 (64-bit, non-prefetchable) [size=16M]
Memory at b0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 07)
Subsystem: ASUSTeK Computer Inc. Skylake Processor Thermal Subsystem [1043:1c5d]

3)dkms status -------->
bbswitch, 0.8, 4.13.0-25-generic, x86_64: installed
bbswitch, 0.8, 4.13.0-29-generic, x86_64: installed
nvidia-384, 384.111, 4.13.0-25-generic, x86_64: installed
nvidia-384, 384.111, 4.13.0-29-generic, x86_64: installed



PS: preciso una cosa, 2 giorni fa ho tentato di selezionare da nvidia prime la scheda intel e al successivo tentativo di boot l'os non si è più avviato, quindi ho reinstallato solo Pop!_os come unico OS nel mio pc (non più quindi in dual boot con windows) sperando che migliorasse le cose. Mi pare di aver notato che tra i driver con ubuntu ci fosse scritto che la scheda intel fosse presente , il driver pure, ma con scritto "non funzionante".Ora purtroppo non ho controllato la scheda dei driver aggiuntivi prima che Pop!_os si bloccasse e lo installassi, ma ora che l'ho installato come unico OS c'è scritto che il driver è selezionato e non c'è più scritto "non funzionante".Non ho avuto il coraggio di tentare la selezione di intel anche sta volta, per evitare di reinstallare inutilmente l'os ancora, ma comunque ho preferito farvelo sapere.
Splugen96
Prode Principiante
 
Messaggi: 8
Iscrizione: ottobre 2017
Sesso: Maschile

Re: Problemi driver nvidia con Ubuntu

Messaggioda Roberto Pontecorvi » martedì 16 gennaio 2018, 22:11

Posta l riultato del comando:
Codice: Seleziona tutto
lshw -c display
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4331
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 14.4 mate /16.4 mate


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: Maxs21r, sps e 15 ospiti