[risolto] Ubuntu lento su HW recente (forse grafica?)

Riconoscimento, installazione e configurazione delle periferiche.

[risolto] Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 18:09

Ho appena assemblato un fisso con questa cfg:
- amd ryzen 2200g con grafica vega8 integrata;
- msi b450-a pro con bios aggiornato ad ultima versione;
- 2x4gb hyperx predator @3200 cl16 (le faccio andare @2400 che è il default)
- hdd @7200rpm
- no scheda grafica dedicata

Appena installato ubuntu 18.04.1LTS con alcuni accorgimenti grafici per completare l'installazione, ovvero ho aggiunto i seguenti parametri dopo ---:
vga=791 nomodeset
perchè funzionarono molto tempo fa per installare lubuntu 14 su un vecchissimo portatile. In entrambi i casi, senza parametri, ho ottenuti schermata nera.
Durante l'installazione ho fatto scaricare gli aggiornamenti ed adesso la versione indicata a terminale è 18.04.2lts.

Ho appena cominciato ad usarlo e mi sono subito accorto che FF che è lentissimo, ma non a caricare, bensì a renderizzare le pagine (spero di essermi espresso bene): per esempio è lentissimo a scorrere i contenuti di una pagina, anzi è impossibile perchè si impalla. Idem se clicco su impostazioni (barra sn desktop): molto lento a cambiare tra una voce e l'altra e, soprattutto, ciò che si visualizza è reso male: magari si sovrappongono parti di 2 schermate apparteneti a 2 voci diferenti, per esempio. In entrambi i casi è un problema anche spostare le finestre sul desktop sia per lentezza che per "ingarbugliamento" di rendering.
Altro appunto, ma devo verificare meglio: credo che certe finestre, appena aperte, "escono" dai contorni del desktop. Ho quindi visto se si poteva aumentare la risoluzione del monitor, così da rimpicciolire tutto, però l'unica disponibile è 1024x768 (4:3) mentre la risoluzione massima del monitor è 1440x900 (4:2.5, tanto per confrontarlo meglio con l'altro rapporto).
L'unica cosa che sembra molto fluida è il file manager, ma l'hdd è quasi vuoto e poco nidificato quindi non mi pronuncio più di tanto. In questo caso, se provo a trascinare la finestra sul desktop molto velocemente, il contenuto è correttamente visualizzato però sul desktop restano "tracce" di colore del passaggio della finestra.

Credo che la responsabilità sia solo della grafica, altrimenti bisognerebbe concludere che l'HW non ce la fa. Che ne pensate e come risolvere?
Io avrei pensato ad un upgrade del kernel, che attualmente è 4.15.0-45-generic, ma come procedere?
Ultima modifica di EagleBuntu il mercoledì 20 marzo 2019, 14:05, modificato 1 volta in totale.
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda willy54 » mercoledì 13 febbraio 2019, 18:23

Abilita i driver proprietari video alcuni problemi dovrebbero risolversi.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS gparted sda inxi -Fz
Hp Pavilon 15-CS2093nl Win10 , UbuntuStudio (provvisorio) ----- disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3331
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 18:35

puoi gentilmente spiegarmi step-by-step come fare?
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda willy54 » mercoledì 13 febbraio 2019, 19:49

Cerca la App Software ed aggiornamenti -----> abilita la casella driver e software con restrizioni -----> nella stessa videata seleziona la scheda Driver -----> attendi che finisca la ricerca-------> Seleziona il driver ------> Applica/installa .
Ovviamente devi essere collegato a internet i driver li cerca in rete.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS gparted sda inxi -Fz
Hp Pavilon 15-CS2093nl Win10 , UbuntuStudio (provvisorio) ----- disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3331
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 20:28

Avviato "software e aggiornamenti"

scheda "software per ubuntu":
tutte le voci (tranne "codice sorgente") erano già selezionate, comprese:
- driver proprietari per i dispositivi (restricted)
- software con restrizioni per copyright o motivi legali (multiverse)

scheda "driver aggiuntivi":
nessun driver aggiuntivo disponibile

ho provato a modificare "scaricare da": server italia -> server principale. sono ritornato in "driver aggiuntivi" e c'era la scritta "ricerca driver disponibili" però alla fine nulla. ho chiuso ed è comparsa la finestra "le informazioni sul software disponibile non sono aggiornate"..."necessaria una connessione a internet funzionante", clicco su "ricarica" e compare finestra "aggiornamento della cache" e sembra che scarica qualcosa, comunque poi chiude tutto. riapro "software e aggiornamenti" ma non cambia nulla.
nonostante dica che non c'è connessione io navigo con FF anche se molto stentatamente e comunque ho visto che "aggiornamento della cache" scaricava informazioni.
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » mercoledì 13 febbraio 2019, 23:07

Giusto per farsi un'idea della situazione grafica, posta il risultato di
Codice: Seleziona tutto
cat /var/log/gpu-manager.log
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 23:49

avevo tentato l'upgrade del kernel ma credo senza risultato. ho messo ukuu e proceduto ad installare il 4.20.8, ovvero l'ultimo disponibile in lista tra quelli stabili, ed ho ottenuto black screen e non ha avviato. poi ho provato con 4.19.0-041900, che ho lasciato attualmente, ma la situazione mi sembra identica a quella sopra descritta, con kernel 4.15.0-45. l'unica differenza che ho notato è che quando avvia spunta qualcosa del tipo "error vgacon" però non posso essere più preciso, non ricordo quel comando per richiamare il listato d'avvio.

cat /var/log/gpu-manager.log
Codice: Seleziona tutto
$ cat /var/log/gpu-manager.log
log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-nvidia-was-loaded file
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.19.0-041900-generic/updates/dkms
Looking for amdgpu modules in /lib/modules/4.19.0-041900-generic/updates/dkms
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? no
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? no
Is nvidia kernel module available? no
Is amdgpu kernel module available? no
Vendor/Device Id: 1002:15dd
BusID "PCI:56@0:0:0"
Is boot vga? yes
Error: can't access /sys/bus/pci/devices/0000:38:00.0/driver
The device is not bound to any driver.
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Does it require offloading? no
last cards number = 1
Has amd? yes
Has intel? no
Has nvidia? no
How many cards? 1
Has the system changed? No
Single card detected
Nothing to do

forse è più opportuno spostare questo thread in problematiche hw?
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda willy54 » giovedì 14 febbraio 2019, 0:53

Posso sbagliarmi ma temo sia dovuto a quel 791 anteposto a nomodeset che manda il tutto in blocco e non lascia trovare driver proprietari.
Non ho molta pratica con le cpu amd ,ma solitamente sono ben supportate. Vedi questa guida se ti può aiutare
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS gparted sda inxi -Fz
Hp Pavilon 15-CS2093nl Win10 , UbuntuStudio (provvisorio) ----- disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3331
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » giovedì 14 febbraio 2019, 2:20

Mi sa che l'hardware è anche troppo recente per linux - c'è da rimboccarsi le maniche.
Da quel che ho visto in giro è richiesto come minimo il kernel 4.15 e come consigliato il 4.18 (dovresti installare dei ppa per poterlo fare).

Ti passo un link dove danno il [Risolto] con Mint cinnamon. Ti fai un'idea.
Q U I il LINK

Per il momento non è ancora roba per principianti.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda carved top » giovedì 14 febbraio 2019, 6:48

Grazie per la segnalazione, sposto in driver e periferiche :ciao:
"It's 106 miles to Chicago, we got a full tank of gas, half a pack of cigarettes, it's dark and we're wearing sunglasses." "Hit it!"
Elementary OS 0.4 Loki | AMD A8-6600k | GTX 750 ti | HyperX Fury 8 GB @ 1600MHz
Avatar utente
carved top
Moderatore Globale
Moderatore Globale
 
Messaggi: 2163
Iscrizione: maggio 2012
Desktop: Pantheon
Distribuzione: Elementary 0.4 Loki x86_64

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » giovedì 28 febbraio 2019, 13:33

Aggiorno perchè ho una notizia buona e una cattiva. Quella buona è che ero riuscito a risolvere il problema, quella cattiva è che si è ripresentato con una variante; spiego di seguito.
Durante la prima installazione, come detto, avevo usato il parametro "nomodeset" per evitare black screen. Ho poi scoperto che tale parametro era rimasto presente nelle opzioni di boot quindi ho provato ad avviare il 4.15.0-29 senza e i problemi grafici sono spariti, quindi ho provveduto a rimuoverlo permanentemente modificando in grub:
Codice: Seleziona tutto
sudo gedit /etc/default/grub

la stringa
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX="nomodeset"

così GRUB_CMDLINE_LINUX=""
Per vari motivi ho avuto necessità di reinstallare win e ubuntu, ho ripetuto la prassi di aggiungere nomodeset in fase d'installazione e, durante la prima sessione di ubuntu, ho installato un nuovo kernel, solo che ho sbagliato ed ho messo il 4.20.11 tramite ukuu.
Usandolo mi sono accorto che a volte mandava in freeze il sistema perciò, volendolo rimuovere, ho riavviato con 4.15.0-29, aspettandomi di ritrovare nomodeset nelle opzioni di boot ma non era presente. Ho provato ad avviare ottenendo black screen e led monitor giallo (come se il pc fosse spento). Ho quindi provato ad aggiungerlo e ubuntu si è avviato però ovviamente le problematiche grafiche si sono ripresentate anche se adesso devo dire che sono molto blande e riesco a navigare, tuttavia chiaramente i driver amd non sono caricati, infatti mancano in output di
Codice: Seleziona tutto
$ sudo lshw -C display
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:38:00.0
       version: c8
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fe600000-fe67ffff
       

mentre prima erano presenti:
Codice: Seleziona tutto
  *-display                 
       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:38:00.0
       version: c8
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: driver=amdgpu latency=0
       resources: irq:53 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fe600000-fe67ffff

L'attuale situazione dunque è che posso avviare il 4.20.11 senza problematiche grafiche ma con saltuari freeze di sitema oppure avviare 4.15.0-29 (ho anche il 4.15.0-45) solo con nomodeset ed ottenere un sistema senza driver amd e blande problematiche grafiche.
Avete idea di come sia possibile e di come risolverla?
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » giovedì 28 febbraio 2019, 14:51

Devi decidere quale via vuoi prendere.

O analisi per cercare di capire cosa provoca i freeze del 4.20 e se c'è rimedio.

Oppure vedere di ripristinare gli amdgpu per il 4.15.
Scegliere una delle due e seguirla fino in fondo (accantonando temporaneamente l'altra), se non va in porto si tenta con l'altra.

La soluzione immediata e definitiva non c'è. La più veloce: reinstalla e, se funziona bene, non cercare kernel successivi a quelli proposti dalla distro.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » giovedì 28 febbraio 2019, 15:52

come accennato, avevo messo il 4.20.11 per sbaglio, cioè senza tener conto che non fosse per ubuntu, quindi non mi interessa usarlo. quindi, e se mi date aiuto, intendo far funzionare il 4.15.0-45, che mi risulta essere l'ultimo per ubuntu e di cui avevo appurato il funzionamento grafico col mio HW.

una domanda mi sorge spontanea: come mai indichi la reinstallazione di ubuntu come una possibile via di risoluzione? è basata soltanto sulla casualità (50-50) o ci sono motivazioni fondate su altro?
forse l'unica variazione nella prassi di installazione, tra la 1^ funzionante e la 2^, è stato aggiungere nomodeset prima o dopo ---, adesso non ricordo più. per il resto credo d'aver fatto tutto in modo identico. il senso di ciò è che se ho commesso un "errore" (o praticato una particolare variazione) nella 2^ installazione, non ne ho consapevolezza, quindi potrei ripeterlo all'infinito.
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » giovedì 28 febbraio 2019, 18:00

una domanda mi sorge spontanea: come mai indichi la reinstallazione di ubuntu come una possibile via di risoluzione?

Il fatto è che, teoricamente, fra kernel vecchi e nuovi non dovrebbero presentarsi problemi come quello che hai esposto - dovrebbe funzionare tutto allo stesso modo.

Il 4.20 però lo hai preso al di fuori dei rilasci dei repo ufficiali (quelli "garantiti"), cosa mancava ancora al 4.20 per poter essere aggiunto ai repo canonici? un bel problema stabilirlo.
Il 4.20, cosa è andato a toccare nelle impostazioni di sistema che il 4.15 non digerisce?
Di solito quando si fanno queste manovre ci si documenta sulle novità introdotte e su cosa ancora c'è da rifinire nei kernel extra.

Insomma potremmo girare in lungo e in largo senza arrivarne a capo, per cui si reinstalla; la reinstallazione ti garantisce un sistema integro.

Visto che il 4.20 non ti interessa, eliminalo completamente (compresi i file di configurazione), poi si riparte con il 4.15 senza il nomodeset, come primo avvio prova:
dal menu di grub premi "e", vai alla riga che inizia con linux e cancelli "nomodeset quiet splash" e al loro posto scrivi single poi premi F10 per avviare, segui le righe a schermo se danno errore o si bloccano -- se il kernel carica bene le righe si fermano e dovrai dare Ctrl+d per caricare il server grafico -- se anche questo è OK ti ritroverai nel desktop.

Nota
se ci saranno, dovrai riportare gli errori (o la schermata che li mostra) e in quale fase questi appaiono (se durante il caricamento del kernel o del server grafico).
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » giovedì 28 febbraio 2019, 18:43

Ok, quindi è stato il 4.20 a sconfigurare gli altri.
Visto che il 4.20 non ti interessa, eliminalo completamente (compresi i file di configurazione)

puoi postare i comandi? immagino sia diverso dall'usare la gui di ukuu per rimuoverlo, giusto?

Non ho inteso come suggerisci procedere alla reinstallazione, in particolare "poi si riparte con il 4.15 senza il nomodeset". Come detto, se non metto il parametro nomodeset per il 4.15 ottengo black screen, compresa sessione live. Puoi chiarire?

PS basta che reinstallo la root mentre lascio stare la home, giusto?
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » giovedì 28 febbraio 2019, 19:23

PS basta che reinstallo la root mentre lascio stare la home, giusto?
Se hai la /home separata sì.

Le istruzioni di prima non riguardavano la reinstallazione del sistema, sono un tentativo per risalire al mancato funzionamento del 4.15 - prima si carica il kernel, se l'errore sta lì si vede di risolverlo -- poi si carica il server grafico e si dovrebbe vedere dove fallisce.

Come detto, se non metto il parametro nomodeset per il 4.15 ottengo black screen
leggi bene, non devi solo togliere il nomodeset ma anche il quiet e splash, e al loro posto devi scrivere single e poi F10 per avviare -- non stai reinstallando nulla -- con questa procedura il sistema viene solo esplorato, non viene modificato in alcun modo.
È una procedura che serve ad individuare l'errore in cui incappa il 4.15.

Rileggi bene le 2 fasi di cui si compone: prima si carica il kernel poi il server grafico.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » giovedì 28 febbraio 2019, 21:17

ok, capito, evidentemente ho frainteso ma abbia pazienza perchè sono molto ignorante in materia e posso interpretare male.
sono andato nelle opzioni di boot del 4.15.0-29, come detto non c'è nomodeset, e mi sono limitato a rimpiazzare "quiet splash" con "single". riavvio con f10 ed ottengo black screen, però con led monitor blu (e non giallo), quindi il segnale dovrebbe esserci stato. ho anche tentato ctrl+d ma invano, quindi reset.

se ritieni che un reinstall di ubuntu (root) possa risolvere con certezza, io procederei perchè impiego solo qualche minuto con questo HW, dimmi tu. prima però ti chiedo di indicarmi quali comandi devo eseguire per "eliminare completamente (compresi i file di configurazione)" il 4.20.
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » venerdì 1 marzo 2019, 1:00

se ritieni che un reinstall di ubuntu (root) possa risolvere con certezza
Reinstallare vuol dire che riparti con la live di installazione, formatti la partizione dove ora hai installato la 18.04 e ce la reinstalli. Ma hai la home separata?
Posta una schermata di gparted.

Se vuoi disinstallare il 4.20 usa la GUI di ukuu, il fatto è che quello è l'ultimo kernel installato e col pacchetto linux-generic non so come comportarmi.
Posta il risultato di
Codice: Seleziona tutto
dpkg-query -l | grep -i linux-generic


Per disinstallare completamente un vecchio kernel si usa
Codice: Seleziona tutto
sudo apt purge "linux-headers-x.x.x*"
sudo apt purge "linux-image-x.x.x*"
sudo apt purge "linux-image-extra-x.x.x*"
dove al posto delle "x.x." ci va il numero della versione, nel tuo caso 4.20. L'asterisco finale indica "qualunque numero o lettera" che completa il numero di versione. Però non credo che tutto questo ti sia chiaro.
Ma da principiante non potevi iniziare con qualcosa di più "tenero" con cui cimentarti? Subito con ukuu e i kernel in sviluppo, vabbè sbagliando s'impara.

Nota Bene: devi avviare col 4.15 ==> disinstallare il 4.20 con i tre comandi di sopra e poi dare subito dopo
Codice: Seleziona tutto
sudo update-grub
Ultima modifica di andrea111 il venerdì 1 marzo 2019, 10:46, modificato 1 volta in totale.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » venerdì 1 marzo 2019, 1:45

provato a rimuovere manualmente il 4.20 dando questi comandi
Codice: Seleziona tutto
    sudo apt purge "linux-headers-4.20*"
    sudo apt purge "linux-image-4.20*"
    sudo apt purge "linux-image-extra-4.20*"

però per il 2^, tra le altre cose, è uscito:
Codice: Seleziona tutto
Il pacchetto "linux-image-4.20.11-042011-generic" non è installato e quindi non è stato rimosso.

per il 3^:
Codice: Seleziona tutto
E: Impossibile trovare il pacchetto linux-image-extra-4.20*
E: Impossibile trovare alcun pacchetto tramite il glob "linux-image-extra-4.20*"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "linux-image-extra-4.20*"

ho aperto ukuu e il 4.20 risultava ancora installato quindi l'ho rimosso da lì e credo abbia agito anche su grub, comunque ho dato anche manualmente il comando per aggiornarlo.
Codice: Seleziona tutto
$ dpkg-query --list | grep -i linux-generic
ii  linux-generic                                 4.15.0.45.47                                 amd64        Complete Generic Linux kernel and headers

Nota: mancava --(l)ist all'input. questo per ringraziarti dell'aiuto che mi stai dando :)

adesso che il 4.20 è svanito nel nulla posso reinstallare ubuntu 18.04lts? comunque sì, ho root e home separate, per rispondere alla tua domanda.
EagleBuntu
Prode Principiante
 
Messaggi: 207
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.3LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » venerdì 1 marzo 2019, 10:56

adesso che il 4.20 è svanito nel nulla posso reinstallare ubuntu 18.04lts?
Potevi farlo anche prima, quando reinstalli una distro formatti la partizione, non ha nessuna importanza cosa c'è nelle partizione in cui vai ad installare.

A quanto pare il 4.20 non era installato, c'erano solo gli headers, probabilmente l'avevi già rimosso senza saperlo.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1540
Iscrizione: novembre 2007

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 19 ospiti