Pagina 1 di 1

impossibile attivare DMA

MessaggioInviato: lunedì 22 agosto 2005, 14:45
da bersi
Ho provato ad attivare il DMA sul lettore dvd e il masterizzatore ma al comando : sudo hdparm -d 1 /dev/hdc
la risposta è questa:
/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
bersi@ubuntupc:~$

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
bersi@ubuntupc:~$
dov'è che sbaglio??? a proposito il mio chipset è nforce 2
Grazie

Re: impossibile attivare DMA

MessaggioInviato: giovedì 26 gennaio 2006, 12:40
da hrs
forse sono in ritardo...
guarda qui


http://doc.gwos.org/index.php/DMA

Re: impossibile attivare DMA

MessaggioInviato: giovedì 26 gennaio 2006, 18:07
da Devnull
Per attivare il Dma te lo ha già detto hrs ma te lo traduco:

Codice: Seleziona tutto
sudo gedit /etc/hdparm.conf


Aggiungi le seguente linea al tuo  hdparm.conf

  /dev/hdc {
  dma = on
  }

  /dev/hda {
  dma = on
  }
Salva ed esci,poi riavvia il sistema.
Da quanto ho capito hai una periferica sul secondario master e una sul primario .Se non è così facci sapere.
Ciao!

Re: impossibile attivare DMA

MessaggioInviato: lunedì 9 luglio 2007, 2:45
da domi84
Scusate se mi accodo qui... ;D
Io uso Xubuntu...come faccio a sapere come si chiama il mio lettore dvd? Se è hda, hdc?! :-\

Re: impossibile attivare DMA

MessaggioInviato: lunedì 9 luglio 2007, 7:54
da Divilinux
i lettori sono tutti /dev/scd*
se avete ancora hdc o hdb e' giunto il momento di cambiare.. ;)

ps. se avete feisty o un kernel superiore al 2.6.19

Re: impossibile attivare DMA

MessaggioInviato: lunedì 9 luglio 2007, 9:34
da domi84
ma dove sbaglio? ::)
Codice: Seleziona tutto
immo@mimmo-laptop:~$ sudo hdparm /dev/scd0

/dev/scd0:
 IO_support   =  0 (default 16-bit)
 readonly     =  0 (off)
 readahead    = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device
mimmo@mimmo-laptop:~$ sudo hdparm -d1 /dev/scd0

/dev/scd0:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
mimmo@mimmo-laptop:~$ sudo hdparm /dev/scd0

/dev/scd0:
 IO_support   =  0 (default 16-bit)
 readonly     =  0 (off)
 readahead    = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device
mimmo@mimmo-laptop:~$

Sto seguendo il wiki:
http://wiki.ubuntu-it.org/Hardware/Disp ... izioni/DMA

Re: impossibile attivare DMA

MessaggioInviato: martedì 21 agosto 2007, 21:03
da domi84
up

Re: impossibile attivare DMA

MessaggioInviato: giovedì 12 maggio 2011, 17:48
da erlaziale
io ho fatto così:
Codice: Seleziona tutto
simone@sakuragi:~$ sudo hdparm -d1 /dev/cdrom

/dev/cdrom:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device
simone@sakuragi:~$ sudo hdparm /dev/cdrom

/dev/cdrom:
 multcount     =  0 (off)
 IO_support    =  1 (32-bit)
 readonly      =  0 (off)
 readahead     = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device


che vuol dire?
grazie