Avviso: vi è stato un importante aggiornamento della piattaforma forum, si prega di visionare la discussione in merito: viewtopic.php?f=17&t=637551.

[Risolto] Problema avvio Ubuntu 17.10 x64 su VirtualBox

Installazione di Ubuntu su macchina virtuale (Virtualbox, Vmware, Qemu, Parallels, KVM, Xen, Virtual pc, ecc.), configurazione del software e gestione del sistema virtualizzato.
Scrivi risposta
Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

[Risolto] Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » lunedì 7 maggio 2018, 22:42

Buonasera,
ho da alcuni mesi la versione 17.10 x64 di Ubuntu installata su VirtualBox. Improvvisamente non riesco più ad accedere alla schermata di login al sistema.

Immagine
Immagine

Ho provato ad accedere ad una shell con permessi di root premendo Shift al boot e lanciando il comando

Codice: Seleziona tutto

sudo ecryptfs-recover-private
per decriptare la mia cartella home e recuperare i miei file (possiedo il Passphrase), però mi ritorna il seguente errore:

Eorr: Unwrapping passphrase and inserting into the user session keyring failed [-5]


Come faccio a ripristinare il sistema in modo da accedere ai miei file direttamente dal file system e recuperare tutto quanto?
Ultima modifica di Fernando3 il lunedì 20 agosto 2018, 20:39, modificato 1 volta in totale.

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » martedì 8 maggio 2018, 6:35

Nelle opzioni di Virtualbox disattiva l'accelerazione 3d, sposto in Ubuntu su Macchina virtuale.

PS: aggiorna alla 18.04

Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » martedì 8 maggio 2018, 14:08

trekfan1 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5057966#p5057966][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Nelle opzioni di Virtualbox disattiva l'accelerazione 3d, sposto in Ubuntu su Macchina virtuale.

PS: aggiorna alla 18.04
È già disattivata. Guardando un po' su Google ho letto che il problema potrebbe essere causato dai driver Nvidia, però non mastico bene Ubuntu per riuscire a risolvere il problema. E non sono nemmeno sicuro che sia la strada giusta.

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » martedì 8 maggio 2018, 17:14

Cosa c'entrano i driver nvidia? La macchina virtuale NON usa la scheda grafica del pc ospite ma una sua scheda grafica virtuale, hai installato le Guest Additions? Che versione di Virtualbox hai installato?

Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » mercoledì 9 maggio 2018, 14:03

trekfan1 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5058069#p5058069][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Cosa c'entrano i driver nvidia? La macchina virtuale NON usa la scheda grafica del pc ospite ma una sua scheda grafica virtuale, hai installato le Guest Additions? Che versione di Virtualbox hai installato?
Sì, ho installato le Guest Additions. Come dicevo nel primo post, uso questa macchina virtuale già da alcuni mesi e non ho mai avuto alcun problema.
Ho VirtualBox 5.2.8.

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » mercoledì 9 maggio 2018, 16:09

L'ultima versione è la 5.2.10, hai installato virtualbox dai repo di ubuntu o dai repo oracle? Scusa ma siamo a corto di indovini :D

Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » mercoledì 9 maggio 2018, 18:55

trekfan1 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5058277#p5058277][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:L'ultima versione è la 5.2.10, hai installato virtualbox dai repo di ubuntu o dai repo oracle? Scusa ma siamo a corto di indovini :D
Sulla macchina host ho Windows 10, quindi ho scaricato VirtualBox dal sito ufficiale. :p
Ti ringrazio molto per la disponibilità :D

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » mercoledì 9 maggio 2018, 18:57

Ok, ma dato che davanti al tuo pc ci sei tu, tu sai cosa gira o no su quel pc! Cmq ripeto: disattiva l'accelerazione 3d dalle opzioni di virtualbox nella sezione "Schermo"

Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » mercoledì 9 maggio 2018, 20:46

trekfan1 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5058333#p5058333][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Ok, ma dato che davanti al tuo pc ci sei tu, tu sai cosa gira o no su quel pc! Cmq ripeto: disattiva l'accelerazione 3d dalle opzioni di virtualbox nella sezione "Schermo"
Come ti ho già detto precedentemente, è già disattivata, il problema purtroppo non è causato da quello. :(

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » giovedì 10 maggio 2018, 21:11

Puoi postare una schermata delle opzioni di virtualbox?

EDIT

E' uscito Virtualbox 5.2.12, aggiorna e prova ad abilitare il 3D nelle opzioni dello schermo di Virtualbox prima bisogna installare le nuove Guest Additions...

Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » lunedì 20 agosto 2018, 19:25

trekfan1 ha scritto:Puoi postare una schermata delle opzioni di virtualbox?

EDIT

E' uscito Virtualbox 5.2.12, aggiorna e prova ad abilitare il 3D nelle opzioni dello schermo di Virtualbox prima bisogna installare le nuove Guest Additions...
Ho aggiornato a VirtualBox 5.2.18, ho abilitato l'accelerazione 3D dalle impostazioni ed ora funziona! :birra:
Grazie mille! :D :D :ciao:

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 23091
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da giulux » lunedì 20 agosto 2018, 19:35

Se non hai più problemi modifica il titolo del primo post mettendoci davanti [Risolto].

Se vuoi puoi installare questo script che aggiunge un pulsante per mettere [Risolto] con un solo click.
Ciao.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: [Risolto] Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » martedì 21 agosto 2018, 8:29

Peccato che ora (dopo 3 mesi dal mio post....) Ubuntu 17.10 sia fuori supporto.

Fernando3
Prode Principiante
Messaggi: 14
Iscrizione: martedì 16 gennaio 2018, 21:45

Re: [Risolto] Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da Fernando3 » martedì 21 agosto 2018, 10:04

Non è un problema, mi importava solo recuperare i miei file, nel frattempo avevo già creato una nuova macchina virtuale con la nuova versione di Ubuntu. :D

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20339
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: [Risolto] Problema avvio Ubuntu 17.10 x64 su VirtualBox

Messaggio da trekfan1 » martedì 21 agosto 2018, 10:46

ok

Scrivi risposta

Torna a

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti