ubuntu in virtualbox: non si avvia la macchina virtuale

Installazione di Ubuntu su macchina virtuale (Virtualbox, Vmware, Qemu, Parallels, KVM, Xen, Virtual pc, ecc.), configurazione del software e gestione del sistema virtualizzato.

ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 6:05

Ho creato la macchina virtuale più o meno così
https://itsfoss.com/install-linux-in-virtualbox/

Ma quando tento di avviarla si apre una finestra che dice

Codice: Seleziona tutto
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please reinstall virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.


Perchè?
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 8:33

1) Sostituisci quel " $XDG_CURRENT_DESKTOP: ..." con GNOME (se hai il launcher a sx) nel profilo
2) Ulteriori info: che hardware hai? che versione di virtualbox usi? Che configurazione hai usato per la macchina virtuale?
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 9:16

trekfan1 Immagine ha scritto:1) Sostituisci quel " $XDG_CURRENT_DESKTOP: ..." con GNOME (se hai il launcher a sx) nel profilo
2) Ulteriori info: che hardware hai? che versione di virtualbox usi? Che configurazione hai usato per la macchina virtuale?


Hardware? Vedere la firma.

Codice: Seleziona tutto
$ apt-cache policy virtualbox
virtualbox:
  Installato: 6.0.6-dfsg-1
  Candidato:  6.0.6-dfsg-1
  Tabella versione:
 *** 6.0.6-dfsg-1 500
        500 http://it.archive.ubuntu.com/ubuntu disco/multiverse amd64 Packages
        100 /var/lib/dpkg/status
Allegati
1.png
Ultima modifica di trekfan1 il martedì 7 maggio 2019, 11:08, modificato 1 volta in totale.
Motivazione: Inseriti i tag CODE, ricordalo per il futuro
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 11:10

Il regolamento ammette massimo 3 righe per la firma comprese le righe vuote, le informazioni sull'hardware bastava che le mettessi nel topic tra tag CODE (tasto CODICE dell'editor completo) inoltre mi aspettavo uno screen più "completo" delle impostazioni della macchina virtuale....
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda frapox » martedì 7 maggio 2019, 11:22

london3 Immagine ha scritto:Ho creato la macchina virtuale più o meno così
https://itsfoss.com/install-linux-in-virtualbox/

Ma quando tento di avviarla si apre una finestra che dice
[...]

Perchè?


Probabilmente non hai i moduli del kernel per virtualbox correttamente installati e/o caricati.
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 548
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 11:41

Per il momento ho disinstallato virtualbox e relativi moduli

Codice: Seleziona tutto
$ sudo apt purge --auto-remove virtualbox*


anche perchè mi ha dato anche altri problemi di sistema: ora sembrano spariti!!!

Se decido di reinstallarlo, vi faccio sapere.

Intanto grazie per l'aiuto :)
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 13:20

Prova a installare virtualbox dai repo oracle: https://www.virtualbox.org/wiki/Downloads
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 14:25

trekfan1 Immagine ha scritto:Prova a installare virtualbox dai repo oracle: https://www.virtualbox.org/wiki/Downloads


Scaricato il file

https://download.virtualbox.org/virtual ... _amd64.deb

è quello giusto?

Installazione

Codice: Seleziona tutto
$ sudo gdebi Scaricati/virtualbox-6.0_6.0.6-130049~Ubuntu~bionic_amd64.deb


Ma il problema si ripresenta (vedere il post iniziale).
Altri dettagli nell'allegato.
Allegati
1.png
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda Pike » martedì 7 maggio 2019, 14:48

A VirtualBox chiuso il comando
Codice: Seleziona tutto
sudo modprobe vboxdrv
è stato eseguito?
Adoro il Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Io almeno me ne sono reso conto
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3997
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:09

Codice: Seleziona tutto
$ sudo modprobe vboxdrv
modprobe: ERROR: could not insert 'vboxdrv': Operation not permitted
Ultima modifica di trekfan1 il martedì 7 maggio 2019, 15:20, modificato 1 volta in totale.
Motivazione: inseriti i tag code, ricordati di usarli in futuro quando posti dei listati
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 15:12

Gli headers del kernel sono installati? Hai installato dkms?

PS: aumenta la memoria video, 12MB sono veramente pochi metti pure 128MB che è il massimo che vbox permette, inoltre per installare da terminale usa
Codice: Seleziona tutto
sudo dpkg -i <nomefile.deb>
(ovviamente senza le parentesi angolari che io ho inserito solo per esempio)

@london3 per favore racchiudi l'output del terminale tra tag CODE, grazie
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:17

trekfan1 Immagine ha scritto:Gli headers del kernel sono installati? Hai installato dkms?

Come si installano?
Rimani in linea se puoi.
Non c'è una chat per parlacci direttamente?
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 15:18

Codice: Seleziona tutto
sudo apt install dkms
per gli headers prima dai questo comando per vedere se sono installati
Codice: Seleziona tutto
dpkg -l | grep headers
L minuscola
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:23

trekfan1 Immagine ha scritto:
Codice: Seleziona tutto
sudo apt install dkms
per gli headers prima dai questo comando per vedere se sono installati
Codice: Seleziona tutto
dpkg -l | grep headers
L minuscola

Codice: Seleziona tutto
$ dpkg -l | grep headers
ii  linux-generic                                 5.0.0.13.14                                amd64        Complete Generic Linux kernel and headers
ii  linux-headers-5.0.0-13                        5.0.0-13.14                                all          Header files related to Linux kernel version 5.0.0
ii  linux-headers-5.0.0-13-generic                5.0.0-13.14                                amd64        Linux kernel headers for version 5.0.0 on 64 bit x86 SMP
ii  linux-headers-generic                         5.0.0.13.14                                amd64        Generic Linux kernel headers
ii  linux-signed-generic                          5.0.0.13.14                                amd64        Complete Signed Generic Linux kernel and headers (dummy transitional package)
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:25

Pike Immagine ha scritto:A VirtualBox chiuso il comando
Codice: Seleziona tutto
sudo modprobe vboxdrv
è stato eseguito?

Rimani il linea anche tu gentilmente.
Vediamo se possiamo risolverla subito.
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda Pike » martedì 7 maggio 2019, 15:26

Magari sono io che cado dal pero ma... Stan già distribuendo il kernel 5.0 come default?
Se la risposta è no, per quale motivo hai il kernel 5.0 installato?
Adoro il Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Io almeno me ne sono reso conto
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3997
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 15:27

Gli headers ci sono
Codice: Seleziona tutto
sudo apt --purge remove linux-signed-generic && sudo apt install -f
Pike la 19.04 ha il kernel 5.0
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:27

Pike Immagine ha scritto:Magari sono io che cado dal pero ma... Stan già distribuendo il kernel 5.0 come default?
Se la risposta è no, per quale motivo hai il kernel 5.0 installato?

Cioè?
Perdona l'ignoranza.

$ inxi
CPU: Dual Core Intel Core i3-8130U (-MT MCP-) speed/min/max: 1258/400/3400 MHz Kernel: 5.0.0-13-generic x86_64
Up: 38m Mem: 1854.5/7868.9 MiB (23.6%) Storage: 476.94 GiB (4.4% used) Procs: 263 Shell: bash 5.0.3
inxi: 3.0.33


Il mio Kernel è 5.0.0-13 giusto?
Ultima modifica di london3 il martedì 7 maggio 2019, 15:30, modificato 1 volta in totale.
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 15:29

@london3 lascia perdere, Pike ha la 18.04 mentre tu usi la 19.04 (se quello che è riportato sotto il tuo nickname è corretto)

@Pike ti ricordo questo topic
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20118
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda Pike » martedì 7 maggio 2019, 15:31

E' relativamente recente, di conseguenza (per mia ignoranza) non ero a conoscenza che fosse già distribuito in una release. E inoltre era indispensabile essere certi che la versione di VirtualBox possa funzionare con il Kernel 5.0, cosa che la 6.0.6 è.
Adoro il Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Io almeno me ne sono reso conto
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3997
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Successiva

Torna a Ubuntu su macchina virtuale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti