ubuntu in virtualbox: non si avvia la macchina virtuale

Installazione di Ubuntu su macchina virtuale (Virtualbox, Vmware, Qemu, Parallels, KVM, Xen, Virtual pc, ecc.), configurazione del software e gestione del sistema virtualizzato.

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:31

trekfan1 Immagine ha scritto:@london3 lascia perdere, Pike ha la 18.04 mentre tu usi la 19.04 (se quello che è riportato sotto il tuo nickname è corretto)

@Pike ti ricordo questo topic

Ok, allora qual'è il problema?
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » martedì 7 maggio 2019, 15:33

trekfan1 Immagine ha scritto:Gli headers ci sono
Codice: Seleziona tutto
sudo apt --purge remove linux-signed-generic && sudo apt install -f
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20114
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda DoctorStrange » martedì 7 maggio 2019, 15:38

VirtualBox ha un sistema di log abbastanza verboso.
Hai provato a consultare questi log e vedere se magari tichiariscono qualche idea, oppure magari possono indirizzarti nella direzione corretta dove cercare il problema.

Di solito i log sono all'interno del percorso: /home/$USER/"VirtualBox VMs", od almeno nella mia distribuzione è così.

Prova a controllare.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1709
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:42

trekfan1 Immagine ha scritto:
trekfan1 Immagine ha scritto:Gli headers ci sono
Codice: Seleziona tutto
sudo apt --purge remove linux-signed-generic && sudo apt install -f

e quindi?

PS

Codice: Seleziona tutto
sudo apt install -f

cosa fa?
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda Stealth » martedì 7 maggio 2019, 15:52

london3 ha scritto:
trekfan1 Immagine ha scritto:
trekfan1 Immagine ha scritto:Gli headers ci sono
Codice: Seleziona tutto
sudo apt --purge remove linux-signed-generic && sudo apt install -f

e quindi? ...

Vuoi una soluzione o un corso a domicilio su ogni comando suggerito, con ogni possibile esito?
london3 ha scritto:PS

Codice: Seleziona tutto
sudo apt install -f

cosa fa?

Come sopra, e se tu cercassi troveresti mille spiegazioni, Questo forum è un contenitore di soluzioni, bisogna solo averne voglia e mostrare po' di interesse.
edit: e mi sono già segnalato da solo
Ultima modifica di Stealth il martedì 7 maggio 2019, 15:54, modificato 1 volta in totale.
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16300
Iscrizione: gennaio 2006
Desktop: Gnome
Distribuzione: Ubuntu 18.04 LTS

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 15:53

DoctorStrange Immagine ha scritto:VirtualBox ha un sistema di log abbastanza verboso.
Hai provato a consultare questi log e vedere se magari tichiariscono qualche idea, oppure magari possono indirizzarti nella direzione corretta dove cercare il problema.

Di solito i log sono all'interno del percorso: /home/$USER/"VirtualBox VMs", od almeno nella mia distribuzione è così.

Prova a controllare.

Codice: Seleziona tutto
$ ls ~/"VirtualBox VMs"
'Clone di ubuntu'
$ ls ~/"VirtualBox VMs/Clone di ubuntu"/
'Clone di ubuntu.vbox'  'Clone di ubuntu.vbox-prev'   ubuntu-disk2.vdi

Non sembrano file di log.
Forse volevi dire il file /var/crash/_usr_lib_virtualbox_VirtualBoxVM.0.crash
Ecco la parte iniziale
Codice: Seleziona tutto
ProblemType: Crash
Architecture: amd64
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Tue May  7 15:11:03 2019
DistroRelease: Ubuntu 19.04
ExecutablePath: /usr/lib/virtualbox/VirtualBoxVM
ExecutableTimestamp: 1555411935
ProcCmdline: /usr/lib/virtualbox/VirtualBoxVM --comment Clone\ di\ ubuntu --startvm b598238c-e3c9-45cf-abbe-2abdb8367b20 --no-startvm-errormsgbox
ProcCwd: /home/mionome
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcMaps:
 55ff642dd000-55ff64302000 r-xp 00000000 103:05 1839323                   /usr/lib/virtualbox/VirtualBoxVM
 55ff64501000-55ff64503000 r--p 00024000 103:05 1839323                   /usr/lib/virtualbox/VirtualBoxVM
 55ff64503000-55ff64504000 rw-p 00026000 103:05 1839323                   /usr/lib/virtualbox/VirtualBoxVM
 55ff64504000-55ff64507000 rw-p 00000000 00:00 0
 55ff6523a000-55ff6529e000 rw-p 00000000 00:00 0                          [heap]
 55ff6529e000-55ff6592e000 rw-p 00000000 00:00 0                          [heap]
 7fb418000000-7fb418021000 rw-p 00000000 00:00 0
 7fb418021000-7fb41c000000 ---p 00000000 00:00 0
 7fb420000000-7fb420021000 rw-p 00000000 00:00 0
 7fb420021000-7fb424000000 ---p 00000000 00:00 0
 7fb425985000-7fb4259d7000 r--p 00000000 103:05 2631148                   /usr/share/fonts/truetype/ubuntu/Ubuntu-B.ttf
 7fb4259d7000-7fb4259d8000 ---p 00000000 00:00 0
 7fb4259d8000-7fb4261d8000 rw-p 00000000 00:00 0
Ultima modifica di london3 il martedì 7 maggio 2019, 16:07, modificato 1 volta in totale.
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda DoctorStrange » martedì 7 maggio 2019, 16:04

Forse i tuoi log si trovano in un percorso diverso. Hai provato a controllare se magari si trovano sotto /var/log, oppure da un'altra parte?
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1709
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 16:09

DoctorStrange Immagine ha scritto:Forse i tuoi log si trovano in un percorso diverso. Hai provato a controllare se magari si trovano sotto /var/log, oppure da un'altra parte?

Codice: Seleziona tutto
$ ls /var/log -l
totale 22404
-rw-r--r--  1 root              root               2293 mag  6 13:05 alternatives.log
-rw-r--r--  1 root              root              63917 apr 25 20:25 alternatives.log.1
drwxr-x---  2 root              adm                4096 mag  7 05:26 apache2
-rw-r-----  1 root              adm               10013 mag  7 16:24 apport.log
-rw-r-----  1 root              adm                1517 mag  1 16:33 apport.log.1
-rw-r-----  1 root              adm                 242 apr 15 09:48 apport.log.2.gz
-rw-r-----  1 root              adm                 225 apr 11 13:32 apport.log.3.gz
-rw-r-----  1 root              adm                 224 apr 10 18:06 apport.log.4.gz
drwxr-xr-x  2 root              root               4096 mag  7 16:37 apt
-rw-r-----  1 syslog            adm               95219 mag  7 17:07 auth.log
-rw-r-----  1 syslog            adm              304659 mag  5 08:58 auth.log.1
-rw-r-----  1 syslog            adm                8772 apr 28 07:56 auth.log.2.gz
-rw-r-----  1 syslog            adm               12563 apr 23 09:33 auth.log.3.gz
-rw-r-----  1 syslog            adm               15507 apr 14 09:05 auth.log.4.gz
-rw-------  1 root              root            1428235 mag  7 15:12 boot.log
-rw-r--r--  1 root              root             102060 ott 18  2018 bootstrap.log
-rw-rw----  1 root              utmp                  0 mag  1 06:26 btmp
-rw-rw----  1 root              utmp                  0 ott 18  2018 btmp.1
drwxr-xr-x  2 root              root               4096 mag  7 05:26 cups
drwxr-xr-x  2 root              root               4096 apr 20 13:18 dist-upgrade
-rw-r--r--  1 root              adm               77155 mag  7 15:12 dmesg
-rw-r--r--  1 root              adm               78022 mag  7 12:47 dmesg.0
-rw-r--r--  1 root              adm               19900 mag  7 12:18 dmesg.1.gz
-rw-r--r--  1 root              adm               19896 mag  7 11:18 dmesg.2.gz
-rw-r--r--  1 root              adm               19850 mag  7 11:10 dmesg.3.gz
-rw-r--r--  1 root              adm               19850 mag  7 10:39 dmesg.4.gz
-rw-r--r--  1 root              root              54620 mag  7 16:37 dpkg.log
-rw-r--r--  1 root              root            3739256 apr 30 21:05 dpkg.log.1
-rw-r--r--  1 root              root              32032 apr 10 12:34 faillog
-rw-r--r--  1 root              root              12037 apr 25 20:25 fontconfig.log
drwx--x--x  2 root              gdm                4096 ott 16  2018 gdm3
-rw-r--r--  1 root              root               1268 mag  7 15:12 gpu-manager.log
drwxr-xr-x  3 root              root               4096 ott 18  2018 hp
drwxr-xr-x  2 root              root               4096 apr  9 15:29 installer
drwxr-sr-x+ 3 root              systemd-journal    4096 apr  9 15:31 journal
-rw-r-----  1 syslog            adm             1825565 mag  7 16:48 kern.log
-rw-r-----  1 syslog            adm             4412476 mag  5 08:58 kern.log.1
-rw-r-----  1 syslog            adm              320410 apr 28 07:56 kern.log.2.gz
-rw-r-----  1 syslog            adm              699146 apr 23 09:33 kern.log.3.gz
-rw-r-----  1 syslog            adm             1032049 apr 14 09:05 kern.log.4.gz
-rw-rw-r--  1 root              utmp             292292 apr 10 12:34 lastlog
drwxr-xr-x  2 root              root               4096 set  3  2018 openvpn
drwx------  2 root              root               4096 ott 18  2018 private
drwx------  2 speech-dispatcher root               4096 set 19  2018 speech-dispatcher
-rw-r-----  1 syslog            adm             3797479 mag  7 17:07 syslog
-rw-r-----  1 syslog            adm             1756711 mag  7 05:26 syslog.1
-rw-r-----  1 syslog            adm              227967 mag  6 09:05 syslog.2.gz
-rw-r-----  1 syslog            adm              417016 mag  5 08:58 syslog.3.gz
-rw-r-----  1 syslog            adm              334724 mag  4 07:52 syslog.4.gz
-rw-r-----  1 syslog            adm              579297 mag  3 05:58 syslog.5.gz
-rw-r-----  1 syslog            adm              713038 mag  2 06:59 syslog.6.gz
-rw-r-----  1 syslog            adm              238740 mag  1 06:26 syslog.7.gz
-rw-------  1 root              root              64064 apr 10 12:34 tallylog
drwxr-s---  2 debian-tor        adm                4096 apr 10 12:34 tor
drwxr-x---  2 root              adm                4096 mag  1 06:26 unattended-upgrades
drwxr-xr-x  2 root              root               4096 apr 20 13:19 upgrade
-rw-r--r--  1 root              root                140 mag  7 15:12 vbox-setup.log
-rw-r--r--  1 root              root                140 mag  7 14:39 vbox-setup.log.1
-rw-rw-r--  1 root              utmp             265728 mag  7 15:12 wtmp
Ultima modifica di london3 il martedì 7 maggio 2019, 16:41, modificato 1 volta in totale.
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » martedì 7 maggio 2019, 16:40

Come sopra, e se tu cercassi troveresti mille spiegazioni, Questo forum è un contenitore di soluzioni, bisogna solo averne voglia e mostrare po' di interesse.


Chiedo scusa, ma ho tante cose da fare, è volevo risolvere tutto all'istante.
Non è sempre possibile, lo so, avete ragione.
Intanto ecco altri dettagli
Codice: Seleziona tutto
$ tail /var/log/apport.log
ERROR: apport (pid 14555) Tue May  7 16:24:11 2019: executable: /usr/lib/virtualbox/VirtualBoxVM (command line "/usr/lib/virtualbox/VirtualBoxVM --comment Clone\ di\ ubuntu --startvm b598238c-e3c9-45cf-abbe-2abdb8367b20 --no-startvm-errormsgbox")
ERROR: apport (pid 14555) Tue May  7 16:24:11 2019: debug: session gdbus call: (true,)

ERROR: apport (pid 14555) Tue May  7 16:24:11 2019: apport: report /var/crash/_usr_lib_virtualbox_VirtualBoxVM.0.crash already exists and unseen, doing nothing to avoid disk usage DoS
ERROR: apport (pid 8782) Tue May  7 17:31:39 2019: called for pid 8776, signal 6, core limit 0, dump mode 2
ERROR: apport (pid 8782) Tue May  7 17:31:39 2019: not creating core for pid with dump mode of 2
ERROR: apport (pid 8782) Tue May  7 17:31:39 2019: executable: /usr/lib/virtualbox/VirtualBoxVM (command line "/usr/lib/virtualbox/VirtualBoxVM --comment Clone\ di\ ubuntu --startvm b598238c-e3c9-45cf-abbe-2abdb8367b20 --no-startvm-errormsgbox")
ERROR: apport (pid 8782) Tue May  7 17:31:39 2019: debug: session gdbus call: (true,)

ERROR: apport (pid 8782) Tue May  7 17:31:39 2019: this executable already crashed 2 times, ignoring
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda frapox » domenica 12 maggio 2019, 17:22

Virtualbox richiede i seguenti passaggi per funzionare sotto ubuntu:

- installazione degli headers del tuo kernel (di solito: linux-headers-generic)
- installazione dei pacchetti: virtualbox (che si tira dietro come dipendenze anche: virtualbox-dkms e virtualbox-qt)
- installazione opzionale del pacchetto: virtualbox-ext-pack (attenzione: contiene sw sottoposto a restrizioni di copyright, quindi a tua discrezione, ma è necessario per usare alcune feature, tipo l'usb 3.0 passthorugh).
- aggiunta del tuo utente al gruppo vboxusers:
Codice: Seleziona tutto
sudo usermod -aG vboxusers tuo_username

- logout/login

a questo punto, controlla se i moduli di vbox sono caricati,
Codice: Seleziona tutto
lsmod | grep -i vbox

se non lo sono, controlla che il dkms abbia fatto il suo lavoro:
Codice: Seleziona tutto
dkms status

dovrebbe uscirti qualcosa tipo: "virtualbox, 6.0.6, 5.0.0-13-generic, x86_64: installed"

Se non esce nulla, prova a forzare l'esecuzione di dkms con:
Codice: Seleziona tutto
sudo dkms autoinstall

dovrebbe restituirti un output che ti indica che i moduli sono stati creati. Riavvia il PC.

A sto punto dovrebbe essere tutto in ordine per creare/eseguire delle VM con virtualbox su ubuntu come macchina host. Ti raccomando di dare un occhiata alle wiki (ubuntu, Arch) che contengono sempre molte info utili.

https://wiki.ubuntu-it.org/Virtualizzazione/VirtualBox
https://wiki.archlinux.org/index.php/VirtualBox
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 531
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » domenica 12 maggio 2019, 17:51

- installazione opzionale del pacchetto: virtualbox-ext-pack (attenzione: contiene sw sottoposto a restrizioni di copyright, quindi a tua discrezione, ma è necessario per usare alcune feature, tipo l'usb 3.0 passthorugh).

Restrizioni di che tipo?
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda frapox » domenica 12 maggio 2019, 18:37

Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 531
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » domenica 12 maggio 2019, 19:49

Le usb funzionano solo se si usa il pacchetto scaricato dal sito Oracle non quello dei repo
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20114
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » lunedì 13 maggio 2019, 10:05

Codice: Seleziona tutto
sudo apt install linux-headers-generic virtualbox


Tra le varie cose esce questo

Codice: Seleziona tutto
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; generated)
   Active: failed (Result: exit-code) since Mon 2019-05-13 10:12:37 CEST; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 10268 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)


PERCHÈ ? ? ?

Codice: Seleziona tutto
$ lsmod | grep -i vbox
[NESSUN OUTPUT]


Sembra che i moduli di vbox non siano stati caricati.
PERCHÈ ? ? ?

Codice: Seleziona tutto
$ dkms status
virtualbox, 6.0.6, 5.0.0-13-generic, x86_64: installed


Qui sembra tutto ok, quindi riavvio il pc, apro virtualbox e creo una nuova macchina.
Appare la solita finestra (vedere allegato 1.png).

PERCHÈ ? ? ?

Inoltre ogni volta che avvio il pc mi appare un box (vedere allegato 2.png).

PERCHÈ ? ? ?
Allegati
2.png
1.png
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda frapox » lunedì 13 maggio 2019, 10:54

I moduli di Vbox non ti vengono caricati, hai guardato nel log per vedere come mai?
Codice: Seleziona tutto
journalctl -b

L'ultimo screenshot qualche indicazione la da, cioè hai il Secure boot attivato? Vai nel bios e disattivalo.

Intanto dai anche un:
Codice: Seleziona tutto
sudo dpkg -l virtualbox* | grep ii

e un
Codice: Seleziona tutto
sudo dpkg -l linux* | grep ii

così capiamo che cosa hai installato esattamente.
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 531
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » lunedì 13 maggio 2019, 11:55

frapox Immagine ha scritto:I moduli di Vbox non ti vengono caricati, hai guardato nel log per vedere come mai?
Codice: Seleziona tutto
journalctl -b

L'ultimo screenshot qualche indicazione la da, cioè hai il Secure boot attivato? Vai nel bios e disattivalo.

Intanto dai anche un:
Codice: Seleziona tutto
sudo dpkg -l virtualbox* | grep ii

e un
Codice: Seleziona tutto
sudo dpkg -l linux* | grep ii

così capiamo che cosa hai installato esattamente.


Codice: Seleziona tutto
$ journalctl -b
[SOLO LE ULTIME RIGHE]
mag 13 12:44:51 lond-ThinkPad-L480 systemd-resolved[874]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
mag 13 12:44:52 lond-ThinkPad-L480 systemd-resolved[874]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
mag 13 12:44:58 lond-ThinkPad-L480 sudo[11886]:     lond : TTY=pts/0 ; PWD=/home/rino/Scrivania/vbox ; USER=root ; COMMAND=/usr/bin/dpkg -l linux*
mag 13 12:44:58 lond-ThinkPad-L480 sudo[11886]: pam_unix(sudo:session): session opened for user root by (uid=0)
mag 13 12:44:58 lond-ThinkPad-L480 sudo[11886]: pam_unix(sudo:session): session closed for user root
mag 13 12:45:01 lond-ThinkPad-L480 systemd-resolved[874]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
mag 13 12:47:08 lond-ThinkPad-L480 dbus-daemon[1754]: [session uid=1000 pid=1754] Activating via systemd: service name='org.freedesktop.Tracker1.Miner.Extract' unit='tracker-extract.service' requested by ':1.63' (uid=1000 pid=2252 comm="/usr/lib/tracker/tracker-miner-fs " label="unconfined")
mag 13 12:47:08 lond-ThinkPad-L480 systemd[1257]: Starting Tracker metadata extractor...
mag 13 12:47:08 lond-ThinkPad-L480 geany.desktop[1959]: # _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
mag 13 12:47:08 lond-ThinkPad-L480 dbus-daemon[1754]: [session uid=1000 pid=1754] Successfully activated service 'org.freedesktop.Tracker1.Miner.Extract'
mag 13 12:47:08 lond-ThinkPad-L480 systemd[1257]: Started Tracker metadata extractor.
mag 13 12:47:08 lond-ThinkPad-L480 geany.desktop[1959]: # _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
mag 13 12:47:08 lond-ThinkPad-L480 geany.desktop[1959]: # watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
mag 13 12:47:08 lond-ThinkPad-L480 geany.desktop[1959]: # unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
mag 13 12:47:08 lond-ThinkPad-L480 geany.desktop[1959]: # watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)
mag 13 12:47:19 lond-ThinkPad-L480 systemd[1257]: tracker-extract.service: Succeeded.
mag 13 12:49:51 lond-ThinkPad-L480 systemd-resolved[874]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
mag 13 12:49:52 lond-ThinkPad-L480 systemd-resolved[874]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
mag 13 12:50:01 lond-ThinkPad-L480 systemd-resolved[874]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.

$ dpkg -l virtualbox* | grep ii
ii  virtualbox                     6.0.6-dfsg-1 amd64        x86 virtualization solution - base binaries
ii  virtualbox-dkms                6.0.6-dfsg-1 all          x86 virtualization solution - kernel module sources for dkms
ii  virtualbox-qt                  6.0.6-dfsg-1 amd64        x86 virtualization solution - Qt based user interface
 
$ dpkg -l linux* | grep ii
ii  linux-base                             4.5ubuntu1           all          Linux image base package
ii  linux-firmware                         1.178                all          Firmware for Linux kernel drivers
ii  linux-generic                          5.0.0.13.14          amd64        Complete Generic Linux kernel and headers
ii  linux-headers-5.0.0-13                 5.0.0-13.14          all          Header files related to Linux kernel version 5.0.0
ii  linux-headers-5.0.0-13-generic         5.0.0-13.14          amd64        Linux kernel headers for version 5.0.0 on 64 bit x86 SMP
ii  linux-headers-generic                  5.0.0.13.14          amd64        Generic Linux kernel headers
ii  linux-image-4.18.0-17-generic          4.18.0-17.18         amd64        Signed kernel image generic
ii  linux-image-5.0.0-13-generic           5.0.0-13.14          amd64        Signed kernel image generic
ii  linux-image-generic                    5.0.0.13.14          amd64        Generic Linux kernel image
ii  linux-libc-dev:amd64                   5.0.0-13.14          amd64        Linux Kernel Headers for development
ii  linux-modules-4.18.0-17-generic        4.18.0-17.18         amd64        Linux kernel extra modules for version 4.18.0 on 64 bit x86 SMP
ii  linux-modules-5.0.0-13-generic         5.0.0-13.14          amd64        Linux kernel extra modules for version 5.0.0 on 64 bit x86 SMP
ii  linux-modules-extra-4.18.0-17-generic  4.18.0-17.18         amd64        Linux kernel extra modules for version 4.18.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.0.0-13-generic   5.0.0-13.14          amd64        Linux kernel extra modules for version 5.0.0 on 64 bit x86 SMP
ii  linux-sound-base                       1.0.25+dfsg-0ubuntu5 all          base package for ALSA and OSS sound systems


Non ho usato sudo, è lo stesso?
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda frapox » lunedì 13 maggio 2019, 12:22

Le ultime righe del journal che hai incollato non servono a nulla, in quanto non riguardano virtualbox.
Codice: Seleziona tutto
man journalctl


I pacchetti che hai installato sono giusti, son gli stessi che ho io.

Hai disattivato da Bios il secure boot?
Hai avviato il kernel 5.0.0-13-generic ?
Codice: Seleziona tutto
uname -a

Hai aggiunto il tuo utente al gruppo vboxusers?
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 531
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda london3 » lunedì 13 maggio 2019, 14:54

frapox Immagine ha scritto:Le ultime righe del journal che hai incollato non servono a nulla, in quanto non riguardano virtualbox.
Codice: Seleziona tutto
man journalctl



https://ufile.io/lye3xqon
clicca su slow download

Hai disattivato da Bios il secure boot?


si

Hai avviato il kernel 5.0.0-13-generic ?
Codice: Seleziona tutto
uname -a



Codice: Seleziona tutto
$ uname -a
Linux lond-ThinkPad-L480 5.0.0-13-generic #14-Ubuntu SMP Mon Apr 15 14:59:14 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


Hai aggiunto il tuo utente al gruppo vboxusers?


Codice: Seleziona tutto
$ groups $USER
london : london adm cdrom sudo dip plugdev lpadmin sambashare docker vboxusers


Direi di si.

Finalmente sembra funzionare.

Rimane il problema della finestra dopo l'avvio di ubuntu: vedere allegato
Allegati
programma-di-sistema.png
Ultima modifica di london3 il lunedì 13 maggio 2019, 15:17, modificato 2 volte in totale.
Computer: Lenovo ThinkPad L480
Avatar utente
london3
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 267
Iscrizione: gennaio 2014
Desktop: ubuntu:GNOME
Distribuzione: Ubuntu 19.10 x86_64

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda frapox » lunedì 13 maggio 2019, 15:01

Allora non so che altro possa essere, mi dispiace.
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 531
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: ubuntu in virtualbox: non si avvia la macchina virtuale

Messaggioda trekfan1 » lunedì 13 maggio 2019, 15:06

Prova ad avviare il sistema HOST (ovvero il pc vero) con il kernel precedente
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20114
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

PrecedenteSuccessiva

Torna a Ubuntu su macchina virtuale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite