Messaggio di errore quando apro terminale

Configurazione e uso delle applicazioni del desktop manager alla base di Lubuntu.

Messaggio di errore quando apro terminale

Messaggioda mber » giovedì 23 novembre 2017, 7:46

Buongiorno a tutti,
Ho fatto qualche piccolo cambiamento a certi file che passano i parametri iniziali p.es. per tenere attivato il numlock in una X session. Non sono sicuro che il problema venga da lì perché non è apparso immediatamente dopo i cambiamenti ma dopo qualche riavvio...

Adesso quando apro un terminal la prima cosa che fa è mettermi questo messaggio:
Codice: Seleziona tutto
Comando "name" non trovato. Forse si intendeva:
 Comando "lame" dal pacchetto "lame" (universe)
 Comando "mame" dal pacchetto "mame" (multiverse)
 Comando "namei" dal pacchetto "util-linux" (main)
 Comando "uname" dal pacchetto "coreutils" (main)
 Comando "named" dal pacchetto "bind9" (main)
 Comando "nvme" dal pacchetto "nvme-cli" (universe)
 Comando "nama" dal pacchetto "nama" (universe)
 Comando "nam" dal pacchetto "nam" (universe)
name: comando non trovato
[user]@[computer]:~$


Qualche consiglio su dove andare a cercare la causa?

Grazie.
Ciao,
Marco

Codice: Seleziona tutto
LXDE su sistema: GNU/Linux & distro: Lubuntu [Ubuntu 16.04.3 LTS x86_64]
Kernel release: 4.10.0-38-generic
Kernel version: #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017
Ultima modifica di trekfan1 il giovedì 23 novembre 2017, 9:44, modificato 1 volta in totale.
Motivazione: Inseriti tag CODE
mber
Prode Principiante
 
Messaggi: 2
Iscrizione: novembre 2017
Desktop: Lubuntu
Distribuzione: Ubuntu 16.04.3 LTS x86_64
Sesso: Maschile

Re: Messaggio di errore quando apro terminale

Messaggioda giulux » giovedì 23 novembre 2017, 8:33

Benvenuto!

Se non specifichi i "piccoli cambiamenti" che hai fatto e a quali file è difficile aiutarti.

in futuro il terminale postalo copiandolo tutto e incollandolo qui tra i tag [ code] e [ /code] che si creano cliccando su Codice in alto, sopra la finestra di scrittura (editor completo) così:
    [ code]listato
    da postare
    [ /code]

Ciao
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 21911
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.1 LTS x86_64
Sesso: Maschile

Re: Messaggio di errore quando apro terminale

Messaggioda daigo » giovedì 23 novembre 2017, 9:20

Boh, forse hai modificato il file .bashrc ?
Posta l'output
Codice: Seleziona tutto
cat ~/.bashrc
daigo
 

Re: Messaggio di errore quando apro terminale

Messaggioda pachisapiu » giovedì 23 novembre 2017, 11:45

mber Immagine ha scritto:Buongiorno a tutti,
Ho fatto qualche piccolo cambiamento a certi file che passano i parametri iniziali p.es. per tenere attivato il numlock in una X session.

Invece di pasticciare il sistema operativo bastava
Codice: Seleziona tutto
sudo apt install numlockx
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1945
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Messaggio di errore quando apro terminale

Messaggioda mber » sabato 25 novembre 2017, 12:59

Ciao e grazie mille.

Ecco l'output richiesto

Codice: Seleziona tutto
$ cat ~/.bashrc
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a
name expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
   # We have color support; assume it's compliant with Ecma-48
   # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
   # a case would tend to support setf rather than setaf.)
   color_prompt=yes
    else
   color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi



Ho anche verificato l'output di

Codice: Seleziona tutto
cat ~/.bashrc|grep name


che dà:

Codice: Seleziona tutto
name expansion context will


Potrete vedere che era una linea di commento con un "a capo" - forse il problema è qui? In effetti, aggiungendo un # il problemino si risolve :D

Sono abbastanza sicuro di non aver pasticciato quello.

A proposito di
Invece di pasticciare il sistema operativo bastava
Codice: Seleziona tutto
sudo apt install numlockx


Ero ben andato a leggere le cose riguardo numlockx e l'avevo effettivamente istallato ma dalle istruzioni che avevo trovato online sembrava necessario dire al sistema operativo in un file di configurazione di mettere il numlock = ON nella sessione X e all'inizio ha funzionato senza l'altro piccolo problema. Adesso c'è questo problama E per di più non funziona più il numlockx. A proposito, io "numlockx on" non l'ho messo nel .bashrc come vedrete. Mistero.

CMQ grazie mille! :ciao:

Marco
mber
Prode Principiante
 
Messaggi: 2
Iscrizione: novembre 2017
Desktop: Lubuntu
Distribuzione: Ubuntu 16.04.3 LTS x86_64
Sesso: Maschile

Re: Messaggio di errore quando apro terminale

Messaggioda pachisapiu » sabato 25 novembre 2017, 14:43

prova a ripristinarlo con
Codice: Seleziona tutto
cp /etc/skel/.bashrc ~/.bashrc
dopo dato il comando chiudi e riapri il terminale
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1945
Iscrizione: maggio 2017
Distribuzione: FreeDOS


Torna a LXDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite