Pagina 1 di 1

Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 13:02
da Giaaamma
Salve a tutti, mi sono registrato perchè è sia un ottimo forum e sia perchè non sono riuscito ad avere una risposta nelle discussioni che già ci sono.

Ho un MSI gl62m con i7 7700HQ, 8GB DDR4, 1TB HDD, e 128GB SSD, GTX1050TI.

Sull'ssd ho installato Windows 10 e sull'hard disk da 1TB ci metto tutti i file e i programmi installati per lasciare libero l'ssd. poi ho ridimensionato la partizione dell'hard disk per farmi una partizione da 100GB e istallare kali linux.
Avvio l'installazione di kali, senza nessun problema, gli do la partizione e lo installo correttamente. terminata l'installazione, cerco di avviare kali. Parte grub, dico di avviare kali e non Windows e comincia il caricamento di kali.
Appena dovrebbe farmi vedere il desktop o perlomeno cercare di caricarlo, si spegne il pc automaticamente. Windows invece parte senza problemi.
Ho anche provato a premere "e" quando ho grub aperto e insierire "acpi=0" ma niente... Cosa potrebbe essere?

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 13:32
da xavier77
Ciao e benvenuto!
Cioè stai installando Kali su pc?
Ti posto un video molto esaustivo:

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 13:37
da Giaaamma
si, sto installando kali perchè ho bisogno proprio di questa distribuzione. ma tanto ho riscontrato lo stesso problema anche con debian

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 14:16
da Filoteo
xavier77 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5156206#p5156206][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Ciao e benvenuto!
Cioè stai installando Kali su pc?
Ti posto un video molto esaustivo:
Mi dissi prima di premere Mostra video YouTube: "ci sarà proprio quel video?". Non sono rimasto deluso :birra:

@Giaaamma Modifica i parametri di avvio premendo e sul GRUB e togli quiet splash. Quale messaggio compare prima di bloccarsi? Prova anche Ubuntu.

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 16:20
da xavier77
Giaaamma [url=https://forum.ubuntu-it.org/viewtopic.php?p=5156209#p5156209][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:si, sto installando kali perchè ho bisogno proprio di questa distribuzione. ma tanto ho riscontrato lo stesso problema anche con debian
Di solito chi usa Kali non lo fa perché ha bisogno proprio di Kali, ma perché ha bisogno di un tool preinstallato in Kali.
Tool che sono installabili pressoché in qualunque altra distribuzione GNU/Linux (Debian, Fedora, Arch. Ubuntu ecc.).
Ora non so il tuo caso, ma valuta bene
  • gli sbattimenti e le perdite di tempo inutili per installarla su un pc (dovuti al kernel customizzato, firmware blacklistati, driver disabilitati all'avvio ecc.).
  • i potenziali pericoli relativi alla sicurezza dovuti ad usare per tutto l'utente root
L'uso "tipico" di Kali è in live, o al massimo installata su USB o macchina virtuale.

Detto ciò, ognuno poi è libero di perdere gestirsi il tempo come crede.
Io volevo solo avvisarti ;) :ciao:

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 17:59
da Giaaamma
l'ultimo messaggio che vedo prima di spegnersi è:
GNOME display manager...

@xavier ho provato anche con debian e mi da lo stesso problema. ubuntu lo tolgo dalla lista da provare perchè non mi piace

aggiornamento 1...

non riesco a trovare il testo quiet splash, ma trovo solo quiet. ma cancellandolo, non parte ugualmente...

ho provato a installarlo 6 volte

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 19:58
da xavier77
Per circoscrivere il problema: se disconnetti momentaneamente la scheda grafica, parte?
Riesci ad accedere ad una shell, anche in modalità ripristino? E nel caso hai provato con i driver proprietari (ovviamente parlo di Debian, Kali ha dei repository suoi)?
https://wiki.debian.org/it/NvidiaGraphicsDrivers

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 20:02
da Giaaamma
La scheda grafica non posso disconnetterla essendo un portatile. si comunque posso entrare nel terminale tramite la modalità ripristino e ho provato ad installare i driver relativi alla mia scheda video presi direttamente da Nvidia. ma nulla, si spegne non appena estrae il contenuto da installare. (è un formato .run che eseguo tramite "./")

Re: Boot di Kali linux problematico

Inviato: mercoledì 9 ottobre 2019, 20:20
da xavier77
Ah ok è un portatile :D
Alcune info:
Debian l'hai installato da netinstall?
In modalità ripristino ti sei ricordato:

Codice: Seleziona tutto

mount -o remount,rw /
(se no non ti salva i cambiamenti)?
Ok i driver dal sito Nvidia, ma quelli nei repo (credo siano in backports)?
Una prova con un altra distro "a caso" che non abbia GNOME e gdm (visto che ė lì che si blocca)?