[Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda trekfan1 » mercoledì 2 aprile 2008, 18:48

Controllate i codici dell'apparecchio e sopratutto nella pagina di configurazione guardate se c'è scritto PIRELLI o DIAL FACE

codici:
705005 -> Dial face WIFI (AGIA)
705000 -> Dial face NO WIFI (AGIB)
704xxx -> Pirelli (AGB, AGA)
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16010
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Unity/Gnome Shell
Distribuzione: Ubuntu 17.04 e 17.10 (dev) 64 bit
Sesso: Maschile

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda lik » mercoledì 2 aprile 2008, 20:11

dont ha scritto:PC FISSO, collegamento pc/router attraverso cavo di rete ethernet.
Distribuzione: Ubuntu
Versione del Kernel: 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
Nome del Router: Alice Gate 2 Plus Wi-Fi
Versione del firmware del router: AGIA_1.2.0
Versione dell'hardware del router: S3PM-2
Esito: il collegamento ad internet funziona, nessun problema a visualizzare le pagine web e/o a scaricare file;[ unico inconveniente periodici freeze di firefox, presenti anche con il router di prima e presumo dovuti ad altri problemi. (http://forum.ubuntu-it.org/viewtopic.ph ... 92#p902892:'( ]


Questo e' strano, perche' finora pare che tutti i kernel 2.6.22 hanno dato il problema.
Sei sicuro che non stai utilizzando l'aggeggio di Telecom come bridge invece che come router? (Cioe' l'hai configurato con pppoeconf?)
Per scoprirlo dovresti eseguire, dal computer che funziona (il PC FISSO) il comando sudo route -n e vedere quale interfaccia e' utilizzata per connetterti ad internet (se e' pppN oppure ethN), ovvero dovresti dirmi il nome dell'interfaccia messa in fondo alla linea che comincia con 0.0.0.0.
grz!
lik
Prode Principiante
 
Messaggi: 4
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda dont » mercoledì 2 aprile 2008, 21:32

lik ha scritto:Questo e' strano, perche' finora pare che tutti i kernel 2.6.22 hanno dato il problema.
Sei sicuro che non stai utilizzando l'aggeggio di Telecom come bridge invece che come router? (Cioe' l'hai configurato con pppoeconf?)
Per scoprirlo dovresti eseguire, dal computer che funziona (il PC FISSO) il comando sudo route -n e vedere quale interfaccia e' utilizzata per connetterti ad internet (se e' pppN oppure ethN), ovvero dovresti dirmi il nome dell'interfaccia messa in fondo alla linea che comincia con 0.0.0.0.
grz!


Siccome il mio è un contratto business, il coso è già configurato come "Bridged+Routed", come mi conferma la relativa pagina di stato del modem. Infatti la configurazione dovrebbe essere su di una scheda con chip inserita nel router (con i dati della linea e i codici di protezione del wireless), la cosiddetta smart card.
Comunque, il risultato di
Codice: Seleziona tutto
sudo route -n
è una tabella, "Kernel IP routing table", con i vari indirizzi, ma tutti dell'interfaccia eth0 (compresa l'ultima).
Avatar utente
dont
Prode Principiante
 
Messaggi: 81
Iscrizione: maggio 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda matley81 » giovedì 3 aprile 2008, 10:02

rispondo al vostro appello e vi do i miei dati:

Distribuzione Ubuntu gutsy 7.10
Versione del kernel : 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
Router: Alice gate 2 plus
Mi carica le pagine a metà (e non finisce mai) su qualsiasi sito vada

Hai bisogno anche firmaware e del  hardware? ho rimesso il vecchio modem alice gate business quindi dovrei rimettere il router che non funziona... ho ripristinato il vecchio visto che era l unico modo per riprendere a navigare
nessuno sa dov è il villaggio degli gnome ?
Avatar utente
matley81
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 586
Iscrizione: settembre 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda matley81 » giovedì 3 aprile 2008, 10:29

ho rimesso per un attimo il router che non funziona... mi sembrava stupido non mettere questi dati. In definitiva ho :

Distribuzione Ubuntu (gutsy 7.10)
Versione del kernel : 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
Router: Alice gate 2 plus
Hardware: S2PF-6
Software: AGIB_1.1.6

Mi carica le pagine a metà (e non finisce mai) su qualsiasi sito vada (ovviamente non ho provato tutti i siti del mondo!!!!!)
nessuno sa dov è il villaggio degli gnome ?
Avatar utente
matley81
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 586
Iscrizione: settembre 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda lik » giovedì 3 aprile 2008, 18:37

dont ha scritto:Comunque, il risultato di
Codice: Seleziona tutto
sudo route -n
è una tabella, "Kernel IP routing table", con i vari indirizzi, ma tutti dell'interfaccia eth0 (compresa l'ultima).

quindi non compare mai ppp0 nella tabella? e l'indirizzo ip del tuo computer (si vede da sudo ifconfig) e' tipo 192.168.0.*?
questo si' che e' strano.  ???
lik
Prode Principiante
 
Messaggi: 4
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda __Neo » giovedì 3 aprile 2008, 20:56

:o Ciao raga
ecco, sono collegato in modalità win e vorrei passare a navigare con ubuntu, ma non sono ancora riuscito
mi rivolgo a voi per uscirne fuori una volta per tutte
ecco le mie caratteristiche

Distribuzione: ubuntu Gutsy Gibbon 7.10 i386
Versione del Kernel: kernel 2.6.22-14
Nome del Router: Alice Gate 2 Plus Wi-fi
Versione dell'Hardware del router: S3PM-2
Versione del Software del router: AGIA_1.2.0
Esito: Attiva -- Ma le pagine si caricano a metà

Che fare???  :'(
__Neo
Prode Principiante
 
Messaggi: 40
Iscrizione: marzo 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda ivan_73 » venerdì 4 aprile 2008, 1:28

....dunque, anche io ho questa configurazione:

Distribuzione: ubuntu Gutsy Gibbon 7.10 i386
Versione del Kernel: kernel 2.6.22-14
Nome del Router: Alice Gate 2 Plus Wi-fi
Versione dell'Hardware del router: S3PM-2
Versione del Software del router: AGIA_1.2.0
Connessione tramite ethernet, tentando la modalità routed, senza pppoe...

Esito: connessione attiva ma pagine spesso non caricate completamente.

Su un'altra macchina ho installato Ubuntu Server ver 6.06.2 LTS Dapper e la connessione funziona in maniera perfetta senza bisogno di usare pppoe....

Sul forum americano ho trovato un tizio che aveva gli stessi problemi (Win XP invece funzionava normalmente) e ha risolto impostando l'MTU del router a 1492 invece che 1500....ora, servirebbe che qulacuno che ha un altro router non Telecom facesse una prova impostando l'MTU a 1492 e verificare se funziona e impostarlo poi a 1500 per verificare che il problema sia quello....dopo di che, in caso, si può provare a telefonare al 187 o 191 e vedere se qualche operatore può o riesce a cambiare questo parametro...

Ivan
ivan_73
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 275
Iscrizione: maggio 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda Tarbo » venerdì 4 aprile 2008, 21:18

Ho lo stesso problema con il cd live di xubuntu e vorrei sapere se utilizzando un altro modem è possibile aggirare il problema fino a che non sarà risolto dalla nuova versione?
Tarbo
Prode Principiante
 
Messaggi: 46
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda trekfan1 » venerdì 4 aprile 2008, 21:47

Io ho un router Wireless Atlantis e l'MTU è impostato a 1492 e funziona perfettamente con ubuntu
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16010
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Unity/Gnome Shell
Distribuzione: Ubuntu 17.04 e 17.10 (dev) 64 bit
Sesso: Maschile

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda manu83 » venerdì 4 aprile 2008, 22:15

ciao a tutti

Stesso problema, io ho Alice ADSL a casa e ho le pagine caricate a metà (con ping funzionante) sia da ethernet che da wireless, ma quando mi collego dall'università, che ha dei router Cisco mi funziona tutto alla grande, sia ethernet che wireless...

S.O. Archlinux e Ubuntu, kernel 2.6.22 per entrambi

Hardware        S3PM-2
Software AGIA_1.2.0

da windows funziona tutto, ovviamente...

Aiutatemi, devo convincere mio fratello a passare a Linux ma se non ci si configura internet lui vuole rimanere su winzozz!!!
Ultima modifica di manu83 il venerdì 4 aprile 2008, 22:18, modificato 1 volta in totale.
manu83
Prode Principiante
 
Messaggi: 13
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda manu83 » venerdì 4 aprile 2008, 23:06

ho trovato su un forum di utenti slackware uno con lo stesso problema, poi sembrano aver risolto, ma io non ce l'ho fatta, ha funzionato solo un attimo poi più niente...
magari può essere uno spunto, provate a leggere poi fatemi sapere...
loro lavorano sulle impostazioni di tcp_ecn e tcp_windowscaling

http://www.slacky.eu/forum/viewtopic.ph ... &sk=t&sd=a

ciao ciao e buona nottata... >:(
manu83
Prode Principiante
 
Messaggi: 13
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda trekfan1 » sabato 5 aprile 2008, 6:28

Leggendo quella pagina tra le varie righe suggeriscono di disabilitare anche ipv6 su firefox

http://forum.ubuntu-it.org/viewtopic.ph ... 9#p1093829
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16010
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Unity/Gnome Shell
Distribuzione: Ubuntu 17.04 e 17.10 (dev) 64 bit
Sesso: Maschile

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda manu83 » sabato 5 aprile 2008, 9:29

la storia dell' ipv6 già l'avevo provata, ma non risolve il nostro problema... ho disabilitato l'ipv6 di firefox ed anche impedito il caricamento del modulo nel sistema operativo (questo su archlinux, su ubuntu l'ho solo tolto da firefox...), ma l'unico risultato è un miglioramento della velocità quando mi collego in posti che non usano alice gate 2 ... meglio di niente, comunque, ma da casa mia internet resta sempre off-limits... :'( ancora pagine a metà... e non mi funziona nemmeno lo scaricamento dei pacchetti dai mirror... (scarica pochi Kbit poi si ferma)  >:(
manu83
Prode Principiante
 
Messaggi: 13
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda matley81 » sabato 5 aprile 2008, 9:57

confermo anche io ho provato a disabilitare l ipv6 ma non mi è cambiato nulla in pratica  ::)
nessuno sa dov è il villaggio degli gnome ?
Avatar utente
matley81
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 586
Iscrizione: settembre 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda manu83 » sabato 5 aprile 2008, 11:15

Signori, ho la soluzione!!

...momento di attesa...

è un problema di impostazione dei tcp_ecn, che di default è a 1.

dal terminale root digitate questi tre comandi nell'ordine che seguono e passa la paura.

echo 1 > /proc/sys/net/ipv4/tcp_syncookie
echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
echo 0 > /proc/sys/net/ipv4/tcp_ecn

a quel punto funziona subito senza reboot e anche se firefox era rimasto aperto (io l'ho appena fatto e ora sto postando da linux...)

N.B: al riavvio siete da capo, fatevi uno script che li lanci prima di connettervi oppure andate a modificare il file /etc/sysctl.conf così:

net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_window_scaling = 0
net.ipv4.tcp_ecn= 0

(b2b) (rotfl)

per tutti i dettagli leggete il forum di slackware che ho postato ieri sera, la risposta di conraid
http://www.slacky.eu/forum/viewtopic.ph ... 98da972954

comunque oltre a quello, l'ipv6 disabilitatelo, così sarete più veloci. (ora scarico a 900 kB/s dai mirror ... con punte di 1.2 MB/s! davvero!!)
Ultima modifica di manu83 il martedì 13 maggio 2008, 15:13, modificato 1 volta in totale.
manu83
Prode Principiante
 
Messaggi: 13
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda dont » sabato 5 aprile 2008, 13:36

manu83 ha scritto:Signori, ho la soluzione!!


Ciao, ho provato a seguire il tuo consiglio e a digitare quei comandi...adesso finalmente navigo in tranquillità, le pagine si caricano completamente! Grazie!

L'unica cosa è che il primo mi da come risultato:
Codice: Seleziona tutto
echo 1 > /proc/sys/net/ipv4/tcp_syncookie
bash: /proc/sys/net/ipv4/tcp_syncookie: Nessun file o directory

Però gli altri due funzionano...e finalmente torno a Ubuntu anche sul laptop!
L'unico inconveniente è che al riavvio, come hai giustamente sottolineato è tutto come prima, io ho provato a modificare /etc/sysctl.conf così:

Codice: Seleziona tutto
#
# /etc/sysctl.conf - Configuration file for setting system variables
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com
#net/ipv4/icmp_echo_ignore_broadcasts=1

# the following stops low-level messages on console
kernel.printk = 4 4 1 7

# enable /proc/$pid/maps privacy so that memory relocations are not
# visible to other users.
kernel.maps_protect = 1

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next line to enable Spoof protection (reverse-path filter)
#net.ipv4.conf.default.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
#net.ipv4.tcp_syncookies=1
#net.ipv4.tcp_window_scaling=0
#net.ipv4.tcp_ecn=0

# Uncomment the next line to enable packet forwarding for IPv4
#net.ipv4.conf.default.forwarding=1

# Uncomment the next line to enable packet forwarding for IPv6
#net.ipv6.conf.default.forwarding=1

però non cambia nulla, non funziona. Faccio qualche errore per caso? Ed eventualmente per creare uno script da lanciare all'avvio come dovrei fare? (ma se creo lo script, dopo non dovrei lanciarlo sempre da root e quindi loggarmi come root ogni volta?) (perdonatemi, ma non me ne intendo molto )
Avatar utente
dont
Prode Principiante
 
Messaggi: 81
Iscrizione: maggio 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda manu83 » sabato 5 aprile 2008, 15:41

devi semplicemente decommentare quelle righe!!!

se c'è il simbolo # davanti alla riga, vuol dire che è un commento e non viene eseguito!!
sistemale e vedrai che va tutto a posto! x lo script lascia stare, così è molto più facile!!

qualcuno scriva [RISOLTO] su questo forum, se funziona per tutti!!!
(good) (good)
manu83
Prode Principiante
 
Messaggi: 13
Iscrizione: aprile 2008

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda dont » sabato 5 aprile 2008, 16:46

manu83 ha scritto:devi semplicemente decommentare quelle righe!!!

(rotfl)
e pensare che c'era pure scritto...mah, sarà la primavera!

Per la cronaca, ho attivato solo le ultime due (window_scaling e ecn) e tutto funge.

Mille grazie ancora a manu83  :-* e a tutti quelli che si sono sbattuti per tentare di risolvere il problema (sperando che tutti riescano a risolverlo ora).  (good)
Avatar utente
dont
Prode Principiante
 
Messaggi: 81
Iscrizione: maggio 2007

Re: [Internet] [Install] Alice Gate 2 Plus Wi-Fi (routed) + Ubuntu 7.10

Messaggioda ivan_73 » martedì 8 aprile 2008, 23:12

....ufficiale che funziona, almeno sul mio laptop.....non ho decommentato la riga:

#net.ipv4.tcp_syncookies=1

e ho aggiunto:

net.ipv4.tcp_window_scaling=0
net.ipv4.tcp_ecn=0

perché non presenti.....ora fila che é una meraviglia!

Grazie a Manu_83!!!!

Ivan
ivan_73
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 275
Iscrizione: maggio 2007

PrecedenteSuccessiva

Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: G_e_r_o_n_i_m_o e 6 ospiti