Avviso: vi è stato un importante aggiornamento della piattaforma forum, si prega di visionare la discussione in merito: viewtopic.php?f=17&t=637551.

[Risolto] [Ati] kernel 2.6.27 driver ati fglrx

Compilazione del kernel, gestione moduli, servizi attivi, e tutti gli interventi per l'ottimizzazione del sistema operativo.
Scrivi risposta
Rossi88
Prode Principiante
Messaggi: 140
Iscrizione: venerdì 29 giugno 2007, 12:47

[Risolto] [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da Rossi88 » venerdì 17 ottobre 2008, 18:14

Vorrei sapere se ci sono problemi fra il kernel 2.6.27 e i driver ati proprietari?

ho fatto varie ricompilazioni del kernel (aiutato anche dalla velocità dell'E8400  ;D) ma ogni volta funzionano solo con i driver vesa, se metto fglrx (ovviamente dopo averli installati per il kernel ricompilato, ho provato sia la versione 8.9 che la 8.10) nada lo schermo resta nero e si freeza tutto con reset obbligato.

Ringrazio tutti coloro risponderanno  (good)

P.S. aggiungo che la stessa procedura l'ho seguita per il kernel 2.6.24 (ricompilato sempre da me), e per il kernel 2.6.24 della distro (quello già precompilato) ed in questi casi il driver fglrx si attiva senza problemi  :'(
Ultima modifica di Rossi88 il giovedì 30 ottobre 2008, 15:18, modificato 1 volta in totale.

Avatar utente
fabioamd87
Rampante Reduce
Rampante Reduce
Messaggi: 5367
Iscrizione: domenica 4 dicembre 2005, 15:40
Desktop: GNOME Shell
Distribuzione: Arch Linux
Località: Cassino
Contatto:

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da fabioamd87 » lunedì 20 ottobre 2008, 15:48

evidentemente non supportano le ultime versioni del kernel...
prova a compilare il 2.6.26

Rossi88
Prode Principiante
Messaggi: 140
Iscrizione: venerdì 29 giugno 2007, 12:47

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da Rossi88 » martedì 21 ottobre 2008, 11:21

OK Grazie della risposta  :)
Se qualcuno volesse postare la propria esperienza con driver ati e kernel 2.6.27 è ben accetto ;)

Avatar utente
robytrevi
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 10901
Iscrizione: lunedì 10 marzo 2008, 14:12
Desktop: mate
Distribuzione: Xenial 32 bit
Località: Modena(provincia)

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da robytrevi » martedì 21 ottobre 2008, 11:29

In teoria i driver 8.10 con kernel 2.6.27 supportano xorg 7.4 da quanto scritto qua, anche se dal sito amd/ati non è scritto.
Però non li ho ancora provati in quanto non ho ancora aggiornato a Intrepid.
Ubuntu 16.04 (Mate), Arch (Gnome-shell), Fedora21(gnome-shell), Debian Jessie(openbox), Windows 7 ; Dell Inspiron 1501; AMD Turion 64x2; ATI XPress 1100 (vista come Radeon Xpress 200M)
Quando si richiede supporto postare il comando "lsb_release -ds && echo $DESKTOP_SESSION && uname -m"

Avatar utente
fabioamd87
Rampante Reduce
Rampante Reduce
Messaggi: 5367
Iscrizione: domenica 4 dicembre 2005, 15:40
Desktop: GNOME Shell
Distribuzione: Arch Linux
Località: Cassino
Contatto:

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da fabioamd87 » martedì 21 ottobre 2008, 18:54

non sono proprio gli 8.10 beta, ma una versione moddata fornita solo dal package manager di ubuntu

Avatar utente
robytrevi
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 10901
Iscrizione: lunedì 10 marzo 2008, 14:12
Desktop: mate
Distribuzione: Xenial 32 bit
Località: Modena(provincia)

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da robytrevi » martedì 21 ottobre 2008, 20:46

Ma se sono nei repository sono "comodi", nel senso che non bisogna installarli semi-manualmente. Li hai provati?
Ubuntu 16.04 (Mate), Arch (Gnome-shell), Fedora21(gnome-shell), Debian Jessie(openbox), Windows 7 ; Dell Inspiron 1501; AMD Turion 64x2; ATI XPress 1100 (vista come Radeon Xpress 200M)
Quando si richiede supporto postare il comando "lsb_release -ds && echo $DESKTOP_SESSION && uname -m"

Rossi88
Prode Principiante
Messaggi: 140
Iscrizione: venerdì 29 giugno 2007, 12:47

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da Rossi88 » mercoledì 22 ottobre 2008, 23:19

Quindi da quanto mi pare di capire mi sa che mi devo procurare, o aspettare il rilascio di Intrepid, questi driver ati pseudo-beta per poter compilare il kernel 2.6.27 e far funzionare la mia scheda video decentemente.
Grazie delle info, io più che altro pensavo di commettere chissà quale strano errore anche se mi sembrava molto strano, inoltre ho notato che negli altri kernel in cui ho installato i driver ati usciva alla fine il messagio installazione finita, mentre quando lo facevo col kernel 2.6.27 si vedevano solo delle istruzioni alla fine dell'installazione ma non il messaggio installazione finita. Quindi penso che andasse qualcosa storto nell'installazione. (Le installazioni dei driver le facevo da root in modalità recovery).

Questi driver ati "beta" in quali repository li posso trovare? sono inseriti in quelli per intrepid o sbaglio?

Rossi88
Prode Principiante
Messaggi: 140
Iscrizione: venerdì 29 giugno 2007, 12:47

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da Rossi88 » martedì 28 ottobre 2008, 15:17

ho provato a trovare e compilare questi driver ma onestamente non ci sono riuscito così ho deciso di passare ad intrepid, ho così ricompilato il kernel 2.6.27.3 utilizzando un make oldconfig che ha configurato il tutto in automatico. Poi ho compilato il kernel e dopo un errore facilmente risolto ho creato i pacchetti del kernel.
Tuttavia non riesco ad installare i pacchetti del kernel, posto gli errori che mi restituisce:

Codice: Seleziona tutto

(Lettura del database ... 122903 file e directory attualmente installati.)
Mi preparo a sostituire linux-image-2.6.27.3 2.6.27.3-10.00.Custom (con linux-image-2.6.27.3_2.6.27.3-10.00.Custom_amd64.deb) ...
Done.
Spacchetto il sostituto di linux-image-2.6.27.3 ...
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.27.3
Found kernel: /boot/vmlinuz-2.6.27-7-generic
Found kernel: /boot/vmlinuz-2.6.24-21-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Configuro linux-image-2.6.27.3 (2.6.27.3-10.00.Custom) ...
Running depmod.
Finding valid ramdisk creators.
Using mkinitramfs-kpkg to build the ramdisk.
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.27.3-10.00.Custom was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.27.3-10.00.Custom was configured last, according to dpkg)
Running postinst hook script update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.27.3
Found kernel: /boot/vmlinuz-2.6.27-7-generic
Found kernel: /boot/vmlinuz-2.6.24-21-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms
run-parts: executing /etc/kernel/postinst.d/nvidia-common
run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 20
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.27.3.postinst line 1181.
dpkg: errore processando linux-image-2.6.27.3 (--install):
 il sottoprocesso post-installation script ha restituito un codice di errore 2
Sono occorsi degli errori processando:
 linux-image-2.6.27.3


su google non son riuscito a trovare nient'altro che un bug segnalato senza alcuna risposta. Che sia colpa di intrepid?
Ovviamente se non riesco a compilare il kernel non posso fare prove e tentativi sui driver  >:(
Ultima modifica di Rossi88 il martedì 28 ottobre 2008, 15:19, modificato 1 volta in totale.

Rossi88
Prode Principiante
Messaggi: 140
Iscrizione: venerdì 29 giugno 2007, 12:47

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da Rossi88 » martedì 28 ottobre 2008, 15:52

nonostante quell'errore che da nell'installazione del pacchetto linux-image il kernel parte comunque e non da errori, la risoluzione del  monitor risulta configurata correttamente anche se i driver fglrx non vengono caricati correttamente ma è bastato reinstallare i seguenti due pacchetti (direttamente con synaptic) per avere i driver fglrx funzionanti:
fglrx-kernel-source
xorg-driver-fglrx

non so se bastava reinstallare solo uno di questi due pacchetti.

Se qualcuno avesse dei suggerimenti su come provare a risolvere quell'errore che da in fase di installazione posti pure  ;), ogni consiglio è ben accetto.

Quindi in definitiva con intrepid è possibile far funzionare i driver proprietari ati anche con kernel 2.6.27.x  :)

Rossi88
Prode Principiante
Messaggi: 140
Iscrizione: venerdì 29 giugno 2007, 12:47

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da Rossi88 » giovedì 30 ottobre 2008, 15:18

leggendo più attentamente l'errore che mi risultava e grazie a questo thread http://ubuntuforums.org/showthread.php?p=5999900 ho risolto il problema, in pratica basta disinstallare il pacchetto nvidia-common completamente.

Spero che questo thread possa servire a qualcuno.

(good)

Avatar utente
bassline
Prode Principiante
Messaggi: 188
Iscrizione: sabato 24 giugno 2006, 17:23
Località: (Bo)

Re: [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da bassline » domenica 9 novembre 2008, 18:55

Rossi88 ha scritto:leggendo più attentamente l'errore che mi risultava e grazie a questo thread http://ubuntuforums.org/showthread.php?p=5999900 ho risolto il problema, in pratica basta disinstallare il pacchetto nvidia-common completamente.

Spero che questo thread possa servire a qualcuno.

(good)


a me è servito, tnx  (b2b)

Avatar utente
PiAnto
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: giovedì 3 agosto 2006, 18:35
Desktop: Kde SC
Distribuzione: Archlinux i686

Re: [Risolto] [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da PiAnto » lunedì 10 novembre 2008, 12:47

Installati dal Gestore driver con restrizioni, 2.6.27-generic in uso.. Tutto funge!

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1600
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: [Risolto] [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da axr » martedì 11 novembre 2008, 20:13

scusate ma a me il gestore deei driver con restrizione non mi vede la scheda ati 9600 mobility readeon
uso intrepid, qualcuno sa come devo fare?
cioa

Avatar utente
PiAnto
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: giovedì 3 agosto 2006, 18:35
Desktop: Kde SC
Distribuzione: Archlinux i686

Re: [Risolto] [Ati] kernel 2.6.27 driver ati fglrx

Messaggio da PiAnto » mercoledì 12 novembre 2008, 12:20

axr ha scritto:scusate ma a me il gestore deei driver con restrizione non mi vede la scheda ati 9600 mobility readeon
uso intrepid, qualcuno sa come devo fare?
cioa


Puoi installarli a mano seguendo: http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide. Per sicurezza controlla col seguente comando se hai davvero una Mobility 9600:

Codice: Seleziona tutto

lspci

Scrivi risposta

Torna a

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti