Compiz su AiGLX per GNOME/KDE/XfCE (aggiorntato al 22/08/2007)

Configurazione e uso dell'interfaccia utente predefinita fino alla versione 16.04 di Ubuntu.

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » mercoledì 25 ottobre 2006, 11:30

Qualcuno nota scatti, anche del mouse, o rallentamenti usando Compiz/AiGLX?
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17562
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Freedreamer » mercoledì 25 ottobre 2006, 12:29

Ok mi funzia tutto. ho messo beryl ed è partito al primo colpo..mah..!
cmq devo dire che noto alcuni rallentamenti rispetto al mio laptop dove uso XGL che mi sembra più fluido ..le caratteristiche sono piu o meno le stesse dei due pc
Avatar utente
Freedreamer
Prode Principiante
 
Messaggi: 139
Iscrizione: agosto 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Freedreamer » mercoledì 25 ottobre 2006, 15:00

libGL warning: 3D driver claims to not support visual 0x4b
direct rendering: Yes
OpenGL renderer string: Mesa DRI R300 20060815 AGP 1x TCL


scusate ma è normale AGP 1x????

come mai così lenta?
Avatar utente
Freedreamer
Prode Principiante
 
Messaggi: 139
Iscrizione: agosto 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda blusa » mercoledì 25 ottobre 2006, 16:25

Janvitus ha scritto:Qualcuno nota scatti, anche del mouse, o rallentamenti usando Compiz/AiGLX?


decisamente. non capivo cosa portasse questo problema, poi ho provato a disabilitare il desktop gl e niente più scatti.
con compiz si verificano praticamente ogni volta che il sistema sta aprendo qualcosa e c''è un picco nell''uso della cpu

Ciao
"Money, it's a crime
Share it fairly but don't take a slice of my pie"
Pink Floyd
Avatar utente
blusa
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 706
Iscrizione: febbraio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda paper0k » mercoledì 25 ottobre 2006, 19:19

blusa ha scritto:
Janvitus ha scritto:Qualcuno nota scatti, anche del mouse, o rallentamenti usando Compiz/AiGLX?


decisamente. non capivo cosa portasse questo problema, poi ho provato a disabilitare il desktop gl e niente più scatti.
con compiz si verificano praticamente ogni volta che il sistema sta aprendo qualcosa e c''è un picco nell''uso della cpu

Ciao

Confermo! Succede la stessa cosa anche a me, se può servire uso un kernel 2.6.18.1 ed i driver beta della NVIDIA
Chiunque può essere ragionevole, ma esser sani di mente è raro (Oscar Wilde)
Wiki|Blog|Twitter|Identi.ca|last.fm
Avatar utente
paper0k
Rampante Reduce
Rampante Reduce
 
Messaggi: 7221
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda luzzo » mercoledì 25 ottobre 2006, 19:26

A me tutto normale per il momento...
Avatar utente
luzzo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 508
Iscrizione: marzo 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda inverse » mercoledì 25 ottobre 2006, 21:56

Janvitus ha scritto:Qualcuno nota scatti, anche del mouse, o rallentamenti usando Compiz/AiGLX?

Confermo, anche dalle mie parti stessi problemi, su 2 configurazioni diverse, ancora devo risalire al problema....
O sono i driver beta di nvidia, o aiglx o compiz.
Avatar utente
inverse
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1006
Iscrizione: ottobre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda giropizza » giovedì 26 ottobre 2006, 8:31

blusa ha scritto:ora però mi sono anche accorto di un altro problema: io aggiungo in sessioni compiz-tray-icon e mi viene rimosso sistematicamente o al riavvio o quando smanetto con compiz, questo non succede al comando gnome-window-decorator.
a qualcuno capita la stessa cosa?

ciao

Anche a me succede, come faccio eventualmente ad integrarlo direttamente nella sessione in modo che parta direttamente al login senza dover tutte le volte abilitarlo a mano?

Grazie
Giropizza
giropizza
Prode Principiante
 
Messaggi: 197
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda blusa » giovedì 26 ottobre 2006, 9:17

giropizza ha scritto:
blusa ha scritto:ora però mi sono anche accorto di un altro problema: io aggiungo in sessioni compiz-tray-icon e mi viene rimosso sistematicamente o al riavvio o quando smanetto con compiz, questo non succede al comando gnome-window-decorator.
a qualcuno capita la stessa cosa?

ciao

Anche a me succede, come faccio eventualmente ad integrarlo direttamente nella sessione in modo che parta direttamente al login senza dover tutte le volte abilitarlo a mano?

Grazie
Giropizza


io ho fatto così:
ho fatto uno scriptino che avvii compiz:
Codice: Seleziona tutto
#!/bin/sh
compiz-tray-icon

l''ho salvato, reso eseguibile, messo nella home e in sessioni ho aggiunto questo script che non viene più eliminato.
magari ci sono soluzioni più eleganti ma così sembra andare bene
Ciao
"Money, it's a crime
Share it fairly but don't take a slice of my pie"
Pink Floyd
Avatar utente
blusa
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 706
Iscrizione: febbraio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda giropizza » giovedì 26 ottobre 2006, 11:11

E se volessi lanciare la tray ed inizializzarla pure come faccio. Mi spiego meglio
con compiz-tray-icon ti appare l'icona ma devo andarci sopra ed abilitare il desktop, se volessi fare tutto in una mossa sola?
Aggiungendo praticamente un comando al tuo script?

Grazie
Giropizza
giropizza
Prode Principiante
 
Messaggi: 197
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » giovedì 26 ottobre 2006, 11:18

inverse ha scritto:
Janvitus ha scritto:Qualcuno nota scatti, anche del mouse, o rallentamenti usando Compiz/AiGLX?

Confermo, anche dalle mie parti stessi problemi, su 2 configurazioni diverse, ancora devo risalire al problema....
O sono i driver beta di nvidia, o aiglx o compiz.


Sono i pacchetti del repository di gandalfn che sono fatti male, non chiedetemi come li ha compilati, forse ha messo qualche flag di troppo, o troppo poco, l''unico rimedio e scaricarvi compiz e compilarvelo "a mano" non è difficile, è come un programma qualsiasi, se volete vi posto i vari procedimenti :)
Una volta compilato compiz io non ho più scatti e nessun problema, e anche i giochi non scattano più, tutto è fluido anche se la cpu è al 100%.
Magari quando ho tempo facco i pacchetti per amd64 per il mio repository.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17562
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda paper0k » giovedì 26 ottobre 2006, 11:26

Ok, aspetto il procedimento per la compilazione di Compiz ;)
Una domandina... quando con Edgy sarà possibile usare Compiz senza installare manualmente i driver beta di NVIDIA?
Chiunque può essere ragionevole, ma esser sani di mente è raro (Oscar Wilde)
Wiki|Blog|Twitter|Identi.ca|last.fm
Avatar utente
paper0k
Rampante Reduce
Rampante Reduce
 
Messaggi: 7221
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda pepito » giovedì 26 ottobre 2006, 11:30

Confermo anche io la presenza di rallentamenti e movimenti "a scatti" con i pacchetti di Gandalf.

Appena ho un attimo di tempo provo a installare compiz da sorgenti e vi faccio sapere.

P.S.
Janvitus hai usato qualche flag particolare per compilare compiz (eventualmente escludendo quelli specifici per architetture a 64 bit)? Grazie in anticipo ;)
pepito
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda inverse » giovedì 26 ottobre 2006, 11:38

Janvitus ha scritto:
inverse ha scritto:
Janvitus ha scritto:Qualcuno nota scatti, anche del mouse, o rallentamenti usando Compiz/AiGLX?

Confermo, anche dalle mie parti stessi problemi, su 2 configurazioni diverse, ancora devo risalire al problema....
O sono i driver beta di nvidia, o aiglx o compiz.


Sono i pacchetti del repository di gandalfn che sono fatti male, non chiedetemi come li ha compilati, forse ha messo qualche flag di troppo, o troppo poco, l''unico rimedio e scaricarvi compiz e compilarvelo "a mano" non è difficile, è come un programma qualsiasi, se volete vi posto i vari procedimenti :)
Una volta compilato compiz io non ho più scatti e nessun problema, e anche i giochi non scattano più, tutto è fluido anche se la cpu è al 100%.
Magari quando ho tempo facco i pacchetti per amd64 per il mio repository.


Janvitus faresti un favore a tutti se posti una procedura per compilarli senza incorrere in troppi problemi ;)

Ps. Grazi e in anticipo ;D
Avatar utente
inverse
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1006
Iscrizione: ottobre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » giovedì 26 ottobre 2006, 12:59

Scaricate Compiz dal sito, la 0.3.2: http://www.freedesktop.org/wiki/Software/Compiz

Se volete controllate l'md5 con il comando md5sum, scompattate il compresso e installate i seguenti pacchetti: librsvg2-dev libgnome-desktop-dev libmetacity-dev libwnck-dev libgnome-window-settings-dev libxcomposite-dev libxdamage-dev libgl1-mesa-dev libglitz-glx1-dev
Installateli pure da terminale, così potete annotarvi cosa installate, e poi in seguito disinstallarli magari, quelli che ho elencato servono per compilare Compiz su GNOME, per XfCE è KDE dovreste installare le loro controparti.

Potrei dimenticarmi qualche pacchetto, anche se non penso, e prima che compilate i nuovi pacchetti per compiz, disinstallate completamente i vecchi, sia quelli di compiz, che quelli di gnome-compiz-manager, ma potete savare le configurazioni. Ora entrate da terminale nella cartella di compiz che si è creata prima, date il seguente configure:

Codice: Seleziona tutto
./configure --prefix=/usr --enable-librsvg


Al termine controllate che sia tutto su "yes" tranne KDE se usate GNOME o XfCE, il contrario se usate KDE, se da un errore è perchè sicuramente manca qualche pacchetto che non ho indicato, installatelo.

Se è tutto andato bene, date il fatidico:

Codice: Seleziona tutto
make


Se anche qui termina senza errori potete installare compiz con:

Codice: Seleziona tutto
sudo make install


o ancora meglio usare checkinstall, consigliatissimo, così vi creerete un pacchetto .deb di facile disinstallazione e aggiornamento, installate checkinstall e poi da terminale invece di dare "sudo make install", date:

Codice: Seleziona tutto
sudo checkinstall


Metteteci i dati che volete, checkinstall vi installerà automaticamente il pacchetto che avete creato, non fate caso se nel pacchetto ci sono gli header di Compiz, servono, potete vedere un esempio di come deve uscire il pacchetto, qui: http://www.box.net/public/iqtrr6dxg6

Ora dovreste compilarvi anche gnome-compiz-manager, e qui servono gli header del pacchetto che avete appena installato, andate qui e scaricatevi il programma: http://www.gnomefiles.org/app.php/Gnome_Compiz_Manager

Da terminale:

Codice: Seleziona tutto
./configure --prefix=/usr --disable-xorg-configuration --enable-static=no --disable-schemas-install


Se tutto va bene date il "make", se anche il make va senza errori, date il fatidico "sudo checkinstall", dovrebbe uscire un pacchetto simile: http://www.box.net/public/d7blz8p2fg

Ora comportatevi come se avreste installato normalmente da repository, riavviate GNOME, o quello che usate, che è meglio.

P.S.: per chi usa una Ubuntu AMD64 potete anche provare ad installare i pacchetti che ho linkato sopra, ma non vi assicuro il corretto funzionamento, se volete provare installate comunque le librerie lbrsvg e libwnck18.
Ultima modifica di Janvitus il sabato 21 aprile 2007, 18:25, modificato 1 volta in totale.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17562
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » giovedì 26 ottobre 2006, 18:40

Modificato il ./configure nel post sopra per quanto riguarda gnome--compiz-manager, me lo ricordavo diversamente.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17562
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda inverse » venerdì 27 ottobre 2006, 0:55

janvitus, gracias..... :o ho bisogno di testare il tutto, ma và tutto molto meglio..
devi solo aggiugere un paio di dipendenze mancanti alla tua guida.
"libgnome-window-settings-dev"
"libxcomposite-dev"
"libxdamage-dev"
Almeno io ho dovuto aggiungerle per avere tutto perfetto.
Avatar utente
inverse
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1006
Iscrizione: ottobre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda Janvitus » venerdì 27 ottobre 2006, 12:26

inverse ha scritto:janvitus, gracias..... :o ho bisogno di testare il tutto, ma và tutto molto meglio..
devi solo aggiugere un paio di dipendenze mancanti alla tua guida.
"libgnome-window-settings-dev"
"libxcomposite-dev"
"libxdamage-dev"
Almeno io ho dovuto aggiungerle per avere tutto perfetto.


Si vero, ero sicuro di aver scordato qualcosa, aggiungo sopra :)

Piccola richiesta: qualcuno che ha un compiz funzionante con gnome, mi manda la cartella delle impostazioni di compiz? si trova in /home/utente/.gconf/apps/ , la email è nel rofilo, grazie :)
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17562
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda inverse » sabato 28 ottobre 2006, 0:37

Ti ho mandato un email janvitus ;D

Confermo dopo un girno di test, ora compiz và una maraviglia
Avatar utente
inverse
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1006
Iscrizione: ottobre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda kimi » sabato 28 ottobre 2006, 12:24

Ciao, ho provato a seguire la guida ma non mi funziona :-[
Io ho una ATI e ho attivato l'accelerazione seguendo la guida della comunità e usando fglrx.
Nel momento in cui vado a modificare xorg.conf, seguendo il post per le ATI, mi è subito sembrato strano il driver radeon. Ho provato comunque a cambiarlo ma a quel punto ubuntu non parte più in modalità grafica. Se invece metto tutto come nella guida tranne il driver dove lascio fglrx ubuntu parte normalmente ma l'accelerazione 3D risulta disattivata e di aiglx neanche l'ombra...

Qualcuno ha qualche consiglio? ;D

Ah, sto usando edgy eft
kimi
Prode Principiante
 
Messaggi: 47
Iscrizione: ottobre 2006

PrecedenteSuccessiva

Torna a Unity

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite