[Internet] Internet Key USB HSPA One Touch X060S (RISOLTO)

Riconoscimento, installazione e configurazione delle periferiche.

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » giovedì 23 luglio 2009, 19:32

importante, fatti una copia di menu.lst sul desktop, non si sa mai
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Install] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » venerdì 24 luglio 2009, 12:36

Ciao Danx,
nel fine settimana riproverò a seguire la guida da te suggerita. E' comunque la prima da me provata..
ti farò sapere... :(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » sabato 25 luglio 2009, 15:33

Ciao Danx, ti allego il mio menu.lst di avvio di ubuntu.
Dove dovrei inserire quanto mi hai indicato? Nella guida di "nn sono un pirla" suggerisce l'inserimento ti riporto:

title Ubuntu jaunty (development branch), kernel 2.6.28-11-generic
uuid 50a2edb9-4014-4a8e-8e19-91a4cd71c439
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=50a2edb9-4014-4a8e-8e19-91a4cd71c439 ro quiet splash vga=0x318 noapic irqpoll pci=routeirq usbserial.vendor=0x1bbb usbserial.product=0x00001
initrd /boot/initrd.img-2.6.28-11-generic

quando l'ho fatto ho pensato si trattasse di un'aggiunta in toto. Tu mi fai capire che devo inserire solo:
usbserial.vendor=0x1bbb usbserial.product=0x000

puoi compilar tu il tutto? Magari guardando capisco qualcosa. Grazie  :(
Allegati
menu.txt
(5.47 KiB) Scaricato 23 volte
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » sabato 25 luglio 2009, 16:03

ti allego il file menu.txt da rinominare come sai .lst (elle esse ti), ho effettuato la modifica solo per l'avvio del kernel 2.6.28-13 se ci sono problemi così puoi avviare l'altro il 28-11, non si può fare una sostituzione in toto come dici tu perchè non potresti più avviare il sistema
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » sabato 25 luglio 2009, 16:05

oops..
Allegati
menu.txt
(5.52 KiB) Scaricato 20 volte
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » sabato 25 luglio 2009, 16:29

ok.. copiato e sostituito. Riavvio il pc.. ma la internet key la metto prima di accenderlo o dopo che S.O. è avviato?
Poi devo dare i comandi che mi hai indicato la volta scorsa, e precisamente

sudo usb_modeswitch
sudo modprobe usbserial vendor=0x1bbb product=0x0000
sudo wvdial


oppure cosa?
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » sabato 25 luglio 2009, 21:03

Allora Danx ho provato sia accendendo il pc ed inserendo dopo la internet Key che accedendo al S.O. con la internet key..
In entrambi i casi ho dato i comandi da te suggeriti nei post precedenti.. Ti posto i vari passaggi con gli output.
Prima di tutto ho dato un lsusb:
salvo@shadow-laptop:~$ lsusb

Bus 002 Device 002: ID 1bbb:f000 T & A Mobile Phones
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b008 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
salvo@shadow-laptop:~$


Poi ho dato in sequenza i comandi:
salvo@shadow-laptop:~$ sudo usb_modeswitch
[sudo] password for salvo:

* usb_modeswitch: tool for controlling "flip flop" mode USB devices
* Version 0.9.6 (C) Josua Dietze 2009
* Works with libusb 0.1.12 and probably other versions

Looking for target devices
Found target devices (1)
Looking for default devices
Found default devices (1)
Prepare switching, accessing latest device
Looking for active default driver to detach it
OK, driver found ("usb-storage")
OK, Driver "usb-storage" successfully detached
Setting up communication with device
Trying to send the message
OK, message successfully sent.
-> See /proc/bus/usb/devices (or call lsusb) for changes. Bye


Ho chiesto un lsusb e ho verificato se ha riconosciuto la key. Ecco l'output:
salvo@shadow-laptop:~$ lsusb

Bus 002 Device 005: ID 1bbb:0000 T & A Mobile Phones
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b008 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
salvo@shadow-laptop:~$


Seguito da:

salvo@shadow-laptop:~$ sudo modprobe usbserial vendor=0x1bbb product=0x0000
salvo@shadow-laptop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK

--> Sending: AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: at+cgdcont=1,"IP","tre.it",,0,0
at+cgdcont=1,"IP","tre.it",,0,0
OK
--> Modem initialized.
--> Sending: ATM1L3DT*99#
--> Waiting for carrier.
ATM1L3DT*99#
--> Disconnecting at Sat Jul 25 20:57:50 2009
salvo@shadow-laptop:~$


Preciso che ho provato a cambiare il numero anche in *99***1#.  >:(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » sabato 25 luglio 2009, 23:07

con quella modifica all'avvio devi inserire la chiavetta prima dell'accensione poi dare solo sudo usb_modeswitch, fai questi controlli e tentativi

sul desktop vedi il disco della chiavetta montato? se si smontalo poi riprova
prova anche con l'apn naviga.tre.it

inoltre da wvdial risulta :

Initializing modem.
--> Sending: ATX3
ATX3
OK                      quindi il modem è rilevato e attivato


-> Sending: AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK

                  comandi interni del modem che vengono ricevuti

-> Sending: at+cgdcont=1,"IP","tre.it",,0,0
at+cgdcont=1,"IP","tre.it",,0,0
OK
                      apn configurato


--> Modem initialized                modem pronto alla connessione!



--> Sending: ATM1L3DT*99#
--> Waiting for carrier.
ATM1L3DT*99#
--> Disconnecting

        poi quando effettua la chiamata al modem remoto aspetta di rilevare il carrier cioè la linea ma poi si disconnette, insomma và tutto bene fino a che non tenta di rilevare la rete,

quindi controlla di avere l'opzione navigatre attiva,
la lucetta sulla chiavetta è di colore verde, blu o azzurro ? col verde non ti connetti deve essere almento blu, azzurro meglio

la sim è inserita nel verso giusto?

non credo sia ancora un problema di hardware ci deve essere qualcosa che non và con la rete, vedi
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » sabato 25 luglio 2009, 23:41

ti devo confessare che non ho mai usato il navigatre con linux, ma lo usavo con windows adesso ho datacard, quello che ti ho scritto mi è servito per chiarirmi le idee e mi è venuto il sospetto che per il naviga tre sia necessaria una diversa configurazione di wvdial, in effetti ho trovato in vari forum l'indicazione ad usare questa stringa

Init2 = AT+CGATT=0,"IP","naviga.tre.it",,0,0
 
che devi mettere in wvdial.conf al posto appunto di init2 e cancellando init3, vedi così
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda swn » domenica 26 luglio 2009, 7:32

nel file  /etc/wvdial.conf

prova a impostare ed a riportare i risultati  :

Init2= AT+CREG?

Init3= AT+COPS?

Init4= AT+CSQ

Init5= at+cgdcont=1,"IP","tre.it"

oppure

Init5= at+cgdcont=1,"IP","naviga.tre.it"



quale porta stai utilizzando ?  /dev/ttyUSB2    ??
swn
Prode Principiante
 
Messaggi: 48
Iscrizione: luglio 2007

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » lunedì 27 luglio 2009, 14:56

Ciao Danx, premesso ho inserito la chiave prima di accendere il laptop e che nel corso del boot del S.O. mi accorgo che viene stampato per qualche secondo i seguenti messaggi di errore:

[    0.000000] unknow boot option 'usbserial.vendor=0x1bbb': ignoring
[    0.000000] unknow boot option 'usbserial.product=0x0000': ignoring

ho proceduto a smontare la key in quanto viene riconosciuta come periferica esterna con sudo usb_modeswitch, poi ho dato necessariamente sudo modprobe usbserial vendor=0x1bbb product=0x0000, ed infine sudo wvdial con il seguente risultato:

salvo@shadow-laptop:/etc$ sudo wvdial

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK
--> Sending: AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: at+cgdcont=1,"IP","naviga.tre.it",,0,0
at+cgdcont=1,"IP","naviga.tre.it",,0,0
OK
--> Modem initialized.
--> Sending: ATM1L3DT*99#
--> Waiting for carrier.
ATM1L3DT*99#
--> Disconnecting at Mon Jul 27 15:37:55 2009
salvo@shadow-laptop:/etc$
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » lunedì 27 luglio 2009, 14:59

Danx ho provato anche a sostituire Init2 = AT+CGATT=0,"IP","naviga.tre.it",,0,0 e cancellare la Init 3, ma il risultato è il seguente.

salvo@shadow-laptop:~$ sudo wvdial

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK
--> Sending: AT+CGATT = 0,"IP","naviga.tre.it",,0,0
AT+CGATT = 0,"IP","naviga.tre.it",,0,0
ERROR
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK
--> Sending: AT+CGATT = 0,"IP","naviga.tre.it",,0,0
AT+CGATT = 0,"IP","naviga.tre.it",,0,0
ERROR
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
ATX3
OK
--> Sending: AT+CGATT = 0,"IP","naviga.tre.it",,0,0
AT+CGATT = 0,"IP","naviga.tre.it",,0,0
ERROR
--> Bad init string.
salvo@shadow-laptop:~$


Preciso che quando sembra connettersi la luce verde da lampeggiante diventa fissa e rimane così anche dopo la disconnessione  >:(
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » lunedì 27 luglio 2009, 15:01

Ciao swn, proverò questa sera. Mi confermi il punto interrogativo (?) al termine della stringa?
Ti anticipo da subito che il /dev/ttyUSB con cui provo è 1 e 2 perché con quello pari a 0 mi da da subito errore "modem non rilevato"...  :(   
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda swn » lunedì 27 luglio 2009, 15:26

prova a modificare il tuo  /etc/wvdial.conf  inserendo questo testo così come te l'ho scritto  (la SIM deve essere senza PIN ) e riporta il risultato   :
gli APN di tre sono :

tre.it
naviga.tre.it
datacard.tre.it


Assicurati di usare quello giusto-



[Dialer Defaults]
Modem = /dev/ttyUSB2
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init1 = ATZ
Init2 = AT+CREG?
Init3 = AT+CSQ
Init4 = AT+COPS?
Init5 = AT+CGDCONT=1,"IP","naviga.tre.it"
Phone = *99#
Dial Command = ATDT
Dial Attempts = 1
Ask Password = off
Username = "tre"
Password = "tre"
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
Ultima modifica di swn il lunedì 27 luglio 2009, 20:01, modificato 1 volta in totale.
swn
Prode Principiante
 
Messaggi: 48
Iscrizione: luglio 2007

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » lunedì 27 luglio 2009, 15:46

per quanto riguarda quei comandi nel boot vedi se togliendo il punto tra usbserial.vendor e usbserial.product smette di fare errore, altrimenti rimuovili del tutto in ogni caso il modem è rilevato, bisogna solo trovare le stringhe giuste
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda swn » lunedì 27 luglio 2009, 20:00

facci sapere...
swn
Prode Principiante
 
Messaggi: 48
Iscrizione: luglio 2007

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » martedì 28 luglio 2009, 14:17

;D udite udite ... configurata e funzionante...

soliti comandi per swichare la key, per forzare i parametri vendor e product  e ricompilato wwdial...
e finalmente la luce...
Grazie ad entrambi.. Danx e swn ;D
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda Danx » martedì 28 luglio 2009, 14:57

ok, benissimo è stata dura ma alla fine... però se adesso ci fai vedere il wvdial.conf così la prossima volta non dobbiamo impazzire, inoltre se vuoi ti passo uno script per non dover tutte le volte digitare i comandi, crei un launcher e via
Avatar utente
Danx
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1853
Iscrizione: ottobre 2008

[Internet] Re: [Internet] Internet Key USB HSPA One Touch X060S

Messaggioda CaioGiulioCesare » martedì 28 luglio 2009, 15:45

Ciao Danx, scrivo collegato con la chiavetta configurata...
Il wvdial.conf configurato è il seguente:

[Dialer Defaults]
Modem = /dev/ttyUSB2
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init1 = ATZ
Init2 = AT+CREG?
Init3 = AT+CSQ
Init4 = AT+COPS?
Init5 = AT+CGDCONT=1,"IP","naviga.tre.it"
Phone = *99#
Dial Command = ATDT
Dial Attempts = 1
Ask Password = off
Username = "tre"
Password = "tre"
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on


C'è un modo per far comparire l'indirizzo I.P. che è attribuito al pc anziché i caratteri mascherati? Posto come mi compare:

salvo@shadow-laptop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CREG?
AT+CREG?
+CREG: 0,1
OK
--> Sending: AT+CSQ
AT+CSQ
+CSQ: 9,99
OK
--> Sending: AT+COPS?
AT+COPS?
+COPS: 0,0,"3 ITA",2
OK
--> Sending: AT+CGDCONT=1,"IP","naviga.tre.it"
AT+CGDCONT=1,"IP","naviga.tre.it"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Jul 28 16:39:38 2009
--> Pid of pppd: 4407
--> Using interface ppp0
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> local  IP address 10.110.97.176
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> remote IP address 10.64.64.64
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> primary  DNS address 62.13.171.1
--> pppd:  H[10] pH[10] �H[10] �H[10]
--> secondary DNS address 62.13.171.2
--> pppd:  H[10] pH[10] �H[10] �H[10]


E' solo un problema di estetica.. sai!
Se puoi mandarmi lo script proposto son sempre contento di apprendere...
Ciao e grazie.. (good)
Avatar utente
CaioGiulioCesare
Prode Principiante
 
Messaggi: 37
Iscrizione: febbraio 2008
Desktop: GNOME
Distribuzione: Ubuntu

Re: [Internet] Internet Key USB HSPA One Touch X060S (RISOLTO)

Messaggioda swn » martedì 28 luglio 2009, 16:46

Occhio che con tre devi stare attento al roaming... e quindi ai "piccioli"...

Il valore della qualità del segnale che hai ( AT+CSQ=[size=100]9[/size],99  )  è al limite...
tieni conto che questo valore deve essere almeno sopra i 13-14  ...

Con TRE   ti consiglio di inserire come stringa di inizializzazione aggiuntiva nel file wvdial   ( ad esempio prima di AT+CSQ  e  AT+COPS?     )   la stringa   :  

at+cops=1,0,”3 ITA”,2    

in modo da evitare il roaming ..  


***

Se apri una nuova finestra del Terminale  e dai :

ifconfig 


vedrai l' IP Pubblico dinamico  (nattato per il gestore TRE come Vodafone ) che ti assegna al momento della connessione...
Ultima modifica di swn il martedì 28 luglio 2009, 16:49, modificato 1 volta in totale.
swn
Prode Principiante
 
Messaggi: 48
Iscrizione: luglio 2007

PrecedenteSuccessiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti

cron