[Video] Problema con flashplugin-nonfree

Installazione, configurazione e uso di programmi e strumenti.

[Video] Problema con flashplugin-nonfree

Messaggioda Popus » mercoledì 9 dicembre 2009, 22:28

Salve a tutti,

sto usando da pochissimo Ubuntu, sono passato dallo 8.04 al 9.10 e tutto funziona, tranne una cosa cioè il fatto che non mi fa aggiornare flashplugin-nonfree dicendo che questo file è "rotto" e prima di essere rimosso va reinstallato.
Io non essendo molto pratico non so come fare. Da Synaptic Manager non riesco a risolvere il problema. Se potreste aiutarmi e spiegarmi facilmente i passaggi ve ne sarei grato  ;D

Grazie ancora

Jacopo
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » mercoledì 9 dicembre 2009, 22:56

ciao,posta il messaggio che esce quando cerchi di aggiornare.
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » mercoledì 9 dicembre 2009, 23:04

E: flashplugin-nonfree: Il pacchetto si trova in uno stato di inconsistenza grave - è  necessario reinstallarlo prima di rimuoverlo.


Questo è quello che mi appare ogni volta

E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover


Spero che questo basti, non so che altro scrivere...se solo fossi + pratico darei + info.

Grazie ancora
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » mercoledì 9 dicembre 2009, 23:13

hai già provato a reinstallarlo,nel terminale
Codice: Seleziona tutto
sudo apt-get install flashplugin-nonfree
e quando ha finito rimuovilo con
Codice: Seleziona tutto
sudo apt-get remove flashplugin-nonfree
se da qualche messaggio d'errore postalo.
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Petr » mercoledì 9 dicembre 2009, 23:14

Nel frattempo che torni ^alessio^ sicuramente più esperto di me, ti chiedo se hai provato da synaptic, usando i filtri che hai in basso a sinistra, a vedere se riesci a trovare e disinstallare il pacchetto corrotto. Se clicchi " filtri personalizzati" e poi su "danneggiato" quando ti appare in alto dovresti vedere se ti appare il pacchetto danneggiato e le possibili opzioni. Saluti                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    HOPS! Già tornato!
Avatar utente
Petr
Rampante Reduce
Rampante Reduce
 
Messaggi: 6203
Iscrizione: agosto 2009
Desktop: Unity
Distribuzione: Ubuntu 14.04 LTS x86_64

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » mercoledì 9 dicembre 2009, 23:20

Allora ho provato con l'istallazione e poi a rimuoverlo, quando ho provato a installarlo mi ha scritto:
I seguenti pacchetti hanno dipendenze non soddisfatte:
  flashplugin-nonfree: Dipende: flashplugin-installer ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

Poi quando ho provato a rimuoverlo mi ha scritto:

dpkg: errore nell'elaborare flashplugin-nonfree (--remove):
Il pacchetto si trova in uno stato di inconsistenza grave - è
necessario reinstallarlo prima di rimuoverlo.
Si sono verificati degli errori nell'elaborazione:
flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

Questo è quanto :-(
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » mercoledì 9 dicembre 2009, 23:28

dai
Codice: Seleziona tutto
sudo apt-get -f install
e posta il risultato.
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » giovedì 10 dicembre 2009, 7:47

Ecco cosa mi dice:

I seguenti pacchetti NUOVI saranno installati:
  flashplugin-installer
I seguenti pacchetti saranno aggiornati:
  flashplugin-nonfree
1 aggiornati, 1 installati, 0 da rimuovere e 3 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0B/21,4kB di archivi.
Dopo quest'operazione, verranno occupati 61,4kB di spazio su disco.
Continuare [S/n]? s
Preconfigurazione dei pacchetti in corso
dpkg: errore nell'elaborare flashplugin-nonfree (--remove):
Il pacchetto si trova in uno stato di inconsistenza grave - è
necessario reinstallarlo prima di rimuoverlo.
Si sono verificati degli errori nell'elaborazione:
flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

Bohhh nn so che inventamme  ::)
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » giovedì 10 dicembre 2009, 16:58

nel terminale
Codice: Seleziona tutto
sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree
e posta il risultato.
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » giovedì 10 dicembre 2009, 17:27

Ecco cosa dice ora:

dpkg: attenzione: viene ignorato il problema poiché è usata l'opzione --force:
Il pacchetto si trova in uno stato di inconsistenza grave - è
necessario reinstallarlo prima di rimuoverlo.
(Lettura del database... 164557 file e directory attualmente installati.)
Rimozione di flashplugin-nonfree...
update-alternatives: error: nessuna alternativa per iceape-flashplugin.
update-alternatives: error: nessuna alternativa per iceape-flashplugin.
dpkg: errore nell'elaborare flashplugin-nonfree (--remove):
il sottoprocesso vecchio script di pre-removal ha restituito lo stato di errore 2
postinst called with argument `abort-remove'
dpkg: errore durante la pulizia:
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
flashplugin-nonfree
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Cesare82 » giovedì 10 dicembre 2009, 21:32

ma se da synaptic spunti il pacchetto con reinstalla non risolvi il problema? In teoria è la cosa più semplice ma dovrebbe andare e risolvere le dipendenze.
Cesare82
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 283
Iscrizione: agosto 2008

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » giovedì 10 dicembre 2009, 22:56

nel terminale
Codice: Seleziona tutto
cd /var/lib/dpkg/info
sudo rm flashplugin-nonfree*
sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree
Codice: Seleziona tutto
sudo apt-get update && sudo apt-get upgrade
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » venerdì 11 dicembre 2009, 8:17

Allora con questi ultimi codici, ha fatto delle cose, ha scaricato qualcosa, ma alla fine:

È utile eseguire "apt-get -f install" per correggere questi problemi.
I seguenti pacchetti hanno dipendenze non soddisfatte:
E: Dipendenze non trovate. Riprovare usando -f.
jacopo@pc-jacopo:/var/lib/dpkg/info$ apt-get -f install
E: Impossibile aprire il file di blocco /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

E da qua non so... :-\    Grazie di nuovo
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Megatux » venerdì 11 dicembre 2009, 9:19

Devi dare quell'ultimo comando anteponendo la parola "sudo"... te lo dice lui stesso... infatti ti ha chiesto se sei root, cioè amministratore..
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » venerdì 11 dicembre 2009, 11:56

primo comando
Codice: Seleziona tutto
cd /var/lib/dpkg/info
secondo comando
Codice: Seleziona tutto
sudo rm flashplugin-nonfree*
terzo comando
Codice: Seleziona tutto
sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree
li hai dati in questo ordine i comandi nel terminale?comunque dai
Codice: Seleziona tutto
sudo apt-get -f install
e se ti da il solito errore riprova a dare i comandi nell'ordine che ti ho postato.
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » venerdì 11 dicembre 2009, 14:19

Ok...il problema è stato risolto e quello rimosso...ma ora se riaccendo il pc mi fa entrare solo in modalità a bassa risoluzione perchè dice che ci sono problemi con la scheda grafica  ::)
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » venerdì 11 dicembre 2009, 15:22

Praticamente poi, se cerco di individuare il monitor, così almeno penso di aver fatto, mi dice questo:

X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux pc-jacopo 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686
Kernel command line: root=UUID=4bae7720-0651-4d3b-be9c-0ee1541ca9b1 ro quiet splash
Build Date: 26 October 2009  05:15:02PM
xorg-server 2:1.6.4-2ubuntu4 (buildd@)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 11 15:14:36 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |  |-->Monitor "Configured Monitor"
(**) |  |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x3bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0427:103c:30cc nVidia Corporation G86 [GeForce 8400M GS] rev 161, Mem @ 0xc6000000/16777216, 0xd0000000/268435456, 0xc4000000/33554432, I/O @ 0x00002000/128
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module  185.18.36  Fri Aug 14 17:50:12 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:    system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Boooooohhhhhhh :(
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma

Re: [Video] Problema con flashplugin-nonfree

Messaggioda ^alessio^ » venerdì 11 dicembre 2009, 22:13

avvia il pc con un altro kernel,dovresti avere il 2.6.31-15 e prova se con questo va.
 
^alessio^
Rampante Reduce
Rampante Reduce
 
Messaggi: 5379
Iscrizione: maggio 2008
Località: como

Re: [Video] Problema con flashplugin-nonfree

Messaggioda Popus » sabato 12 dicembre 2009, 8:33

Ehm no.... ho solo 2.6.31-16 e 2.6.24-16 (che però non mi ci fa entrare, nel senso che mi dice non valido). Graziea ancora
Popus
Prode Principiante
 
Messaggi: 22
Iscrizione: aprile 2008
Località: Roma


Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite