AVerTV HD a835

Riconoscimento, installazione e configurazione delle periferiche.

Re: AVerTV HD a835

Messaggioda Xgaz » domenica 12 dicembre 2010, 21:40

Scusatemi...credo di aver fatto io una c***** ieri sera!
Entro domani mattina sistemo tutto...

EDIT: Ok, adesso dovrebbe essere di nuovo tutto a posto. Scusate di nuovo!
Ultima modifica di Xgaz il domenica 12 dicembre 2010, 23:56, modificato 1 volta in totale.
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda BadMan88 » domenica 12 dicembre 2010, 23:58

quindi si può provare anche con nuovo kernel?
Avatar utente
BadMan88
Prode Principiante
 
Messaggi: 88
Iscrizione: maggio 2010
Località: Genova

Re: AVerTV HD a835

Messaggioda Xgaz » lunedì 13 dicembre 2010, 0:28

BadMan88 ha scritto:quindi si può provare anche con nuovo kernel?


Non ho provato ma credo di si  ;)
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda cdr89 » lunedì 13 dicembre 2010, 0:59

Grande!!! :D
Ora la mia Cinergy T Stick USB viene correttamente riconosciuta e funziona!
Grazie 1000!!!

Ecco l'output di dmesg:

Codice: Seleziona tutto
$ dmesg | grep TerraTec
[   18.549607] input: TerraTec Cinergy T-Stick as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.1/input/input6
[   18.549745] generic-usb 0003:0CCD:0093.0001: input,hidraw0: USB HID v1.01 Keyboard [TerraTec Cinergy T-Stick] on usb-0000:00:1a.0-1.4/input1
[   19.182265] dvb-usb: found a 'TerraTec Cinergy T Stick' in cold state, will try to load a firmware
[   19.924936] dvb-usb: found a 'TerraTec Cinergy T Stick' in warm state.
[   19.925357] DVB: registering new adapter (TerraTec Cinergy T Stick)
[   20.519548] dvb-usb: TerraTec Cinergy T Stick successfully initialized and connected.
cdr89
Prode Principiante
 
Messaggi: 43
Iscrizione: dicembre 2010

Re: AVerTV HD a835

Messaggioda Xgaz » lunedì 13 dicembre 2010, 1:06

cdr89 ha scritto:Grande!!! :D
Ora la mia Cinergy T Stick USB viene correttamente riconosciuta e funziona!
Grazie 1000!!!

Ecco l'output di dmesg:

Codice: Seleziona tutto
$ dmesg | grep TerraTec
[   18.549607] input: TerraTec Cinergy T-Stick as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.1/input/input6
[   18.549745] generic-usb 0003:0CCD:0093.0001: input,hidraw0: USB HID v1.01 Keyboard [TerraTec Cinergy T-Stick] on usb-0000:00:1a.0-1.4/input1
[   19.182265] dvb-usb: found a 'TerraTec Cinergy T Stick' in cold state, will try to load a firmware
[   19.924936] dvb-usb: found a 'TerraTec Cinergy T Stick' in warm state.
[   19.925357] DVB: registering new adapter (TerraTec Cinergy T Stick)
[   20.519548] dvb-usb: TerraTec Cinergy T Stick successfully initialized and connected.



Ottimo!

Crocetta sulla Terratec T-Stick  (good)
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda pplmarini » lunedì 13 dicembre 2010, 22:17

Bingo! Ha funzionato! adesso la pennetta va alla grande. Ho faticato un pò a configurare i canali ma adesso funziona sia su vlc che metv. la cosa strana è che W_scan mi ha datto ogni volta risultati diversi, ma alla fine dopo vari tentativi ha visto quasi tutti i canali. Grazie a tutti e in particolare (ovviamente) a xgaz.
ciao paolo
Avatar utente
pplmarini
Prode Principiante
 
Messaggi: 121
Iscrizione: dicembre 2007
Desktop: UBUNTU
Distribuzione: Ubuntu 14.04.1 LTS x86_64

Re: AVerTV HD a835

Messaggioda Xgaz » lunedì 13 dicembre 2010, 23:53

pplmarini ha scritto:Bingo! Ha funzionato! adesso la pennetta va alla grande. Ho faticato un pò a configurare i canali ma adesso funziona sia su vlc che metv. la cosa strana è che W_scan mi ha datto ogni volta risultati diversi, ma alla fine dopo vari tentativi ha visto quasi tutti i canali. Grazie a tutti e in particolare (ovviamente) a xgaz.
ciao paolo


Come volevasi dimostare...

:-X :-X
Quindi, riepilogando, è molto probabile che le due pennette siano identiche !!


Lascio a voi la sentenza su questo sistema di vendita di due prodotti praticamente identici a prezzi diversi...

...e vi chiedo: vale la pena che modifico la patch o è meglio che ne faccio una di test da riprovare con tutte e due le pennette? (non vorrei rovinare di nuovo quella che funziona!)
Ultima modifica di Xgaz il giovedì 16 dicembre 2010, 1:30, modificato 1 volta in totale.
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda BadMan88 » martedì 14 dicembre 2010, 0:56

E' andato tutto a posto (good).
Rimane un solo problema: me tv non becca tutti i canali ???, mentre kaffeine 0.8.8 si (rai e mediaset inclusi) ::). A me interessano principalmente i programmi rai e mediaset, sai come posso farglieli beccare? Te lo chiedo perchè me tv ogni volta che lo avvio funziona bene mentre kaffeine nella maggior parte dei casi no.

Ho cercato xbmc perchè so che un buon media center e vorrei installarlo su ubuntu. Il problema è che non c'è il file .deb c'è solo quello .tar.gz, sai come si installano questi ultimi? Io non sono molto pratico di ubuntu come avrai intuito ;D.
Ultima modifica di BadMan88 il martedì 14 dicembre 2010, 2:36, modificato 1 volta in totale.
Avatar utente
BadMan88
Prode Principiante
 
Messaggi: 88
Iscrizione: maggio 2010
Località: Genova

Re: AVerTV HD a835

Messaggioda ubiubuntu » martedì 14 dicembre 2010, 22:36

Ho rifatto la procedura per ben 2 volte perché ho dei problemi di stabilità dopo la ricerca dei canali, sia con w-scan che con me-tv
Mentre con Kaffeine 0.88 non ho grossi problemi (prendo i canali rai e mediaset), con gli altri due programmi (e questo lo vedo soprattutto con me-tv) la pennetta cerca i canali e li trova quasi tutti, ma verso il termine della scansione non mi riconosce più la pennetta.
Cerco di spiegarmi in maniera sintetica: quando avvio ubuntu la pennetta viene riconosciuta:
Codice: Seleziona tutto
[ 1120.730952] DVB: registering new adapter (Avermedia AverTV Volar HD PRO (A835))
[ 1120.739073] af9033: firmware version: LINK:11.15.10.0 OFDM:5.48.10.0
[ 1120.741827] DVB: registering adapter 0 frontend 0 (Afatech AF9033 DVB-T)...
[ 1120.758140] NXP TDA18218HN successfully identified.
[ 1120.758161] dvb-usb: Avermedia AverTV Volar HD PRO (A835) successfully initialized and connected.

nota: kaffeine e me-tv me la riconoscono con questo nome: Afatech AF9033 DVB-T

Quando cerco di completare la scansione con me-tv mi dice questo:
Codice: Seleziona tutto
[  874.184227] af9035: recv bulk message failed:-110
[  874.184246] af9033: I2C read failed reg:002c
[  876.185215] af9035: recv bulk message failed:-110
[  876.185230] af9033: I2C read failed reg:0047
[  878.185264] af9035: recv bulk message failed:-110
[  878.185294] af9033: I2C read failed reg:0048
[  880.197197] af9035: recv bulk message failed:-110
[  880.197215] af9033: I2C read failed reg:0045
[  882.197211] af9035: recv bulk message failed:-110
[  882.197231] af9033: I2C read failed reg:002c
[  884.197437] af9035: recv bulk message failed:-110
[  884.197455] af9033: I2C read failed reg:0047
[  886.216456] af9035: recv bulk message failed:-110
[  886.216474] af9033: I2C read failed reg:0045
[  888.212335] af9035: recv bulk message failed:-110
[  888.212364] af9033: I2C read failed reg:0048
[  890.213145] af9035: recv bulk message failed:-110
[  890.213163] af9033: I2C read failed reg:0047
[  892.212302] af9035: recv bulk message failed:-110
[  892.212333] af9033: I2C read failed reg:002c
[  894.213206] af9035: recv bulk message failed:-110
[  894.213231] af9033: I2C read failed reg:0047
[  896.213264] af9035: recv bulk message failed:-110
[  896.213283] af9033: I2C read failed reg:0048
[  898.224266] af9035: recv bulk message failed:-110
[  898.224291] af9033: I2C read failed reg:0045
[  900.229225] af9035: recv bulk message failed:-110
[  900.229244] af9033: I2C read failed reg:002c
[  902.228250] af9035: recv bulk message failed:-110
[  902.228279] af9033: I2C read failed reg:0047
[  904.253465] af9035: recv bulk message failed:-110
[  904.253483] af9033: I2C read failed reg:0045
[  906.253212] af9035: recv bulk message failed:-110
[  906.253238] af9033: I2C read failed reg:0048
[  908.257688] af9035: recv bulk message failed:-110
[  908.257706] af9033: I2C read failed reg:0047


E non so come poter risolvere, perché non so dove sia l'errore. Spero di non aver sbagliato qualcosa
ubiubuntu
Prode Principiante
 
Messaggi: 4
Iscrizione: dicembre 2010

Re: AVerTV HD a835

Messaggioda cicione78 » mercoledì 15 dicembre 2010, 2:17

Xgaz ha scritto:Allora...ho buone notizie (spero)!

Ho avuto un pò di tempo per lavorarci su e ho fatto un bel mix tra:

- driver per AF9015 (con supporto al tda18218) di Antii Palosaari
- driver per AF9035 sempre di Palosaari + supporto di Terratec (quelli della T-Stick per intenderci)
- informazioni riportate nell' utilissimo link postato da pplmarini

Il risultato è una patch al driver AF9015+TDA18218, che dovrebbe aggiungere il supporto alle periferiche AF9035+TDA18218 e quindi anche alla A835
07ca:b835 AVerMedia Technologies, Inc.
 8)

L'ho provata su Ubuntu 10.10 Maverick con kernel 2.6.35-23-generic
La mia pennetta con AF9015+TDA18218 funziona ancora; per la AF9035+TDA18218 mi serve il vostro aiuto  ;)


Questa la procedura (da fare con chiavetta estratta):

1) Aggiornamento compilatori ed headers del kernel:
Codice: Seleziona tutto
sudo apt-get install mercurial build-essential linux-image-`uname -r` linux-headers-`uname -r`


2) Download del repository dei drivers:
Codice: Seleziona tutto
hg clone http://linuxtv.org/hg/~anttip/tda18218


3) Portarsi nella cartella dei drivers:
Codice: Seleziona tutto
cd tda18218


4) Scaricare la mia patch:
Codice: Seleziona tutto
wget http://xgazza.altervista.org/Linux/DVB/Drivers/tda18218_patch_af9035.diff


5) Patchare i drivers:
Codice: Seleziona tutto
patch -p1 < tda18218_patch_af9035.diff


6) Lanciare la compilazione:
Codice: Seleziona tutto
make

Dopo circa dieci secondi stoppare con: CTRL+C

7) Modificare il config:
Codice: Seleziona tutto
sed -i 's/CONFIG_DVB_FIREDTV=m/CONFIG_DVB_FIREDTV=n/' ./v4l/.config


8 ) Rilanciare la compilazione:
Codice: Seleziona tutto
make


9) Installare i drivers:
Codice: Seleziona tutto
sudo make install


Adesso servirà il firmware; lo potete trovare nel pacchetto originale della Terratec: http://linux.terratec.de/files/terratec_af9035.zip
...oppure lo potete comodamente scaricare dal mio sito:
Codice: Seleziona tutto
cd /lib/firmware

Codice: Seleziona tutto
sudo wget http://xgazza.altervista.org/Linux/DVB/dvb-usb-af9035-01.fw

Quando ha fatto, riavviate:
Codice: Seleziona tutto
sudo reboot


Inserite finalmente la chiavetta e verificate se i vari kaffeine o me-tv la riconoscono...

Vi sono grato anche se mi postate il risultato di:
Codice: Seleziona tutto
dmesg | tail -n 50

...subito dopo che avete inserito la chiavetta

Attendo riscontri...  (b2b)



EDIT 11 Dec 2010: Modificata patch e tolto un comando per modificare il .config
EDIT 12 Dec 2010: Modificata patch per risolvere piccolo errore sul modulo del tuner tua9001 (TerraTec Cinergy T Stick)


[  27.784606] HDA Intel 0000:02:00.1: irq 45 for MSI/MSI-X
[  27.784627] HDA Intel 0000:02:00.1: setting latency timer to 64
[  27.872991] Bluetooth: Generic Bluetooth USB driver ver 0.6
[  27.873160] usbcore: registered new interface driver btusb
[  27.907577] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro
[  28.246593] type=1400 audit(1292371833.708:5): apparmor="STATUS" operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" pid=1150 comm="apparmor_parser"
[  28.250841] type=1400 audit(1292371833.708:6): apparmor="STATUS" operation="profile_load" name="/usr/lib/cups/backend/cups-pdf" pid=1154 comm="apparmor_parser"
[  28.251391] type=1400 audit(1292371833.708:7): apparmor="STATUS" operation="profile_load" name="/usr/sbin/tcpdump" pid=1155 comm="apparmor_parser"
[  28.251470] type=1400 audit(1292371833.708:8): apparmor="STATUS" operation="profile_load" name="/usr/sbin/cupsd" pid=1154 comm="apparmor_parser"
[  28.252754] type=1400 audit(1292371833.708:9): apparmor="STATUS" operation="profile_load" name="/usr/bin/evince" pid=1152 comm="apparmor_parser"
[  28.254013] type=1400 audit(1292371833.708:10): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient3" pid=1151 comm="apparmor_parser"
[  28.254546] type=1400 audit(1292371833.708:11): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=1151 comm="apparmor_parser"
[  28.276235]  alloc irq_desc for 46 on node -1
[  28.276238]  alloc kstat_irqs on node -1
[  28.276253] tg3 0000:03:00.0: irq 46 for MSI/MSI-X
[  28.310026] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  28.415276] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input7
[  28.549097] tg3 0000:03:00.0: eth0: Link is down
[  29.065710] Bluetooth: L2CAP ver 2.14
[  29.065713] Bluetooth: L2CAP socket layer initialized
[  29.123132] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  29.123135] Bluetooth: BNEP filters: protocol multicast
[  29.229093] Bluetooth: SCO (Voice Link) ver 0.6
[  29.229096] Bluetooth: SCO socket layer initialized
[  29.466972] ppdev: user-space parallel port driver
[  29.935266] Bluetooth: RFCOMM TTY layer initialized
[  29.935275] Bluetooth: RFCOMM socket layer initialized
[  29.935279] Bluetooth: RFCOMM ver 1.11
[  30.159691]  alloc irq_desc for 47 on node -1
[  30.159695]  alloc kstat_irqs on node -1
[  30.159707] fglrx_pci 0000:02:00.0: irq 47 for MSI/MSI-X
[  30.160546] [fglrx] Firegl kernel thread PID: 1454
[  30.160786] [fglrx] IRQ 47 Enabled
[  30.303413] [fglrx] Gart USWC size:1196 M.
[  30.303416] [fglrx] Gart cacheable size:474 M.
[  30.303421] [fglrx] Reserved FB block: Shared offset:0, size:1000000
[  30.303423] [fglrx] Reserved FB block: Unshared offset:f941000, size:3bf000
[  30.303425] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000
[  30.564999] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro,commit=0
[  33.775405] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
[  34.286812] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro,commit=0
[  39.036785] eth1: no IPv6 routers present
[  46.524901] hub 2-1:1.0: port 1 disabled by hub (EMI?), re-enabling...
[  46.525149] usb 2-1.1: USB disconnect, address 3
[  46.922882] usb 2-1.1: new low speed USB device using ehci_hcd and address 6
[  47.040493] input: PS/2+USB Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input8
[  47.040667] generic-usb 0003:1267:0212.0002: input,hidraw0: USB HID v1.11 Mouse [PS/2+USB Mouse] on usb-0000:00:1d.0-1.1/input0
[  47.781429] usb 2-1.3: new high speed USB device using ehci_hcd and address 7
[  134.798289] PPP BSD Compression module registered
[  134.802497] PPP Deflate Compression module registered

Ancora niente, avrò sbagliato qualcosa? E' un pò troppo vago il passaggio che dice di stoppare la procedura con Ctrl+C, dopo "CIRCA" 10 sec....
cicione78
Prode Principiante
 
Messaggi: 4
Iscrizione: novembre 2010

Re: AVerTV HD a835

Messaggioda Xgaz » giovedì 16 dicembre 2010, 0:31

Eccomi...

Immaginando che per alcuni anche la modifica di un file di testo o fermare un processo con i tasti "ctrl" e "c" sia un'operazione ostica,
ho rifatto la patch...

Adesso dovrebbe supportare direttamente tutte e due le pennette:

A - Avermedia AVerTV A835 HD PRO (ID 07ca:a835)
B - Avermedia AVerTV A835 HD       (ID 07ca:b835)

Quindi l'operazione adesso è semplificata:

1) Se non è la prima volta che fate l'operazione, rimuovete la vecchia cartella dei drivers:
Codice: Seleziona tutto
sudo rm -R tda18218


2) Controllate di avere gli headers sempre aggiornati (specialmente se upgradate il kernel):
Codice: Seleziona tutto
sudo apt-get install linux-headers-`uname -r`


3) Scaricate i drivers:
Codice: Seleziona tutto
hg clone http://linuxtv.org/hg/~anttip/tda18218


4) Portatevi nella cartella dei drivers:
Codice: Seleziona tutto
cd tda18218


5) Scaricate la mia new patch:
Codice: Seleziona tutto
wget http://xgazza.altervista.org/Linux/DVB/Drivers/patch_af9035_tda18218.diff


6) Patchate i drivers:
Codice: Seleziona tutto
patch -p1 < patch_af9035_tda18218.diff


7) Compilate:
Codice: Seleziona tutto
make


8 ) Installate:
Codice: Seleziona tutto
sudo make install


9) Il firmware dovreste averlo già; altrimenti, se è la prima volta che fate l'operazione:
Codice: Seleziona tutto
cd /lib/firmware

Codice: Seleziona tutto
sudo wget http://xgazza.altervista.org/Linux/DVB/dvb-usb-af9035-01.fw


10) Riavviate:
Codice: Seleziona tutto
sudo reboot



Ringrazio fin d'ora chi avrà tempo e voglia di rifare questa procedura (anche a chi funziona già) e darmi un riscontro sul funzionamento  (b2b)

Per i problemi di instabilità: credo che sia dovuto al firmware; ma finchè qualcuno mooolto più bravo di me non riuscirà ad estrarre un firmware più specifico, dal driver originale Avermedia per windows, dovremo accontentarci di quello fornito da Terratec....  :'(

Ciao

[glow=red,2,300]ATTENZIONE! EDIT:[/glow] Non usate questa procedura poichè obsoleta. Con Ubuntu 10.10 usate questa http://forum.ubuntu-it.org/viewtopic.ph ... 4693&nbsp; ;)
Ultima modifica di Xgaz il lunedì 18 aprile 2011, 0:15, modificato 1 volta in totale.
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda BadMan88 » giovedì 16 dicembre 2010, 16:27

Ho rifatto la procedura che hai corretto e... funziona e non funziona ::), mi spiego meglio.
Quando avvio me-tv non rileva alcun dispositivo, ma se lo chiudo e sconnetto la chiavetta e la ricollego la vede, ma me-tv dice "lock del canale falliito" ???. Ovvero vede un dispositivo dvb (che identifica come Afatech AF9033 DVB-T) ma non riesce a visualizzare il canale. Che posso fare?
Ti posto l' output di dmesg | tail -n 50:
Codice: Seleziona tutto
tiziano@tiziano-K7Upgrade-600:~$ dmesg | tail -n 50
[  576.640866] sd 6:0:0:0: [sdg] Attached SCSI removable disk
[  654.157893] WARNING! power/level is deprecated; use power/control instead
[  654.242165] usb 1-3.2: USB disconnect, address 14
[ 1275.920044] usb 3-2: new full speed USB device using uhci_hcd and address 10
[ 1291.032031] usb 3-2: device descriptor read/64, error -110
[ 1306.248035] usb 3-2: device descriptor read/64, error -110
[ 1306.464035] usb 3-2: new full speed USB device using uhci_hcd and address 11
[ 1321.576055] usb 3-2: device descriptor read/64, error -110
[ 1336.792029] usb 3-2: device descriptor read/64, error -110
[ 1337.008053] usb 3-2: new full speed USB device using uhci_hcd and address 12
[ 1347.416022] usb 3-2: device not accepting address 12, error -110
[ 1347.528039] usb 3-2: new full speed USB device using uhci_hcd and address 13
[ 1357.936033] usb 3-2: device not accepting address 13, error -110
[ 1357.936064] hub 3-0:1.0: unable to enumerate USB device on port 2
[ 1358.136162] usb 1-3.5: new high speed USB device using ehci_hcd and address 15
[ 1358.335759] usblp0: USB Bidirectional printer dev 15 if 1 alt 0 proto 2 vid 0x04A9 pid 0x1721
[ 1358.337683] usbcore: registered new interface driver usblp
[ 1358.784769] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'xsane' sets config #1
[ 1359.408286] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'usb' sets config #1
[ 1362.451217] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'xsane' sets config #1
[ 1363.462549] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'xsane' sets config #1
[ 1835.728062] usb 3-2: new full speed USB device using uhci_hcd and address 14
[ 1850.840029] usb 3-2: device descriptor read/64, error -110
[ 1866.056058] usb 3-2: device descriptor read/64, error -110
[ 1866.272047] usb 3-2: new full speed USB device using uhci_hcd and address 15
[ 1881.384031] usb 3-2: device descriptor read/64, error -110
[ 1896.600088] usb 3-2: device descriptor read/64, error -110
[ 1896.816038] usb 3-2: new full speed USB device using uhci_hcd and address 16
[ 1907.224070] usb 3-2: device not accepting address 16, error -110
[ 1907.336103] usb 3-2: new full speed USB device using uhci_hcd and address 17
[ 1917.744107] usb 3-2: device not accepting address 17, error -110
[ 1917.744137] hub 3-0:1.0: unable to enumerate USB device on port 2
[ 1917.877315] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'simple-scan' sets config #1
[ 1920.515685] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'simple-scan' sets config #1
[ 1921.519252] usb 1-3.5: usbfs: interface 1 claimed by usblp while 'simple-scan' sets config #1
[ 2190.290323] tvtime[3016]: segfault at 6b0 ip 0804cf64 sp bfeedafc error 4 in tvtime[8048000+76000]
[ 2232.679128] tvtime[3020]: segfault at 6b0 ip 0804cf64 sp bfc3df3c error 4 in tvtime[8048000+76000]
[ 2250.505840] tvtime[3022]: segfault at 6b0 ip 0804cf64 sp bfd2d87c error 4 in tvtime[8048000+76000]
[ 2298.036102] usb 1-4: new high speed USB device using ehci_hcd and address 16
[ 2298.260098] dvb-usb: found a 'Avermedia AverTV Volar HD & HD PRO (A835)' in cold state, will try to load a firmware
[ 2298.291492] dvb-usb: downloading firmware from file 'dvb-usb-af9035-01.fw'
[ 2298.643361] dvb-usb: found a 'Avermedia AverTV Volar HD & HD PRO (A835)' in warm state.
[ 2298.643483] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 2298.646259] DVB: registering new adapter (Avermedia AverTV Volar HD & HD PRO (A835))
[ 2298.724966] af9033: firmware version: LINK:11.15.10.0 OFDM:5.48.10.0
[ 2298.727964] DVB: registering adapter 0 frontend 0 (Afatech AF9033 DVB-T)...
[ 2298.759847] NXP TDA18218HN successfully identified.
[ 2298.759861] dvb-usb: Avermedia AverTV Volar HD & HD PRO (A835) successfully initialized and connected.
[ 2298.776547] usbcore: registered new interface driver dvb_usb_af9035
[ 2364.951802] tvtime[3064]: segfault at 6b0 ip 0804cf64 sp bfd209cc error 4 in tvtime[8048000+76000]
tiziano@tiziano-K7Upgrade-600:~$

Non capisco ::) eppure viene riconosciuta ed inizializzata...
Kaffeine invece a volte funziona e a volte no ho provato adesso ad avviarlo da treminale e questo è l' output:
Codice: Seleziona tutto
tiziano@tiziano-K7Upgrade-600:~$ kaffeine
kbuildsycoca running...
Reusing existing ksycoca
/dev/dvb/adapter0/frontend0 : opened ( Afatech AF9033 DVB-T ) (0ms)
0 EPG plugins loaded for device 0:0.
Loaded epg data : 0 events (0 msecs)
tiziano@tiziano-K7Upgrade-600:~$ Tuning to: Iris / autocount: 0
DvbCam::probe(): /dev/dvb/adapter0/ca0: : File o directory non esistente
Using DVB device 0:0 "Afatech AF9033 DVB-T"
tuning DVB-T to 858000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
...............

Not able to lock to the signal on the given frequency
Frontend closed
Tuning delay: 1768 ms
Tuning to: Iris / autocount: 0
Using DVB device 0:0 "Afatech AF9033 DVB-T"
tuning DVB-T to 858000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
....... LOCKED.
Tuning time = 715 ms
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 864 ms
pipe opened
demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.
xine pipe opened /home/tiziano/.kaxtv.ts
Asked to stop
pipe closed
Live stopped
Tuning to: ITALIA 1 / autocount: 1
NOUT: 1
Tuning delay: 0 ms
demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.
pipe opened
xine pipe opened /home/tiziano/.kaxtv1.ts
Recording started: ITALIA 1
NOUT: 1
Recording stopped: ITALIA 1
Asked to stop
pipe closed
Live stopped
Tuning to: CANALE 5 / autocount: 2
NOUT: 1
Tuning delay: 0 ms
demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.
pipe opened
xine pipe opened /home/tiziano/.kaxtv.ts
Asked to stop
pipe closed
Live stopped
dvbstream::run() end
dvbEvents 0:0 ended
fdDvr closed
Frontend closed
Tuning to: Virginradio TV / autocount: 3
Using DVB device 0:0 "Afatech AF9033 DVB-T"
tuning DVB-T to 842000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
............... LOCKED.
Tuning time = 1525 ms
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 1526 ms
demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.
pipe opened
xine pipe opened /home/tiziano/.kaxtv1.ts
Asked to stop
pipe closed
Live stopped
dvbstream::run() end
dvbEvents 0:0 ended
fdDvr closed
Frontend closed
Saved epg data : 0 events (0 msecs)

Se ci fai caso nelle prime stringhe, subito dopo aver avvaito kaffeine (0.8.8) si nota quella difficoltà che anche me-tv palesa... che ne pensi?

P.S.: Mi sono siegato bene? ;D
Avatar utente
BadMan88
Prode Principiante
 
Messaggi: 88
Iscrizione: maggio 2010
Località: Genova

Re: AVerTV HD a835

Messaggioda BadMan88 » venerdì 17 dicembre 2010, 1:15

Non riesco a capire il comportamento di questa pennetta, mi spiego meglio.
Ho appena avviato ubuntu e avviato kaffeine e l' icona Digital TV è scomparsa.... ??? ::) Allora chiudo il programma e lancio un dmesg | tail -n 50 e questo è l' output:
Codice: Seleziona tutto
tiziano@tiziano-K7Upgrade-600:~$ dmesg | tail -n 50
[   25.535006] saa7134[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   25.535016] saa7134[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   25.535026] saa7134[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   25.535036] saa7134[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   25.668596] tuner 1-0043: chip found @ 0x86 (saa7134[0])
[   25.712711] tda9887 1-0043: creating new instance
[   25.712718] tda9887 1-0043: tda988[5/6/7] found
[   25.796071] Chip ID is not zero. It is not a TEA5767
[   25.796306] tuner 1-0060: chip found @ 0xc0 (saa7134[0])
[   25.844148] mt20xx 1-0060: microtune: companycode=3cbf part=42 rev=09
[   25.876081] mt20xx 1-0060: microtune MT2050 found, OK
[   25.888132] eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
[   25.904100] type=1400 audit(1292539151.820:6): apparmor="STATUS" operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" pid=975 comm="apparmor_parser"
[   25.926152] type=1400 audit(1292539151.844:7): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient3" pid=978 comm="apparmor_parser"
[   25.926538] type=1400 audit(1292539151.844:8): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=978 comm="apparmor_parser"
[   25.926751] type=1400 audit(1292539151.844:9): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=978 comm="apparmor_parser"
[   25.948219] saa7134[0]: registered device video1 [v4l2]
[   25.948263] saa7134[0]: registered device vbi0
[   25.949409]   alloc irq_desc for 22 on node -1
[   25.949412]   alloc kstat_irqs on node -1
[   25.949425] VIA 82xx Audio 0000:00:11.5: PCI INT C -> GSI 22 (level, low) -> IRQ 22
[   25.949599] VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
[   26.017915] saa7134 ALSA driver for DMA sound loaded
[   26.017970] saa7134[0]/alsa: saa7134[0] at 0xdfffbc00 irq 18 registered as card -2
[   26.035086] type=1400 audit(1292539151.952:10): apparmor="STATUS" operation="profile_load" name="/usr/bin/evince" pid=981 comm="apparmor_parser"
[   26.065691] type=1400 audit(1292539151.984:11): apparmor="STATUS" operation="profile_load" name="/usr/bin/evince-previewer" pid=981 comm="apparmor_parser"
[   26.512193] af9035: recv bulk message failed:-110
[   26.512202] af9035: eeprom read failed:-5
[   26.512223] dvb_usb_af9035: probe of 1-4:1.0 failed with error -5
[   26.512292] usbcore: registered new interface driver dvb_usb_af9035
[   26.596595]   alloc irq_desc for 16 on node -1
[   26.596602]   alloc kstat_irqs on node -1
[   26.596614] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   26.596628] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   26.598681] NVRM: loading NVIDIA UNIX x86 Kernel Module  173.14.28  Wed Sep 29 09:47:25 PDT 2010
[   26.782823] apm: BIOS not found.
[   28.063458] agpgart-via 0000:00:00.0: AGP 3.5 bridge
[   28.063478] agpgart-via 0000:00:00.0: putting AGP V3 device into 8x mode
[   28.063541] nvidia 0000:01:00.0: putting AGP V3 device into 8x mode
[   28.126819] Bluetooth: L2CAP ver 2.14
[   28.126825] Bluetooth: L2CAP socket layer initialized
[   28.273343] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   28.273349] Bluetooth: BNEP filters: protocol multicast
[   28.491984] Bluetooth: SCO (Voice Link) ver 0.6
[   28.491991] Bluetooth: SCO socket layer initialized
[   28.814201] Bluetooth: RFCOMM TTY layer initialized
[   28.814212] Bluetooth: RFCOMM socket layer initialized
[   28.814215] Bluetooth: RFCOMM ver 1.11
[   33.760722] EXT4-fs (sdb5): re-mounted. Opts: errors=remount-ro,commit=0
[   36.784018] eth0: no IPv6 routers present

E La Chiavetta? che fine ha fatto? :o Allora provo a scollegarla e riattaccarla dopo circa 20 secondi e.... voilà:
Codice: Seleziona tutto
tiziano@tiziano-K7Upgrade-600:~$ dmesg | tail -n 50
[ 1203.732043] usb 1-4: new high speed USB device using ehci_hcd and address 10
[ 1203.884989] dvb-usb: found a 'Avermedia AverTV Volar HD & HD PRO (A835)' in cold state, will try to load a firmware
[ 1204.395895] dvb-usb: downloading firmware from file 'dvb-usb-af9035-01.fw'
[ 1204.756039] dvb-usb: found a 'Avermedia AverTV Volar HD & HD PRO (A835)' in warm state.
[ 1204.756157] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 1204.758176] DVB: registering new adapter (Avermedia AverTV Volar HD & HD PRO (A835))
[ 1204.840999] af9033: firmware version: LINK:11.15.10.0 OFDM:5.48.10.0
[ 1204.844001] DVB: registering adapter 0 frontend 0 (Afatech AF9033 DVB-T)...
[ 1204.873499] NXP TDA18218HN successfully identified.
[ 1204.873513] dvb-usb: Avermedia AverTV Volar HD & HD PRO (A835) successfully initialized and connected.

nota: il secondo codice che ho postato è l' ultima parte del risultato di: dmesg | tail -n 50 che mostra il riconoscimento e l' inizializzazione della pennetta....... ma quando avvio kaffeine e provo a mettermi su un canale:
Codice: Seleziona tutto
tiziano@tiziano-K7Upgrade-600:~$ kaffeine
kbuildsycoca running...
/dev/dvb/adapter0/frontend0 : opened ( Afatech AF9033 DVB-T ) (0ms)
0 EPG plugins loaded for device 0:0.
Loaded epg data : 0 events (0 msecs)
tiziano@tiziano-K7Upgrade-600:~$ Tuning to: CANALE 5 / autocount: 0
DvbCam::probe(): /dev/dvb/adapter0/ca0: : File o directory non esistente
Using DVB device 0:0 "Afatech AF9033 DVB-T"
tuning DVB-T to 858000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
...............

Not able to lock to the signal on the given frequency
Frontend closed
Tuning delay: 1759 ms
Tuning to: CANALE 5 / autocount: 0
Using DVB device 0:0 "Afatech AF9033 DVB-T"
tuning DVB-T to 858000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
...............

E succede anche per tutti gli altri canali. :'( Qualcuno mi spiega che cacchio succede??
Ultima modifica di BadMan88 il venerdì 17 dicembre 2010, 1:18, modificato 1 volta in totale.
Avatar utente
BadMan88
Prode Principiante
 
Messaggi: 88
Iscrizione: maggio 2010
Località: Genova

Re: AVerTV HD a835

Messaggioda Xgaz » venerdì 17 dicembre 2010, 13:16

Io di solito le pennette le inserisco sempre quando il sistema si è inizializzato; non ho mai provato a lasciale inserite e riavviare...

Questo non so cosa sia:
DvbCam::probe(): /dev/dvb/adapter0/ca0: : File o directory non esistente
...hai un modulo CAM installato?  ???

Se kaffeine non fa il lock su alcuni canali è perchè non ha segnale sufficiente...
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda pplmarini » lunedì 20 dicembre 2010, 17:25

per xgaz,
Ho rifatto la procedura ( quella per avertv volar hd pro) ed è andata bene.
W-scan (usato per vlc) molto spesso non riesce a terminare la procedura (mi da un dvb-channels.conf vuoto) ma insistendo alla fine riesce a terminare la procedura.
kaffeine va benissimo ma bisogna provare fra le varie opzioni (it-bologna,it-aosta,etc)per avere tutti i canali.
ritengo che il programma più affidabile sia kaffeine,nonstante il mio sistema sia ubuntu e non kubuntu.
ciao paolo
Avatar utente
pplmarini
Prode Principiante
 
Messaggi: 121
Iscrizione: dicembre 2007
Desktop: UBUNTU
Distribuzione: Ubuntu 14.04.1 LTS x86_64

Re: AVerTV HD a835

Messaggioda Xgaz » lunedì 20 dicembre 2010, 23:58

Al posto di it-... , prova "AUTO"

Ti farà la scansione su tutta la banda...
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda Softec » domenica 26 dicembre 2010, 23:07

Ciao ragazzi,

vi scrivo perchè sono disperato con l'installazione della chiavetta Terratec Cinergy T Stick, non riesco in nessun modo.

ho seguito la guida e non mi ha dato nessun errore ne make ne make install

vi posto i risultati dei commandi sperando che qualcuno mi dia almeno una dritta per sapere dove andare a cercare.

uso Ubuntu 10.10 con kernel 2.6.35-24

lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 08ff:1600 AuthenTec, Inc. AES1600
Bus 005 Device 002: ID 0b05:1751 ASUSTek Computer, Inc. BT-253 Bluetooth Adapter
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 064e:f111 Suyin Corp.
Bus 002 Device 002: ID 0ccd:0093 TerraTec Electronic GmbH
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg quando riavvio il PC
[    2.723827] usbcore: registered new interface driver hiddev
[    2.727010] input: TerraTec Cinergy T-Stick as /devices/pci0000:00/0000:00:1d.7/usb2/2-3/2-3:1.1/input/input4
[    2.727081] generic-usb 0003:0CCD:0093.0001: input,hidraw0: USB HID v1.01 Keyboard [TerraTec Cinergy T-Stick] on usb-0000:00:1d.7-3/input1
[    2.727096] usbcore: registered new interface driver usbhid
[    2.727097] usbhid: USB HID core driver

dmesg quando scollego e ricollego la chiavetta
[ 3983.108260] usb 2-3: USB disconnect, address 2
[ 3987.884079] usb 2-3: new high speed USB device using ehci_hcd and address 4
[ 3988.027002] input: TerraTec Cinergy T-Stick as /devices/pci0000:00/0000:00:1d.7/usb2/2-3/2-3:1.1/input/input9
[ 3988.027356] generic-usb 0003:0CCD:0093.0002: input,hidraw0: USB HID v1.01 Keyboard [TerraTec Cinergy T-Stick] on usb-0000:00:1d.7-3/input1
[ 3988.045633] dvb_usb_af9035: disagrees about version of symbol dvb_usb_device_init
[ 3988.045636] dvb_usb_af9035: Unknown symbol dvb_usb_device_init (err -22)

grazie in anticipo a tutti.
Softec
Prode Principiante
 
Messaggi: 2
Iscrizione: dicembre 2010

Re: AVerTV HD a835

Messaggioda Xgaz » martedì 28 dicembre 2010, 0:50

Strano a qualcun'altro funziona...

Difficile capire dov' è l'intoppo se non hai avuto errori durante la compilazione  :-\

Prova a darmi il risultato di
Codice: Seleziona tutto
dmesg | tail -n 30
dopo aver tolto e reinserito la pennetta
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

Re: AVerTV HD a835

Messaggioda Softec » martedì 28 dicembre 2010, 9:22

ecco il risultato,

[  312.916371] usb 2-3: new high speed USB device using ehci_hcd and address 3
[  313.459125] usbcore: registered new interface driver hiddev
[  313.462335] input: TerraTec Cinergy T-Stick as /devices/pci0000:00/0000:00:1d.7/usb2/2-3/2-3:1.1/input/input8
[  313.462421] generic-usb 0003:0CCD:0093.0001: input,hidraw0: USB HID v1.01 Keyboard [TerraTec Cinergy T-Stick] on usb-0000:00:1d.7-3/input1
[  313.462435] usbcore: registered new interface driver usbhid
[  313.462436] usbhid: USB HID core driver
[  313.526023] dvb_usb_af9035: disagrees about version of symbol dvb_usb_device_init
[  313.526026] dvb_usb_af9035: Unknown symbol dvb_usb_device_init (err -22)
[  313.528594] dvb_usb_af9035: disagrees about version of symbol dvb_usb_device_init
[  313.528597] dvb_usb_af9035: Unknown symbol dvb_usb_device_init (err -22)
[  322.936123] CE: hpet increased min_delta_ns to 16875 nsec

nel pomeriggio riprovo a fare tutta la procedura ma sarà difficile, ho provato sia la tua guida che altre con scarsi risultati. C'è un log del make? da consultare in seguito e non mentre compila?

grazie mille dell'aiuto
Softec
Prode Principiante
 
Messaggi: 2
Iscrizione: dicembre 2010

Re: AVerTV HD a835

Messaggioda Xgaz » venerdì 31 dicembre 2010, 0:55

Il modulo non sembra compilato correttamente...

Prova  a fare così:

Codice: Seleziona tutto
sudo rm /lib/modules/`uname -r`/kernel/drivers/media/dvb/dvb-usb/dvb-usb-af9035.ko

Codice: Seleziona tutto
sudo apt-get install linux-headers-`uname -r`


Rientra nella cartella dei drivers:
Codice: Seleziona tutto
cd tda18218


pulisci:
Codice: Seleziona tutto
 sudo make clean
Codice: Seleziona tutto
sudo make distclean


e rifà la compilazione:
Codice: Seleziona tutto
make
Codice: Seleziona tutto
sudo make install


Se ci sono errori, in teoria, l'operazione di make si ferma e ti viene visualizzato l'errore...
Avatar utente
Xgaz
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2568
Iscrizione: marzo 2009

PrecedenteSuccessiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: criceto45 e 12 ospiti