[RISOLTO] servizio di sistema per la stampa non disponibile

Riconoscimento, installazione e configurazione delle periferiche.

[RISOLTO] servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 14:12

salve ragazzi, vorrei chiedere una mano perchè non riesco ad installare una stampante.
nello specifico devo collegare una vecchia laser parallela tramite un adattatore usb.cercando in rete pare che questi adattatori vengano automaticamente riconosciuti e installati da ubuntu, quindi qui nessun problema apparente.

il problema è che se vado su
Applicazioni - Strumenti di sistema - Impostazioni di sistema - Stampanti
qui mi compare un messaggio: il servizio di sistema per la stampa sembra non essere disponibile.
quindi rendendo impossibile l'eventuale installazione e configurazione.

come posso fare per attivarlo? possibili cause?
ringrazio anticipatamente.
Ultima modifica di ciko2k il mercoledì 18 gennaio 2012, 19:44, modificato 1 volta in totale.
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda steff » sabato 14 gennaio 2012, 14:44

Prova
Codice: Seleziona tutto
 sudo service cups start
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37026
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 15:43

sudo service cups start
mi da questo messaggio

start: Job failed to start
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda steff » sabato 14 gennaio 2012, 15:58

Prova
Codice: Seleziona tutto
sudo apt-get --purge remove cups && sudo apt-get install cups

Codice: Seleziona tutto
sudo service cups restart
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37026
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 17:18

grazie mille ora sembra funzionare, il " servizio di sistema per la stampa" sembra essere operativo al 100%
ma non mi da la possibilità di inserire manualmente una stampante, come se potesse installare una stampante solo dopo averla rilevata in automatico.. hai consigli?
dovrei caricare un modello specifco (hp 6L) ma non essendo una stampante usb non me la può rilevare.. inoltra tra il pc e la stampante c'è l'adattattore usb-parallela..
se puoi aiutarmi te ne sarei davvero grato..
intanto grazie ancora!! (b2b)

PS pensi sia più idoneo chiudere questo topic e aprirne ora un altro con il problema dell'adattatore?
Ultima modifica di ciko2k il sabato 14 gennaio 2012, 17:20, modificato 1 volta in totale.
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda magozurlinux » sabato 14 gennaio 2012, 19:53

Ho risolto ad un altro utente la stampante parallela collegata con un adattatore usb - parallelo.

Da terminale postami questi comandi coll'adattatore usb - parallelo inserito:

Codice: Seleziona tutto
lsusb


Codice: Seleziona tutto
dmesg | grep usb
XUBUNTU 16.04 LTS x86_64 Desktop :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20209
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 20:39

grazie mille per la diaponibilità  (b2b)

comando : lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 05e1:0501 Syntek Semiconductor Co., Ltd DC-1125 Webcam
Bus 003 Device 007: ID 4348:5584 WinChipHead CH34x printer adapter cable
Bus 003 Device 005: ID 04f3:0217 Elan Microelectronics Corp.
Bus 004 Device 002: ID 0b05:1712 ASUSTek Computer, Inc. BT-183 Bluetooth 2.0+EDR adapter

comando : dmesg | grep usb
[    0.523050] usbcore: registered new interface driver usbfs
[    0.523050] usbcore: registered new interface driver hub
[    0.523050] usbcore: registered new device driver usb
[    1.644130] usb 1-8: new high speed USB device number 5 using ehci_hcd
[    2.016066] usb 3-1: new full speed USB device number 2 using uhci_hcd
[    2.408054] usb 3-2: new low speed USB device number 3 using uhci_hcd
[    2.816079] usb 4-1: new full speed USB device number 2 using uhci_hcd
[    9.614865] usbcore: registered new interface driver btusb
[    9.917659] usbcore: registered new interface driver stkwebcam
[  10.097585] input: USB Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input8
[  10.097738] generic-usb 0003:04F3:0217.0001: input,hidraw0: USB HID v1.11 Mouse [USB Mouse] on usb-0000:00:1d.1-2/input0
[  10.097769] usbcore: registered new interface driver usbhid
[  10.097771] usbhid: USB HID core driver
[  116.216106] usb 3-2: USB disconnect, device number 3
[  118.448124] usb 3-1: USB disconnect, device number 2
[  120.328075] usb 3-1: new full speed USB device number 4 using uhci_hcd
[  121.664054] usb 3-2: new low speed USB device number 5 using uhci_hcd
[  121.848243] input: USB Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input9
[  121.848488] generic-usb 0003:04F3:0217.0002: input,hidraw0: USB HID v1.11 Mouse [USB Mouse] on usb-0000:00:1d.1-2/input0
[ 2284.000171] usb 3-1: USB disconnect, device number 4
[ 2290.444094] usb 2-2: new full speed USB device number 2 using uhci_hcd
[ 2290.678114] usb 2-2: usbfs: USBDEVFS_CONTROL failed cmd mtp-probe rqt 128 rq 6 len 1024 ret -71
[ 3119.760128] usb 2-2: USB disconnect, device number 2
[ 3420.596055] usb 3-1: new full speed USB device number 6 using uhci_hcd
[ 7761.116187] usb 3-1: USB disconnect, device number 6
[ 7761.356093] usb 3-1: new full speed USB device number 7 using uhci_hcd
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda magozurlinux » sabato 14 gennaio 2012, 21:08

Prego, di nulla.

Proviamo con una regola udev senza la stampante inserita nella porta usb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 05e1:0501 Syntek Semiconductor Co., Ltd DC-1125 Webcam
Bus 003 Device 007: ID 4348:5584 WinChipHead CH34x printer adapter cable
Bus 003 Device 005: ID 04f3:0217 Elan Microelectronics Corp.
Bus 004 Device 002: ID 0b05:1712 ASUSTek Computer, Inc. BT-183 Bluetooth 2.0+EDR adapter


da terminale dai questo comando:

Codice: Seleziona tutto
sudo gedit /etc/udev/rules.d/10-usbprinter.rules


inserisci questi parametri:

Codice: Seleziona tutto
ATTR{idVendor}=="4348", ATTR{idProduct}=="5584", MODE:="0660", GROUP:="lp"


salva ed esci dall'editor di testo.

Da terminale dai questo comando:

Codice: Seleziona tutto
sudo service udev restart


Da terminale controlla che il tuo username appartenga al gruppo lp:

Da terminale dai questo comando:

Codice: Seleziona tutto
groups


se nella riga non vedi il gruppo lp da terminale dai questo comando:

Codice: Seleziona tutto
sudo adduser tuo-username lp


Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo rmmod -r usblp


Codice: Seleziona tutto
sudo service cups restart


Riavvia il pc.

Inserisci la stampante alla porta usb e postami questo comando:

Codice: Seleziona tutto
dmesg | grep usb
XUBUNTU 16.04 LTS x86_64 Desktop :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20209
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 21:36

mi ha dato un messaggio di errore e non so cosa fare..

ciko@ciko-F3JC:~$ sudo rmmod -r usblp
[sudo] password for ciko:
rmmod: invalid option -- 'r'
Usage: rmmod [-fhswvV] modulename ...
-f (or --force) forces a module unload, and may crash your
    machine.  This requires the Forced Module Removal option
    when the kernel was compiled.
-h (or --help) prints this help text
-s (or --syslog) says use syslog, not stderr
-v (or --verbose) enables more messages
-V (or --version) prints the version code
-w (or --wait) begins a module removal even if it is used
    and will stop new users from accessing the module (so it
    should eventually fall to zero).


poi fattto comunque il restart di cup e riavvio pc

ciko@ciko-F3JC:~$ dmesg | grep usb
[    0.519076] usbcore: registered new interface driver usbfs
[    0.519101] usbcore: registered new interface driver hub
[    0.519154] usbcore: registered new device driver usb
[    1.512056] usb 1-8: new high speed USB device number 4 using ehci_hcd
[    1.884046] usb 3-2: new low speed USB device number 2 using uhci_hcd
[    2.071560] input: USB Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input5
[    2.071702] generic-usb 0003:04F3:0217.0001: input,hidraw0: USB HID v1.11 Mouse [USB Mouse] on usb-0000:00:1d.1-2/input0
[    2.071724] usbcore: registered new interface driver usbhid
[    2.071726] usbhid: USB HID core driver
[    2.292047] usb 4-1: new full speed USB device number 2 using uhci_hcd
[  28.793830] usbcore: registered new interface driver btusb
[  28.849034] usbcore: registered new interface driver stkwebcam
[  77.520052] usb 3-1: new full speed USB device number 3 using uhci_hcd
[  110.331877] usb[1756]: segfault at 0 ip 001878fc sp bfbb9164 error 4 in libc-2.13.so[110000+176000]

scusa ma sono davvero ignorante su linux
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 21:38

dimenticavo, il mio user compariva sul gruppo lp
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda steff » sabato 14 gennaio 2012, 22:57

Codice: Seleziona tutto
sudo rmmod -r usblp
[sudo] password for ciko:
rmmod: invalid option -- 'r'

Il comando doveva essere rmmod senza -r o modprobe -r, era un svista
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37026
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 23:08

comando : sudo rmmod usblp
ERROR: Module usblp does not exist in /proc/modules

grazie ancora
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda magozurlinux » sabato 14 gennaio 2012, 23:18

Hai collegato l'adattatore usb - parallelo alla stampante ed inserito nella porta usb?

non vedo nulla relativo a usblp relativo alla stampante collegata alla usb.
XUBUNTU 16.04 LTS x86_64 Desktop :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20209
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 23:22

con il comando   sudo modprobe -r usblp sembra non succedere nulla, mi manda a capo su una nuova riga

ho inserito il connettore usb parallelo e digitatato dmesg | grep usb

[    0.519076] usbcore: registered new interface driver usbfs
[    0.519101] usbcore: registered new interface driver hub
[    0.519154] usbcore: registered new device driver usb
[    1.512056] usb 1-8: new high speed USB device number 4 using ehci_hcd
[    1.884046] usb 3-2: new low speed USB device number 2 using uhci_hcd
[    2.071560] input: USB Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input5
[    2.071702] generic-usb 0003:04F3:0217.0001: input,hidraw0: USB HID v1.11 Mouse [USB Mouse] on usb-0000:00:1d.1-2/input0
[    2.071724] usbcore: registered new interface driver usbhid
[    2.071726] usbhid: USB HID core driver
[    2.292047] usb 4-1: new full speed USB device number 2 using uhci_hcd
[   28.793830] usbcore: registered new interface driver btusb
[   28.849034] usbcore: registered new interface driver stkwebcam
[   77.520052] usb 3-1: new full speed USB device number 3 using uhci_hcd
[  110.331877] usb[1756]: segfault at 0 ip 001878fc sp bfbb9164 error 4 in libc-2.13.so[110000+176000]
[  618.680118] usb 3-1: USB disconnect, device number 3
[  627.468075] usb 2-2: new full speed USB device number 2 using uhci_hcd
[ 4051.248115] usb 2-2: USB disconnect, device number 2
[ 6436.504069] usb 3-1: new full speed USB device number 4 using uhci_hcd
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda steff » sabato 14 gennaio 2012, 23:24

Quando non ottieni risposta il terminale ha eseguito senza errore il comando. Ma altro non so di quel state provando.
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37026
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: servizio di sistema per la stampa non disponibile

Messaggioda magozurlinux » sabato 14 gennaio 2012, 23:31

Il cavo usb - parallelo funziona?

quì parla di un bug vecchiotto, non so se è stato risolto e si riferisce al tuo adattatore usb - parallelo.

https://bugs.launchpad.net/ubuntu/+sour ... bug/308788
XUBUNTU 16.04 LTS x86_64 Desktop :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20209
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: servizio di sistema per la stampa non disponibile

Messaggioda magozurlinux » sabato 14 gennaio 2012, 23:35

Col comando dmesg | grep usb avrebbe dovuto visualizzare un output tipo questo:

Codice: Seleziona tutto
usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x4348 pid 0x5584
XUBUNTU 16.04 LTS x86_64 Desktop :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20209
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 23:40

ciao, si avevo già notato quella discussione, ma non c'avevo capito molto.
ho provato i comandi che mi avevi dato e ho avuto un errore e poi qualche risultato che ho postato sopra.
non saprei come rendermi conto se è stato riconosciuto come bridge per la stampante o meno.
viene visto alla porta usb, con il comando lsusb, infatti si vede.
ma non saprei come impostarlo.
vado su impostazioni di sistema-stampanti-aggiungi stampante-locale e non mi trova nulla.
sotto win7 l'ho installato senza problemi, ho aggiunto la stampante e poi l'ho associata al percorso dell'adattatore.
qui in linux non saprei come inserire la nuova stampante e far vedere al pc la stampante tramite il cavo usb-parallela.
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda ciko2k » sabato 14 gennaio 2012, 23:42

dovrei riprovare alcuni comandi?
ciko2k
Prode Principiante
 
Messaggi: 36
Iscrizione: giugno 2011

Re: servizio di sistema per la stampa non disponibile

Messaggioda magozurlinux » sabato 14 gennaio 2012, 23:47

Prova a dare questo comando senza la stampante collegata:

Codice: Seleziona tutto
sudo modprobe usblp


inserisci la stampante ad una porta usb

Da terminale postami questo comando:

Codice: Seleziona tutto
dmesg | grep usb
XUBUNTU 16.04 LTS x86_64 Desktop :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20209
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: Bergoglio, raffaele63, Stefano_Zambelli-58 e 15 ospiti