[Risolto] Ubuntu non si spegne

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

[Risolto] Ubuntu non si spegne

Messaggio da apophis »

Spero di postare nella sezione più adatta... Come da titolo, quando voglio arrestare il sistema, a volte succede che il tutto si pianta sulla schermata celeste con la pallina che gira, e pur aspettando svariati minuti, rimane in quello stato, e mi tocca spegnere tenendo premuto il tasto di accensione del computer... A cosa può essere dovuto? Fino a poco tempo fa funzionava normalmente... Non saprei neanche che screen postare, quindi attendo consigli ;)
Ultima modifica di apophis il giovedì 14 febbraio 2013, 19:40, modificato 1 volta in totale.
Avatar utente
gabry2105
Prode Principiante
Messaggi: 168
Iscrizione: domenica 15 novembre 2009, 15:57
Desktop: Ubuntu-2d
Distribuzione: Ubuntu 12.04

Re: Ubuntu non si spegne

Messaggio da gabry2105 »

A me succedeva una cosa simile con una vecchia distribuzione di ubuntu (8.04 mi pare), avevo risolto disattivando gli ACPI da bios. Nel mio caso il problema era dato dall'incompatibilita' della distribuzione con il mio hardware
Voglio la pace non solo per me.
Avatar utente
Mdfalcubo
Moderatore Globale
Moderatore Globale
Messaggi: 20374
Iscrizione: venerdì 26 dicembre 2008, 11:17
Desktop: Solo XFCE
Distribuzione: Xubuntu 64 bit
Sesso: Maschile

Re: Ubuntu non si spegne

Messaggio da Mdfalcubo »

È difficile dare consigli senza sapere nulla del pc in questione nè della versione di ubuntu che stai usando...
"Il genere umano è stimolante, è la gente che non sopporto,, (Linus - Peanuts)
"Se vuoi una mano per essere aiutato la trovi alla fine del tuo braccio,,
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22637
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Ubuntu non si spegne

Messaggio da magozurlinux »

Da terminale dai questo comando:

Codice: Seleziona tutto

sudo gedit /etc/default/grub
scorri le prime righe e posizionati su questa riga

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

modificala aggiungendo acpi=force

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

salva ed esci dall'editor di testo.

Da terminale dai questo comando:

Codice: Seleziona tutto

sudo update-grub
Riavvia il pc.
Xubuntu 20.04 LTS amd64 :ciao:
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

Re: Ubuntu non si spegne

Messaggio da apophis »

Ho cambiato quella riga il grub, ma non è cambiato niente... Io uso Ubuntu 12.04 e ho un Acer Aspire 5741... Ah, l'unica cosa che sono riuscito a notare è che se ho tutte le applicazioni chiuse (oppure solo chrome aperto), si spegne normalmente, mentre se ho più applicazioni aperte rimane piantato... Non c'è un modo per togliere la grafica e vedere quello che succede quando si spegne?
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22637
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Ubuntu non si spegne

Messaggio da magozurlinux »

Da terminale dai questo comando:

Codice: Seleziona tutto

sudo gedit /etc/modules
aggiungi in fondo questa riga

apm power_off=1

salva ed esci dall'editor di testo.

Riavvia il pc.
Xubuntu 20.04 LTS amd64 :ciao:
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

Re: Ubuntu non si spegne

Messaggio da apophis »

Perfetto, si pianta su questa riga:

Codice: Seleziona tutto

Checking for running unattended-upgrades: speech-dispatcher disabled; edit /etc/defaulf/speech-dispatcher
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22637
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Ubuntu non si spegne

Messaggio da magozurlinux »

Da terminale postami questo comando:

Codice: Seleziona tutto

cat /etc/default/speech-dispatcher
Xubuntu 20.04 LTS amd64 :ciao:
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

Re: Ubuntu non si spegne

Messaggio da apophis »

Ecco il contenuto del file

Codice: Seleziona tutto

# Defaults for the speech-dispatcher initscript, from speech-dispatcher

# Set to yes to start system wide Speech Dispatcher
RUN=no
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22637
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Ubuntu non si spegne

Messaggio da magozurlinux »

Prova così:

Da terminale dai questo comando:

Codice: Seleziona tutto

sudo gedit /etc/default/speech-dispatcher
modifica il parametro

RUN=no con yes

salva ed esci dall'editor di testo.

Riavvia il pc.
Xubuntu 20.04 LTS amd64 :ciao:
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

Re: Ubuntu non si spegne

Messaggio da apophis »

Niente, continua a piantarsi... Ma che cos'è questo speech-dispatcher?

Edit: l'unico risultato è stato l'audio non funzionante dopo il riavvio...
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: Ubuntu non si spegne

Messaggio da cristian_c »

apophis » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4319445#p4319445]ieri, 19:45[/url] ha scritto:Niente, continua a piantarsi... Ma che cos'è questo speech-dispatcher?

Edit: l'unico risultato è stato l'audio non funzionante dopo il riavvio...
Prova a premere F2 o alt+F2 alla chiusura e posta una foto della schermata :)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

Re: Ubuntu non si spegne

Messaggio da apophis »

Scusate i lunghi tempi per la risposta, ma oggi sono stato tutto il giorno, ho provato mille volte a fare questa cosa, e non sono riuscito, dato che si pianta troppo in fretta e non riesco a premere F2 prima che succeda... ogni cosa che pigio dopo che si è piantato risulta completamente ininfluente... Ma non c'è un modo per disattivare definitivamente lo splash screen?
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: Ubuntu non si spegne

Messaggio da cristian_c »

apophis » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4320479#p4320479]8 minuti fa[/url] ha scritto:Scusate i lunghi tempi per la risposta, ma oggi sono stato tutto il giorno, ho provato mille volte a fare questa cosa, e non sono riuscito, dato che si pianta troppo in fretta e non riesco a premere F2 prima che succeda... ogni cosa che pigio dopo che si è piantato risulta completamente ininfluente... Ma non c'è un modo per disattivare definitivamente lo splash screen?
Prova a leggere qui: http://askubuntu.com/questions/104940/c ... i-shutdown :)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
apophis
Prode Principiante
Messaggi: 28
Iscrizione: lunedì 21 gennaio 2013, 13:34
Desktop: Gnome Shell
Distribuzione: Ubuntu 12.04.1 LTS

Re: Ubuntu non si spegne

Messaggio da apophis »

Ok grazie mille, facendo una ricerca prima, mi sono imbattuto in questo ed in questo post, e sono riuscito a togliere lo splash screen... Comunque appena mi si ripianta, posto una foto dello schermo...

Edit: oggi effettivamente mentre spegnevo mi sono imbattuto in una schermata come postata nel primo topic che ho indicato, ma (stupido me) non ho fatto una foto perchè in precedenza mi ero imbattuto in quel coso dello speech dispatcher, ed ho lasciato perdere... non ho idea di come possa essere successo! comunque sia, il problema (leggendo il secondo post) sembra essere nei driver della scheda video... La mia è una ATI Mobility Radeon 5470, e ho installato i driver da Impostazioni di sistema->Driver aggiuntivi, e adesso ho abilitato gli aggiornamenti dove c'è scritto "post-release", e adesso il driver in uso è 9.0.2 [Sep 20 2012], mentre in precedenza era 8.96.4 [Mar 12 2012]... Se dovesse ripresentarsi il problema comunque vi farò sapere

Reedit: segnalo come risolto, il problema non si è più presentato :)
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Rogerxx00 e 8 ospiti