Problema ubuntu 13.04 : no audio

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
urss94
Prode Principiante
Messaggi: 19
Iscrizione: sabato 5 settembre 2009, 10:26
Desktop: Unity
Distribuzione: Ubuntu Plus 11 Remix 13.04 X64
Località: ragusa

Problema ubuntu 13.04 : no audio

Messaggio da urss94 »

salve a tutti! sul mio toshiba C660/D ho installato ubuntu 13.04 ma mi sono accorto che dopo l'installazione il SO non rileva la scheda audio che utilizza i driver ALSA (Advanced Linux Sound Architecture) ho cercato in ogni modo una soluzione ma senza successo ....

come posso risolvere il prioblema? :ciao: :nono:

Saluti

urss94
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

urss94 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4373726#p4373726][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:salve a tutti! sul mio toshiba C660/D ho installato ubuntu 13.04 ma mi sono accorto che dopo l'installazione il SO non rileva la scheda audio che utilizza i driver ALSA (Advanced Linux Sound Architecture) ho cercato in ogni modo una soluzione ma senza successo ....

come posso risolvere il prioblema? :ciao: :nono:

Saluti

urss94
Apri un terminale e digita:

Codice: Seleziona tutto

lspci -k
copiando il risultato qui all'interno dei tag 'code' ;)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
zato12
Prode Principiante
Messaggi: 16
Iscrizione: sabato 4 maggio 2013, 16:41
Desktop: ubuntu
Distribuzione: ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da zato12 »

ho lo stesso problema
ho appena iniziato ad usare Ubuntu ed è il primo messagggio che scrivo (!)
provo a riportare all'interno di un "tag code" l'output di Terminal

Codice: Seleziona tutto

giuseppe@giuseppe-VPCL11M1E:~$ lspci -k
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
	Subsystem: Sony Corporation Device 9060
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
	Kernel driver in use: pcieport
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: mei
00:19.0 Ethernet controller: Intel Corporation 82567V-2 Gigabit Network Connection
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: e1000e
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: uhci_hcd
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: uhci_hcd
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: uhci_hcd
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
	Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Port 2
	Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: uhci_hcd
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: uhci_hcd
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: uhci_hcd
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: ehci-pci
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIB (ICH10) LPC Interface Controller
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: lpc_ich
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: ata_piix
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
	Subsystem: Sony Corporation Device 9060
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce G210M] (rev a2)
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: nouveau
02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Foxconn International, Inc. Device e007
	Kernel driver in use: ath9k
03:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: sdhci-pci
03:00.1 System peripheral: Ricoh Co Ltd R5U2xx (R5U230 / R5U231 / R5U241) [Memory Stick Host Controller]
	Subsystem: Sony Corporation Device 9060
03:00.3 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 PCIe IEEE 1394 Controller
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: firewire_ohci
03:00.4 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller
	Subsystem: Sony Corporation Device 9060
	Kernel driver in use: sdhci-pci
Saluti
zato12
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

@zato12,
apri un terminale e digita:

Codice: Seleziona tutto

cat /proc/asound/card0/codec* | grep Codec
copiando il risultato qui sempre all'interno dei tag 'code' ;)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
zato12
Prode Principiante
Messaggi: 16
Iscrizione: sabato 4 maggio 2013, 16:41
Desktop: ubuntu
Distribuzione: ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da zato12 »

cristian_c,
ecco quello che ottengo:

Codice: Seleziona tutto

Codec: Realtek ALC889
grazie
zato12
maxdemian77
Prode Principiante
Messaggi: 14
Iscrizione: lunedì 6 maggio 2013, 8:51
Desktop: Unity
Distribuzione: Ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da maxdemian77 »

Anche io ho lo stesso problema, ce l'avevo anche con la 12.10, però con la 12.10 avevo risolto configurando e compilando con ogni nuovo kernel che usciva con i seguenti comandi:

Codice: Seleziona tutto

cd alsa-driver*
sudo ./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)
sudo make
sudo make install
Da quando ho installato la 13.04, ho riprovato con lo stesso metodo ma già il configure mi da problemi:

Codice: Seleziona tutto

checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa/alsa-driver-1.0.25
checking cross compile... 
checking for directory with ALSA kernel sources... /usr/src/alsa/alsa-driver-1.0.25/alsa-kernel
checking for directory with kernel source... /usr/src/linux-headers-3.8.9-030809-generic
checking for directory with kernel build... /usr/src/linux-headers-3.8.9-030809-generic
checking for kernel linux/version.h ... linux/version.h
checking for kernel linux/autoconf.h generated/autoconf.h... generated/autoconf.h
checking for kernel linux/utsrelease.h generated/utsrelease.h... generated/utsrelease.h
checking for kernel version... 3.8.9-030809-generic
checking for GCC version... Kernel compiler:  Used compiler: gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3

*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.

checking for built-in ALSA... no
checking for existing ALSA module... yes
checking for Red Hat kernel... auto
checking for Red Hat kernel... no
checking for SUSE kernel... auto
checking for SUSE kernel... no
checking for updating alsa-kernel version.h... yes
checking for CONFIG_EXPERIMENTAL... yes
checking for directory to store kernel modules... /lib/modules/3.8.9-030809-generic/kernel/sound
checking for verbose procfs... on
checking for verbose printk... on
checking for debug level... none
checking for ISA support in kernel... yes
checking for processor type... i686
checking for ISA DMA API... yes
checking for kernel linux/config.h... no
Creating <linux/config.h>...
checking for deprecated linux/config.h... checking to modify of kernel linux/kmod.h... no
checking for kernel linux/utsrelease.h... no
Creating a dummy <linux/utsrelease.h>...
checking for kernel linux/compiler.h... yes
checking for kernel linux/pm.h... yes
checking for kernel linux/spinlock.h... yes
checking for kernel linux/irq.h... yes
checking for kernel linux/threads.h... yes
checking for kernel linux/rwsem.h... yes
checking for kernel linux/gameport.h... yes
checking for kernel linux/export.h... yes
checking for kernel media/v4l2-dev.h... yes
checking for kernel linux/devfs_fs_kernel.h... no
Creating a dummy <linux/devfs_fs_kernel.h>...
checking for kernel linux/highmem.h... yes
checking for kernel linux/ratelimit.h... yes
checking for kernel linux/workqueue.h... yes
checking for kernel linux/dma-mapping.h... yes
checking for kernel asm/hw_irq.h... yes
checking for kernel linux/device.h... yes
checking for kernel linux/platform_device.h... yes
checking for kernel linux/isa.h... yes
checking for kernel linux/jiffies.h... yes
checking for kernel linux/compat.h... yes
checking for kernel linux/log2.h... yes
checking for kernel linux/adb.h... yes
checking for kernel linux/cuda.h... yes
checking for kernel linux/pmu.h... yes
checking for kernel linux/io.h... yes
checking for kernel linux/moduleparam.h... yes
checking for kernel linux/syscalls.h... yes
checking for kernel linux/firmware.h... yes
checking for kernel linux/err.h... yes
checking for kernel linux/bitmap.h... yes
checking for kernel linux/mutex.h... yes
checking for kernel linux/pm_qos.h... yes
checking for kernel linux/pm_qos_params.h... no
Creating <linux/pm_qos_params.h>...
checking for kernel linux/kthread.h... yes
checking for kernel asm/irq_regs.h... yes
checking for kernel linux/seq_file.h... yes
checking for kernel linux/debugfs.h... yes
checking for kernel linux/gpio.h... yes
checking for kernel linux/bug.h... yes
checking for kernel linux/math64.h... yes
checking for kernel linux/regulator/consumer.h... yes
checking for kernel linux/dmi.h... yes
checking for kernel linux/bitrev.h... yes
checking for kernel linux/hrtimer.h... yes
checking for kernel linux/gcd.h... yes
checking for kernel linux/gfp.h... yes
checking for kernel pcmcia/cs_types.h... no
Creating <pcmcia/cs_types.h>...
checking for kernel pcmcia/cs.h... no
Creating <pcmcia/cs.h>...
checking for kernel linux/lzo.h... yes
checking for kernel linux/async.h... yes
checking for kernel linux/bitrev.h... yes
checking for kernel linux/smp_lock.h... no
Creating a dummy <linux/smp_lock.h>...
checking for kernel linux/i8253.h... yes
checking for kernel linux/atomic.h... yes
Copying trace/events headers
checking for kernel linux/tracepoint.h... yes
checking for kernel trace/define_trace.h... yes
Creating a workaround <linux/tracepoint.h>...
checking for kernel module symbol versions... yes
checking for has ioport support... yes
checking for PCI support in kernel... yes
checking for I2C driver in kernel... yes
checking for I2C_POWERMAC in kernel... unknown
checking for firmware loader... yes
checking for input subsystem in kernel... yes
checking for pc-speaker platform in kernel... yes
checking for SMP... yes
checking for Video device support in kernel... yes
checking for ISA PnP driver in kernel... yes
checking for PnP driver in kernel... yes
checking for Kernel ISA-PnP support... yes
checking for strlcpy... no
checking for snprintf... no
checking for vsnprintf... no
checking for scnprintf... no
checking for sscanf... no
checking for vmalloc_to_page... no
checking for vzalloc... no
checking for old kmod... yes
checking for PDE... no
checking for pci_set_consistent_dma_mask... no
checking for pci_dev_present... no
checking for msleep... no
checking for msecs_to_jiffies... no
checking for tty->count is the atomic type... no
checking for video_drvdata... no
checking for V4L1 layer... no
checking for V4L2 layer... yes
checking for kernel media/v4l2-ctrls.h... yes
checking for io_remap_pfn_range... no
checking for new io_remap_page_range... no
checking for kcalloc... no
checking for kstrdup... no
checking for kstrndup... no
checking for kzalloc... no
checking for create_workqueue with flags... no
checking for pci_ioremap_bar... no
checking for saved_config_space in pci_dev... no
checking for register_sound_special_device... no
checking for driver extra-version... 
checking for driver version... 1.0.25
checking for dynamic minor numbers... no
checking for sequencer support... yes
checking for OSS/Free emulation... yes
checking for OSS PCM plugin system inclusion... yes
checking for RTC support... no
checking for HPET support... yes
checking for Procfs support... yes
checking for USB support... yes
checking for kernel linux/usb/audio-v2.h... yes
checking for kernel linux/usb/audio.h... yes
checking for valid v1 in linux/usb/audio.h... no
Creating <linux/usb/audio.h>...
checking for valid linux/usb/audio-v2.h... no
Creating <linux/usb/audio-v2.h>...
checking for kernel linux/usb/ch9.h... yes
checking usb_alloc_coherent... no
checking for class_simple... no
checking for old driver suspend/resume callbacks... no
checking for removal of page-reservation for nopage/mmap... no
checking for nested class_device... no
checking for new IRQ handler... no
checking for gfp_t... no
checking for GFP_DMA32... no
checking for page_to_pfn... no
checking for PnP suspend/resume... no
checking for device_create_drvdata... no
checking for pm_qos_request... no
checking for static pm_qos_request... no
checking for new unlocked/compat_ioctl... no
checking for builtin _Bool support... yes
checking for x86-compatible PC... no
checking for High-Res timers... yes
checking for kernel PCMCIA
checking for PCMCIA support... yes
checking for PC9800 support in kernel... no
checking for parallel port support... yes
checking for power management... yes
checking for CONFIG_HAS_DMA... yes
checking for FireWire support... yes
checking for cards to compile driver for... hda-intel
checking for additonal options to compile driver for... all
configure: creating ./config.status
config.status: creating version
config.status: creating Makefile.conf
config.status: WARNING:  'Makefile.conf.in' seems to ignore the --datarootdir setting
config.status: creating snddevices
config.status: creating utils/alsa-driver.spec
config.status: creating utils/buildrpm
config.status: creating toplevel.config
config.status: creating utils/alsasound
config.status: creating utils/alsasound.posix
config.status: creating include/pci_ids_compat.h
config.status: creating include/i2c-id_compat.h
config.status: creating include/config.h
config.status: creating include/config1.h
config.status: creating include/version.h
config.status: include/version.h is unchanged
config.status: creating include/autoconf-extra.h
Hacking autoconf.h...
e quando compilo mi dàil seguente risultato:

Codice: Seleziona tutto

cc1: some warnings being treated as errors
make[3]: *** [/usr/src/alsa/alsa-driver-1.0.25/acore/hwdep.o] Errore 1
make[2]: *** [/usr/src/alsa/alsa-driver-1.0.25/acore] Errore 2
make[1]: *** [_module_/usr/src/alsa/alsa-driver-1.0.25] Errore 2
make[1]: uscita dalla directory "/usr/src/linux-headers-3.8.9-030809-generic"
make: *** [compile] Errore 2
Ho provato ad installare il pacchetto linux-source ma niente, ho anche provato con il kernel 8.9, stesso risultato. Ho un Packard bell easy note con codec Realtek alc260. La cosa strana è che il metodo di installare manualmente alsa-driver con 12.10 funzionava mentre con 13.04 non funziona più, spero possiate aiutarmi. Grazie
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

Digita:

Codice: Seleziona tutto

cp /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz $HOME
gzip -d HD-Audio-Models.txt.gz
@maxdemian77,
quale pacchetto di alsa-driver avevi scaricato? :)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
maxdemian77
Prode Principiante
Messaggi: 14
Iscrizione: lunedì 6 maggio 2013, 8:51
Desktop: Unity
Distribuzione: Ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da maxdemian77 »

alsa-driver-1.0.25
zato12
Prode Principiante
Messaggi: 16
Iscrizione: sabato 4 maggio 2013, 16:41
Desktop: ubuntu
Distribuzione: ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da zato12 »

provo ad allegare il file zippato ottenuto

zato12
Allegati
HD-Audio-Models.txt.gz
(3.1 KiB) Scaricato 86 volte
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

Sì, ma da dove l'hai scaricato? :)
provo ad allegare il file zippato ottenuto
Guarda che il secondo comando estrae la cartella :D
Comunque, la tabella dice questo:

Codice: Seleziona tutto

ALC882/883/885/888/889
======================
  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  macmini3	Macmini 3,1
  mba21		Macbook Air 2,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  imac91	iMac 9,1
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m540r	Clevo M540R (6ch + digital)
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT
  auto		auto-config reading BIOS (default)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
zato12
Prode Principiante
Messaggi: 16
Iscrizione: sabato 4 maggio 2013, 16:41
Desktop: ubuntu
Distribuzione: ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da zato12 »

cristian_c,
abbi pazienza, ti avevo premesso che sono completamento nuovo di ubuntu/linux -> vedo che nel testo estratto c'è una riga che può riguardare il mio computer e cioé

Codice: Seleziona tutto

 sony-vaio-tt  Sony VAIO TT
ma non so cosa fare per muovere un passo avanti per risolvere il problema
zato12
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

zato12 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4382847#p4382847][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:cristian_c,
abbi pazienza, ti avevo premesso che sono completamento nuovo di ubuntu/linux -> vedo che nel testo estratto c'è una riga che può riguardare il mio computer e cioé

Codice: Seleziona tutto

 sony-vaio-tt  Sony VAIO TT
ma non so cosa fare per muovere un passo avanti per risolvere il problema
zato12
Apri un terminale e digita:

Codice: Seleziona tutto

aplay -l
Inoltre, posta anche una schermata di alsamixer ;)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
maxdemian77
Prode Principiante
Messaggi: 14
Iscrizione: lunedì 6 maggio 2013, 8:51
Desktop: Unity
Distribuzione: Ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da maxdemian77 »

maxdemian77 Immagine ha scritto:alsa-driver-1.0.25


Sì, ma da dove l'hai scaricato? :)
ho provato sia il pacchetto scaricato dal sito realtek che il pacchetto scaricato da alsa-project.org
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

maxdemian77 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4383095#p4383095][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
maxdemian77 Immagine ha scritto:alsa-driver-1.0.25


Sì, ma da dove l'hai scaricato? :)
ho provato sia il pacchetto scaricato dal sito realtek che il pacchetto scaricato da alsa-project.org
Mi servirebbero link più diretti ai pacchetti scaricati :)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
maxdemian77
Prode Principiante
Messaggi: 14
Iscrizione: lunedì 6 maggio 2013, 8:51
Desktop: Unity
Distribuzione: Ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da maxdemian77 »

maxdemian77 Immagine ha scritto:

maxdemian77 Immagine ha scritto:alsa-driver-1.0.25


Sì, ma da dove l'hai scaricato? :)


ho provato sia il pacchetto scaricato dal sito realtek che il pacchetto scaricato da alsa-project.org


Mi servirebbero link più diretti ai pacchetti scaricati :)
alsa-project
ftp://ftp.alsa-project.org/pub/driver/a ... 25.tar.bz2
realtek
http://www.realtek.com.tw/downloads/dow ... Down=false
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

maxdemian77 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4383161#p4383161][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
maxdemian77 Immagine ha scritto:

maxdemian77 Immagine ha scritto:alsa-driver-1.0.25


Sì, ma da dove l'hai scaricato? :)


ho provato sia il pacchetto scaricato dal sito realtek che il pacchetto scaricato da alsa-project.org


Mi servirebbero link più diretti ai pacchetti scaricati :)
alsa-project
ftp://ftp.alsa-project.org/pub/driver/a ... 25.tar.bz2
realtek
http://www.realtek.com.tw/downloads/dow ... Down=false
Può darsi che il problema sia questo:

Codice: Seleziona tutto

checking for GCC version... Kernel compiler:  Used compiler: gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3

*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
zato12
Prode Principiante
Messaggi: 16
Iscrizione: sabato 4 maggio 2013, 16:41
Desktop: ubuntu
Distribuzione: ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da zato12 »

ecco cosa ottengo con aplay -l:

Codice: Seleziona tutto

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
in alsamixer (schermata) ho selezionato la scheda HDA Intel ma senza alcun risultato
saluti
zato12
maxdemian77
Prode Principiante
Messaggi: 14
Iscrizione: lunedì 6 maggio 2013, 8:51
Desktop: Unity
Distribuzione: Ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da maxdemian77 »

Può darsi che il problema sia questo:

Codice: Seleziona tutto
checking for GCC version... Kernel compiler: Used compiler: gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3

*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.
E quindi che posso fare?
maxdemian77
Prode Principiante
Messaggi: 14
Iscrizione: lunedì 6 maggio 2013, 8:51
Desktop: Unity
Distribuzione: Ubuntu 13.04 i686

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da maxdemian77 »

Codice: Seleziona tutto

cat /proc/version
Linux version 3.8.9-030809-generic (apw@gomeisa) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #201304260102 SMP Fri Apr 26 05:11:37 UTC 2013
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
Messaggi: 23422
Iscrizione: lunedì 29 ottobre 2007, 11:31

Re: [URGENTE] Problema ubuntu 13.04 : no audio

Messaggio da cristian_c »

in alsamixer (schermata) ho selezionato la scheda HDA Intel ma senza alcun risultato
saluti
zato12
Al link non è visibile alcuna schermata :nono:
maxdemian77 ha scritto:
Può darsi che il problema sia questo:

Codice: Seleziona tutto
checking for GCC version... Kernel compiler: Used compiler: gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3

*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.
E quindi che posso fare?
Apri un terminale e digita:

Codice: Seleziona tutto

cat /etc/apt/sources.list && ls /etc/apt/sources.list.d/
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Bing [Bot] e 3 ospiti