[RISOLTO]aggiornamento da 12.04 a 12.10 avvio solo testuale

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Scrivi risposta
Avatar utente
sirrus
Prode Principiante
Messaggi: 82
Iscrizione: lunedì 28 gennaio 2008, 23:59

[RISOLTO]aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da sirrus »

Salve a tutti... oggi Ho provato ad aggiornare alla versione 12.10, dopo aver riavviato il pc ubuntu si avvia solo testualmente, cioè accedo come fosse un terminale e basta... che devo fare per riavere la modalità grafica ¿
Ho sul pc una scheda grafica ASUS EAH3450 se il problema fosse solo di aggiornamento dei driver della scheda grafica come posso aggiornarli dalla riga di comando ¿ grazie a tutti per l'aiuto...
Ultima modifica di sirrus il giovedì 16 maggio 2013, 0:49, modificato 1 volta in totale.
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7796
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10-21.04 (NO UEFI)
Località: Ancona

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da et4beta »

Fosse non hai, come invece viene raccomandato quando si fa un avanzamento di versione, disattivato i driver ed i ppa di terze parti prima di aggiornare la versione di Ubuntu.
Se così fosse, cosa che purtroppo accade spesso, non so darti indicazioni con le quali risolvere con certezza.
Se non riuscissi ad avere suggerimenti validi per procedure alternative, ti consiglio di salvare su altra partizione o su supporto esterno la home e di reinstallare sopra da zero con CD/DVD o pendrive USB.
Inoltre, opinione personale, lascia perdere la 12.10, rimetti la 12.04.2, più stabile e supportata più a lungo, tanto nella 12.10 non ci sono cambiamenti significativi né vantaggi reali.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.
Avatar utente
sirrus
Prode Principiante
Messaggi: 82
Iscrizione: lunedì 28 gennaio 2008, 23:59

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da sirrus »

et4beta [url=http://forum.ubuntu-it.org/viewtopic.php?p=4387490#p4387490][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Fosse non hai, come invece viene raccomandato quando si fa un avanzamento di versione, disattivato i driver ed i ppa di terze parti prima di aggiornare la versione di Ubuntu.
Bhe ma se cosi fosse allora mi vien da pensare che questa disattivazione si possa fare anche testualmente e non solo.graficamente, così da toglierli e aggiornare alla 13.04 ed avere il pc che funziona in modalità grafica cm prima
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7796
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10-21.04 (NO UEFI)
Località: Ancona

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da et4beta »

Il problema non è disattivarli graficamente o da terminale, ma è nel disattivarli PRIMA dell'avanzamento, farlo dopo, cioè dopo che il sistema si è "incasinato", purtroppo non sembra riuscire risolvere.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.
Avatar utente
sirrus
Prode Principiante
Messaggi: 82
Iscrizione: lunedì 28 gennaio 2008, 23:59

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da sirrus »

et4beta [url=http://forum.ubuntu-it.org/viewtopic.php?p=4387873#p4387873][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Il problema non è disattivarli graficamente o da terminale, ma è nel disattivarli PRIMA dell'avanzamento, farlo dopo, cioè dopo che il sistema si è "incasinato", purtroppo non sembra riuscire risolvere.
Ok ma se io lì disattivassi ora e poi avanzassi alla 13.04 non risolverei ¿ non sarebbe là stessa cosa ¿
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22098
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da trekfan1 »

Dipende da come ha effettuato l'avanzamento, se cambiando semplicemente i repo o usando uno dei comandi appositi:

update-manager
do-release-upgrade

negli ultimi due casi i repo di terze parti dovrebbero venire disabilitati automaticamente.

da terminale dopo avere fatto il login dai questi comandi:

Codice: Seleziona tutto

sudo dpkg --configure -a
o

Codice: Seleziona tutto

sudo apt-get update && sudo apt-get dist-upgrade
Avatar utente
sirrus
Prode Principiante
Messaggi: 82
Iscrizione: lunedì 28 gennaio 2008, 23:59

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da sirrus »

Grazie del passaggio... una volta dato il primo comando cosa dovrebbe succedere ¿ io l'avanzamento l'ho fatto tramite il gestore dei pacchetti...

Ho dato anche là seconda coppia di comandi e mi ha aggiornato FireFox e Thunderbird, mi ha scaricato il plugin di flash.... ma non mi è cambiato nulla...

Ho anche rinviato il pc e mi trovo sempre nella versione testuale...

È giusto o dopo quei comandi sarebbe dovuto cambiare qualche cosa ¿

Grazie mille
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22098
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da trekfan1 »

Il primo comando completa la configurazione di eventuali pacchetti non ancora configurati.

I secondi aggiornano il contenuto degli indici e installano eventuale software ancora da installare.

Prova a dare (sempre da terminale):

Codice: Seleziona tutto

sudo apt-get install --reinstall xserver-xorg xserver-xorg-core xserver-xorg-input-all lightdm ubuntu-desktop
una volta completata l'installazione prova a dare

Codice: Seleziona tutto

sudo start lightdm
Avatar utente
sirrus
Prode Principiante
Messaggi: 82
Iscrizione: lunedì 28 gennaio 2008, 23:59

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da sirrus »

Grazie sei un grande si è aperta là parte grafica... domanda ora sarà permanente o quando spengono poi mi ritrovo in testuale e devo poi riavviare lightdm cm Ho fatto ora ¿

Grazie ancora grazie grazie
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22098
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da trekfan1 »

Dovrebbe partire in automatico, prova a riavviare varie volte per vedere se è tutto ok.

PS: piccola curiosità: come mai scrivi il punto interrogativo al contrario?

PPS: Se è tutto OK metti [Risolto] al titolo del primo post cliccando su Modifica
Avatar utente
sirrus
Prode Principiante
Messaggi: 82
Iscrizione: lunedì 28 gennaio 2008, 23:59

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da sirrus »

trekfan1 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4388285#p4388285][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Dovrebbe partire in automatico, prova a riavviare varie volte per vedere se è tutto ok.
fatto ma prima di provare volevo una conferma da te e si riavvia e funziona tutto grazie mille
PS: piccola curiosità: come mai scrivi il punto interrogativo al contrario?
scusa mi dimentico sempre è una cosa che faccio senza pensare quando scrivo con il cellulare... mi diverte e contraddistingue ogni mio messaggio col telefonino il punto di domanda al rovescio e così a forza di farlo anche quando scrivo in posti dove non dovrebbe esserci ce lo metto... ;)
PPS: Se è tutto OK metti [Risolto] al titolo del primo post cliccando su Modifica
certo lo faccio subito aspettavo solo una tua conferma prima di provare a riavviare ed essere sicuro che fosse effettivamente risolto


grazie mille ancora per l'aiuto
jump1973
Prode Principiante
Messaggi: 76
Iscrizione: giovedì 1 dicembre 2011, 23:41

Re: dopo aggiornamento da 12.04 a 12.10 avvio solo testuale

Messaggio da jump1973 »

vorrei riaprire questa discussione in quanto non riesco ad far partire la parte grafica. ho lo schermo in parte testuale....l'ultima riga mi scrive (initramfs)
come dovrei proseguire essendo un ignorante in questi casi?
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22098
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: [RISOLTO]aggiornamento da 12.04 a 12.10 avvio solo test

Messaggio da trekfan1 »

@jump1973 se provi a cercare troverai decine di topic sull'argomento.
jump1973
Prode Principiante
Messaggi: 76
Iscrizione: giovedì 1 dicembre 2011, 23:41

Re: [RISOLTO]aggiornamento da 12.04 a 12.10 avvio solo test

Messaggio da jump1973 »

Scusate ma non ho trovato niente in dettaglio sul mio problema. Chiedo un aiuto dall'inizio possibilmente.
appena accendo il PC si avia in una schermata nera testuale e l'ultima riga scrive (inimtramfs), non mi prende neanche il login, ho provatostartx ma niente, un mio amico mi ha detto di provare di scrivere ps e mi elenca una serie di codici e mi ha detto che non è niente di grave....quindi come mi devo comportare? confido in una risposta.....Grazie
Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: Google [Bot] e 4 ospiti