[Risolto] Rete Ethernet, dispositivo non gestito

Networking, configurazione della connessione, periferiche e condivisioni di rete.
Scrivi risposta
Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

[Risolto] Rete Ethernet, dispositivo non gestito

Messaggio da milazzo87 »

Salve a tutti.

Ho appena installato Ubuntu minimale, l'installatore ha subito riconosciuto la connessione di rete via cavo e l'installazione è andata a buon fine. Dopo aver installato il sistema, dovendo scegliere un DE, ho optato per l'installazione del metapacchetto lubuntu-core. Anche in questo caso tutto bene, a parte un problema che per ora non mi ha creato fastidi, ma che temo me ne creerà in futuro. Vi spiego.

Il sistema è correttamente collegato a internet (ora vi sto scrivendo dal suddetto computer e ho anche installato diversi pacchetti), ma cliccando sull'icona delle connessioni di rete, c'è scritto in grigio (non cliccabile) Rete Internet - dispositivo non gestito.

Ho commentato il file /etc/network/interfaces, come viene suggerito in questo topicsu debianizzati.org, ma il problema non l'ho risolto.

Qualche idea? E soprattutto, credete sia un problema che compromette l'usabilità del computer o posso passarci sopra?

Grazie in anticipo.
Ultima modifica di milazzo87 il lunedì 28 aprile 2014, 12:57, modificato 1 volta in totale.
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]
Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: Rete Ethernet, dispositivo non gestito

Messaggio da milazzo87 »

Nessuno sa come aiutami? Come temevo, la cosa mi ha creato problemi: ho scollegato il cavo, e ricollegandolo non riesco più a collegarmi...
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]
Avatar utente
carved top
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2179
Iscrizione: domenica 27 maggio 2012, 11:38
Desktop: Pantheon
Distribuzione: Elementary 0.4 Loki x86_64

Re: Rete Ethernet, dispositivo non gestito

Messaggio da carved top »

ciao Milazzo, sono capitato qui perchè cercavo lo stesso errore e ho le stesse modalità d'installazione che hai scritto; seguendo il link di debianizzati ho risolto però, tu hai commentato solo "allow-hotplug eth0" oppure anche le due righe di sotto? io ho commentato tutto, riavviato e funziona, ho il nome della rete e posso riconnetterla quando voglio :ciao:

p.s. è possibile che ormai hai cambiato os ma se qualcuno venisse a leggere qui almeno trova qualche spunto:

date il comando:

Codice: Seleziona tutto

sudo nano /etc/network/interfaces
e commentate le righe cosi:

Codice: Seleziona tutto

# The primary network interface
#allow-hotplug eth0
#auto eth0
#iface eth0 inet dhcp
riavviate il pc o trovate il modo di riavviare il demone e verificate che funzioni :ciao:
"It's 106 miles to Chicago, we got a full tank of gas, half a pack of cigarettes, it's dark and we're wearing sunglasses." "Hit it!"
Ubuntu custom | Fractal Design Node 202 | AMD Ryzen 5 1600 & Cryorig C7 | Sapphire Radeon RX 580 Nitro + | Crucial Ballistix Sport 8 GB @ 3000MHz
Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: Rete Ethernet, dispositivo non gestito

Messaggio da milazzo87 »

Avevo dimenticato questa discussione. Il problema si risolve riavviando il demone dopo aver commentato le righe come f te indicato. Grazie. Metto risolto, anche se con un pochino di ritardo.
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]
Avatar utente
ale multimediale
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3681
Iscrizione: mercoledì 14 agosto 2013, 18:24
Desktop: i3-wm
Distribuzione: Arch,Win10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da ale multimediale »

Grandi ragazzi,a me ha fatto lo stesso scherzo su kubuntu 14.04 installato con appunto il cd minimale.Con un eccezzione pero,nm-applet non era manco presente sull pannello,ho dovuto creare uno script e metterlo tra i programmi all'avvio.Pero l'icona non funzionava,aveva una bella X su e non mi dava nessuna connessione attiva nonostante la connessione via lan fungeva.Allora ho commentato il file e ho aggiunto anche questa stringa che mancava

Codice: Seleziona tutto

#allow-hotplug eth0
riavviato e ora va ;) Cosi posso impostare i dns direttamente da li..Non vi dico quanto tempo ci ho perso sopra a cercare la soluzione..Credo che questo theard servirà a molti... :D
"Il progresso è fatto da uomini pigri che cercano modi più facili per fare le cose"
Xubuntu
Avatar utente
carved top
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2179
Iscrizione: domenica 27 maggio 2012, 11:38
Desktop: Pantheon
Distribuzione: Elementary 0.4 Loki x86_64

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da carved top »

quella riga che l'hai aggiunta a fare se poi la commenti? :lol: adesso sono curioso: come si riavvia il demone che non ho trovato il comando? :D
"It's 106 miles to Chicago, we got a full tank of gas, half a pack of cigarettes, it's dark and we're wearing sunglasses." "Hit it!"
Ubuntu custom | Fractal Design Node 202 | AMD Ryzen 5 1600 & Cryorig C7 | Sapphire Radeon RX 580 Nitro + | Crucial Ballistix Sport 8 GB @ 3000MHz
Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da milazzo87 »

Allora, oggi ero da cellulare, quindi per maggiore precisione, la soluzione è questa:

nel file /etc/network/interfaces si devono commentare queste righe:

Codice: Seleziona tutto

# The primary network interface
#allow-hotplug eth0
#auto eth0
#iface eth0 inet dhcp
Poi, riavviare il network manager con

Codice: Seleziona tutto

/etc/init.d/network-manager restart
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]
Avatar utente
carved top
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2179
Iscrizione: domenica 27 maggio 2012, 11:38
Desktop: Pantheon
Distribuzione: Elementary 0.4 Loki x86_64

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da carved top »

ottimo, ottimo, grazie ancora :D :ciao:
"It's 106 miles to Chicago, we got a full tank of gas, half a pack of cigarettes, it's dark and we're wearing sunglasses." "Hit it!"
Ubuntu custom | Fractal Design Node 202 | AMD Ryzen 5 1600 & Cryorig C7 | Sapphire Radeon RX 580 Nitro + | Crucial Ballistix Sport 8 GB @ 3000MHz
Avatar utente
ale multimediale
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3681
Iscrizione: mercoledì 14 agosto 2013, 18:24
Desktop: i3-wm
Distribuzione: Arch,Win10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da ale multimediale »

carved top ha scritto:quella riga che l'hai aggiunta a fare se poi la commenti? :lol: adesso sono curioso: come si riavvia il demone che non ho trovato il comando? :D
Hai ragione,beh gia che c'ero l'ho aggiunta magari un giorno o l'altro mi servirà per qual cosa..Booo..Per il riavvio del demone;riavvia tutto no?!?!!?!? :fiuu: O fa come dice milazzo :D

Ah,tra l'altro dopo il riavvio mi è spuntata l'opzione network manager nel vassoio,che prima non c'era,quindi ho rimosso lo script... ;)
"Il progresso è fatto da uomini pigri che cercano modi più facili per fare le cose"
Xubuntu
Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da milazzo87 »

ale multimediale [url=http://forum.ubuntu-it.org/viewtopic.php?p=4572848#p4572848][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
carved top ha scritto:quella riga che l'hai aggiunta a fare se poi la commenti? :lol: adesso sono curioso: come si riavvia il demone che non ho trovato il comando? :D
Hai ragione,beh gia che c'ero l'ho aggiunta magari un giorno o l'altro mi servirà per qual cosa..Booo..Per il riavvio del demone;riavvia tutto no?!?!!?!? :fiuu: O fa come dice milazzo :D

Ah,tra l'altro dopo il riavvio mi è spuntata l'opzione network manager nel vassoio,che prima non c'era,quindi ho rimosso lo script... ;)
Credo che la procedura descritta funzioni utilizzando Gnome network manager, mentre con KDE i comandi dovrebbero essere diversi (io su KDE sono così ferrato che non so nemmeno che network manager utilizza).
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]
Avatar utente
ale multimediale
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3681
Iscrizione: mercoledì 14 agosto 2013, 18:24
Desktop: i3-wm
Distribuzione: Arch,Win10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da ale multimediale »

Da quello che ho capito Kde usa lo stesso di ubuntu cioe gnome network manager,almeno io avevo quello installato in synaptic di default,pero cliccando sull'icona sul panello la grafica è diversa e anche il programma per impostare la rete ha una grafica diversa..Comunque è sempre gnome network manager..
"Il progresso è fatto da uomini pigri che cercano modi più facili per fare le cose"
Xubuntu
Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da milazzo87 »

Perfetto, allora il procedimento è lo stesso.
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]
Avatar utente
ale multimediale
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3681
Iscrizione: mercoledì 14 agosto 2013, 18:24
Desktop: i3-wm
Distribuzione: Arch,Win10

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da ale multimediale »

E si infatti ora funziona alla grande dopo la modifica del file..;)
"Il progresso è fatto da uomini pigri che cercano modi più facili per fare le cose"
Xubuntu
Avatar utente
jackynet92
Moderatore Globale
Moderatore Globale
Messaggi: 13413
Iscrizione: sabato 3 settembre 2011, 1:41
Desktop: Mate
Distribuzione: Ubuntu 16.04 64bit
Sesso: Maschile
Località: Torino

Re: [RISOLTO] Rete Ethernet, dispositivo non gestito

Messaggio da jackynet92 »

Grazie della soluzione. Provata su lubuntu 12.04 e funziona :birra:
Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 0 ospiti