[risolto] Pacchetti danneggiati non riparabili

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Avatar utente
Sevin
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 361
Iscrizione: martedì 21 ottobre 2008, 12:05
Desktop: XFCE
Distribuzione: Xubuntu 18.04
Sesso: Maschile

[risolto] Pacchetti danneggiati non riparabili

Messaggio da Sevin » martedì 1 maggio 2018, 14:46

Ho installato da poco la 18.04 e oggi, provando a vedere se funzionava lo scanner e quindi installando il relativo driver, mi sono apparsi dei pacchetti danneggiati che ho provato a sistemare

questo è quello che mi risponde il sistema

Codice: Seleziona tutto

mario @ outremer  ~/Scaricati
└─ $ ▶ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libperl5.26:i386
I seguenti pacchetti NUOVI saranno installati:
  libperl5.26:i386
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
34 non completamente installati o rimossi.
È necessario scaricare 0 B/3.155 kB di archivi.
Dopo quest'operazione, verranno occupati 16,3 MB di spazio su disco.
Continuare? [S/n] 
(Lettura del database... 272388 file e directory attualmente installati.)
Preparativi per estrarre .../libperl5.26_5.26.1-6_i386.deb...
Estrazione di libperl5.26:i386 (5.26.1-6)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libperl5.26/changelog.Debian.gz" (condiviso), diverso da altre istanze del pacchetto libperl5.26:i386
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
mario @ outremer  ~/Scaricati
└─ $ ▶ sudo apt --fix-broken install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libperl5.26:i386
I seguenti pacchetti NUOVI saranno installati:
  libperl5.26:i386
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
34 non completamente installati o rimossi.
È necessario scaricare 0 B/3.155 kB di archivi.
Dopo quest'operazione, verranno occupati 16,3 MB di spazio su disco.
Continuare? [S/n] 
(Lettura del database... 272388 file e directory attualmente installati.)
Preparativi per estrarre .../libperl5.26_5.26.1-6_i386.deb...
Estrazione di libperl5.26:i386 (5.26.1-6)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libperl5.26/changelog.Debian.gz" (condiviso), diverso da altre istanze del pacchetto libperl5.26:i386
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
mario @ outremer  ~/Scaricati
└─ $ ▶ 

Ho provato ad eseguire apt clean, poi apt autoclean e apt autoremove e anche a riavviare il sistema ma l'errore rimane e non riesco a risolvere.... :muro: :muro: :muro:

Qualche suggerimento?
Ultima modifica di Sevin il martedì 1 maggio 2018, 15:39, modificato 1 volta in totale.
Mai mangiare la neve gialla!!!

Avatar utente
a323109
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1184
Iscrizione: venerdì 26 luglio 2013, 19:23
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.3 LTS
Sesso: Maschile
Località: Area 51

Re: Pacchetti danneggiati non riparabili

Messaggio da a323109 » martedì 1 maggio 2018, 15:01

Io no facio opraio!
Io no pago afito

Avatar utente
Sevin
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 361
Iscrizione: martedì 21 ottobre 2008, 12:05
Desktop: XFCE
Distribuzione: Xubuntu 18.04
Sesso: Maschile

Re: Pacchetti danneggiati non riparabili

Messaggio da Sevin » martedì 1 maggio 2018, 15:18

non mi fa installare deborphan

Codice: Seleziona tutto

mario @ outremer  ~/Scaricati
└─ $ ▶ sudo apt install deborphan
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libsnmp30:i386 : Dipende: libperl5.26:i386 (>= 5.26.0~rc1) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
mario @ outremer  ~/Scaricati
└─ $ ▶ 
Mai mangiare la neve gialla!!!

Avatar utente
a323109
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1184
Iscrizione: venerdì 26 luglio 2013, 19:23
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.3 LTS
Sesso: Maschile
Località: Area 51

Re: Pacchetti danneggiati non riparabili

Messaggio da a323109 » martedì 1 maggio 2018, 15:28

Codice: Seleziona tutto

mario @ outremer  ~/Scaricati
Sei parecchio incasinato. Ma perchè hai il terminale in /scaricati???
Io no facio opraio!
Io no pago afito

Avatar utente
Sevin
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 361
Iscrizione: martedì 21 ottobre 2008, 12:05
Desktop: XFCE
Distribuzione: Xubuntu 18.04
Sesso: Maschile

Re: Pacchetti danneggiati non riparabili

Messaggio da Sevin » martedì 1 maggio 2018, 15:39

ho aperto il terminale lì perchè stavo vedendo alcuni file scaricati, ma questo non cambia lo stato delle cose.

Ho risolto, comunque, andando in /usr/share/doc/libperl5.26 e cancellando a mano (come amministratore) il file changelog.Debian.gz che era quello che nel messaggio bloccava il sistema.

A questo punto, dando apt install -f ha funzionato senza problemi.

Soluzione probabilmente grezza, ma che ha funzionato :D :D :D
Mai mangiare la neve gialla!!!

mm74
Prode Principiante
Messaggi: 2
Iscrizione: domenica 26 luglio 2009, 16:29

Re: Pacchetti danneggiati non riparabili

Messaggio da mm74 » domenica 27 maggio 2018, 15:08

Sevin [url=https://forum.ubuntu-it.org/viewtopic.php?p=5056574#p5056574][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:ho aperto il terminale lì perchè stavo vedendo alcuni file scaricati, ma questo non cambia lo stato delle cose.

Ho risolto, comunque, andando in /usr/share/doc/libperl5.26 e cancellando a mano (come amministratore) il file changelog.Debian.gz che era quello che nel messaggio bloccava il sistema.

A questo punto, dando apt install -f ha funzionato senza problemi.

Soluzione probabilmente grezza, ma che ha funzionato :D :D :D


Ciao anche io ho il stesso problema scusami come hai fatto a cancellare quel pacchetto a me non lo permette grazie

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 15591
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian sid

Re: [risolto] Pacchetti danneggiati non riparabili

Messaggio da caturen » domenica 27 maggio 2018, 18:18

Ciao anche io ho il stesso problema scusami come hai fatto a cancellare quel pacchetto a me non lo permette grazie
devi dare il comando da sudo

Avatar utente
MisterEma79
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 892
Iscrizione: lunedì 22 settembre 2008, 9:53
Località: Savona - Italy

Re: [risolto] Pacchetti danneggiati non riparabili

Messaggio da MisterEma79 » giovedì 14 giugno 2018, 22:28

mi potresti spiegare i passaggi bene, grazie

Avatar utente
Sevin
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 361
Iscrizione: martedì 21 ottobre 2008, 12:05
Desktop: XFCE
Distribuzione: Xubuntu 18.04
Sesso: Maschile

Re: [risolto] Pacchetti danneggiati non riparabili

Messaggio da Sevin » giovedì 14 giugno 2018, 22:35

da terminale

Codice: Seleziona tutto

sudo rm /usr/share/doc/libperl5.26/changelog.Debian.gz
Mai mangiare la neve gialla!!!

Scrivi risposta

Torna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: MSN [Bot], Nocchy e 10 ospiti