Dipendenze non soddisfatte (Linux Mint)

Informazioni, consigli e novità sulla galassia delle distribuzioni GNU/Linux, *nix, *BSD e su altri sistemi operativi non liberi.

Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » martedì 28 agosto 2018, 22:44

Ciao a tutti/e, credo di aver fatto un pasticcio coi kernel tentando di rimuovere le installazioni vecchie. Ora:

Codice: Seleziona tutto
xhino@1312 ~ $ sudo apt install -f
[sudo] password di xhino:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
The following additional packages will be installed:
  linux-image-4.15.0-33-generic linux-modules-4.15.0-33-generic
Pacchetti suggeriti:
  fdutils linux-hwe-tools
I seguenti pacchetti NUOVI saranno installati:
  linux-image-4.15.0-33-generic linux-modules-4.15.0-33-generic
0 aggiornati, 2 installati, 0 da rimuovere e 31 non aggiornati.
2 non completamente installati o rimossi.
È necessario scaricare 0 B/20,9 MB di archivi.
Dopo quest'operazione, verranno occupati 74,4 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 625954 file e directory attualmente installati.)
Preparativi per estrarre .../linux-modules-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb...
Estrazione di linux-modules-4.15.0-33-generic (4.15.0-33.36~16.04.1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/linux-modules-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb (--unpack):
 impossibile copiare i dati estratti per "./boot/System.map-4.15.0-33-generic" in "/boot/System.map-4.15.0-33-generic.dpkg-new": scrittura non riuscita (Spazio esaurito sul device)
Segnalazione apport non scritta poiché il messaggio di errore indica un errore per disco pieno.
               dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Preparativi per estrarre .../linux-image-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb...
Estrazione di linux-image-4.15.0-33-generic (4.15.0-33.36~16.04.1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/linux-image-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb (--unpack):
 impossibile copiare i dati estratti per "./boot/vmlinuz-4.15.0-33-generic" in "/boot/vmlinuz-4.15.0-33-generic.dpkg-new": scrittura non riuscita (Spazio esaurito sul device)
Segnalazione apport non scritta poiché il messaggio di errore indica un errore per disco pieno.
               dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/linux-modules-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb
 /var/cache/apt/archives/linux-image-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
xhino@1312 ~ $ dpkg -l | grep linux-image
ii  linux-image-4.10.0-38-generic                               4.10.0-38.42~16.04.1                                    amd64        Linux kernel image for version 4.10.0 on 64 bit x86 SMP
ii  linux-image-4.13.0-43-generic                               4.13.0-43.48~16.04.1                                    amd64        Linux kernel image for version 4.13.0 on 64 bit x86 SMP
ii  linux-image-4.13.0-45-generic                               4.13.0-45.50~16.04.1                                    amd64        Linux kernel image for version 4.13.0 on 64 bit x86 SMP
ii  linux-image-4.15.0-24-generic                               4.15.0-24.26~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-4.15.0-29-generic                               4.15.0-29.31~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-4.15.0-30-generic                               4.15.0-30.32~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-4.15.0-32-generic                               4.15.0-32.35~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-extra-4.10.0-38-generic                         4.10.0-38.42~16.04.1                                    amd64        Linux kernel extra modules for version 4.10.0 on 64 bit x86 SMP
ii  linux-image-extra-4.13.0-43-generic                         4.13.0-43.48~16.04.1                                    amd64        Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP
ii  linux-image-extra-4.13.0-45-generic                         4.13.0-45.50~16.04.1                                    amd64        Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP


Non riesco a installare più nulla. Ho cercato nel forum soluzioni ma nulla. Mi scuso in anticipo se questo esatto problema sia stato già risolto.
Ultima modifica di trekfan1 il mercoledì 29 agosto 2018, 8:38, modificato 1 volta in totale.
Motivazione: Sistemato il titolo
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit

Re: Dipendenze non soddisfatte (Linuz Mint)

Messaggioda giulux » mercoledì 29 agosto 2018, 5:11

Sposto in altre distribuzioni.

Per il tuo problema prova
Codice: Seleziona tutto
 sudo apt autoremove
per eliminare i vecchi kernel.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 21448
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 17.10
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Dipendenze non soddisfatte (Linuz Mint)

Messaggioda DoctorStrange » mercoledì 29 agosto 2018, 8:24

Se leggi bene dice il motivo dell'errore:
Codice: Seleziona tutto
Segnalazione apport non scritta poiché il messaggio di errore indica un errore per disco pieno.
, dunque la domanda sorge spontanea: visto che si parla di kernel, quanto spazio ti è rimasto nella partizione /boot ?
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1217
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda -eternauta- » giovedì 30 agosto 2018, 18:34

Melu Immagine ha scritto:Ciao a tutti/e, credo di aver fatto un pasticcio coi kernel tentando di rimuovere le installazioni vecchie. Ora:

Codice: Seleziona tutto
xhino@1312 ~ $ sudo apt install -f
[sudo] password di xhino:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
The following additional packages will be installed:
  linux-image-4.15.0-33-generic linux-modules-4.15.0-33-generic
Pacchetti suggeriti:
  fdutils linux-hwe-tools
I seguenti pacchetti NUOVI saranno installati:
  linux-image-4.15.0-33-generic linux-modules-4.15.0-33-generic
0 aggiornati, 2 installati, 0 da rimuovere e 31 non aggiornati.
2 non completamente installati o rimossi.
È necessario scaricare 0 B/20,9 MB di archivi.
Dopo quest'operazione, verranno occupati 74,4 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 625954 file e directory attualmente installati.)
Preparativi per estrarre .../linux-modules-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb...
Estrazione di linux-modules-4.15.0-33-generic (4.15.0-33.36~16.04.1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/linux-modules-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb (--unpack):
 impossibile copiare i dati estratti per "./boot/System.map-4.15.0-33-generic" in "/boot/System.map-4.15.0-33-generic.dpkg-new": scrittura non riuscita (Spazio esaurito sul device)
Segnalazione apport non scritta poiché il messaggio di errore indica un errore per disco pieno.
               dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Preparativi per estrarre .../linux-image-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb...
Estrazione di linux-image-4.15.0-33-generic (4.15.0-33.36~16.04.1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/linux-image-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb (--unpack):
 impossibile copiare i dati estratti per "./boot/vmlinuz-4.15.0-33-generic" in "/boot/vmlinuz-4.15.0-33-generic.dpkg-new": scrittura non riuscita (Spazio esaurito sul device)
Segnalazione apport non scritta poiché il messaggio di errore indica un errore per disco pieno.
               dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/linux-modules-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb
 /var/cache/apt/archives/linux-image-4.15.0-33-generic_4.15.0-33.36~16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
xhino@1312 ~ $ dpkg -l | grep linux-image
ii  linux-image-4.10.0-38-generic                               4.10.0-38.42~16.04.1                                    amd64        Linux kernel image for version 4.10.0 on 64 bit x86 SMP
ii  linux-image-4.13.0-43-generic                               4.13.0-43.48~16.04.1                                    amd64        Linux kernel image for version 4.13.0 on 64 bit x86 SMP
ii  linux-image-4.13.0-45-generic                               4.13.0-45.50~16.04.1                                    amd64        Linux kernel image for version 4.13.0 on 64 bit x86 SMP
ii  linux-image-4.15.0-24-generic                               4.15.0-24.26~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-4.15.0-29-generic                               4.15.0-29.31~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-4.15.0-30-generic                               4.15.0-30.32~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-4.15.0-32-generic                               4.15.0-32.35~16.04.1                                    amd64        Signed kernel image generic
ii  linux-image-extra-4.10.0-38-generic                         4.10.0-38.42~16.04.1                                    amd64        Linux kernel extra modules for version 4.10.0 on 64 bit x86 SMP
ii  linux-image-extra-4.13.0-43-generic                         4.13.0-43.48~16.04.1                                    amd64        Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP
ii  linux-image-extra-4.13.0-45-generic                         4.13.0-45.50~16.04.1                                    amd64        Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP


Non riesco a installare più nulla. Ho cercato nel forum soluzioni ma nulla. Mi scuso in anticipo se questo esatto problema sia stato già risolto.

Uno alla volta dai questi comandi in un terminale.
Codice: Seleziona tutto
sudo apt autoremove

Codice: Seleziona tutto
sudo apt autoclean

Codice: Seleziona tutto
sudo apt update && sudo apt full-upgrade

:ciao:
A questo mondo niente rimane uguale, la notte più lunga eterna non è. (Bertolt Brecht)
Avatar utente
-eternauta-
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1559
Iscrizione: maggio 2007
Località: Auronzo di Cadore (BL)
Desktop: Cinnamon
Distribuzione: Mint 19 Tara 64bit
Sesso: Maschile

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » domenica 2 settembre 2018, 15:09

-eternauta- Immagine ha scritto:Uno alla volta dai questi comandi in un terminale.
Codice: Seleziona tutto
sudo apt autoremove

Codice: Seleziona tutto
sudo apt autoclean

Codice: Seleziona tutto
sudo apt update && sudo apt full-upgrade

:ciao:


Ecco cosa mi appare:
Codice: Seleziona tutto
xhino@1312 ~ $ sudo apt autoremove
[sudo] password di xhino:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 linux-modules-extra-4.15.0-33-generic : Dipende: linux-image-4.15.0-33-generic ma non è installato oppure
                                                  linux-image-unsigned-4.15.0-33-generic ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.
xhino@1312 ~ $ sudo apt autoclean
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Del libpoppler58 0.41.0-0ubuntu1.7 [758 kB]
Del poppler-utils 0.41.0-0ubuntu1.7 [130 kB]
Del libpoppler-glib8 0.41.0-0ubuntu1.7 [104 kB]
Del papirus-icon-theme 20180826-2565+pkg18~ubuntu16.04.1 [9 743 kB]
xhino@1312 ~ $ sudo apt update && sudo apt full-upgrade
Ign:1 http://ftp.acc.umu.se/mirror/linuxmint.com/packages sylvia InRelease
Trovato:2 http://ftp.acc.umu.se/ubuntu xenial InRelease                       
Trovato:3 http://ppa.launchpad.net/moka/daily/ubuntu xenial InRelease         
Trovato:4 http://security.ubuntu.com/ubuntu xenial-security InRelease         
Scaricamento di:5 http://ftp.acc.umu.se/ubuntu xenial-updates InRelease [109 kB]
Trovato:6 http://ppa.launchpad.net/numix/ppa/ubuntu xenial InRelease           
Trovato:7 http://ftp.acc.umu.se/ubuntu xenial-backports InRelease             
Trovato:8 http://archive.canonical.com/ubuntu xenial InRelease                 
Trovato:9 http://ftp.acc.umu.se/mirror/linuxmint.com/packages sylvia Release   
Ign:10 http://packages.linuxmint.com sylvia InRelease                         
Scaricamento di:11 http://ppa.launchpad.net/papirus/papirus/ubuntu xenial InRelease [18,0 kB]
Trovato:12 http://packages.linuxmint.com sylvia Release                       
Trovato:13 http://ppa.launchpad.net/tails-team/tails-installer/ubuntu xenial InRelease
Scaricamento di:14 http://ftp.acc.umu.se/ubuntu xenial-updates/universe amd64 Packages [681 kB]
Scaricamento di:16 http://ftp.acc.umu.se/ubuntu xenial-updates/universe i386 Packages [623 kB]
Scaricamento di:18 http://ppa.launchpad.net/papirus/papirus/ubuntu xenial/main Sources [3 596 B]
Scaricamento di:19 http://ppa.launchpad.net/papirus/papirus/ubuntu xenial/main amd64 Packages [3 280 B]
Scaricamento di:20 http://ppa.launchpad.net/papirus/papirus/ubuntu xenial/main i386 Packages [3 284 B]
Recuperati 1 441 kB in 2s (606 kB/s)     
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
40 pacchetti possono essere aggiornati: eseguire "apt list --upgradable" per vederli.
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 linux-modules-extra-4.15.0-33-generic : Dipende: linux-image-4.15.0-33-generic ma non è installato oppure
                                                  linux-image-unsigned-4.15.0-33-generic ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda pachisapiu » domenica 2 settembre 2018, 16:26

posta
Codice: Seleziona tutto
df -h
Carbonara is my law - Chi ?
Curriculum - OffTopic
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1669
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » martedì 4 settembre 2018, 17:35

pachisapiu Immagine ha scritto:posta
Codice: Seleziona tutto
df -h


Codice: Seleziona tutto
xhino@1312 ~ $ df -h
File system                Dim. Usati Dispon. Uso% Montato su
udev                       2,9G     0    2,9G   0% /dev
tmpfs                      587M  8,7M    578M   2% /run
/dev/mapper/mint--vg-root  452G  276G    153G  65% /
tmpfs                      2,9G   58M    2,9G   2% /dev/shm
tmpfs                      5,0M  4,0K    5,0M   1% /run/lock
tmpfs                      2,9G     0    2,9G   0% /sys/fs/cgroup
/dev/sda2                  473M  472M       0 100% /boot
/dev/sda1                  511M  3,5M    508M   1% /boot/efi
cgmfs                      100K     0    100K   0% /run/cgmanager/fs
tmpfs                      587M   28K    587M   1% /run/user/1000


Ho provato ad installare un pacchetto, ecco cosa mi dice: "I seguenti pacchetti presentano dipendenze non soddisfatte:
linux-modules-extra-4.15.0-33-generic: Depends: linux-image-unsigned-4.15.0-33-generic ma non è installato"
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda pachisapiu » martedì 4 settembre 2018, 17:46

hai la partizione di /boot piena devi riuscire a rimuovere qualche kernel vecchio , posta
Codice: Seleziona tutto
dpkg -l | grep linux-image
Carbonara is my law - Chi ?
Curriculum - OffTopic
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1669
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » martedì 4 settembre 2018, 17:55

pachisapiu Immagine ha scritto:hai la partizione di /boot piena devi riuscire a rimuovere qualche kernel vecchio , posta


dpkg -l | grep linux-image
ii linux-image-4.10.0-38-generic 4.10.0-38.42~16.04.1 amd64 Linux kernel image for version 4.10.0 on 64 bit x86 SMP
ii linux-image-4.13.0-43-generic 4.13.0-43.48~16.04.1 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP
ii linux-image-4.13.0-45-generic 4.13.0-45.50~16.04.1 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP
ii linux-image-4.15.0-24-generic 4.15.0-24.26~16.04.1 amd64 Signed kernel image generic
ii linux-image-4.15.0-29-generic 4.15.0-29.31~16.04.1 amd64 Signed kernel image generic
ii linux-image-4.15.0-30-generic 4.15.0-30.32~16.04.1 amd64 Signed kernel image generic
ii linux-image-4.15.0-32-generic 4.15.0-32.35~16.04.1 amd64 Signed kernel image generic
ii linux-image-extra-4.10.0-38-generic 4.10.0-38.42~16.04.1 amd64 Linux kernel extra modules for version 4.10.0 on 64 bit x86 SMP
ii linux-image-extra-4.13.0-43-generic 4.13.0-43.48~16.04.1 amd64 Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP
ii linux-image-extra-4.13.0-45-generic 4.13.0-45.50~16.04.1 amd64 Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » martedì 4 settembre 2018, 18:00

Se questo può esserti d'aiuto: (immagine allegata)

È un problema che ho il pc criptato?
Allegati
Schermata del 2018-09-04 18-53-37.png
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda caturen » martedì 4 settembre 2018, 18:23

Codice: Seleziona tutto
    sudo dpkg --remove --force-remove-reinstreq   linux-image-4.10.0-38-generic    linux-image-4.13.0-43-generic inux-image-4.13.0-45-generic    linux-image-4.15.0-24
e vedi come si comporta
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14361
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » martedì 4 settembre 2018, 20:27

caturen Immagine ha scritto:
Codice: Seleziona tutto
    sudo dpkg --remove --force-remove-reinstreq   linux-image-4.10.0-38-generic    linux-image-4.13.0-43-generic inux-image-4.13.0-45-generic    linux-image-4.15.0-24
e vedi come si comporta

Codice: Seleziona tutto
dpkg: problemi con le dipendenze impediscono la rimozione di linux-image-4.10.0-38-generic:
 linux-image-extra-4.10.0-38-generic dipende da linux-image-4.10.0-38-generic.
 linux-kernel-generic dipende da linux-image-4.10.0-38-generic.

dpkg: errore nell'elaborare il pacchetto linux-image-4.10.0-38-generic (--remove):
 problemi con le dipendenze - rimozione non possibile
dpkg: problemi con le dipendenze impediscono la rimozione di linux-image-4.13.0-43-generic:
 linux-image-extra-4.13.0-43-generic dipende da linux-image-4.13.0-43-generic.

dpkg: errore nell'elaborare il pacchetto linux-image-4.13.0-43-generic (--remove):
 problemi con le dipendenze - rimozione non possibile
dpkg: attenzione: viene ignorata la richiesta di rimuovere inux-image-4.13.0-45-generic poiché non è installato
dpkg: attenzione: viene ignorata la richiesta di rimuovere linux-image-4.15.0-24 poiché non è installato
Si sono verificati degli errori nell'elaborazione:
 linux-image-4.10.0-38-generic
 linux-image-4.13.0-43-generic
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda caturen » martedì 4 settembre 2018, 21:01

Codice: Seleziona tutto
 sudo dpkg --remove --force-remove-reinstreq linux-image-extra-4.10.0-38-generic  linux-image-4.10.0-38-generic
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14361
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Dipendenze non soddisfatte (Linux Mint)

Messaggioda Melu » giovedì 6 settembre 2018, 11:45

caturen Immagine ha scritto:
Codice: Seleziona tutto
 sudo dpkg --remove --force-remove-reinstreq linux-image-extra-4.10.0-38-generic  linux-image-4.10.0-38-generic

Codice: Seleziona tutto
dpkg: problemi con le dipendenze impediscono la rimozione di linux-image-extra-4.10.0-38-generic:
 linux-kernel-generic dipende da linux-image-extra-4.10.0-38-generic.

dpkg: errore nell'elaborare il pacchetto linux-image-extra-4.10.0-38-generic (--remove):
 problemi con le dipendenze - rimozione non possibile
dpkg: problemi con le dipendenze impediscono la rimozione di linux-image-4.10.0-38-generic:
 linux-image-extra-4.10.0-38-generic dipende da linux-image-4.10.0-38-generic.
 linux-kernel-generic dipende da linux-image-4.10.0-38-generic.

dpkg: errore nell'elaborare il pacchetto linux-image-4.10.0-38-generic (--remove):
 problemi con le dipendenze - rimozione non possibile
Si sono verificati degli errori nell'elaborazione:
 linux-image-extra-4.10.0-38-generic
 linux-image-4.10.0-38-generic
Toinen Puheenjohtaja
Uudeenmaan Autonominen Maakunta
Medordförande
Nylands Autonom Landskap
Avatar utente
Melu
Prode Principiante
 
Messaggi: 3
Iscrizione: marzo 2016
Località: Helsinki
Distribuzione: Linux Mint 18.33 Cinnamon 64-bit


Torna a Altre distribuzioni e sistemi operativi

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite