[Risolto]Installazione Ubuntu con shimx64 non riuscita

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » giovedì 13 settembre 2018, 13:52

Grub è installato... ma non parte! Parte sempre e solo Windows 10! Ho provato anche con Boot repair e niente! Finchè non posso aggiungere shimx64 come affidabile non posso fare nulla.
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » sabato 15 settembre 2018, 18:47

Up
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 10:46

Questo è ciò che vede GParted in live:
Allegati
Schermata del 2018-09-16 08-44-00.png
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda maxbigsi » domenica 16 settembre 2018, 13:23

ciao Megatux :ciao: qui l'esperto è Gerry Ghetto :sisi: alcuni giorni fa ho voluto fare una prova su macchina virtuale installando win10 e ubuntu in UEFI ma dopo il primo avvio che vedevo grub dopo partiva solo ed esclusivamente win10 :muro: ... alla fine mi sono arreso :D meno male che il mio hard disk fisico non ha mai visto windows in vita sua :lol:
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16296
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 16.04 64bit
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda willy54 » domenica 16 settembre 2018, 13:56

Alcune domande per cominciare, io ho fatto parecchie installazioni Uefi mode sui più computer diverse distribuzioni tutte ubuntu derivate è non ho mai dovuto aggiungere niente manualmente in nessun posto. Qusto premesso, ho sempre creato le live con Rufus , utilizzando l'ultima versione disponibile la 3.02 devi selezionare Schema partizionamento = Gpt per Uefi ----> tipo destinazione = Uefi non Csm -----> tpo formattazione = Fat32 selezioni la iso da inserire , bada bene di verificare che la iso non sia corrotta con Md5Sum , gli unici problemi avuti derivati da iso corrotte.
Avvii la generazione Usb appare un messaggio devi selezionare il proposto .
A questo punto in vindows disattivi Avvio Veloce , se hai la versione professional è necessario se attivo anche disabilitare bitlocker, usa l'ultima opzione per installare Altro selezioni le partizioni per ./ e per ./home se hai la home separata, per il bootloader dovrebbe segnalarti il nome della partizione Uefi , spesso sui preistallati si chiama - Windows Boot Loader - ed installi normalmente , selezionando come avvio quello che nel nome ha compreso la dicitura < .... Usb....Partition1 >
Hai già installato l'ultimo firmware ma questo è utile solo per il miglior riconoscimento delle periferiche se non sono quelle di serie con cui il pc è nato.
Questa è la procedura che ho sempre utilizzato io , e l'unico problema è stato con una iso Ubuntu-Mate in quanto non verificata prima, era corrotta.
Il fatto che parta solo windows è quasi sicuramente dovuto o ad Avvio Veloce attivo o hai messo il grub in partizioni errate ( prob. Sda) .
Una prova che puoi fare è attivare nel bios la compatibilità Csm/Legacy e vedere se vedi il grub . Se lo vedi hai fatto una installazione ibrida in legacy/Csm mode. Oppure la tua distribuzione non supporta la installazione Uefi mode.
:ot: Uno dei gravi problemi sono guide oltremodo datate e non più attuali con le moderne distribuzioni, su ogni guida dovrebbe essere presente la data di edizione e la data di ultima revisione per verificare immediatamente se sono applicabili. / :ot:
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1997
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda giulux » domenica 16 settembre 2018, 14:32

Ciao Mega, io di efi non so niente però, stimolato dal tuo problema, ho dato un'occhiata il giro trovando questo su Chiedi, da cui mi pare di capire che:
- shim64 va usato quando si vuole mantenere il secure boot, mentre tu lo hai disabilitato
- le indicazioni che vengono da bootrepair in tal caso sembrerebbero sbagliate.

Vedi un po' tu, in attesa che arrivi Gerry Ghetto, se quei suggerimenti ti aiutano a risolvere.
:ciao:
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 21887
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.1 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda willy54 » domenica 16 settembre 2018, 14:39

Ho fatto moltissime installazioni di Ubuntu derivate in uefi mode senza mai preoccuparmi del Secure Boot gli SO quali Ubuntu e derivate hanno attualmente la firma digitale che scavalca il Secure Boot , che sia attivo o meno non pregiudica la corretta installazione se il supporto di installazione è fatto a dovere e se viene selezionato il device giusto per l'installazio ( No ! Usb disck , ma ....Usb.... partition1 ) e la partizione giusta per installare il bootloader-Uefi. L'unica che ha il flag boot/esp, ma questo è citato in pochissime guide.
Molte installazioni falliscono anche da dvd se scritte su dvd RW in quanto il filesystem di un disco RW è Raw mentre per una installazione Uefi è necessario che il filesystem del disco sià ISO 9660
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1997
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 15:34

Allora... forse non sono stato chiaro... la chiavetta l'ho fatta in Uefi e partizionamento gpt tramite Rufus, ho anche disabilitato il Secure boot e l'avvio veloce... ho fatto così tante prove che mi sta venendo l'esaurimento nervoso.... continua inesorabilmente a partire sempre e solo Windows 10 qualsiasi cosa io faccia o modifichi.
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 15:52

Grub va installato sempre in sda, anche in sistema UEFI?
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 16:15

giulux Immagine ha scritto:Ciao Mega, io di efi non so niente però, stimolato dal tuo problema, ho dato un'occhiata il giro trovando questo su Chiedi, da cui mi pare di capire che:
- shim64 va usato quando si vuole mantenere il secure boot, mentre tu lo hai disabilitato
- le indicazioni che vengono da bootrepair in tal caso sembrerebbero sbagliate.

Vedi un po' tu, in attesa che arrivi Gerry Ghetto, se quei suggerimenti ti aiutano a risolvere.
:ciao:

Ho appena provato a eseguire questo suggerimento... niente, anche dando entrambi i comandi su Windows, si avvia sempre e solo Windows 10, anche perchè il prompt mi restituisce il risultato che i comandi sono sconosciuti. Adesso prendo il pc e lo lancio di sotto. Mi sono rotto!
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda maxbigsi » domenica 16 settembre 2018, 16:45

a questo punto non devi disabilitare il secure boot leggendo quanto detto da willy54 ;)

Megatux ha scritto:Grub va installato sempre in sda, anche in sistema UEFI?


no :nono:
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16296
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 16.04 64bit
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda wilecoyote » domenica 16 settembre 2018, 16:54

:) Salve, leggo che hai già provato con Boot-Repair, però talvolta ci vuole qualcosa di più «forte».

Prova con SuperGrubDisk, qui la sua wiki AmministrazioneSistema/SuperGrubDisk.

Mi raccomando, come specifica la wiki, d'usare l'ultima versione che supporta UEFI.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 8526
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 17:16

maxbigsi ha scritto:a questo punto non devi disabilitare il secure boot leggendo quanto detto da willy54
Anche disabilitando il Secure boot il risultato non cambia. :muro:
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda willy54 » domenica 16 settembre 2018, 17:16

No grub non va installato in sda ma nella partizione che ha il flag boot,esp , solitamente è sda2 con win10 se non hai altri so win installati , ma l'installer ubuntu-Uefi dovrebbe già proporre: Windows Boot Manager
Boot Repair e Supergrub disk non hanno effetto sulle installazioni uefi .
Nel precedente post ti avevo chiesto di fare una prova, abilitare nel bios Csm/Legacy per vedere se il grub avviava entrambi e vedere se l'installazione era ibrida.
Ultima modifica di willy54 il domenica 16 settembre 2018, 17:20, modificato 1 volta in totale.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1997
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 17:17

Megatux Immagine ha scritto:
maxbigsi ha scritto:a questo punto non devi disabilitare il secure boot leggendo quanto detto da willy54
Anche disabilitando il Secure boot il risultato non cambia. :muro:

maxbigsi ha scritto:no
E dove va messo, allora? Nei portatili ho installato tranquillamente in sda, e funziona il dual boot.
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 17:18

willy54 Immagine ha scritto:No grub non va installato in sda ma nella partizione che ha il flag boot,esp , solitamente è sda2 con win10 se non hai altri so win installati , ma l'installer ubuntu-Uefi dovrebbe già proporre: Windows Boot Manager
Ho provato anche installando in sda2... parte sempre e soltanto Windows 10!
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda wilecoyote » domenica 16 settembre 2018, 17:26

:) Salve, @willy54 aggiornati, SuperGrubDisk ora supporta e lavora anche su UEFI.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 8526
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda willy54 » domenica 16 settembre 2018, 17:35

Hai verificato la iso che non sia corrotta con Md5sum ?
Quando avvii la live appare un menu con Try Ubuntu without installing oppure ti parte la schermata grafica con le lingue sulla dx ed le due scelte Prova ed Installa ?
Prova ad attivare Csm/Legacy nel bios vedi cosa succede.
Di windows versione Home o professional ? Se professional va disattivato in windows il bitlocker se attivo.
Rispondi chiaramente alle domande

Hai ragione la mia versione ha ormai 4-5 anni.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1997
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Megatux » domenica 16 settembre 2018, 19:14

willy54 Immagine ha scritto:Hai verificato la iso che non sia corrotta con Md5sum ?
Quando avvii la live appare un menu con Try Ubuntu without installing oppure ti parte la schermata grafica con le lingue sulla dx ed le due scelte Prova ed Installa ?
Prova ad attivare Csm/Legacy nel bios vedi cosa succede.
Di windows versione Home o professional ? Se professional va disattivato in windows il bitlocker se attivo.
Rispondi chiaramente alle domande

Hai ragione la mia versione ha ormai 4-5 anni.

Md5sum non è più installabile nè scaricabile, il sito risulta irraggiungibile e non mi permette di scaricarlo.
Ho installato Ubuntu in Uefi, e vedo la schermata con "Try Ubuntu without installing", quella grigia e non viola, quindi è giusta.
Non ho ancora provato ad attivare Csm legacy, ma se lo attivo, non partirà Windows, che è installato in Uefi.
Windows è in versione home.
Il mondo sarebbe migliore con Gnu/Linux Ubuntu!
Avatar utente
Megatux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11791
Iscrizione: settembre 2009
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS x86_64
Sesso: Maschile

Re: Installazione Ubuntu con shimx64 non riuscita

Messaggioda Toshio » domenica 16 settembre 2018, 20:10

Ciao Megatux
ti stanno già aiutando altri e non vorrei aggiungere confusione. Una domanda veloce: dopo l'installazione di win andata a buon fine e dopo l'installazione di ubuntu andata a buon fine, sei andato nel bios ad impostare la priorità di avvio? C'è la possibilità nel tuo bios di impostarla? Ovviamente devi mettere per primo Ubuntu perchè se come primo c'è Window il grub naturalmente non si vedrà mai.
Toshio
Prode Principiante
 
Messaggi: 151
Iscrizione: aprile 2014

PrecedenteSuccessiva

Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: LinoPersona e 7 ospiti