Riavvio non corretto secondo hard disk

Riconoscimento, installazione e configurazione delle periferiche.

Riavvio non corretto secondo hard disk

Messaggioda alukard990 » venerdì 7 dicembre 2018, 17:36

Salve a tutti, ho montato un ssd sul mio portatile asus per ravvivarlo un po' e spostato l'hdd al posto del lettore dvd, che ormai è obsoleto, in modo da tenerlo come storage dati. Ho notato che da lubuntu 16.04 se provo a riavviare il pc il disco emette il classico rumore dello spegnimento forzato mentre da w10 non accade. Cosa posso fare? Attualmente non vi è alcun filesystem sull'hdd in quanto ho appena cancellato tutto.
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda magozurlinux » sabato 8 dicembre 2018, 19:22

Ciao.

Da BIOS controlla l'ordine di boot.

Vedi anche se c'è la voce Hard-disks, controlla che il primo sia l'SSD ed il secondo HDD, salva le impostazioni e riavvia il pc.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20919
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » sabato 8 dicembre 2018, 21:30

magozurlinux Immagine ha scritto:Ciao.

Da BIOS controlla l'ordine di boot.

Vedi anche se c'è la voce Hard-disks, controlla che il primo sia l'SSD ed il secondo HDD, salva le impostazioni e riavvia il pc.


Ciao e grazie per avermi risposto, in ogni caso non c'è alcuna voce Hard-disks nel mio bios, l'ordine di boot sembra giusto. In allegato posto 2 link dove mostro le schermate del mio bios. https://imgur.com/a/rAGRsek https://imgur.com/a/405GvbW. In ogni caso ho notato che lubuntu mi legge l'hard disk meccanico come primario (sda) e l'ssd come secondario (sdb) pur avendo cambiato la disposizione fisica dei supporti.
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda magozurlinux » domenica 9 dicembre 2018, 17:59

Prego, di nulla!

Dal BIOS, nella scheda BOOT, disattiva Boot Option #2 e Boot Option #3; salva le impostazioni e riavvia il portatile.

Quelle opzioni di boot servono se sul primo hard-disk non trova il S.O., passa al 2°, se non trova nulla sul 2° passa alla terza opzione, se non trova il S.O. emette errore alla schermata iniziale durante il POST.

Dal GRUB scegli quale S.O. vuoi far partire Lubuntu o Windows, se è installato in dual boot.

Ciao.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20919
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Riavvio non corretto secondo hard disk

Messaggioda willy54 » domenica 9 dicembre 2018, 18:40

Normale non ci sia nessuna voce hard disk nel bios-boot non avendo nessun SO installato sul hdd.
Credo sia anche ipossibile procedere a quanto richiesto dal Mago , in quanto corrispondono ai riferimenti presenti nella partizione Uefi , cancellando la opzione 2 non si avvierebbe più windows e cancellando la 3 non sarebbero più disponibili le opzioni avanzate di Ubuntu.
L'unica cosa possibile da bios/firmware è tramite i tasti + e - spostare le opzioni su e giù.
Per il problema dello start/stop del hdd è in quanto lo slot per dvdrom non è predisposto in origine per lo scopo a cui è dedicato, ed il diverso funzionamento dei 2 SO , mentre windows monta lo slot solo a necessità Xbuntu tenta il montaggio in ogni caso , per evitarlo è possibile modificare fstab in maniera che non sia attivato al boot , ma qui io cedo la palla per disconoscenza del funzionamento di fstab.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2649
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » lunedì 10 dicembre 2018, 9:45

Purtroppo credo che il problema sia irrisolvibile, ho appena formattato l'hdd in NTFS in modo da poterlo leggere anche da windows e ora il problema si presenta anche da lì. Non si potrebbe fare in modo da entrambi i sistemi, magari con soluzioni diverse, che il disco venga attivato solo se richiesto? Alla fine lo userei di rado però non mi andrebbe di tenerlo come esterno.
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda magozurlinux » lunedì 10 dicembre 2018, 12:14

Ciao.

Questo l'hai provato?

viewtopic.php?f=9&t=631870#p5100071
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20919
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Riavvio non corretto secondo hard disk

Messaggioda Sam9999 » lunedì 10 dicembre 2018, 12:29

Ora essendo EFi non so, ma gli HD di norma vengono rilevati in BIOS e quindi se non c'è forse lo hai collegato male.
Magari controlla i ponticelli dell'HD se vuole essere messo slave...
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1495
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Re: Riavvio non corretto secondo hard disk

Messaggioda willy54 » lunedì 10 dicembre 2018, 12:51

Per windows la soluzione potresti trovarla in Gestione Disco ( da tastiera Win+R, poi impartire diskmgmt.msc), ma non so se lo spegne completamente , lo uso per nascondere la partizione Win7 da Win10 e la partizione win10 da win7 con dischi completi mai provato e con ssd non sento rumori, le partizioni diventano invisibili al SO , ma non sono mai andato a fondo sulla questione.
Per linux derivate esiste anche in App dischi una funzione per modificare lo stand by ma non la ho mai provata.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2649
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » lunedì 10 dicembre 2018, 14:16

magozurlinux Immagine ha scritto:Ciao.

Questo l'hai provato?

viewtopic.php?f=9&t=631870#p5100071

Come suggerito da willy54 non posso cancellare da EFI boot2 e boot3 in quanto non potrei accedere a windows 10 e le opzioni avanzate di ubuntu.

willy54 ha scritto:Per windows la soluzione potresti trovarla in Gestione Disco ( da tastiera Win+R, poi impartire diskmgmt.msc), ma non so se lo spegne completamente , lo uso per nascondere la partizione Win7 da Win10 e la partizione win10 da win7 con dischi completi mai provato e con ssd non sento rumori, le partizioni diventano invisibili al SO , ma non sono mai andato a fondo sulla questione.
Per linux derivate esiste anche in App dischi una funzione per modificare lo stand by ma non la ho mai provata.

Ho provato ad impostare lo stand by dall'applicazione Dischi e sembra che il problema del riavvio forzato non si verifica più. Per mettere una parola fine alla questione farò una serie di tentativi. Vi terrò aggiornati e nel frattempo proverò a settare lo stand by anche da w10 :D
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » lunedì 10 dicembre 2018, 14:31

Modificherò di volta in volta questa risposta in modo tale da non aprirne altre.
Aggiornamento 1: da lubuntu lo stand by dopo X secondi/minuti dall'ultima operazione non funziona e il problema continua a persistere. Dalla stessa applicazione smontando il disco e andando nel menù indicato con le tre linee orizzontali c'è l'opportunità di mandare in stand by subito il disco. Una volta inserita la password il disco si sospende davvero e il problema al riavvio del pc non si verifica più. Forse impostando un timeout l'operazione non va a buon fine in quanto ci sarebbe bisogno del privilegio di root che mi è stato richiesto sospendendo il disco manualmente. In questo caso potrei provare a farci un piccolo script bash che ad ogni avvio di sessione mi disattivi il disco.

Aggiornamento 2: dall'app Dischi sono riuscito ad impostare un timeout per lo stand by, probabilmente l'altra volta dimenticai semplicemente di salvare le impostazioni :D . Da windows 10 in Gestione dischi ho impostato lo stand by ad 1 minuto. Il problema sembra risolto sotto entrambi i sistemi operativi.
Ultima modifica di alukard990 il mercoledì 12 dicembre 2018, 12:57, modificato 3 volte in totale.
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda magozurlinux » lunedì 10 dicembre 2018, 18:15

Ciao.

Da terminale postami questi comandi:

Codice: Seleziona tutto
cat /etc/fstab


Codice: Seleziona tutto
sudo blkid


per vedere se viene montato in /etc/fstab.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20919
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » martedì 11 dicembre 2018, 9:31

magozurlinux Immagine ha scritto:Ciao.

Da terminale postami questi comandi:

Codice: Seleziona tutto
cat /etc/fstab


Codice: Seleziona tutto
sudo blkid


per vedere se viene montato in /etc/fstab.


Codice: Seleziona tutto
cat /etc/fstab
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=3085b28e-5d88-4947-9afb-df513834fd11 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb2 during installation
UUID=F0AB-E8A8  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sdb6 during installation
UUID=09d84125-0726-4a6c-904e-ca07be466cc4 /home           ext4    defaults        0       2
# swap was on /dev/sdb7 during installation
UUID=a1ef186b-2cda-4075-ba0e-def52214364e none            swap    sw       


Codice: Seleziona tutto
sudo blkid
/dev/sda1: LABEL="Volume" UUID="3870718A7071501C" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ced22446-528d-48fa-bb0c-6c75994de0fa"
/dev/sdb1: LABEL="Ripristino" UUID="B670AABA70AA80AB" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b0c7f11c-488c-49b1-a248-76f4469c5960"
/dev/sdb2: UUID="F0AB-E8A8" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e985e3d8-2457-46d0-834b-f11845a71703"
/dev/sdb3: PARTLABEL="Microsoft reserved partition" PARTUUID="802741c5-e91e-4dd3-82f5-92dfa1dbdf99"
/dev/sdb4: UUID="BACCB442CCB3F6AB" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4070ebf9-564a-4c73-b645-56a045974cce"
/dev/sdb5: UUID="3085b28e-5d88-4947-9afb-df513834fd11" TYPE="ext4" PARTUUID="fed0ba46-35c9-498a-bced-5284e5356363"
/dev/sdb6: UUID="09d84125-0726-4a6c-904e-ca07be466cc4" TYPE="ext4" PARTUUID="c52d281c-31c8-41d0-a65b-3bb31ac4fccb"
/dev/sdb7: UUID="a1ef186b-2cda-4075-ba0e-def52214364e" TYPE="swap" PARTUUID="c81c0266-5c8e-497d-b093-b2ecec83c9b1"


Attualmente il disco è in stand by
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda OMBRA_Linux » martedì 11 dicembre 2018, 11:14

1° Controlla di avere inserito bene i cavi Sata. ( Già cosi dovresti risolvere )
In tal caso puoi anche:
2° Da Windows 10, da Start digita la parola ( Partition ) si aprirà il gestore dischi, una volta dentro monta il disco assegnandogli una lettera come si vede qui Youtube che dovrebbe darti già di default. Poi volendo, puoi assegnare un nome all'unità Driver.
Se per vivere devi strisciare, alzati e muori.
Avatar utente
OMBRA_Linux
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1262
Iscrizione: febbraio 2015
Località: Napoli
Desktop: Android Linux Windows10
Distribuzione: Android / Linux / Windows10
Sesso: Maschile

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » martedì 11 dicembre 2018, 12:25

OMBRA_Linux Immagine ha scritto:1° Controlla di avere inserito bene i cavi Sata. ( Già cosi dovresti risolvere )
In tal caso puoi anche:
2° Da Windows 10, da Start digita la parola ( Partition ) si aprirà il gestore dischi, una volta dentro monta il disco assegnandogli una lettera come si vede qui Youtube che dovrebbe darti già di default. Poi volendo, puoi assegnare un nome all'unità Driver.

Il disco è montato bene nel caddy e a sua volta aggianciato bene all'attacco sulla scheda madre, in origine non lo avevo montato bene e il disco non veniva nemmeno riconosciuto. A quanto pare è un problema dovuto all'adattamento dell'hdd mediante caddy al posto del lettore dvd. Sembra che mandando in stand by il disco il problema si sia risolto. Non ho messo ancora la dicitura risolto al thread in quanto voglio fare verifiche più approfondite su più giorni.
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda OMBRA_Linux » martedì 11 dicembre 2018, 21:06

Cioè in pratica l'SSD funziona bene e l'Hard Disk che da problemi ma viene letto, è cosi?.
Beh prima di tutto da Bios, sa non l'hai già fatto, devi impostare l'SSD come disco primario di avvio salvare e uscire. Dopo di che se da ancora problemi da gestione dischi controlli se e montato.
Se per vivere devi strisciare, alzati e muori.
Avatar utente
OMBRA_Linux
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1262
Iscrizione: febbraio 2015
Località: Napoli
Desktop: Android Linux Windows10
Distribuzione: Android / Linux / Windows10
Sesso: Maschile

Re: Riavvio non corretto secondo hard disk

Messaggioda giulux » martedì 11 dicembre 2018, 21:26

Non ho letto attentamente e quindi potrei sbaglire (nel caso me ne scuso) ma mi sembra dall'esito del comando blkid che il disco in questione venga identificato come sda1, mentre normalmente sda è il disco su cui risiede il sistema operativo e parte per primo.
Sei sicuro che l'ordine di avvio sia impostato giustamente?
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22598
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Re: Riavvio non corretto secondo hard disk

Messaggioda alukard990 » mercoledì 12 dicembre 2018, 9:07

giulux Immagine ha scritto:Non ho letto attentamente e quindi potrei sbaglire (nel caso me ne scuso) ma mi sembra dall'esito del comando blkid che il disco in questione venga identificato come sda1, mentre normalmente sda è il disco su cui risiede il sistema operativo e parte per primo.
Sei sicuro che l'ordine di avvio sia impostato giustamente?

Sì l'ordine di boot è impostato bene, non ho capito perché il disco meccanico me lo identifica sempre come sda e l'ssd come sdb dove risiede realmente il SO.
OMBRA_Linux ha scritto:Cioè in pratica l'SSD funziona bene e l'Hard Disk che da problemi ma viene letto, è cosi?.
Beh prima di tutto da Bios, sa non l'hai già fatto, devi impostare l'SSD come disco primario di avvio salvare e uscire. Dopo di che se da ancora problemi da gestione dischi controlli se e montato.

Ho spulciato tutto il bios ma non c'è modo di impostarlo come primario, solamente cambiare l'ordine di boot si può.
alukard990
Prode Principiante
 
Messaggi: 181
Iscrizione: febbraio 2014
Desktop: Mate
Distribuzione: 18.04, 64bit

Re: Riavvio non corretto secondo hard disk

Messaggioda giulux » mercoledì 12 dicembre 2018, 9:25

Posta come già chiesto
Codice: Seleziona tutto
cat /etc/fstab
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22598
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Re: Riavvio non corretto secondo hard disk

Messaggioda OMBRA_Linux » mercoledì 12 dicembre 2018, 10:10

alukard990 Immagine ha scritto:
giulux Immagine ha scritto:Non ho letto attentamente e quindi potrei sbaglire (nel caso me ne scuso) ma mi sembra dall'esito del comando blkid che il disco in questione venga identificato come sda1, mentre normalmente sda è il disco su cui risiede il sistema operativo e parte per primo.
Sei sicuro che l'ordine di avvio sia impostato giustamente?

Sì l'ordine di boot è impostato bene, non ho capito perché il disco meccanico me lo identifica sempre come sda e l'ssd come sdb dove risiede realmente il SO.
OMBRA_Linux ha scritto:Cioè in pratica l'SSD funziona bene e l'Hard Disk che da problemi ma viene letto, è cosi?.
Beh prima di tutto da Bios, sa non l'hai già fatto, devi impostare l'SSD come disco primario di avvio salvare e uscire. Dopo di che se da ancora problemi da gestione dischi controlli se e montato.

Ho spulciato tutto il bios ma non c'è modo di impostarlo come primario, solamente cambiare l'ordine di boot si può.





In che senso non c'è modo di impostarlo come primario?
Di solito si accede al Bios si seleziona l'HD o L'SSD che si vuole far partire lo si sposta con i tasti direzionali usando le freccette <-- --> su/giù ( L' altro bisogna metterlo su Disable ) e una volta impostato salvi tutto cliccando il tasto ( F10 )
Edit: Non voglio pensare che tu non l'abbia fatto già.
Se per vivere devi strisciare, alzati e muori.
Avatar utente
OMBRA_Linux
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1262
Iscrizione: febbraio 2015
Località: Napoli
Desktop: Android Linux Windows10
Distribuzione: Android / Linux / Windows10
Sesso: Maschile

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 10 ospiti