Problema: sistema di pacchetti danneggiato nvidia 390

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » lunedì 24 dicembre 2018, 19:55

Ciao, premetto che sono abbastanza neofita. Ho un sistema operativo installato 18.04. Premetto che rispetto alla versione 14.04.3 che è la prima installata non è mai andato un granchè bene. Forse colpa del PC ormai un pò datato. Un pentium dual core con 2 giga di RAM. Risale almeno al 2007. Comunque mi è partita la gestione della scheda video è si visualizza male. Schermate grandi. Ad ogni modo sotto quanto accade quando cerco di aggiornare:

Verificare se sono in uso repository di terze parti. Qualora così fosse, disabilitarli, poiché questi sono talvolta causa di problemi.
Inoltre eseguire il seguente comando in un terminale: apt-get install -f
Transaction failed: Il sistema di pacchetti è danneggiato
I seguenti pacchetti presentano dipendenze non soddisfatte:

libnvidia-ifr1-390: Depends: libnvidia-gl-390 ma non è installato
nvidia-driver-390: Depends: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
Depends: nvidia-dkms-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: nvidia-kernel-source-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: libnvidia-compute-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: nvidia-compute-utils-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: libnvidia-decode-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: libnvidia-encode-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: nvidia-utils-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: xserver-xorg-video-nvidia-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: libnvidia-cfg1-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: libnvidia-ifr1-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
Depends: libnvidia-fbc1-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato

Dopo aver eseguito il comando "sudo apt-get install -f appare quanto sotto:

Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Viene inoltre proposto di: verificare se sono in uso repository di terze parti. Qualora così fosse, disabilitarli, poiché questi sono talvolta causa di problemi.... Ma non saprei come fare per verificare e disabilitare. Ho trovato in giro nel forum qualche esempio ma non mi fido senza guida.

Grazie per la vostra disponibilità qualora mi indicaste qualche soluzione... :muro: :o :)
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda willy54 » lunedì 24 dicembre 2018, 20:14

Racchiudi i listati tra i tag [ code ] come da immagine
Per conoscere se hai dei ppa aggiuntivi pubblica
Codice: Seleziona tutto
inxi -r
se necessario installalo come da istruzione del terminale
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4049
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » martedì 25 dicembre 2018, 0:12

Di seguito il risulato del comando "inxi -r":

Repos: Active apt sources in file: /etc/apt/sources.list
deb http://it.archive.ubuntu.com/ubuntu/ bionic main restricted universe
deb-src http://it.archive.ubuntu.com/ubuntu/ bionic multiverse universe main restricted #Added by software-properties
deb http://it.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe
deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-updates multiverse universe main restricted #Added by software-properties
deb http://it.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://it.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
deb http://it.archive.ubuntu.com/ubuntu/ bionic-backports main restricted multiverse universe
deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-backports main restricted multiverse universe #Added by software-properties
deb http://it.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe
deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-security multiverse universe main restricted #Added by software-properties
deb http://it.archive.ubuntu.com/ubuntu/ bionic-security multiverse
deb http://it.archive.ubuntu.com/ubuntu/ bionic-proposed main multiverse restricted universe
Active apt sources in file: /etc/apt/sources.list.d/ubuntu-audio-dev-ubuntu-ppa-xenial.list
deb-src http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu bionic main # disabilitato durante l'avanzamento a bionic

Abbi pazienza ma ho difficoltà a interpretare tecnicamente quanto mi dici. Spero venga fuori ciò che mi richiedi. Di seguito il resto

Da sudo apt-get update:

Codice: Seleziona tutto
Ignorato:1 http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu bionic InRelease
Trovato:2 http://it.archive.ubuntu.com/ubuntu bionic InRelease
Trovato:3 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease       
Errore:4 http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu bionic Release 
  404  Not Found [IP: 91.189.95.83 80]
Trovato:5 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease     
Trovato:6 http://it.archive.ubuntu.com/ubuntu bionic-security InRelease
Trovato:7 http://it.archive.ubuntu.com/ubuntu bionic-proposed InRelease
Lettura elenco dei pacchetti... Fatto               
E: Il repository "http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu bionic Release" non ha un file Release.
N: L'aggiornamento da tale repository non può essere eseguito in modo sicuro ed è quindi disabilitato come impostazione predefinita.
N: Consultare la pagina man apt-secure(8) per la creazione di un repository e la configurazione utente.


Da sudo apt-get upgrade:

Codice: Seleziona tutto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non è installato
 nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).


Grazie e Buon Natale naturalmente :ciao: :birra:
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda willy54 » martedì 25 dicembre 2018, 0:54

Da inxi -r da disabilitare
Active apt sources in file: /etc/apt/sources.list.d/ubuntu-audio-dev-ubuntu-ppa-xenial.list

causa questo errore
Errore:4 http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]
in sudo apt-get update: e questo in
E: Il repository "http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu bionic Release" non ha un file Release.

quello che che è necessario fare
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non è installato
nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
aggiungo
Codice: Seleziona tutto
sudo apt-get autoremove
se tutto va a posto bene , in caso contrario verificare poi nuovamente con
Codice: Seleziona tutto
sudo apt-get -f install
sudo apt update
sudo apt upgrade

postando se vengono fuori errori.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4049
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda giulux » martedì 25 dicembre 2018, 6:08

@Pitagora per favore modifica i tuoi post, come ti è stato già chiesto, mettendo tutti i listati tra i tag code (pulsante Codice in alto) come da clip d'esempio
0tag_codice.gif

Quanto ai tuoi problemi:
dai nel terminale
Codice: Seleziona tutto
software-properties-gtk
vai alla scheda[i] altro software[/i] e togli la spunta - o, meglio, elimina - quel ppa relativo a ubuntu-audio-dev-ubuntu-ppa-xenial.list, chiudi facendo aggiornare e poi dai
Codice: Seleziona tutto
sudo apt update && sudo apt install -f
se hai ancora errori postal.
Buon natale.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22934
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » martedì 25 dicembre 2018, 14:22

Ciao Willy, purtroppo non riesco a capire consa fare quando dici: Da inxi -r da disabilitare. Intendi dire che accorre disabilitare "Active apt sources in file: /etc/apt/sources.list.d/ubuntu-audio-dev-ubuntu-ppa-xenial.list"? Se si, non saprei come fare. Dovresti purtroppo indicarmi passo-passo i passaggi.

Rispondendo a Giulux ho fatto quanto mi dicevi. Eliminato tutto quanto relativo ai ppa ubuntu-audio-dev-ubuntu-ppa-xenial.list. Credo di aver fatto tutto a regola.
Dando il comando "sudo apt install -f" appare:

Prima parte prima di dare comando "S/n":

Codice: Seleziona tutto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libnvidia-gl-390
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
23 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
Continuare? [S/n] S


Seconda parte dopo comando "S":

Codice: Seleziona tutto
(Lettura del database... 219764 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
alfiere@alfiere-System-Product-Name:~$ software-properties-gtk



Appare ancora un errore mi sembra. Grazie 1000 a tutti!!!

P.S.: Buon Natale a tutti!!! Attendo vostre nuove. Per Willy, abbi pszienza. Se puoi dammi qualche dritta e proseguo quando mi hai detto di fare.
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda giulux » martedì 25 dicembre 2018, 14:50

Proviamo così
Codice: Seleziona tutto
sudo dpkg -i --force-overwrite /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
e poi
Codice: Seleziona tutto
sudo apt autoremove
quindi
Codice: Seleziona tutto
sudo apt update
e se non hai errori
Codice: Seleziona tutto
sudo apt install -f

Se hai errori postali.

N.B. Quello che diceva willy è quanto hai già fatto rimuovendo il ppa.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22934
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » martedì 25 dicembre 2018, 15:12

Ciao, permane ancora qualcosa:

Codice: Seleziona tutto
(Lettura del database... 219764 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


1000 grazie
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda giulux » martedì 25 dicembre 2018, 15:22

Purtroppo devo staccare: mentre aspetti che arrivi qualcun altro ad aiutrti guarda se tra i risultati di questa ricerca sull'errore trovi qualcosa di utile.
Ciao.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22934
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » mercoledì 26 dicembre 2018, 21:01

Ciao Giulux, da un post che ho trovato nel link che mi hai indicato ho provato a far qualcosa come di seguito e dall'ultimo post di di Jabwack avente come tema "disinstallare pacchetto fglrx:

ono stato via qualche giorno, comunque oggi ho risolto così:
-dato l'errore
Codice: Seleziona tutto
dpkg-divert: corrispondenza errata sul pacchetto
nel rimuovere "diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by fglrx"
trovato "diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by xorg-driver-fglrx"

-ho modificato il file diversions di dpkg:
Codice: Seleziona tutto
sudo gedit /var/lib/dpkg/diversions

e ho sostituito le righe che mi restituivano errore nel modo in cui sarebbero dovute essere

Nel mio caso comprendo anch'io che occorra (credo) modificare il file "diversions" di dpkg ma non so purtroppo come fare a livello di sintassi per far uscire il corretto gedit e da dove. Ne tantomeno come modificare le righe che danno l'errore e come identificarle. Trattasi di operazini al di sopra delle mie possibilità! :muro: :nono:

Grazie a chiunque......
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda woddy68 » mercoledì 26 dicembre 2018, 21:32

Mi sembra che stai facendo tanta confusione !
Il driver fglrx è quello proprietario di AMD (tra l'altro non più disponibile e non più sviluppato da Ubuntu 16.04), cosa c'entra questo con la tua Nvidia è un mistero ! Il casino a me sa che lo hai fatto aggiungendo un ppa (tra l'altro non più funzionante) che solo dal nome sa tanto di ppa con software in sviluppo.
Quindi se ancora non lo hai fatto disabilita i ppa che tu hai aggiunto e lascia quelli di default e spera di riuscire a sistemare.
Un consiglio, evitare di aggiungere ppa a caso su consiglio di blog di dubbia attendibilità, utilizza solo documentazione ufficiale o al limite chiedi. Evita di fare modifiche al sistema quando operi da sudo, se non sai quello che stai facendo, mi riferisco tra l'altro alla modifica di dpkg, non è così che si impara e si sistemano le cose.
Purtroppo non sono in grado di aiutarti, aspetta qualcuno che abbia più dimestichezza....Ciao
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15.1 Kde -- openSUSE Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Kde Neon
No Windows :o :nono: ;)
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4708
Iscrizione: febbraio 2011
Desktop: Kde Plasma5
Distribuzione: Leap 15.1 - Tumbleweed- Kde Neon
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » giovedì 27 dicembre 2018, 22:28

Ciao Woody. Francamente non so come abbia fatto ad aggiungere un ppa. Non saprei nemmeno quali disabilitare dato che non so quali ho aggiunto anche se involontariamente. Non ho modificato nulla in dpkg perchè non sono mai riuscito a editare un testo ne tantomeno a modificarlo per fare qualche errore. Non lo avrei comunque fatto perchè se non sai ciò che fai non conviene fare esperimenti. Sin ad ora i comandi "sudo" li ho adoperati su consiglio degli operatori del forum. Grazie, ciao
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda woddy68 » venerdì 28 dicembre 2018, 19:04

Innanzitutto apri software e aggiornamenti (lo trovi nelle applicazioni), nella scheda "altro software" togli la spunta a tutto, lasciala solo quella su Partner di Canonical. https://wiki.ubuntu-it.org/Repository/Ubuntu
Poi controlla con
Codice: Seleziona tutto
sudo apt update

se ha ancora errori, ma credo ne avrai ancora, quindi posta qui tutto il listato.
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15.1 Kde -- openSUSE Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Kde Neon
No Windows :o :nono: ;)
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4708
Iscrizione: febbraio 2011
Desktop: Kde Plasma5
Distribuzione: Leap 15.1 - Tumbleweed- Kde Neon
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » venerdì 28 dicembre 2018, 21:31

Ciao Woody ,fatto!

Risultato di "sudo apt update":

Codice: Seleziona tutto
Trovato:1 http://it.archive.ubuntu.com/ubuntu bionic InRelease
Ignorato:2 http://archive.canonical.com/ubuntu trusty InRelease
Trovato:3 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease       
Trovato:4 http://archive.canonical.com/ubuntu trusty Release                 
Trovato:5 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease     
Trovato:6 http://it.archive.ubuntu.com/ubuntu bionic-security InRelease
Trovato:7 http://it.archive.ubuntu.com/ubuntu bionic-proposed InRelease
Lettura elenco dei pacchetti... Fatto                 
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati.


Risultato di "sudo apt install -f":

Codice: Seleziona tutto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libnvidia-gl-390
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
23 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
Continuare? [S/n] S
(Lettura del database... 219764 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Pare ci sia sempre l'errore. Premetto che ho lascaito la spunta su 2 voci "Partner di Canonical". Una su "Partner di Canonical semplice e una su "Partner di Canonical (Cosice sorgente)".

Grazie, ciao :ciao:
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » venerdì 4 gennaio 2019, 16:14

Ciao, non so se qualcuno mi può dare una mano in questo problema ancora insoluto... Il problema è che oltretutto no mi scarica più nessun aggiornamento...

Grazie :cry: :ciao:
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda wilecoyote » venerdì 4 gennaio 2019, 16:31

Immagine Salve, sembra esserci un pacchetto inchiodato nel sistema.

Ti passo un comando dalle maniere alquanti forti per schiodare, può avere effetti collaterali, valuta se lo vuoi provare.

Prima però è tassativo accertati d'aver rimosso tutti i ppa ed altre aggiunte da rete, dai questo comando:

Codice: Seleziona tutto
software-properties-gtk


Nella scheda 'Altro software' verifica d'aver tolto la spunta a tutto tranne a 'Partner di Canonical', quindi chiudi che avvierà l'eventuale aggiornamento delle sorgenti.

Adesso il comando forte:

Codice: Seleziona tutto
sudo rm -r /var/lib/apt/lists/* -vf
sudo rm /var/lib/dpkg/info/libnvidia-gl-390*
sudo dpkg --configure -a
sudo apt update
sudo apt install --reinstall libnvidia-gl-390
sudo apt upgrade


Il 1° ripulisce la lista sorgente, 2° rimuove le informazioni del pacchetto oggetto, il 3° riconfigura il sistema pacchetti, il 4° aggiorna la lista pacchetti, il 5° forza il reinstallo, il 6° installa eventuali aggiornamenti.

Come detto può dare effetti collaterali, di regola li si sistema col comando:

Codice: Seleziona tutto
sudo apt install -f


Immagine Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9276
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda a323109 » venerdì 4 gennaio 2019, 17:38

Piragora Immagine ha scritto:Ciao Woody ,fatto!

Risultato di "sudo apt update":

Codice: Seleziona tutto
Trovato:1 http://it.archive.ubuntu.com/ubuntu bionic InRelease
Ignorato:2 http://archive.canonical.com/ubuntu trusty InRelease
Trovato:3 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease       
Trovato:4 http://archive.canonical.com/ubuntu trusty Release                 
Trovato:5 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease     
Trovato:6 http://it.archive.ubuntu.com/ubuntu bionic-security InRelease
Trovato:7 http://it.archive.ubuntu.com/ubuntu bionic-proposed InRelease
Lettura elenco dei pacchetti... Fatto                 
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati.


Risultato di "sudo apt install -f":

Codice: Seleziona tutto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libnvidia-gl-390
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
23 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
Continuare? [S/n] S
(Lettura del database... 219764 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Pare ci sia sempre l'errore. Premetto che ho lascaito la spunta su 2 voci "Partner di Canonical". Una su "Partner di Canonical semplice e una su "Partner di Canonical (Cosice sorgente)".

Grazie, ciao :ciao:


Codice: Seleziona tutto
Trovato:3 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease       
Trovato:4 http://archive.canonical.com/ubuntu trusty Release


Curiosita': Come mai trova sia bionic e sia trusty???
Keep calm and carry on!
Avatar utente
a323109
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1152
Iscrizione: luglio 2013
Località: Area 51
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.3 LTS
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda wilecoyote » venerdì 4 gennaio 2019, 17:50

Immagine Salve, li trova poiché erroneamente aggiunti, ecco perché ho precisato di far piazza pulita di tutte le aggiunte.

Immagine Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9276
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda Piragora » venerdì 4 gennaio 2019, 22:05

Ciao Wile, quali effetti collaterali può avere? Perchè se è il caso che memorizzi tutto quanto ho su Ubunto lo faccio, così male che va non perdo i miei documenti...... Grazie, ciao
Piragora
Prode Principiante
 
Messaggi: 53
Iscrizione: settembre 2016
Sesso: Maschile

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Messaggioda wilecoyote » venerdì 4 gennaio 2019, 22:32

Immagine Salve, il backup è da fare a prescindere.

Per effetti collaterali intendo rimozione di qualche pacchetto/programma, magari utile, quando si litiga con pacchetti provenienti da fonti terze qualche quiproquo con le dipendenze è sempre da mettere in conto.

Immagine Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9276
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Successiva

Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite