Connessione ad internet macchinosa

Riconoscimento, installazione e configurazione delle periferiche.

Connessione ad internet macchinosa

Messaggioda breynm_07 » mercoledì 2 gennaio 2019, 10:34

yos minnas, in questi giorni di ferie, stò smanettando sul mio primo portatile ed ho installato 3 SO , ubuntu 18 gnome, ubuntu 16 unity ed linuxmint 18. Nessun problema riscontrato nei test coi SO da live, però da installati, solo ubuntu 18 non mi ha dato problemi (ma me gnome3 non piace :nono: ) mentre con Ubuntu 16 e Linuxmint 18 impossibilità di connessione via ethernet :muro: (questo problema da live non c'era :sisi: ), in entrambi i casi nm-applet mi dice " dispositivo non pronto" oppure non appaiono le righe delle connessioni che avevo configurato. Riesco finalmente a connettermi, ma devo smanettare ogni volta su networkmanager editor: allora prima di connettere fisicamente il cavo, avvio l'editor delle connessioni di networkmanager e configuro una nuova connessione, ma senza dare l'ok, collegare il cavo, dare l'ok, e la connessione parte, siccome uso i dns open, clicco sulla riga relativa su nm-applet, a questo punto posso anche cancellare la nuova connessione configurata, dato che per disconnettermi devo staccare il cavo, e se voglio riconnettermi devo ripetere la papparderla sopra descritta :muro: :muro:
Ultima modifica di breynm_07 il venerdì 4 gennaio 2019, 17:51, modificato 1 volta in totale.
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda pachisapiu » mercoledì 2 gennaio 2019, 10:47

oppure non appaiono le righe delle connessioni che avevo configurato.

spiega bene cosa avresti configurato che non vedi ... magari il problema è proprio lì
pachisapiu
 

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » mercoledì 2 gennaio 2019, 11:08

pachisapiu ha scritto:
oppure non appaiono le righe delle connessioni che avevo configurato.

spiega bene cosa avresti configurato che non vedi ... magari il problema è proprio lì

Di solito quando un modem acceso e funzionante viene collegato al pc (via ethernet o wifi) cliccando su nm-applet, sotto la riga Reti Ethernet o sotto la riga Rete WiFi appaiono le righe con i nomi delle connessioni che sono state configurate mediante nm-connection-editor, e questo non mi succede quando collego il modem al pc, sul modem si accende la luce dell' avvenuto collegamento con pc, l'icona di netspeed su linuxmint 18 cambia, e mostra le 2 freccine, ma non mostra le righe delle connessioni precedentemente configurate su nm-applet, appaiono solo dopo aver fatto la procedura descritta nel primo post.
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda pachisapiu » mercoledì 2 gennaio 2019, 11:45

di solito la connessione via ethernet non richiede configurazioni va di default come è ...
pachisapiu
 

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » mercoledì 2 gennaio 2019, 11:52

Ieri ho aggiornato linuxmint 18, e tra pacchetti c'era anche networmanager, ma non è cambiato niente
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda magozurlinux » mercoledì 2 gennaio 2019, 13:00

Salve,

da terminale postami questi comandi:

Codice: Seleziona tutto
lspci -nnk | grep -i net -n2


Codice: Seleziona tutto
ifconfig -a


Codice: Seleziona tutto
route -n
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21441
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Impossibilità di connessione automatica ad internet

Messaggioda Stealth » mercoledì 2 gennaio 2019, 13:28

Domanda un po' laterale: ma se la 18.04 (che per me è buona almeno quanto la 16.04 ma ha un lungo supporto) funziona bene, perchè non ci installi unity e vai avanti tranquillo?
ciao
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16267
Iscrizione: gennaio 2006
Desktop: Gnome
Distribuzione: Ubuntu 18.04 LTS

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » mercoledì 2 gennaio 2019, 16:33

Stealth ha scritto:Domanda un po' laterale: ma se la 18.04 (che per me è buona almeno quanto la 16.04 ma ha un lungo supporto) funziona bene, perchè non ci installi unity e vai avanti tranquillo?
ciao

Non ho tanta voglia di smanettare, e cmq anche unity non mi piace, però lo preferisco a gnome,ed ho installato ubuntu 18 gnome perchè gli altri avevano lo stesso problema, eppoi ho ripreso per mano il portatile vecchio solo perchè photorec non finiva più di recuperare dei file(ho aspettato 75h e passa, i file recuperati sono al 99,9 corrotti :muro: :muro: :muro: :muro: :muro: ) da un HDD impestato da badblocks.
Grazie magozurlinux, speravo proprio sul tuo aiuto, questo è l'output con modem sconnesso dal pc
Codice: Seleziona tutto
~ $ lspci -nnk | grep -i net -n2
36- Kernel driver in use: ahci
37- Kernel modules: ahci, pata_acpi
38:00:0a.0 Ethernet  controller [0200]: NVIDIA Corporation MCP77 Ethernet [10de:0760] (rev a2)
39: Subsystem: Hewlett-Packard Company MCP77 Ethernet [/color] [103c:360a]
40- Kernel driver in use: forcedeth
41- Kernel modules: forcedeth
 
 
~ $ ifconfig -a
enp0s10   Link encap:Ethernet  IndirizzoHW 00:1f:16:6f:25:55 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:0 (0.0 B)  Byte TX:0 (0.0 B)
 
lo        Link encap:Loopback locale 
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:944 errors:0 dropped:0 overruns:0 frame:0
          TX packets:944 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:75280 (75.2 KB)  Byte TX:75280 (75.2 KB)

le 3 parole "Ethernet" nel terminale appaiono così
Ethernet

non appare la scheda wifi perchè lo tolta al tempo di Window vista, visto che al tempo non mi serviva, ed ad oggi non ho voglia di usarla
il terzo commando senza modem
Codice: Seleziona tutto
~ $ route -n
Tabella di routing IP del kernel
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

con il modem collegato ad internet
Codice: Seleziona tutto
~ $ route -n
Tabella di routing IP del kernel
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 enp0s10
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp0s10
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 enp0s10
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda magozurlinux » mercoledì 2 gennaio 2019, 17:06

Prego, di nulla!

Suppongo che hai attivo l'IPv6 nella scheda di rete ethernet.

Da terminale dai questo comando, va dato una volta sola:

Codice: Seleziona tutto
echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth.conf


riavvia il pc.

Da terminale postami questi comandi:

Codice: Seleziona tutto
dmesg | grep forcedeth


Codice: Seleziona tutto
ping -c4 192.168.1.1


Codice: Seleziona tutto
ping -c4 www.google.it
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21441
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » mercoledì 2 gennaio 2019, 18:53

Nelle connessioni da me configurate su nm-applet, l'ipv6 è disabilitato, mentre non lo è quella nuova, che creo per far partire la connessione, cmq anche disabilitandolo parte lo stesso
Codice: Seleziona tutto
~ $ echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth.conf
[sudo] password di breynm_07:
options forcedeth msi=0 msix=0


Al riavvio ho provato a vedere se la connessione compariva senza smanettamenti, ma nisba
senza connessione
Codice: Seleziona tutto
~ $ dmesg | grep forcedeth
[    3.012074] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[    3.584717] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:1f:16:6f:25:55
[    3.584720] forcedeth 0000:00:0a.0: highdma csum pwrctl mgmt lnktim msi desc-v3
[    3.587366] forcedeth 0000:00:0a.0 enp0s10: renamed from eth0
[   29.354880] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[   29.355110] forcedeth 0000:00:0a.0 enp0s10: no link during initialization

con connessione
Codice: Seleziona tutto
~ $ dmesg | grep forcedeth
[    3.012074] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[    3.584717] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:1f:16:6f:25:55
[    3.584720] forcedeth 0000:00:0a.0: highdma csum pwrctl mgmt lnktim msi desc-v3
[    3.587366] forcedeth 0000:00:0a.0 enp0s10: renamed from eth0
[   29.354880] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[   29.355110] forcedeth 0000:00:0a.0 enp0s10: no link during initialization
[  257.610503] forcedeth 0000:00:0a.0 enp0s10: link up
[  272.359301] forcedeth 0000:00:0a.0 enp0s10: link down
[  293.041613] forcedeth 0000:00:0a.0 enp0s10: link up

in entrambi i casi la parola "forcedeth" è in rosso
Codice: Seleziona tutto
 $ ping -c4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.605 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.428 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.447 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.446 ms

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3051ms
rtt min/avg/max/mdev = 0.428/0.481/0.605/0.074 ms

Codice: Seleziona tutto
~ $ ping -c4 8.8.4.4
PING 8.8.4.4 (8.8.4.4) 56(84) bytes of data.
64 bytes from 8.8.4.4: icmp_seq=1 ttl=120 time=15.0 ms
64 bytes from 8.8.4.4: icmp_seq=2 ttl=120 time=15.3 ms
64 bytes from 8.8.4.4: icmp_seq=3 ttl=120 time=14.6 ms
64 bytes from 8.8.4.4: icmp_seq=4 ttl=120 time=15.4 ms

--- 8.8.4.4 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 14.649/15.124/15.417/0.322 ms
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda magozurlinux » mercoledì 2 gennaio 2019, 19:17

E' in rosso, va bene.

Gli outputs che hai postato vanno bene, non ci sono perdite di pacchetti col ping.

Da terminale postami questi comandi:

Codice: Seleziona tutto
dmesg | grep enp0s10


Codice: Seleziona tutto
sudo nmcli con show


Codice: Seleziona tutto
nmcli dev status


Codice: Seleziona tutto
nmcli device show enp0s10
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21441
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » giovedì 3 gennaio 2019, 11:52

Una cosa prima, se disabilito e poi riabilito la funzionalità di rete sul menù a tendina di nn-applet con modem connesso al pc, ma senza una connessione attiva, mi appare la voce "dispositivo non pronto", se poi stacco il cavo dal pc, la voce rimane nel menù, per farla sparire devo disabilitare e poi riabilitare la funzionalità di rete.
Scusa magozurlinux prima di dare i commandi, ho smanettato di mio
Codice: Seleziona tutto
~ $ dmesg | grep enp0s10
[    3.635254] forcedeth 0000:00:0a.0 enp0s10: renamed from eth0
[   28.038737] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[   28.039442] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[   28.039673] forcedeth 0000:00:0a.0 enp0s10: no link during initialization
[   28.041300] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  218.851695] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  218.852706] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[  218.856430] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  218.856456] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s10: link becomes ready
[  313.216017] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  313.217064] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[  333.787954] forcedeth 0000:00:0a.0 enp0s10: link down
[  349.967766] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  349.968782] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[  349.969053] forcedeth 0000:00:0a.0 enp0s10: no link during initialization
[  349.973096] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  510.343514] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  510.344514] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[  510.348231] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[  510.349855] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s10: link becomes ready
[  635.354502] forcedeth 0000:00:0a.0 enp0s10: link down
[  656.380929] forcedeth 0000:00:0a.0 enp0s10: link up

Con sudo l'out è identico
Codice: Seleziona tutto
~ $ nmcli con show
NOME      UUID                                  TIPO            DEVICE 
open    3fcf40df-e153-4098-bc69-aae05a3548c1  802-3-ethernet  enp0s10
open1  43df971e-989a-4c77-aab1-d8aa454d6724  802-3-ethernet  --


Codice: Seleziona tutto
~ $ nmcli dev status
DEVICE   TIPO      STATO        CONNESSIONE
enp0s10  ethernet  collegato    open     
lo       loopback  non gestito  --


Codice: Seleziona tutto
~ $ nmcli device show enp0s10
GENERAL.DEVICE:                         enp0s10
GENERAL.TIPO:                           ethernet
GENERAL.HWADDR:                         00:1F:16:6F:25:55
GENERAL.MTU:                            1500
GENERAL.STATO:                          100 (collegato)
GENERAL.CONNESSIONE:                    open
GENERAL.PERCORSO-CON:                   /org/freedesktop/NetworkManager/ActiveConnection/2
WIRED-PROPERTIES.PORTANTE:              on
IP4.INDIRIZZO[1]:                       192.168.1.2/24
IP4.GATEWAY:                            192.168.1.1
IP4.INSTRADAMENTO[1]:                   dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             208.67.222.222
IP4.DNS[2]:                             208.67.222.220
IP6.INDIRIZZO[1]:                       fe80::21f:16ff:fe6f:2555/64
IP6.GATEWAY:


Scusa una domanda ma il mt = 1000 di questa riga
Codice: Seleziona tutto
IP4.INSTRADAMENTO[1]:                   dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000

significa che sono distante 1 Km dalla centralina?
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda magozurlinux » giovedì 3 gennaio 2019, 18:14

breynm_07 Immagine ha scritto:Una cosa prima, se disabilito e poi riabilito la funzionalità di rete sul menù a tendina di nn-applet con modem connesso al pc, ma senza una connessione attiva, mi appare la voce "dispositivo non pronto", se poi stacco il cavo dal pc, la voce rimane nel menù, per farla sparire devo disabilitare e poi riabilitare la funzionalità di rete.

Scusa una domanda ma il mt = 1000 di questa riga
Codice: Seleziona tutto
IP4.INSTRADAMENTO[1]:                   dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000

significa che sono distante 1 Km dalla centralina?


Ciao.

No! quell'output va bene, l'ho anch'io così, mi connetto tramite chiavetta Internet usb.

Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo -H gedit /etc/sysctl.conf


vai in fondo al file ed aggiungi queste righe:

Codice: Seleziona tutto
# IPv6 disabled
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


salva ed esci dall'editor di testo.

Riavvia il pc.

Da terminale postami questi comandi:

Codice: Seleziona tutto
nmcli device show open


Codice: Seleziona tutto
cat /etc/network/interfaces


Codice: Seleziona tutto
dmesg | grep enp0s10


Codice: Seleziona tutto
sudo systemctl list-units | grep -iE '(net|wicd|dhcp|conn)'


Codice: Seleziona tutto
cat /var/lib/NetworkManager/NetworkManager.state
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21441
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » venerdì 4 gennaio 2019, 10:04

Yos magozurlin
Codice: Seleziona tutto
~ $ nmcli device show open
Errore: dispositivo "open" non trovato.

Allora ho dato
Codice: Seleziona tutto
~ $ nmcli con show open
connection.id:                          open
connection.uuid:                        3fcf40df-e153-4098-bc69-aae05a3548c1
connection.interface-name:              enp0s10
connection.type:                        802-3-ethernet
connection.autoconnect:                 no
connection.autoconnect-priority:        0
connection.timestamp:                   1546513433
connection.read-only:                   no
connection.permissions:                 user:breynm_07
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (predefinito)
connection.secondaries:                 
connection.gateway-ping-timeout:        0
connection.metered:                     sconosciuto
connection.lldp:                        -1 (default)
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  full
802-3-ethernet.auto-negotiate:          yes
802-3-ethernet.mac-address:             00:1F:16:6F:25:55
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.mac-address-blacklist:   
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:       
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:           
802-3-ethernet.wake-on-lan:             1 (default)
802-3-ethernet.wake-on-lan-password:    --
ipv4.method:                            auto
ipv4.dns:                               208.67.222.222,208.67.222.220
ipv4.dns-search:                       
ipv4.dns-options:                       (predefinito)
ipv4.dns-priority:                      0
ipv4.addresses:                         
ipv4.gateway:                           --
ipv4.routes:                           
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   yes
ipv4.dhcp-client-id:                    --
ipv4.dhcp-timeout:                      0
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv4.dad-timeout:                       -1 (predefinito)
ipv6.method:                            ignore
ipv6.dns:                               
ipv6.dns-search:                       
ipv6.dns-options:                       (predefinito)
ipv6.dns-priority:                      0
ipv6.addresses:                         
ipv6.gateway:                           --
ipv6.routes:                           
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       0 (disabilitato)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --

Codice: Seleziona tutto
~ $ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Codice: Seleziona tutto
~ $ dmesg | grep enp0s10
[    3.592311] forcedeth 0000:00:0a.0 enp0s10: renamed from eth0
[   29.424150] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[   29.424865] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[   29.425095] forcedeth 0000:00:0a.0 enp0s10: no link during initialization
[   29.425479] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready

Qui mi viene un dubbio, dato che ho di default il modem spento e staccato dal pc, quando non mi serve internet, quindi ho acceso il modem, lo collego al pc, ma non ad internet, e ridò il commando
Codice: Seleziona tutto
~ $ dmesg | grep enp0s10
[    3.592311] forcedeth 0000:00:0a.0 enp0s10: renamed from eth0
[   29.424150] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[   29.424865] forcedeth 0000:00:0a.0 enp0s10: MSI enabled
[   29.425095] forcedeth 0000:00:0a.0 enp0s10: no link during initialization
[   29.425479] IPv6: ADDRCONF(NETDEV_UP): enp0s10: link is not ready
[ 1022.545724] forcedeth 0000:00:0a.0 enp0s10: link up
[ 1022.547034] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s10: link becomes ready

Questo commando l'ho dato da tty dall'utente amministratore, con modem acceso, connesso al pc ma non ad internet, e rimane così anche per il commando successivo
Codice: Seleziona tutto
~ $ sudo systemctl list-units | grep -iE '(net|wicd|dhcp|conn)'
sys-devices-pci0000:00-0000:00:0a.0-net-enp0s10.device            loaded active plugged   MCP77 Ethernet
sys-subsystem-net-devices-enp0s10.device                          loaded active plugged   MCP77 Ethernet
sys-fs-fuse-connections.mount                                     loaded active mounted   FUSE Control File System
systemd-networkd-resolvconf-update.path                           loaded active waiting   Trigger resolvconf update for networkd DNS
networking.service                                                loaded active exited    Raise network interfaces
NetworkManager-wait-online.service                                loaded active exited    Network Manager Wait Online
NetworkManager.service                                            loaded active running   Network Manager
nmbd.service                                                      loaded active running   LSB: start Samba NetBIOS nameserver (nmbd)
network-online.target                                             loaded active active    Network is Online
network-pre.target                                                loaded active active    Network (Pre)
network.target                                                    loaded active active    Network

Codice: Seleziona tutto
~ $ cat /var/lib/NetworkManager/NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

Scusa una domanda: ma nella riga WirelessEnabled=true non ci dovrebbe essere false, visto che la scheda wifi è assente?
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Impossibilità di connessione automatica ad internet

Messaggioda magozurlinux » venerdì 4 gennaio 2019, 11:40

breynm_07 Immagine ha scritto:Scusa una domanda: ma nella riga WirelessEnabled=true non ci dovrebbe essere false, visto che la scheda wifi è assente?


Per default la riga WirelessEnabled=true va bene così, anche se non hai la scheda di rete wireless integrata o usb.

Gli outputs vanno bene.

Hai provato a resettare il modem/router?
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21441
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Impossibilità di connessione automatica ad internet

Messaggioda thece » venerdì 4 gennaio 2019, 13:37

:ciao:

Mi sa che hai pastrocchiato (pesantemente) nel creare la connessione di rete

breynm_07 Immagine ha scritto:
Codice: Seleziona tutto
~ $ nmcli con show open
...
connection.autoconnect:                 no
...


Per riabilitare la connessione automatica (se è solamente questo il problema)

Codice: Seleziona tutto
nmcli connection modify "open" connection.autoconnect yes



I passi che hai postato nel tuo 1° post per (ri)creare la connessione hanno un certo non so che di folle ... :lol:
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10734
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: Connessione ad internet macchinosa

Messaggioda breynm_07 » venerdì 4 gennaio 2019, 17:53

@Thece hai quasi indovinato, ma la tua osservazione mi ha fatto capire che ho messo il titolo sbagliato e così ho dato adito a malinterpretazione, :muro: e vi chiedo scusa a tutti :muro: :muro: :muro: perciò ho provveduto a modifcare il titolo, quindi ripeto qual'è il mio problema, io non ho problemi con l'automatismo delle connessioni, per quello basta vistare la casella apposita su nm-connection-editor quando si crea una nuova connessione, il mio problema stà che quando collego il modem (acceso s'ìntende) al pc non mi appaiono nel menù a tendina di nm-applet sotto la voce Reti Ethernet le righe con i nomi delle connessioni da me configurate, quindi mi è impossibile cliccarci sopra (perchè assenti) ed attivare la connessione da me in precedenza configurata ma devo smanettare così come ho scritto nel 1° post, spero di essere stato chiaro
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Connessione ad internet macchinosa

Messaggioda thece » venerdì 4 gennaio 2019, 18:39

Chiaro.

Iniziamo con un piccolo output, poi vediamo.

Codice: Seleziona tutto
nmcli connection
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10734
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: Impossibilità di connessione automatica ad internet

Messaggioda breynm_07 » lunedì 7 gennaio 2019, 18:11

breynm_07 ha scritto: ...
Codice: Seleziona tutto
~ $ nmcli con show
NOME      UUID                                  TIPO            DEVICE 
open    3fcf40df-e153-4098-bc69-aae05a3548c1  802-3-ethernet  enp0s10
open1  43df971e-989a-4c77-aab1-d8aa454d6724  802-3-ethernet  --

Già postato sopra
magozurlinux ha scritto: ....
Hai provato a resettare il modem/router?

Si l'ho fatto di recente, come ho detto nel 1° post, con ubuntu 18 gnome, nessun problema, da installato e da live , con altre 2 , da live, nessun problema, addirittura potevo anche usare la sospensione, cosa che non posso fare nelle installate, coll'altro portatile, nessun problema, nè prima nè dopo aver resettato il modem.
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile

Re: Connessione ad internet macchinosa

Messaggioda breynm_07 » domenica 13 gennaio 2019, 2:11

A quanto pare nessuna buona nuova, comunque ho ridotto la manipolazione, mettendo in automatico una o tutte le connessione configurate, così ho eliminato lo smanettamento descritto nel 1° post, però per disconnettermi devo staccare il cavo, visto che dall'applet di NM non appare la voce "disconnetti"
Grande è l'impossibile, osare la confusione, il cielo sopra e sotto, ci si può solo perdere (CCCP)
C'era una volta una mela davanti alla finestra, un giorno una fredda folata di vento antartico violò la finestra e bacò la mela
Avatar utente
breynm_07
Prode Principiante
 
Messaggi: 150
Iscrizione: novembre 2012
Località: Treviso-prov.
Desktop: mate
Distribuzione: Arch Linux 64
Sesso: Maschile


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 9 ospiti