[Risolto] non riesco a connettermi via ssh al server

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

[Risolto] non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 19:08

Sto impazzendo perchê non riesco a capire quale sia il problema.
Voglio connettermi al mio server via ssh (per usare sftp) ma mi risponde costantemente 'Permission denied'.
Ho letto cento discussioni su internet, ma non risolvo.

Questa è la risposta corta:
Codice: Seleziona tutto
docente@Aula16:~$ ssh 192.168.3.10
The authenticity of host '192.168.3.10 (192.168.3.10)' can't be established.
RSA key fingerprint is SHA256:gVQldXj45DvS8SrIcallo9KVDONgsw05JyGvoyGesT0.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.3.10' (RSA) to the list of known hosts.
docente@192.168.3.10's password:
Permission denied, please try again.
docente@192.168.3.10's password:
Permission denied, please try again.
docente@192.168.3.10's password:
docente@192.168.3.10: Permission denied (publickey,password).
docente@Aula16:~$


e questa è la risposta lunga:
Codice: Seleziona tutto
docente@Aula16:~$ ssh -vvv 192.168.3.10
OpenSSH_7.6p1 Ubuntu-4ubuntu0.1, OpenSSL 1.0.2n  7 Dec 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "192.168.3.10" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.3.10 [192.168.3.10] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/docente/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.1
debug1: Remote protocol version 2.0, remote software version dropbear
debug1: no match: dropbear
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to 192.168.3.10:22 as 'docente'
debug3: hostkeys_foreach: reading file "/home/docente/.ssh/known_hosts"
debug3: record_hostkey: found key type RSA in file /home/docente/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from 192.168.3.10
debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ssh-rsa-cert-v01@openssh.com,rsa-sha2-512,rsa-sha2-256,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256@libssh.org,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1,kexguess2@matt.ucc.asn.au
debug2: host key algorithms: ssh-rsa,ssh-dss
debug2: ciphers ctos: aes128-ctr,aes256-ctr
debug2: ciphers stoc: aes128-ctr,aes256-ctr
debug2: MACs ctos: hmac-sha1,hmac-md5
debug2: MACs stoc: hmac-sha1,hmac-md5
debug2: compression ctos: none
debug2: compression stoc: none
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ssh-rsa
debug1: kex: server->client cipher: aes128-ctr MAC: hmac-sha1 compression: none
debug1: kex: client->server cipher: aes128-ctr MAC: hmac-sha1 compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ssh-rsa SHA256:gVQldXj45DvS8SrIcallo9KVDONgsw05JyGvoyGesT0
debug3: hostkeys_foreach: reading file "/home/docente/.ssh/known_hosts"
debug3: record_hostkey: found key type RSA in file /home/docente/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from 192.168.3.10
debug1: Host '192.168.3.10' is known and matches the RSA host key.
debug1: Found key in /home/docente/.ssh/known_hosts:1
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 4294967296 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey after 4294967296 blocks
debug2: key: /home/docente/.ssh/id_rsa ((nil))
debug2: key: /home/docente/.ssh/id_dsa ((nil))
debug2: key: /home/docente/.ssh/id_ecdsa ((nil))
debug2: key: /home/docente/.ssh/id_ed25519 ((nil))
debug3: send packet: type 5
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/docente/.ssh/id_rsa
debug3: no such identity: /home/docente/.ssh/id_rsa: No such file or directory
debug1: Trying private key: /home/docente/.ssh/id_dsa
debug3: no such identity: /home/docente/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /home/docente/.ssh/id_ecdsa
debug3: no such identity: /home/docente/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /home/docente/.ssh/id_ed25519
debug3: no such identity: /home/docente/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
docente@192.168.3.10's password:
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
docente@192.168.3.10's password:
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
docente@192.168.3.10's password:
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
docente@192.168.3.10: Permission denied (publickey,password).
docente@Aula16:~$



Ora vado sul server e posto i file .config

Ecco il ssh_config
Codice: Seleziona tutto
supervisore@Serverlab:~$ cat /etc/ssh/ssh_config

# This is the ssh client system-wide configuration file.  See
# ssh_config(5) for more information.  This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
#  1. command line options
#  2. user-specific file
#  3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options.  For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

Host *
#   ForwardAgent no
#   ForwardX11 no
#   ForwardX11Trusted yes
   PasswordAuthentication yes
#   HostbasedAuthentication no
#   GSSAPIAuthentication no
#   GSSAPIDelegateCredentials no
#   GSSAPIKeyExchange no
#   GSSAPITrustDNS no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   IdentityFile ~/.ssh/id_ecdsa
#   IdentityFile ~/.ssh/id_ed25519
#   Port 22
#   Protocol 2
#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc
#   MACs hmac-md5,hmac-sha1,umac-64@openssh.com
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
#   VisualHostKey no
#   ProxyCommand ssh -q -W %h:%p gateway.example.com
#   RekeyLimit 1G 1h
    SendEnv LANG LC_*
    HashKnownHosts yes
    GSSAPIAuthentication yes
supervisore@Serverlab:~$


ed ecco il sshd_config
Codice: Seleziona tutto
supervisore@Serverlab:~$ cat /etc/ssh/sshd_config
#   $OpenBSD: sshd_config,v 1.101 2017/03/14 07:19:07 djm Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

PubkeyAuthentication no
# Expect .ssh/authorized_keys2 to be disregarded by default in future.
#AuthorizedKeysFile   .ssh/authorized_keys .ssh/authorized_keys2

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
PermitEmptyPasswords yes

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# override default of no subsystems
Subsystem   sftp   /usr/lib/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#   X11Forwarding no
#   AllowTcpForwarding no
#   PermitTTY no
#   ForceCommand cvs server

AllowUsers docente
Ultima modifica di smurf il sabato 15 giugno 2019, 5:33, modificato 2 volte in totale.
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 19:15

Ecco le cartelle della home dell'utente sul server

Codice: Seleziona tutto
supervisore@Serverlab:~$ ls -al /home/docente
total 100
drwxr-xr-x 16 docente docente 4096 ene  8 12:23 .
drwxr-xr-x  5 root    root    4096 ene  8 12:19 ..
-rw-------  1 docente docente   85 ene  8 12:26 .bash_history
-rw-r--r--  1 docente docente  220 ene  8 12:19 .bash_logout
-rw-r--r--  1 docente docente 3771 ene  8 12:19 .bashrc
drwxr-xr-x  8 docente docente 4096 ene  8 12:21 .cache
drwx------ 13 docente docente 4096 ene  8 12:21 .config
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Descargas
-rw-r--r--  1 docente docente   23 ene  8 12:21 .dmrc
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Documentos
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Escritorio
drwx------  3 docente docente 4096 ene  8 12:21 .gnupg
-rw-------  1 docente docente  330 ene  8 12:21 .ICEauthority
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Imágenes
drwx------  3 docente docente 4096 ene  8 12:21 .local
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Música
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Plantillas
-rw-r--r--  1 docente docente  807 ene  8 12:19 .profile
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Público
drwxr-xr-x  3 docente docente 4096 ene  8 12:21 snap
drwx------  2 docente docente 4096 ene  8 12:59 .ssh
drwxr-xr-x  2 docente docente 4096 ene  8 12:21 Vídeos
-rw-------  1 docente docente   54 ene  8 12:21 .Xauthority
-rw-------  1 docente docente 6113 ene  8 12:27 .xsession-errors
supervisore@Serverlab:~$ sudo ls -al /home/docente/.ssh
total 8
drwx------  2 docente docente 4096 ene  8 12:59 .
drwxr-xr-x 16 docente docente 4096 ene  8 12:23 ..
-rw-r--r--  1 docente docente    0 ene  8 12:59 known_hosts
supervisore@Serverlab:~$
Ultima modifica di smurf il martedì 8 gennaio 2019, 19:48, modificato 1 volta in totale.
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 19:28

hai provato con "ssh docente@192.168.3.10" a connetterti ed inserire la password di docente?

Scusa, docente è anche utente nel computer remoto ?
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 19:44

Sam9999 Immagine ha scritto:hai provato con "ssh docente@192.168.3.10" a connetterti ed inserire la password di docente?

si, sono i due output che ho postato all'inizio del post



Scusa, docente è anche utente nel computer remoto ?

ovviamente si.


edit:

scusa quelli li ho fatti senza docente@ , perché prende in automatico l'utente corrente, comunque ecco qui:

Codice: Seleziona tutto
docente@Aula16:~$ ssh docente@192.168.3.10
docente@192.168.3.10's password:
Permission denied, please try again.
docente@192.168.3.10's password:
Permission denied, please try again.
docente@192.168.3.10's password:
docente@192.168.3.10: Permission denied (publickey,password).
docente@Aula16:~$
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 19:58

Qualche dato in più.

stando sul server stesso posso fare login via ssh , nessun problema, da remoto no. Non capisco.

Da remoto vedo la porta aperta:
Codice: Seleziona tutto
docente@Aula16:~$ nc -v 192.168.3.10 22
Connection to 192.168.3.10 22 port [tcp/ssh] succeeded!
SSH-2.0-dropbear


A questo punto immagino sia un problema di rete, o sbaglio?
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 21:39

Da remoto hai abilitato a poterti connettere?
Credo si possa abilitare o disabilitare sia root che utente.
Fai una cosa in /etc/ssh/sshd_config elimina o commenta la riga finale e riprova
"AllowUsers docente"

Inoltre noto che ti puoi connettere anche come root@192.168.3.10 22 in quanto non lo hai disabilitato, quidni sarebbe da decommentare "PermitRootLogin prohibit-password"
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 21:45

si, ho già tolto la riga AllowUsers.

A cosa ti riferisci con
Da remoto hai abilitato a poterti connettere?
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 21:47

smurf Immagine ha scritto:si, ho già tolto la riga AllowUsers.

A cosa ti riferisci con
Da remoto hai abilitato a poterti connettere?


No ninete ho visto che c'è la configurazione solo per root gli altri utenti sono quelli PAM gia abilitati "UsePAM yes"

Ho controlalto la tua configurazione e il file è uguale al mio.. inoltre pinghi quindi non sei bloccato da firewall.

Hai un denyhost abilitato ?
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 21:54

Hai un denyhost abilitato ?


non so cos'è
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 22:02

smurf Immagine ha scritto:
Hai un denyhost abilitato ?


non so cos'è



Serve per bannare gli IP che cercano di entrare via ssh.... ma se non lo hai, quindi non è colpa sua.
magari controlla lo stesso se in iptables, nella firewall hai l'ip bloccato per ssh o porta 22.
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 22:07

no, non c'è nessun blocco per ip
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 22:10

smurf Immagine ha scritto:no, non c'è nessun blocco per ip


Allora non so... c'è da controllare gli utenti del pc dove ti connetti se è tutto a posto con l'utente docente.

Non mi ricordo se una volta, ma pera per ftp normale che non si connetteva, poi dopo un po' di tempo (un pio di settimane), aggiornamenti di sistema e una reinstallazione si risolse.

Prova con l'utente root se si connette.

Puoi anche provare a creare un altro utente e quindi connetterti con quello ..
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Re: non riesco a connettermi via ssh al server

Messaggioda Filoteo » martedì 8 gennaio 2019, 22:17

Il server SSH al quale ti connetti è Dropbear, non OpenSSH quindi modificare le impostazioni di quest’ultimo è ininfluente. Io proverei a disabilitare Dropbear e abilitare OpenSSH al suo posto.
Filoteo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 538
Iscrizione: agosto 2015
Desktop: Gnome
Distribuzione: Arch Linux

Re: non riesco a connettermi via ssh al server

Messaggioda DoctorStrange » martedì 8 gennaio 2019, 22:19

Visto che parli di remoto, hai aperto le porte sulmrouter, per il forwarding? Ma sospetto di si, perchè sembra che la connessione ti si apra.

Prova a consultare i log di ssh sotto /var/log .
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1717
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 22:21

Filoteo Immagine ha scritto:Il server SSH al quale ti connetti è Dropbear, non OpenSSH quindi modificare le impostazioni di quest’ultimo è ininfluente. Io proverei a disabilitare Dropbear e abilitare OpenSSH al suo posto.


come si fa?
io ho installato openssh-server come sempre da repos....
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda smurf » martedì 8 gennaio 2019, 22:23

DoctorStrange Immagine ha scritto:Visto che parli di remoto, hai aperto le porte sulmrouter, per il forwarding? Ma sospetto di si, perchè sembra che la connessione ti si apra.

Prova a consultare i log di ssh sotto /var/log .


non c'è nessun log per ssh in /var/log
La terra non è una eredità che riceviamo dai nostri genitori, ma un prestito che ci fanno i nostri figli.
Avatar utente
smurf
Rampante Reduce
Rampante Reduce
 
Messaggi: 5490
Iscrizione: luglio 2006
Località: Lima - Perú
Desktop: MATE con Compiz
Distribuzione: Ubuntu 18.04 con kernel 5.0
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 22:25

smurf Immagine ha scritto:
Filoteo Immagine ha scritto:Il server SSH al quale ti connetti è Dropbear, non OpenSSH quindi modificare le impostazioni di quest’ultimo è ininfluente. Io proverei a disabilitare Dropbear e abilitare OpenSSH al suo posto.


come si fa?
io ho installato openssh-server come sempre da repos....


Hai installato anche openssh-client ?
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Re: non riesco a connettermi via ssh al server

Messaggioda DoctorStrange » martedì 8 gennaio 2019, 22:28

Auth.log e syslog dovrebbero tracciare tutte le connessioni.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1717
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: non riesco a connettermi via ssh al server

Messaggioda Filoteo » martedì 8 gennaio 2019, 22:34

Fai
Codice: Seleziona tutto
systemctl status dropbear
e
Codice: Seleziona tutto
systemctl status sshd
Filoteo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 538
Iscrizione: agosto 2015
Desktop: Gnome
Distribuzione: Arch Linux

Re: non riesco a connettermi via ssh al server

Messaggioda Sam9999 » martedì 8 gennaio 2019, 22:35

In sshd_config hai da commentare

Codice: Seleziona tutto
# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
PermitEmptyPasswords yes
PubkeyAuthentication no


Vedo che sono stati abilitati a me non lo sono..
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1827
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.10 (Eoan Ermine)

Successiva

Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti