Risolto: Sparizione uscita audio hdmi

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming e altro.
Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Risolto: Sparizione uscita audio hdmi

Messaggio da rickybanzai » mercoledì 29 gennaio 2020, 22:24

Buonasera, dopo molti mesi di onorato servizio è sparita l'opzione "hdmi" dal menu "imostazioni di sistema - Audio", lasciandomi solo con "cuffie analogiche e linea out" - che vanno tutte e due sullo stereo collegato all'uscita audio.
Ho fatto qualche ricerca e qualche tentativo senza esito:

Codice: Seleziona tutto

ricky@hal-9000:~$ cat /proc/asound/cards
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb00000 irq 16
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe940000 irq 40
ricky@hal-9000:~$ aplay /usr/share/sounds/alsa/Front_Center.wav
Riproduzione in corso WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Frequenza 48000 Hz, Mono
ricky@hal-9000:~$ alsamixergui

ricky@hal-9000:~$ aplay /usr/share/sounds/alsa/Front_Center.wav
Riproduzione in corso WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Frequenza 48000 Hz, Mono
ricky@hal-9000:~$ alsamixergui

ricky@hal-9000:~$ 

Allego l'aspetto attuale del menu citato (audio in impostazioni di sistema.
Non ho fatto nulla di hardware nè software, installato alcunchè di nessun genere nè fatto alcun esperimento rispetto a quando funzionava regolarmente e l'audio della tv funziona regolarmente.
Ringrazio e saluto.
Immagine
Ultima modifica di rickybanzai il domenica 28 giugno 2020, 11:34, modificato 1 volta in totale.
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39054
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Sparizione uscita audio hdmi

Messaggio da steff » giovedì 30 gennaio 2020, 8:28

In

Codice: Seleziona tutto

alsamixer
puoi arrivare alla scheda con F6?
Potrebbe essere un problema a livello utente/gui, potresti provare di creare un altro utente e verificare con questo.
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
Apanta
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 525
Iscrizione: domenica 17 gennaio 2010, 10:51
Distribuzione: Ubu16.04desk-Ubu18.04-mx19
Sesso: Maschile
Località: Marsala

Re: Sparizione uscita audio hdmi

Messaggio da Apanta » giovedì 30 gennaio 2020, 11:24

in passato, sulla medesima distribuzione (dalla quale ti sto scrivendo) ho risolto il problema installando pavucontrol.

lo trovi sul software center e ti consente di gestire in maniera migliore le periferiche audio.
In alternativa da terminale:

Codice: Seleziona tutto

sudo apt install pavucontrol
Allegati
regolaz.volume pulseaudio.png
La presunzione di sapere è peggio dell'ignoranza

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » venerdì 31 gennaio 2020, 18:46

Ho installato pavucontrol, ma la situazione non cambia: allego la finestra che mi si presenta aprendolo. Ho provato ad attivare tutti i file audio dell'elenco, ma non succede niente. C'è un passo avanti, hdmi adesso è ricomparsa, ma viene segnalata unplugged. Il video veramente passa...ho provato a staccare e riattaccare il cavo un paio di volte sperando nell'ossido, ma senza esito.
edit:
ravanando in pavucontrol apro la scheda riproduzione e vedo una bella barra tipo vu meter che mi segnala che chrome (tramite youtube) eroga audio. provo a riprodurre un file audio e si aggiunge anche vlc alla videata. Sembra che l'audio venga prodotto, ma si perda tra l'uscita e la tv (l'audio della tv funziona). Cavo danneggiato, oppure un opzione che mi sfugge?
Immagine
Immagine
Ultima modifica di rickybanzai il venerdì 31 gennaio 2020, 18:53, modificato 1 volta in totale.
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39054
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Sparizione uscita audio hdmi

Messaggio da steff » venerdì 31 gennaio 2020, 18:53

E sotto port cliccando la freccia niente?
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
Apanta
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 525
Iscrizione: domenica 17 gennaio 2010, 10:51
Distribuzione: Ubu16.04desk-Ubu18.04-mx19
Sesso: Maschile
Località: Marsala

Re: Sparizione uscita audio hdmi

Messaggio da Apanta » venerdì 31 gennaio 2020, 20:01

A me invece segnala plugged in, per cui penso ad un cavo hdmi difettoso.
prova a sostituirlo.
Allegati
pavucontrol.png
La presunzione di sapere è peggio dell'ignoranza

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » venerdì 31 gennaio 2020, 21:09

@ steff: SI! sotto "PORT" cliccando per spostare il cursore del volume fa una specie di "BOP" proporzionale al volume scelto. Allora mi viene da pensare ad un settaggio che zittisce l'uscita audio...ma cosa può essere? magari un impostazione della scheda video? per curiosità sono andato a vedere in impostazioni di sistema - driver aggiuntivi: nessun driver aggiuntivo disponibile. Può essere collegato al problema?
edit: anche cambiando cavo dà sempre unplugged...però il "bop" lo fa...
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39054
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Sparizione uscita audio hdmi

Messaggio da steff » sabato 1 febbraio 2020, 8:58

Veramente intendevo il menu a tendina attivata con la freccia giù, per vedere se c'è un altro port.
Penso anch' io che è zittito però.
Per scrupolo potresti provare un altro utente, prova anche avviare con un altro kernel precedente, visto che prima andava.
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » sabato 1 febbraio 2020, 16:01

In Uscite mi propone 2 possibilità:
1) hdmi(unplugged) e cliccando a dx sulla freccetta si apre la tendina ma c'è solo quello, e
2) Linea out (plugged in) che propone anche Cuffie analogiche (funzionano tutti e 2 e finiscono allo stereo).
Utilizzare l'utente ospite non ha prodotto risultati.
La sparo per disperazione, ma installare l'ultimo Catalist per la scheda video? attualmente sto usando xorg, magari un altro driver fa il miracolo. Bene o male, la hdmi è attaccata alla scheda video...
Oppure, tornando al tuo suggerimento...come cambio kernel?? :shy:
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39054
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Sparizione uscita audio hdmi

Messaggio da steff » sabato 1 febbraio 2020, 18:12

Per cambiare kernel all'avvio premi subito maiusc, dovrebbe apparire grub, poi sotto avanzate scegli quello precedente o ancora un altro.
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5276
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Sparizione uscita audio hdmi

Messaggio da Roberto Pontecorvi » domenica 2 febbraio 2020, 21:45

Puoi postare il risultato del comando:

Codice: Seleziona tutto

alsamixer

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » lunedì 3 febbraio 2020, 18:28

Ecco la risposta di alsamixer:

Immagine

Il mio pc è dual boot, quindi grub parte sempre, però mi sembra che proponga solo un kernel. Ricontrollerò, di solito non ci faccio molta attenzione.
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Avatar utente
Apanta
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 525
Iscrizione: domenica 17 gennaio 2010, 10:51
Distribuzione: Ubu16.04desk-Ubu18.04-mx19
Sesso: Maschile
Località: Marsala

Re: Sparizione uscita audio hdmi

Messaggio da Apanta » lunedì 3 febbraio 2020, 18:46

Io credo sia solo un problema di scegliere la configurazione giusta.
Il mio pavucontrol é:
Immagine
cliccando sulla linguetta relativa al profilo dell'uscita hdmi, io trovo diverse soluzioni tra cui quella funzionante per me.
Allegati
pavucontrol2.png
La presunzione di sapere è peggio dell'ignoranza

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5276
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Sparizione uscita audio hdmi

Messaggio da Roberto Pontecorvi » lunedì 3 febbraio 2020, 20:51

Come vedi dalla schermata sulla sua destra ci sono dei segni, questo vuol dire che ci sono altre informazioni. Allarga la schermata e ripostala completa.

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » martedì 4 febbraio 2020, 20:47

Il cambio di kernel ha fatto il miracolo, hdmi è tornata. Allego output di alsamixer in versione completa, relativo alla sessione col kernel funzionante.
Schermata del 2020-02-04 20-01-39.png
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5276
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Sparizione uscita audio hdmi

Messaggio da Roberto Pontecorvi » mercoledì 5 febbraio 2020, 8:20

Se hai risòlto bene. Se vuoi continuare i controlli da alsamixer premi F6 scegli la scheda video e se vuoi puoi postare la schermata che ti propone. Devi far attenzione alle voci indicate come -> S/pidf siano attivate

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » martedì 11 febbraio 2020, 17:14

Partito col kernel problematico, in opzioni - audio hdmi non c'è ma funziona lo stesso, allego la videata di alsamixer scelta (f6) = HDA ATI HDMI - come da indicazioni. s/pidf è sovrastato da un "00", farebbe pensare a una disattivazione (ipotizzo perchè non conosco).
Il problema acuto è risolto, ma non mi dispiacerebbe, per una volta, capire cosa è successo...e magari sistemarlo.
Grazie.
Schermata del 2020-02-11 17-06-54.png
Schermata del 2020-02-11 17-06-54.png (21.83 KiB) Visualizzato 669 volte
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5276
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Sparizione uscita audio hdmi

Messaggio da Roberto Pontecorvi » mercoledì 12 febbraio 2020, 21:30

Quando la porta HDMI è disattivata s/pdif è "MM". Può essere un problema di avvio dei programmi di gestione, che si erano incasinati. Con gli aggiornamenti come sei messo??

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 208
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: Sparizione uscita audio hdmi

Messaggio da rickybanzai » venerdì 14 febbraio 2020, 19:10

Mi sembra di aver fatto un aggiornameto un pò prima dell'inizio dei problemi (ma direi che non sono iniziati subito dopo, ha funzionato regolare per un pò), attualmente se accedo all'applicazione degli aggiornamenti mi rova 82 MB da scaricare, ma non trovo una data dell'ultimo aggiornamento.

@AntonelaG

Codice: Seleziona tutto

ricky@hal-9000:~$ xrandr
Screen 0: minimum 320 x 200, current 1360 x 768, maximum 8192 x 8192
HDMI-0 connected primary 1360x768+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080     50.00 +  60.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1280x1024     75.02    60.02  
   1360x768      60.02* 
   1280x768      59.87    59.99  
   1280x720      60.00    50.00    59.94  
   1024x768      75.08    70.07    60.00  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
ricky@hal-9000:~$ 

Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5276
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Sparizione uscita audio hdmi

Messaggio da Roberto Pontecorvi » domenica 16 febbraio 2020, 8:58

Come vedi:
HDMI-0 connected
la porta è in uso. Può essere che c^è qualche problema per completare l'aggiornamento. Da terminale dai i seguenti comandi:

Codice: Seleziona tutto

sudo apt update
sudo apt dist-upgrade

Scrivi risposta

Ritorna a “Multimediale”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite