problemi nvidia geforce gtx770

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

problemi nvidia geforce gtx770

Messaggio da rickybanzai » domenica 26 gennaio 2020, 11:42

Buongiorno,
sul mio pc, dopo un mese di funzionamento corretto, incontro problemi di scheda video. Quando inizia a caricar ubuntu, sparisce l'immagine e il monitor segnala mancanza di segnale video. Ho provato ad attivare i driver proprietari da Impostazioni di sistema - software e aggiornamenti - driver aggiuntivi ma non cambia una virgola. Ho scaricato il driver dal sito di Nvidia (440.40) ma mi segnala:

Codice: Seleziona tutto

        NVIDIA Accelerated Graphics Driver for Linux-x86_64 (390.132)


  ERROR: You appear to be running an X server; please exit X before            
         installing.  For further details, please see the section INSTALLING   
         THE NVIDIA DRIVER in the README available on the Linux driver         
         download page at www.nvidia.com.

                                       OK  

  NVIDIA Software Installer for Unix/Linux                      www.nvidia.com 


X server dovrebbe essere già disattivato. Ho provato anche un versione più vecchia del driver, 390.132, ma il risultato è lo stesso.
In questo momento funziona tutto, ma non so se succederà di nuovo.
Saluto e ringrazio.
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » venerdì 31 gennaio 2020, 9:09

Posta il risultato del comandi:

Codice: Seleziona tutto

dpkg -l | grep nvidia

ulisse77
Prode Principiante
Messaggi: 15
Iscrizione: venerdì 17 febbraio 2012, 10:06

Re: problemi nvidia geforce gtx770

Messaggio da ulisse77 » venerdì 31 gennaio 2020, 9:21

anche io ho avuto gli stessi problemi, però dopo che avevo quasi perso la speranza, al successivo riavvio ho trovato il driver 390 installato, e il sistema riporta che è installato in maniera manuale

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » sabato 1 febbraio 2020, 16:37

Codice: Seleziona tutto

nene@nene-enigma:~$ dpkg -l | grep nvidia
ii  nvidia-384                                  384.130-0ubuntu0.16.04.2                        amd64        NVIDIA binary driver - version 384.130
ii  nvidia-opencl-icd-384                       384.130-0ubuntu0.16.04.2                        amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                0.8.2                                           amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                             361.42-0ubuntu1                                 amd64        Tool for configuring the NVIDIA graphics driver
nene@nene-enigma:~$ 

Attualmente il pc parte regolarmente una volta su 3, circa.
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » domenica 2 febbraio 2020, 21:21

Vedo che sono in uso i 384. Prova a configurarli di nuovo con il comando:

Codice: Seleziona tutto

sudo dpkg-reconfigure nvidia-384
e poi:

Codice: Seleziona tutto

sudo dpkg-reconfigure xserver-xorg
e riavvia il pc. Quale distribuzione usi??? Cosi vediamo se ci sono altri problemi, come proseguire. Inoltre se non hai due schede grfiche ti consiglio di eliminare -> nvidia-prime.

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » venerdì 7 febbraio 2020, 19:35

Eseguiti i 2 comandi, questo è tutto quello che il terminale ha fatto:

Codice: Seleziona tutto

nene@nene-enigma:~$ sudo dpkg-reconfigure nvidia-384
[sudo] password di nene: 
Removing all DKMS Modules
Done.
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-384
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Loading new nvidia-384-384.130 DKMS files...
Building only for 4.15.0-76-generic
Building for architecture x86_64
Building initial module for 4.15.0-76-generic
Done.

nvidia_384:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-76-generic/updates/dkms/

nvidia_384_modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-76-generic/updates/dkms/

nvidia_384_drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-76-generic/updates/dkms/

nvidia_384_uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-76-generic/updates/dkms/

depmod....

DKMS: install completed.
Elaborazione dei trigger per initramfs-tools (0.122ubuntu8.16)...
update-initramfs: Generating /boot/initrd.img-4.15.0-76-generic
nene@nene-enigma:~$ sudo dpkg-reconfigure xserver-xorg
dpkg-query: il pacchetto "xserver-xorg" non è installato e non è disponibile alcuna informazione
Usare "dpkg --info" (= "dpkg-deb --info") per esaminare gli archivi e
"dpkg --contents" (= "dpkg-deb --contents") per elencarne il contenuto.
/usr/sbin/dpkg-reconfigure: xserver-xorg non è installato
nene@nene-enigma:~$ -
a questo punto devo ancora riavviare.
In teoria ho 2 schede video: la gtx 770 e l'integrata della scheda madre, che però non uso.
Edit: riavviato e funziona. Per la verità l'utilizzatrice mi dice che gli ultimi 10 avvii sono stati tutti regolari. Rispetto al 1° febbraio, quando partiva 1 volta su 3, non ho fatto niente (e neppure l'utilizzatrice).
Edit 2: ubuntu 16.4,
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Avatar utente
Apanta
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 468
Iscrizione: domenica 17 gennaio 2010, 10:51
Distribuzione: Ubu16.04desk-Ubu18.04-mx19
Sesso: Maschile
Località: Marsala

Re: problemi nvidia geforce gtx770

Messaggio da Apanta » venerdì 7 febbraio 2020, 19:51

Se funziona . . . . . non toccare :D :D
La presunzione di sapere è peggio dell'ignoranza

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » mercoledì 12 febbraio 2020, 21:32

Molto bene.

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » venerdì 14 febbraio 2020, 19:13

Seguo con entusiasmo il consiglio degli esperti e non ci metto ulteriormente le mani. Passato un pò di tempo non sono emersi altri problemi. Quindi...risolto! Non so come ma risolto....Metto "risolto" nel titolo anche se non so cosa sia successo nè come abbia fatto?
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » martedì 18 febbraio 2020, 9:04

sudo dpkg-reconfigure nvidia-384
Sono stati riconfigurati di nuovo i drive. C'è ancora qualcosa d sistemare, vuoi continuare???

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » giovedì 27 febbraio 2020, 14:49

Voglio continuare,si!! nel frattempo, dopo alcuni giorni di funzionamento regolare, che faceva credere per il meglio, siamo sprofondati nell'abisso: si accende una volta su 10.
Attualmente scrivo con un altro. Riassumo hardware e software: mobo asus m5a78l-m le usb3, processore amd athlon 2 x2 250, sdd kingston 480 gb sata3, ram 4 gb ddr3 corsair, sk video nvidia geforce gtx770, ubuntu 16.04.
Oggi ho aggiornato con successo il bios della scheda madre con l'ultimo driver disponibile sul sito asus, ma non è servito a niente. Il sistema esegue il boot, inizia a caricare ubuntu e dopo un pò perde il segnale video. La barra di caricamento si presenta un pò strana, i pallini sono arancio al centro di un quadratino viola. Ne fa tre e poi non dà più nessun segni di vita.
Non parte neppure con la live: riconosce la chiavetta e inizia a caricare da li, ma dopo un pò perde il segnale video.
...sarà mica la gtx abbrustolita???? l'ho comprata usata, ma usata poco...
L'alimentatore è sui 700w e le recensioni dicono non sono puramente nominali (in breve dovrebbe essere ampiamente sufficiente).
Speravo di aver risolto e invece non so che pesci prendere... :muro:
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » venerdì 28 febbraio 2020, 12:26

Il grub in iniziale ti compare? Se si ti fa accedere in modo recovery?

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » venerdì 28 febbraio 2020, 15:52

Il grub parte a volte, normalmente se parte e la grafica è quella consueta, il pc si avvia regolarmente. Altre volte ubuntu parte direttamente, senza grub, ma si pianta e altre volte ci sono problemi di grafica già nella visualizzazione di grub, che appare anormalmente grande e sgranato (come avesse la risoluzione troppo bassa) e si pianta anche in questo caso. 3 tipologie di avvio diverse.
Ho provato anche a fare qualche tentativo con un supergrub disk, ma senza esito.
In software e aggiornamenti - driver aggiuntivi risulta attivo Nvidia binary driver 384.130.
In fase di installazione del SO non avevo installato grub perchè il sistema avrebbe avuto solo ubuntu, pensando che meno roba c'era meno problemi avrei avuto. Invece....
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » venerdì 28 febbraio 2020, 17:11

Da modo recovery:
- abilita rete;
- Passa a una shell con privileggi di root;
- dai i comandi di aggiornamento del sistema;
- dai i comandi del post precedente (riconfigurazione dei drive e xorg);
- ripara pacchetti danneggiati;
e per ultimo:
- Ripristina l'avvio normale.

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » domenica 1 marzo 2020, 21:41

Tutto chiaro, solo una conferma: per aggiornare il sistema uso:

Codice: Seleziona tutto

sudo apt update
sudo apt dist-upgrade
è corretto?
Grazie delle indicazioni e speriamo bene. Forse ci vorrà qualche giorno prima del tentativo.
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4885
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate
Sesso: Maschile
Località: Versilia

Re: problemi nvidia geforce gtx770

Messaggio da Roberto Pontecorvi » lunedì 2 marzo 2020, 6:12

I comandi per aggiornare sono quelli.

Avatar utente
rickybanzai
Prode Principiante
Messaggi: 190
Iscrizione: sabato 17 ottobre 2009, 21:03

Re: problemi nvidia geforce gtx770

Messaggio da rickybanzai » domenica 8 marzo 2020, 16:20

Ho fatto tutto come suggerito, ma non è servito. Preso dalla disperazione, ho rimosso la scheda video gtx770 e rimontato l'hd con windows. Volevo verificare con un sistema che sapevo funzionante. Dopo un passaggio di supergrubdisk, che ha ripristinato il bootloader di win, è partito windows regolarmente.
Riprovo il sdd con ubuntu, sempre senza sk. video, e mi parte se uso SGD. Penso di avere 2 problemi, il grub da rigenerare e probabilmente la scheda video che non funziona (sempre) correttamente.
Adesso proverò a rigenerare il grub e poi, se sistemo quello, rimonto la gtx e incrocio le dita. Diciamo che per il momento usare la scheda video integrata sarebbe accettabile.
Grazie per tutto l'aiuto, a prescindere dal successo.... :birra:
Edit: adesso sembra partire regolarmente senza aiuti di sorta da sgd o dischi live. La prova con la gtx770 la farò tra qualche giorno, appena trovo il coraggio....
Pc autoassemblato: Amd athlon 4 x 3.5 GHz, Asrock fm2a68m-dg3+, 4 GB ram, Sapphire hd 5570 1 GB, SSD Samsung 250 GB, HD Western Digital 1 TB, HD Western Digital 2 TB, 1 HD Seagate 1 TB, case non identificato, alimentatore 650 W, 3 fan. Ubuntu 16.4 + win 10 dual boot grub. :birra:

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Aidhen, Google [Bot] e 30 ospiti