[Risolto] Reti 5Ghz non rilevate

Networking, configurazione della connessione, periferiche e condivisioni di rete.
Scrivi risposta
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

[Risolto] Reti 5Ghz non rilevate

Messaggio da rman010 »

Buongiorno a tutti, ho da poco installato Ubuntu 20.04 LTS sul mio notebook HP fq-0020nl montante come network adapter la scheda Realtek RTL8821CE che so per certo sia dual-band. Il mio problema è che non capisco come mai non riesca a rilevare le reti wireless in 5Ghz (che ho in casa e che sono certo siano accessibili).
Se qualcuno può illuminarmi lo ringrazio in anticipo!
Ultima modifica di rman010 il lunedì 21 settembre 2020, 1:17, modificato 1 volta in totale.
Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6063
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Reti 5Ghz non rilevate

Messaggio da willy54 »

Se hai una rtl8821ce il tuo pc è Uefi, come hai installato ?
quanto segue è tratto da inxi -Fz del mio Pavilion e le reti 5ghz funzionano benissimo.

Codice: Seleziona tutto

enzo@enzo-HP-Pavilion-Laptop-15-cs2xxx:~$ inxi -Fz
System:
  Kernel: 5.4.0-42-lowlatency x86_64 bits: 64 Desktop: Xfce 4.14.2
  Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 15-cs2xxx
  v: Type1ProductConfigId serial: <filter>
  Mobo: HP model: 84C1 v: 15.32 serial: <filter> UEFI: Insyde v: F.22
  date: 05/27/2020
Battery:
  ID-1: BAT0 charge: 40.8 Wh condition: 40.8/40.8 Wh (100%)
CPU:
  Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP
  L2 cache: 8192 KiB
  Speed: 2781 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 2900 2: 2900
  3: 2900 4: 2900 5: 2902 6: 2899 7: 2901 8: 2900
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX250] driver: nvidia v: 440.100
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce MX250/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-42-lowlatency
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  driver: rtl8821ce
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: eno1 state: down mac: <filter>
Drives:
  Local Storage: total: 471.36 GiB used: 14.29 GiB (3.0%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB
  ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
Partition:
  ID-1: / size: 39.98 GiB used: 13.90 GiB (34.8%) fs: ext4
  dev: /dev/nvme0n1p6
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

Re: Reti 5Ghz non rilevate

Messaggio da rman010 »

willy54 ha scritto:
lunedì 14 settembre 2020, 14:53
Se hai una rtl8821ce il tuo pc è Uefi, come hai installato ?
quanto segue è tratto da inxi -Fz del mio Pavilion e le reti 5ghz funzionano benissimo.

Codice: Seleziona tutto

enzo@enzo-HP-Pavilion-Laptop-15-cs2xxx:~$ inxi -Fz
System:
  Kernel: 5.4.0-42-lowlatency x86_64 bits: 64 Desktop: Xfce 4.14.2
  Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 15-cs2xxx
  v: Type1ProductConfigId serial: <filter>
  Mobo: HP model: 84C1 v: 15.32 serial: <filter> UEFI: Insyde v: F.22
  date: 05/27/2020
Battery:
  ID-1: BAT0 charge: 40.8 Wh condition: 40.8/40.8 Wh (100%)
CPU:
  Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP
  L2 cache: 8192 KiB
  Speed: 2781 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 2900 2: 2900
  3: 2900 4: 2900 5: 2902 6: 2899 7: 2901 8: 2900
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX250] driver: nvidia v: 440.100
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce MX250/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-42-lowlatency
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  driver: rtl8821ce
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: eno1 state: down mac: <filter>
Drives:
  Local Storage: total: 471.36 GiB used: 14.29 GiB (3.0%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB
  ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
Partition:
  ID-1: / size: 39.98 GiB used: 13.90 GiB (34.8%) fs: ext4
  dev: /dev/nvme0n1p6
Chiedo venia, installato cosa?
In ogni caso questo è il mio, in caso possa servire

Codice: Seleziona tutto

inxi -fz

System:    Kernel: 5.4.0-47-generic x86_64 bits: 64 Desktop: i3 4.17.1 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:   Type: Laptop System: HP product: HP Laptop 15s-fq0xxx v: N/A serial: <filter> 
           Mobo: HP model: 864F v: 55.18 serial: <filter> UEFI: AMI v: F.07 date: 10/18/2019 
Battery:   ID-1: BAT0 charge: 13.4 Wh condition: 37.1/37.1 Wh (100%) 
CPU:       Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 801 2: 800 3: 800 4: 800 
           5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: i915 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.0.8 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-47-generic 
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter driver: rtl8821ce 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 9.53 GiB (4.0%) 
           ID-1: /dev/nvme0n1 model: KBG30ZMV256G KIOXIA size: 238.47 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
Partition: ID-1: / size: 58.99 GiB used: 9.33 GiB (15.8%) fs: ext4 dev: /dev/nvme0n1p6 
           ID-2: /boot size: 1.85 GiB used: 140.5 MiB (7.4%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-3: swap-1 size: 1.91 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p7 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 222 Uptime: 27m Memory: 15.45 GiB used: 1.06 GiB (6.9%) Shell: bash 
           inxi: 3.0.38
Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6063
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Reti 5Ghz non rilevate

Messaggio da willy54 »

Postami

Codice: Seleziona tutto

sudo parted -l
efibootmgr -v
rfkill list all 
Di prima cosa la partizione di swap non ti serve con 16 gb di ram, già non serve con solo 8 gb.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

Re: Reti 5Ghz non rilevate

Messaggio da rman010 »

willy54 ha scritto:
lunedì 14 settembre 2020, 15:08
Postami

Codice: Seleziona tutto

sudo parted -l
efibootmgr -v
rfkill list all 
Di prima cosa la partizione di swap non ti serve con 16 gb di ram, già non serve con solo 8 gb.
Si in effetti quello swap non ha senso di esistere.

Codice: Seleziona tutto

sudo parted -l

Model: KBG30ZMV256G KIOXIA (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  274MB  273MB   fat32           EFI system partition          boot, esp
 2      274MB   290MB  16,8MB                  Microsoft reserved partition  msftres
 3      290MB   187GB  187GB   ntfs            Basic data partition          msftdata
 5      187GB   189GB  2048MB  ext4
 6      189GB   253GB  64,6GB  ext4
 7      253GB   256GB  2050MB  linux-swap(v1)                                swap
 4      256GB   256GB  510MB   ntfs            Basic data partition          hidden, diag

Codice: Seleziona tutto

efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,0002,9999
Boot0000* ubuntu	HD(1,GPT,05f24657-a018-43d6-bf09-66ed94f052df,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Windows Boot Manager	HD(1,GPT,05f24657-a018-43d6-bf09-66ed94f052df,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...&................
Boot0002* Solid State Disk	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-08-0D-04-00-B3-D9-4D)/HD(1,GPT,05f24657-a018-43d6-bf09-66ed94f052df,0x800,0x82000)..BO
Boot9999* USB Drive (UEFI)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)..BO

Codice: Seleziona tutto

rfkill list all

0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6063
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Reti 5Ghz non rilevate

Messaggio da willy54 »

I driver sono installati giusti, hai provato se con windows vede le reti ?
Con qualche probabilità con l'aggiornamento fatto da terminale dovrebbe andare a posto.
Anche a me prima degli aggiornamenti il bluetooth non funzionava aggiornata l'installazione tutto è andato a posto.

Codice: Seleziona tutto

sudo apt update 
sudo apt upgrade
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

Re: Reti 5Ghz non rilevate

Messaggio da rman010 »

willy54 ha scritto:
lunedì 14 settembre 2020, 18:43
I driver sono installati giusti, hai provato se con windows vede le reti ?
Con qualche probabilità con l'aggiornamento fatto da terminale dovrebbe andare a posto.
Anche a me prima degli aggiornamenti il bluetooth non funzionava aggiornata l'installazione tutto è andato a posto.

Codice: Seleziona tutto

sudo apt update 
sudo apt upgrade
Mi sono dimenticato di dire che ho aperto il thread perchè con windows non riscontro lo stesso problema. Ed inoltre non credo sia un problema di aggiornamenti perchè aggiorno il software quotidianamente (tra cui oggi) :nono: :nono:
Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6063
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Reti 5Ghz non rilevate

Messaggio da willy54 »

Per windows sul sito HP trovi gli aggiornamenti anche per il tuo wifi .
Registrandoti viene fornito un programma di diagnostica molto efficente che controlla ogni periferica incluso l'alimentatore.
Credo sia disponibile anche un nuovo bios/firmware datato luglio 2020.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

Re: Reti 5Ghz non rilevate

Messaggio da rman010 »

willy54 ha scritto:
lunedì 14 settembre 2020, 20:49
Per windows sul sito HP trovi gli aggiornamenti anche per il tuo wifi .
Registrandoti viene fornito un programma di diagnostica molto efficente che controlla ogni periferica incluso l'alimentatore.
Credo sia disponibile anche un nuovo bios/firmware datato luglio 2020.
Ti ringrazio per l'informazione ma con windows non ho nessun tipo di problema! Il problema resta solo con Ubuntu, e quanto può incidere un aggiornamento del firmware?
Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6063
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Reti 5Ghz non rilevate

Messaggio da willy54 »

A volte poco, a volte sistema molte cose.
E' comunque sempre opportuno avere l'ultimo disponibile. Se un produttore pubblica un aggiornamento del bios/firmware è per correggere problemi di quello precedente.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

Re: Reti 5Ghz non rilevate

Messaggio da rman010 »

willy54 ha scritto:
martedì 15 settembre 2020, 12:37
A volte poco, a volte sistema molte cose.
E' comunque sempre opportuno avere l'ultimo disponibile. Se un produttore pubblica un aggiornamento del bios/firmware è per correggere problemi di quello precedente.
Certamente, su questo non ci sono dubbi, ma secondo me è un problema più relativo al sistema operativo, o sbaglio?
rman010
Prode Principiante
Messaggi: 33
Iscrizione: mercoledì 3 gennaio 2018, 12:43
Desktop: i3
Distribuzione: Ubuntu 20.04.1 LTS 64bit
Sesso: Maschile

Re: Reti 5Ghz non rilevate

Messaggio da rman010 »

willy54 ha scritto:
martedì 15 settembre 2020, 12:37
A volte poco, a volte sistema molte cose.
E' comunque sempre opportuno avere l'ultimo disponibile. Se un produttore pubblica un aggiornamento del bios/firmware è per correggere problemi di quello precedente.
Ho in ogni caso effettuato l'aggiornamento ma non è cambiato nulla in termini di reti rilevate.

EDIT:

Ho risolto installando il driver per la scheda https://github.com/tomaspinho/rtl8821ce
Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 10 ospiti