[Risolto]Guvcview non funziona dopo avanzamento a 20.04

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming e altro.
davideuk
Prode Principiante
Messaggi: 34
Iscrizione: domenica 20 gennaio 2019, 21:29
Desktop: mate
Distribuzione: Ubuntu Mate 20.04.1 LTS x86_64
Sesso: Maschile

[Risolto]Guvcview non funziona dopo avanzamento a 20.04

Messaggio da davideuk »

Un saluto a tutti. Dopo l'avanzamento da 180.4 a 20.04 Guvcview ha smesso di funzionare. Se lancio il programma da menù appare una finestra con questo messaggio

Codice: Seleziona tutto

no video device found
se invece lancio il programma da terminale:

Codice: Seleziona tutto

GUVCVIEW: version 2.0.6
GUVCVIEW: couldn't open /root/.config/guvcview2/video0 for read: File o directory non esistente
V4L2_CORE: ERROR opening V4L interface: File o directory non esistente
GUVCVIEW (1): Guvcview error no video device found
(guvcview:16109): Gtk-WARNING **: 00:17:45.570: Theme parsing error: <data>:1:17: not a number
(guvcview:16109): Gtk-WARNING **: 00:17:45.570: Theme parsing error: <data>:1:31: Using Pango syntax for the font: style property is deprecated; please use CSS syntax
(guvcview:16109): Gtk-WARNING **: 00:17:45.570: Theme parsing error: <data>:1:17: not a number
(guvcview:16109): Gtk-WARNING **: 00:17:45.570: Theme parsing error: <data>:1:32: Using Pango syntax for the font: style property is deprecated; please use CSS syntax
La webcam è esterna con collegamento usb. Ho provato a rimuovere il programma e reinstallarlo ma non è cambiato nulla. Cosa può essere successo.
Un grazie anticipato per l'eventuale aiuto.
Ultima modifica di davideuk il sabato 17 ottobre 2020, 18:34, modificato 1 volta in totale.
Avatar utente
ivantu
Rampante Reduce
Rampante Reduce
Messaggi: 5584
Iscrizione: sabato 8 giugno 2013, 9:25
Desktop: Lubuntu
Distribuzione: 20.04 LTS, 20.10 21.04
Sesso: Maschile

Re: Guvcview non funziona dopo avanzamento a 20.04

Messaggio da ivantu »

cosa ti rispondono questi comandi al terminale?

con la webcam collegata alla porta usb

Codice: Seleziona tutto

cheese --device=/dev/video0

Codice: Seleziona tutto

ls -l /dev/video0

Codice: Seleziona tutto

dmesg | grep usb

Codice: Seleziona tutto

lsusb

Codice: Seleziona tutto

locate video0
Buona giornata utenti del forum. :ciao: ivantu
davideuk
Prode Principiante
Messaggi: 34
Iscrizione: domenica 20 gennaio 2019, 21:29
Desktop: mate
Distribuzione: Ubuntu Mate 20.04.1 LTS x86_64
Sesso: Maschile

Re: Guvcview non funziona dopo avanzamento a 20.04

Messaggio da davideuk »

ivantu ha scritto:
sabato 17 ottobre 2020, 12:34
cosa ti rispondono questi comandi al terminale? con la webcam collegata alla porta usb
Grazie ivantu per l'interessamento, ecco quanto mi hai chiesto

Codice: Seleziona tutto

cheese --device=/dev/video0
Gtk-Message: 16:12:37.336: Failed to load module "topmenu-gtk-module"
** Message: 16:12:41.777: cheese-application.vala:214: Error during camera setup: Nessun dispositivo trovato
(cheese:3262): cheese-CRITICAL **: 16:12:41.784: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed
(cheese:3262): GLib-CRITICAL **: 16:12:41.784: g_variant_new_string: assertion 'string != NULL' failed
(cheese:3262): GLib-CRITICAL **: 16:12:41.784: g_variant_ref_sink: assertion 'value != NULL' failed
(cheese:3262): GLib-GIO-CRITICAL **: 16:12:41.784: g_settings_schema_key_type_check: assertion 'value != NULL' failed
(cheese:3262): GLib-CRITICAL **: 16:12:41.784: g_variant_get_type_string: assertion 'value != NULL' failed
(cheese:3262): GLib-GIO-CRITICAL **: 16:12:41.784: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
(cheese:3262): GLib-CRITICAL **: 16:12:41.784: g_variant_unref: assertion 'value != NULL' failed
** (cheese:3262): CRITICAL **: 16:12:41.784: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed

Codice: Seleziona tutto

ls -l /dev/video0
ls: impossibile accedere a '/dev/video0': File o directory non esistente

Codice: Seleziona tutto

dmesg | grep usb
L'output è molto lungo, devo cercare qualcosa in particolare o te lo posto lungo com'è?

Codice: Seleziona tutto

lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 003 Device 003: ID 413c:2111 Dell Computer Corp. Dell USB Wired Entry Keyboard
Bus 003 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 003 Device 006: ID 0cf3:0036 Qualcomm Atheros Communications 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Codice: Seleziona tutto

locate video0
/home/davideuk/.config/guvcview2/video0
davideuk
Prode Principiante
Messaggi: 34
Iscrizione: domenica 20 gennaio 2019, 21:29
Desktop: mate
Distribuzione: Ubuntu Mate 20.04.1 LTS x86_64
Sesso: Maschile

Re: Guvcview non funziona dopo avanzamento a 20.04

Messaggio da davideuk »

AGGIORNAMENTO
Problema risolto. La webcam non è collegata direttamente al computer ma ad una multipresa usb dove di solito collego anche gli HD portatili.
Non riuscendo a collegare un HD ho fatto un po' di prove, risultato la multi presa non funziona più. Collegando l'HD direttamente al computer funziona, idem per la webcam collegata direttamente funziona. Vi chiedo scusa di non essermene accorto prima e di avervi sottratto tempo prezioso.
Grazie ancora.
Scrivi risposta

Ritorna a “Multimediale”

Chi c’è in linea

Visualizzano questa sezione: Google [Bot] e 8 ospiti