[Risolto] WIFI non funzionante dopo aggiornamento a 22.04

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
OMBRA_Linux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2001
Iscrizione: mercoledì 18 febbraio 2015, 14:24
Desktop: Android Linux Windows
Distribuzione: Android / Linux / Windows10-11
Sesso: Maschile
Località: Napoli

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da OMBRA_Linux »

stevini ha scritto:
lunedì 23 maggio 2022, 18:28
Ho controllato i driver e non mi da nessun driver da installare a parte quello della scheda grafica.
Dopo aver dato:

Codice: Seleziona tutto

sudo sysctl kernel.dmesg_restrict=0
questo è l'output che restituisce al comando sucessivo:

Codice: Seleziona tutto

stevini@stevini-N551JK:~$ dmesg | grep ath
[    3.746323] usbcore: registered new interface driver ath3k
[    3.857199] ath: phy0: ASPM enabled: 0x42
[    3.857205] ath: EEPROM regdomain: 0x6a
[    3.857206] ath: EEPROM indicates we should expect a direct regpair map
[    3.857209] ath: Country alpha2 being used: 00
[    3.857210] ath: Regpair used: 0x6a
[    3.967792] ath9k 0000:04:00.0 wlp4s0: renamed from wlan0
[    9.918658]  ath_txq_unlock_complete+0x12d/0x160 [ath9k]
[    9.918685]  ath_tx_edma_tasklet+0xef/0x4c0 [ath9k]
[    9.918733]  ath9k_tasklet+0x14e/0x290 [ath9k]
[   29.617949] audit: type=1107 audit(1653227142.675:75): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=2188 label="snap.snap-store.ubuntu-software" peer_pid=1042 peer_label="unconfined"
[   29.618275] audit: type=1107 audit(1653227142.675:77): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" mask="send" name=":1.7" pid=2188 label="snap.snap-store.ubuntu-software" peer_pid=1042 peer_label="unconfined"
[   29.620531] audit: type=1107 audit(1653227142.679:79): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=2188 label="snap.snap-store.ubuntu-software" peer_pid=1042 peer_label="unconfined"
[   38.360474] audit: type=1107 audit(1653219951.131:88): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call"  bus="system" path="/" interface="org.freedesktop.DBus.ObjectManager" member="GetManagedObjects" mask="send" name="org.bluez" pid=2780 label="snap.opera.opera" peer_pid=1020 peer_label="unconfined"
[  658.325304] ath: phy0: ASPM enabled: 0x42
[ 1900.652309] ath: phy0: ASPM enabled: 0x42
[ 1930.573711] ath: phy0: ASPM enabled: 0x42
[ 5757.810871] ath: phy0: ASPM enabled: 0x42
[ 5789.024364] ath: phy0: ASPM enabled: 0x42
[ 5819.393336] ath: phy0: ASPM enabled: 0x42
[ 5849.170407] ath: phy0: ASPM enabled: 0x42
[ 5880.387486] ath: phy0: ASPM enabled: 0x42
[ 5911.920638] ath: phy0: ASPM enabled: 0x42
[ 5942.493909] ath: phy0: ASPM enabled: 0x42
[ 5972.251790] ath: phy0: ASPM enabled: 0x42
[ 6002.412147] ath: phy0: ASPM enabled: 0x42
[ 6033.565805] ath: phy0: ASPM enabled: 0x42
[ 6064.347803] ath: phy0: ASPM enabled: 0x42
[ 6093.753087] ath: phy0: ASPM enabled: 0x42
[ 6123.854140] ath: phy0: ASPM enabled: 0x42
[ 6154.707142] ath: phy0: ASPM enabled: 0x42
[ 6185.111879] ath: phy0: ASPM enabled: 0x42
stevini@stevini-N551JK:~$

No parlo di Driver da installare.
Parlo che da ''Gestore Driver'' puoi abilitare i Driver proprietari poi riavvii il Pc e controlli se funziona.
Se per vivere devi strisciare, alzati e muori.
Avatar utente
stevini
Prode Principiante
Messaggi: 160
Iscrizione: giovedì 31 maggio 2007, 0:02

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da stevini »

@thece
Ieri ho aggiornato il kernel e purtroppo nessun cambiamento.
Ho inoltre provato a seguire i passi del collegamento che mi hai inviato:

Codice: Seleziona tutto

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
"Then changed the value from 3 to 2, save changes and reboot. if not working, switch back to 3."

Codice: Seleziona tutto

sudo nano /etc/gai.conf
"look for the line with precedence ::ffff:0:0/96 100 and removed the # character that preceded it. save changes and reboot. if not working add # back."

Non ottengo però nulla ne con la prima che con il seconda modifica dei file. Mentre riguardo al terzo, driver proprietari, non ne vedo visualizzati altri che quello della scheda grafica.
:(
stevini
Avatar utente
stevini
Prode Principiante
Messaggi: 160
Iscrizione: giovedì 31 maggio 2007, 0:02

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da stevini »

@OMBRA_Linux
Non saprei come installare un driver non presente nella lista dei driver aggiuntivi. E' quindi un problema di driver? Come posso fare?
Allego uno screenshot dei driver che visualizzo
Immagine
stevini
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24058
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da magozurlinux »

Con Ubuntu 20.04 LTS funziona?
Xubuntu 20.04 LTS 64bit - Saluti da magozurlinux :ciao:
Avatar utente
stevini
Prode Principiante
Messaggi: 160
Iscrizione: giovedì 31 maggio 2007, 0:02

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da stevini »

@magozurlinux
Beh, posto che aggiorno il sistema ogni 6 mesi, ed utilizzo Ubuntu da 15 anni, è la prima volta che mi da questo problema.
Quindi si, con la 20.04 la connessione WIFI mi funzionava.
stevini
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24058
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da magozurlinux »

stevini ha scritto:
lunedì 23 maggio 2022, 18:28
dmesg | grep ath
[ 3.746323] usbcore: registered new interface driver ath3k
[ 3.857199] ath: phy0: ASPM enabled: 0x42
[ 3.857205] ath: EEPROM regdomain: 0x6a
[ 3.857206] ath: EEPROM indicates we should expect a direct regpair map
[ 3.857209] ath: Country alpha2 being used: 00
[ 3.857210] ath: Regpair used: 0x6a
[ 3.967792] ath9k 0000:04:00.0 wlp4s0: renamed from wlan0
[ 9.918658] ath_txq_unlock_complete+0x12d/0x160 [ath9k]
[ 9.918685] ath_tx_edma_tasklet+0xef/0x4c0 [ath9k]
[ 9.918733] ath9k_tasklet+0x14e/0x290 [ath9k]
[ 29.617949] audit: type=1107 audit(1653227142.675:75): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=2188 label="snap.snap-store.ubuntu-software" peer_pid=1042 peer_label="unconfined"
[ 29.618275] audit: type=1107 audit(1653227142.675:77): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" mask="send" name=":1.7" pid=2188 label="snap.snap-store.ubuntu-software" peer_pid=1042 peer_label="unconfined"
[ 29.620531] audit: type=1107 audit(1653227142.679:79): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=2188 label="snap.snap-store.ubuntu-software" peer_pid=1042 peer_label="unconfined"
[ 38.360474] audit: type=1107 audit(1653219951.131:88): pid=1022 uid=105 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/" interface="org.freedesktop.DBus.ObjectManager" member="GetManagedObjects" mask="send" name="org.bluez" pid=2780 label="snap.opera.opera" peer_pid=1020 peer_label="unconfined"
[ 658.325304] ath: phy0: ASPM enabled: 0x42
[ 1900.652309] ath: phy0: ASPM enabled: 0x42
[ 1930.573711] ath: phy0: ASPM enabled: 0x42
[ 5757.810871] ath: phy0: ASPM enabled: 0x42
[ 5789.024364] ath: phy0: ASPM enabled: 0x42
[ 5819.393336] ath: phy0: ASPM enabled: 0x42
[ 5849.170407] ath: phy0: ASPM enabled: 0x42
[ 5880.387486] ath: phy0: ASPM enabled: 0x42
[ 5911.920638] ath: phy0: ASPM enabled: 0x42
[ 5942.493909] ath: phy0: ASPM enabled: 0x42
[ 5972.251790] ath: phy0: ASPM enabled: 0x42
[ 6002.412147] ath: phy0: ASPM enabled: 0x42
[ 6033.565805] ath: phy0: ASPM enabled: 0x42
[ 6064.347803] ath: phy0: ASPM enabled: 0x42
[ 6093.753087] ath: phy0: ASPM enabled: 0x42
[ 6123.854140] ath: phy0: ASPM enabled: 0x42
[ 6154.707142] ath: phy0: ASPM enabled: 0x42
[ 6185.111879] ath: phy0: ASPM enabled: 0x42
La scheda di rete wireless Atheros non funziona correttamente dovuto a dei bugs.

Da terminale connesso ad Internet dai questi comandi:

Codice: Seleziona tutto

sudo apt install apparmor-profiles

Codice: Seleziona tutto

sudo apparmor_status

Codice: Seleziona tutto

sudo systemctl reload apparmor.service
riavvia il pc.
Xubuntu 20.04 LTS 64bit - Saluti da magozurlinux :ciao:
Avatar utente
stevini
Prode Principiante
Messaggi: 160
Iscrizione: giovedì 31 maggio 2007, 0:02

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da stevini »

@magozurlinux
Tutti e 3 i comandi dati e riavviato.
Purtroppo nessuna bella notizia, continua a non connettersi.
stevini
Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18649
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da Janvitus »

stevini ha scritto:
martedì 24 maggio 2022, 19:58
@magozurlinux
Tutti e 3 i comandi dati e riavviato.
Purtroppo nessuna bella notizia, continua a non connettersi.
Ad ora, e non so perché ubuntu non faccia un backport della patch, si deve installare un kernel più nuovo del 5.15, io ho risolto installando il 5.17 dal repo mainline.
+Fedora 36 • +Xubuntu 22.04
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 12265
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 11 (Bullseye) - KDE

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da thece »

@stevini
Janvitus ha scritto:
martedì 24 maggio 2022, 20:23
Ad ora, e non so perché ubuntu non faccia un backport della patch, si deve installare un kernel più nuovo del 5.15, io ho risolto installando il 5.17 dal repo mainline.
Io ci proverei magari avvalendomi dell'uso di Mainline
Avatar utente
stevini
Prode Principiante
Messaggi: 160
Iscrizione: giovedì 31 maggio 2007, 0:02

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da stevini »

@thece
non e' rischioso aggiornare tramite repository esterno e aggiornare il kernel ad una versione non ancora ufficiale? Non sono molto esperto a dir il vero... e nell'ignoranza vado sempre per la soluzione piu sicura
stevini
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 12265
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 11 (Bullseye) - KDE

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da thece »

stevini ha scritto:
mercoledì 25 maggio 2022, 14:03
@thece
non e' rischioso aggiornare tramite repository esterno e aggiornare il kernel ad una versione non ancora ufficiale? Non sono molto esperto a dir il vero... e nell'ignoranza vado sempre per la soluzione piu sicura
Il repository esterno si riferisce solamente all'applicazione Mainline che semplifica l'operazione di installazione dei kernel. I kernel vengono prelevati da https://kernel.ubuntu.com/~kernel-ppa/mainline/ e sono preparati da Ubuntu.
Sinceramente è un'applicazione della quale ignoravo l'esistenza fino a oggi. L'ho installata sulla VM che uso per fare i test per il Forum e ha funzionato senza alcun problema. Ho installato e poi disinstallato il kernel 5.18.0.
Il sito che ti ho linkato spiega molto bene come installare e usare Mainline, sia da terminale che da GUI.
La scelta è la tua.
Avatar utente
frapox
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2800
Iscrizione: sabato 31 dicembre 2005, 19:22
Desktop: Kde Plasma, Gnome
Distribuzione: Arch, Debian
Località: Sud Europa

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da frapox »

stevini ha scritto:
mercoledì 25 maggio 2022, 14:03
@thece
non e' rischioso aggiornare tramite repository esterno e aggiornare il kernel ad una versione non ancora ufficiale? Non sono molto esperto a dir il vero... e nell'ignoranza vado sempre per la soluzione piu sicura
Se no puoi provare il kernel "oem" di Ubuntu che attualmente è alla 5.17 (l'attuale stabile) ed è nei repo ufficiali.

Codice: Seleziona tutto

sudo apt install linux-oem-22.04
MP: frapox at suchat dot org (Jabber) || frapox chiocciola libero punto it (mail) ; cat $richieste_di_supporto > /dev/null
Slava Ukraïni! 🇺🇦
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22752
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 22.04 e 22.10 (dev) x64
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da trekfan1 »

C'è anche il repo xanmod
Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18649
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da Janvitus »

Comunque sembra abbiano risolto.
+Fedora 36 • +Xubuntu 22.04
Avatar utente
stevini
Prode Principiante
Messaggi: 160
Iscrizione: giovedì 31 maggio 2007, 0:02

RISOLTO WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da stevini »

Si alla fine ho continuato a connettermi tramite tethering usb con il mio cellulare, sino a che, dopo piu o meno un mese e mezzo, Ubuntu stesso si è aggiornato ed è stato tutto risolto.
stevini
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
Messaggi: 6657
Iscrizione: venerdì 21 settembre 2012, 16:37
Desktop: GNOME, Xfce (e altri)
Distribuzione: Ubuntu/Xubuntu 20.04 + eOS + altre
Sesso: Maschile
Contatti:

Re: RISOLTO WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da xavier77 »

stevini ha scritto:
sabato 9 luglio 2022, 7:17
Si alla fine ho continuato a connettermi tramite tethering usb con il mio cellulare, sino a che, dopo piu o meno un mese e mezzo, Ubuntu stesso si è aggiornato ed è stato tutto risolto.
Ok, ma il tag "Risolto" va nel titolo del primo intervento, non nell'ultimo!
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22752
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 22.04 e 22.10 (dev) x64
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: WIFI non funzionante dopo aggiornamento a 22.04

Messaggio da trekfan1 »

Tra parentesi quadre ed evitando di scriverlo tutto maiuscolo
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Google [Bot] e 5 ospiti