[Risolto] Problema con ssh in "un verso"

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

[Risolto] Problema con ssh in "un verso"

Messaggioda davide88 » giovedì 29 gennaio 2009, 18:34

Salve a tutti, ho un problema con ssh:
io ho due computer che voglio collegare nella rete di casa tramite un router pirelli. Sul portatile è installato Ubuntu, mentre sul fisso è installato Gentoo. Il fatto è questo:
quando eseguo il log sul fisso dal portatile tutto funziona bene, ma quando cerco di loggarmi dal fisso al portatile non funziona nulla. Le porte del router sono aperte ho anche aperto la porta di iptables sul portatile con il comando seguente:
Codice: Seleziona tutto
sudo iptables -A INPUT -p tcp --dport 22 -j ACCEPT

per riuscire a farmi dare una risposta dal portatile ma nulla. Ho attivato sshd con il comando seguente:
Codice: Seleziona tutto
sudo /etc/init.d/ssh start

Non riesco a capire cosa sbaglio... Il fatto è che in questo modo non riesco a trasferire files dal fisso al portatile. Cosa dimentico???
Grazie per l'aiuto.
Davide.
Ultima modifica di davide88 il venerdì 30 gennaio 2009, 9:33, modificato 1 volta in totale.
davide88
Prode Principiante
 
Messaggi: 16
Iscrizione: giugno 2008

Re: Problema con ssh in "un verso"

Messaggioda badìl » giovedì 29 gennaio 2009, 18:47

Scusa la domanda ma hai installato il server ssh  sul portatile?
Avatar utente
badìl
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: Problema con ssh in "un verso"

Messaggioda davide88 » giovedì 29 gennaio 2009, 18:52

Si, si... infatti quando lo accendo mi da l'ok...
davide88
Prode Principiante
 
Messaggi: 16
Iscrizione: giugno 2008

Re: Problema con ssh in "un verso"

Messaggioda badìl » giovedì 29 gennaio 2009, 18:54

Ma in pratica ti resta il terminale in attesa e non fa niente? C'era un post simile in sicurezza.
Avatar utente
badìl
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: Problema con ssh in "un verso"

Messaggioda davide88 » giovedì 29 gennaio 2009, 18:58

Esatto... Ho messo anche un post su
Codice: Seleziona tutto
gentoo.org

ma mi hanno risposto che è ubuntu il problema...
davide88
Prode Principiante
 
Messaggi: 16
Iscrizione: giugno 2008

Re: Problema con ssh in "un verso"

Messaggioda badìl » giovedì 29 gennaio 2009, 19:51

Hai la 8.10 o la 8.04? A me con la 8.04 funziona bene ubuntu-ubuntu in entrambi i sensi.
Avatar utente
badìl
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: Problema con ssh in "un verso"

Messaggioda davide88 » giovedì 29 gennaio 2009, 20:13

Anch'io ho la 8.04 che opzioni hai nel tuo
Codice: Seleziona tutto
sshd_config
???
davide88
Prode Principiante
 
Messaggi: 16
Iscrizione: giugno 2008

Re: Problema con ssh in "un verso"

Messaggioda davide88 » giovedì 29 gennaio 2009, 20:17

E' possibile che il problema sia il collegamento al router???
Mi spiego: il mio router ha una porta ethernet e una usb... Il portatile è collegato alla usb...
Non so più dove andare a parare... >:(
davide88
Prode Principiante
 
Messaggi: 16
Iscrizione: giugno 2008

Re: Problema con ssh in "un verso"

Messaggioda badìl » giovedì 29 gennaio 2009, 20:25

davide88 ha scritto:Anch'io ho la 8.04 che opzioni hai nel tuo
Codice: Seleziona tutto
sshd_config
???


Codice: Seleziona tutto
# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile   %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes
Avatar utente
badìl
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: [Risolto] Problema con ssh in "un verso"

Messaggioda davide88 » venerdì 30 gennaio 2009, 9:37

Ho risolto!!!
Il probelma non era
Codice: Seleziona tutto
sshd_config
il fatto è che oltre a iptables c'è anche firestarter come firewall anche se l'icona non compare nelle applicazioni che girano(quelle in alto a destra) dopo il boot. Non credendo fosse acceso non gli avevo detto di non bloccarmi il traffico su quelle porte... Come volevasi dimostrare era una belinata... Sorry per aver fatto perdere tempo e grazie per gli aiuti...
Davide.
davide88
Prode Principiante
 
Messaggi: 16
Iscrizione: giugno 2008

Re: [Risolto] Problema con ssh in "un verso"

Messaggioda badìl » venerdì 30 gennaio 2009, 16:07

Firestarter è solo un'interfaccia grafica per iptables, se imposti le regole manualmente puoi anche disinstallarlo.
Avatar utente
badìl
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007


Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti