[RISOLTO] Risoluzione vnc

Installazione, configurazione e uso di programmi e strumenti.
cris_1986
Prode Principiante
Messaggi: 124
Iscrizione: martedì 7 aprile 2009, 23:46

[RISOLTO] Risoluzione vnc

Messaggio da cris_1986 »

ciao a tutti,
sto usando con buoni risultati la funzione di ubuntu che mi permette da un pc qualsiasi di connettermi alla macchina ubuntu ( vnc )
Unico difetto è che quando mi connetto alla macchina ubuntu da una qualsiasi macchina la macchina ubuntu la visualizzo con risoluzione 640*480 e quando vado per aumentarla non mi offre altre possibilità.
Se invece voglio aumentare la risoluzione non da remoto ma bensi dal "davanti al pc" allora me la fa aumentare quanto voglio.
Come posso fare per settare la macchina ubuntu in modo tale che anche in remoto offrà una risoluzione di almeno 800*600 ( se è di piu va meglio)

Grazie a tutti
Ultima modifica di cris_1986 il giovedì 16 aprile 2009, 13:40, modificato 1 volta in totale.
Avatar utente
8vincent8
Prode Principiante
Messaggi: 69
Iscrizione: mercoledì 6 febbraio 2008, 22:35
Località: Torino

Re: Risoluzione vnc

Messaggio da 8vincent8 »

probabilmente non ci sono i driver della scheda video per quello ti da solo quella risoluzione almeno a me era quello! (yes)
Un gioco On-Line provalo ora è gratis!!!

http://s4.battleknight.it/index.php?loc ... f=Nzg2Mjc2
espi81

Re: Risoluzione vnc

Messaggio da espi81 »

Ciao, io ho avuto il tuo stesso dilemma,
ma non ricordo come ho risolto  :-[
pero` ti posso postare lo xorg del mio server
cui accedo da UltraVNC su client XP
il server e` una 8.04.2 (hardy heron non so se tu hai la stessa versione)
c'e` un campo nel mio xorg.conf in cui imposto la risoluzione a 1024x768
confrontalo con il tuo e fai delle prove
ci tengo a sottolineare che non mi assumo responsabilita` su eventuali casini al tuo sistema,
per il semplice fatto che io ho preso le voci aggiunte dalla rete e, ringraziando Gnu/Linux,
ha funzionato. Forse ti conviene fare un back up del tua attuale xorg

Codice: Seleziona tutto

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.back
e poi modificare il tuo xorg.conf cosi` male che vada dai un bel

Codice: Seleziona tutto

sudo cp /etc/X11/xorg.back /etc/X11/xorg.conf
anche con putty da un client xp.
(ho messo sudo nei comandi perche` mi pare devi essere root per mettere le mani su xorg.conf)

io di driver per la scheda video non ne ho installati, uso i vesa forniti con la 8.04.2
(il mio server e` stato recuperato unendo componenti reperiti in giro per gli scantinati
dell'uni... sinceramente non saprei neanche dirti che configurazione ho....)

ecco lo xorg.conf che mi apre la risoluzione del VNC viewer su 1024x768

Codice: Seleziona tutto

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"it"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"vesa"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
	HorizSync   30.0 - 95.0
	VertRefresh 50.0 - 160.0
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	24
	SubSection "Display"
		Depth     24
		Modes "1024x768"
	EndSubSection 
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
EndSection
Spero funzioni!!!

p.s.: purtroppo non sono molto attivo su questo forum, fondamentalmente perche` non ne capisco molto, e poi perche` ho poco tempo libero... non so quando potro` leggere le risposte, prova a vedere se qualcun'altro ti da una mano, oppure google in genere aiuta sempre!  ;)
cris_1986
Prode Principiante
Messaggi: 124
Iscrizione: martedì 7 aprile 2009, 23:46

Re: Risoluzione vnc

Messaggio da cris_1986 »

ho risolto: è bastato aggiungere le seguenti righe al file xorg.conf :

SubSection "Display"
Depth    24
Modes "1024x768" "800x600"
EndSubSection


Il file xorg.conf risulta quindi cosi:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth    24
Modes "1024x768" "800x600"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection




Grazie a tutti
Scrivi risposta

Ritorna a “Applicazioni”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 14 ospiti