[RISOLTO]4gb di ram e problemi

Riconoscimento, installazione e configurazione delle periferiche.

[RISOLTO]4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 6:52

Salve non so se sono nella stanza giusta perchè è un problema generale legato al 99% alla memoria che ho installato.

Ok ho un portatile con 2 gb di ram, e ho istallato la nuova versione 9.04. Andava tutto bene... fin quando govedi ho deciso di mettere 4gb di ram , 2 moduli da 2 gb.
Vado a comprarli ; 2 moduli da 2 gb l' uno, spengo il notebook, smonto, rimonto e accendo... il boot va bene ma all' avvio mi da subito problemi, per sintesi scrivo che ha rilevato che il sistema non ha trovato i driver nvidia e/o non ha potuto caricare il modulo del kernel relativo ad nvidia... scusate ora non ricordo...

allora dopo aver premuto ok mi compare una schermata blu dicendomi che non si è potuto caricare il server X, dopo alcuni tentativi riesco ad arrivare alla login  e al desktop ma in low graphics. Tutto si vede sgranato.

Sono entrato nel canale irc e qualcuno mi ha fatto riconfigurare xorg, disinstallare i driver nvidia e reinstallarli.... ma nada..

Sconfitto decido di riformattare... tanto ho sempre tutto salvato.... e l' avevo appena installato...
Cmq inserisco il cd, deciso subito per l' installazione ma nada il sistema si blocca prima che si arrivi alla scelta della lingua, gli errori sono relativi al server X.

E' come se Ubuntu non riesce a capire quanta memoria ha la scheda video, ah dimenticavo, con Ubuntu caricato in low graphics sono riuscito a lanciare le info di sistema e mi vede solo 3 gb di ram....
Devo aggiungere anche che Vista parte correttamente e mi vede pure solo 3 gb ma non ho altri problemi.

Oggi faccio la prova di smontare e rimontare i vecchi moduli ram.

La causa sembra la nuova ram ma che si fa?, devo ricomprarle?
Ultima modifica di pepigno75 il mercoledì 6 maggio 2009, 8:07, modificato 1 volta in totale.
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pico977 » lunedì 4 maggio 2009, 7:37

Il fatto che ti riveli solo 3 giga con tutta probabilità è dovuto al fatto che stai usando una distribuzione a 32 bit (per vista è sicuramente così, non mi risult che sia venduto alcun PC con SO della MS a 64bit, per quelli devi pagare oltre, ovviamente!).

per quanto riguarda i driver nvidia, rimettendo solo i 2 giga di partenza, il problema rientra?
L'esperienza è il tipo di insegnante più difficile. Prima ti fa l'esame, poi ti spiega la lezione
Avatar utente
pico977
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 588
Iscrizione: maggio 2008

Re: 4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 8:37

Si rimettendo le 2 gb funziona bene... ma le dimm sono corsair una buona marca... e Windows funzioba bene...
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pico977 » lunedì 4 maggio 2009, 8:55

Tempo addietro ho avuto un problema simile con una mb asus, ed una cpu che non ne voleva sapere di andare, alla fine ho risolto aggiornando la bios (operazione compiuta con una CPU in prestito, riconosciuta e funzionante  ;D )
Intanto guarda un poco che versione hai di bios e qual'è l'ultima versione rilasciata dal costruttore.
Casomai valuta se è il caso di fare l'upgrade, considera comunque che tale operazione non è indolore.
L'esperienza è il tipo di insegnante più difficile. Prima ti fa l'esame, poi ti spiega la lezione
Avatar utente
pico977
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 588
Iscrizione: maggio 2008

Re: 4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 9:00

Si grazie.... non mi andrebbe proprio aggiornare il bios.. che palle...

Sto provando ora con una live per vedere se parte e poi con l' alternate....
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 9:28

Sal canale irc mi hanno detto che è questo bu:

https://bugs.launchpad.net/ubuntu/+sour ... bug/342926
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda Guiodic » lunedì 4 maggio 2009, 9:41

Sì il problema è abbastanza logico da capire. Il Bios alloca la memoria della scheda sopra la RAM. Ma essendo la Ram di 4 gb ovviamente il sistema non arriva alla memoria video.

Un utente dice che semplicemente installando la 64bit ha risolto (altri no, ma potresti provare comunque).
Altri utenti indicano alcuni cambiamenti da fare nella configurazione del bios, vedi se sono possibili sul tuo computer.
Avatar utente
Guiodic
Accecante Asceta
Accecante Asceta
 
Messaggi: 28474
Iscrizione: aprile 2007
Località: Roma

Re: 4gb di ram e problemi

Messaggioda pico977 » lunedì 4 maggio 2009, 10:08

Sì il problema è abbastanza logico da capire. Il Bios alloca la memoria della scheda sopra la RAM. Ma essendo la Ram di 4 gb ovviamente il sistema non arriva alla memoria video.


Infatti

Il problema, stando a quanto riportato sul link, è che la memoria video viene allocata nella parte finale dei 4 Giga di ram, per cui, o indirizzi a64 bit, o non puoi puntarla, la soluzione viene da se è usare la distro a 64 bit, questo ragionamento va a quel paese se hai un chipsets north-bridge a 32 bit.

Prova a vedere se da bios puoi piazzare la ram della scheda video all'inizio della ram.

facci sapere
L'esperienza è il tipo di insegnante più difficile. Prima ti fa l'esame, poi ti spiega la lezione
Avatar utente
pico977
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 588
Iscrizione: maggio 2008

Re: 4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 10:52

Ma una domanda... posso installare la distro di Ubuntu a 64 bit anche se non ho un pc a 64bit? e altra domanda da ignorantone... ho degli effetti collaterali?
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pico977 » lunedì 4 maggio 2009, 11:27

No, se non hai un processore a 64 bit, non puoi installare la distro a 64bit, ma comunque se non hai un processore a 64 bit, non te ne fai niente neanche di 4giga di ram...

Per curiosità, che processore hai?
L'esperienza è il tipo di insegnante più difficile. Prima ti fa l'esame, poi ti spiega la lezione
Avatar utente
pico977
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 588
Iscrizione: maggio 2008

Re: 4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 11:28

Ecco la mia configurazione.

http://www.giuseppesorce.com/Report.htm
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pepigno75 » lunedì 4 maggio 2009, 11:45

Sto già installando la versione 64bit e non mi sta dando problemi.
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pico977 » lunedì 4 maggio 2009, 12:33

ottimo, metti risolto al topic
L'esperienza è il tipo di insegnante più difficile. Prima ti fa l'esame, poi ti spiega la lezione
Avatar utente
pico977
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 588
Iscrizione: maggio 2008

Re: 4gb di ram e problemi

Messaggioda pepigno75 » martedì 5 maggio 2009, 6:36

Mi dispiace non mettere risolto... ma ieri ho installato... tutto bene... ci ho lavorato un po...stamattina... accedo al sistema...e nada il solito problema di caricamento nvidia kernel module.... mannaggia... sono un po deluso a sto punto... non posso lavorare con 4gb di ram...
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pico977 » martedì 5 maggio 2009, 7:06

hai provato a vedere se da bios puoi mappare la memoria video su indirizzi bassi della ram?
L'esperienza è il tipo di insegnante più difficile. Prima ti fa l'esame, poi ti spiega la lezione
Avatar utente
pico977
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 588
Iscrizione: maggio 2008

Re: 4gb di ram e problemi

Messaggioda pepigno75 » martedì 5 maggio 2009, 8:03

Ora controllo...ma non so non vedo tante voci... vado in advanced settings ma non mi fa cambiare quasi nulla...
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pepigno75 » martedì 5 maggio 2009, 8:39

Niente da fare ho provato ogni opzione del bios ma non vedo nessun modo per controllare la ram...
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pepigno75 » martedì 5 maggio 2009, 10:04

Sto reinstallando la versione 64bit... sembra andare ma poi succede qualcosa... e non va più...

uffa che delusione però... voglio i 4gb con Ubuntu...
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007

Re: 4gb di ram e problemi

Messaggioda pepigno75 » martedì 5 maggio 2009, 14:25

Sembra che ho risolto... grazie alle guida di aldolatino sono riuscito ad installare dei driver nvidia in beta 185.

http://www.aldolat.it/2009/sistema/driv ... -e-ubuntu/


e adesso sembra andare..
pepigno75
Prode Principiante
 
Messaggi: 73
Iscrizione: settembre 2007


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 11 ospiti