ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 12:34

con questa e' mia intezione riassumere in questa discussioni tutti i problemini che riguardano questo notebook con ubuntu:

dopo mille prove ho istallato la nuova versione di ubuintu 10.11 alpha 1 (kernell 2.6.34) questa magicamente riconosce quasi tutto anche la rete wifi

-ora rimane la gestione -ACPI e scheda video ATi 5650

1) x la gestione dell'alimentazione dell'alimentazione batteria ecc mi sono convinto che l'unica strada e' seguire i preziosi consigli di Luigi Salvati cosi' seguendo il suo blog :
http://luigisalvati.wordpress.com/
ho istallato il modulo omnibook deb
poi ho provato le varie configurazioni ma non sono riuscito a combinare niente
sicuramnte sbaglio io  >:(
Luigi prova a congliarci tu
grazie

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 13:08

Si fa quel che si può  ;)
Innanzitutto posta il metodo con cui hai installato il modulo(compilato o no) dopo di che posta il risultato che ti esce da terminale dopo aver caricato il modulo.

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 13:25

si grazie
ora accedo su ubuntu (rotfl)

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 13:37

ho scaricato da qui omnibook:
http://heanet.dl.sourceforge.net/projec ... -0_all.deb

poi lo ho istallato cliccandoci sopra poi ho caricato il modulo tipo

sudo modprobe omnibook ectype=(10..11...13...14)

-ho cercato di caricare anche i vari modulo all'avvio
sudo gedit /etc/modules 
es:
giorg2@giorg2-desktop:~$ sudo gedit /etc/modules
[sudo] password for giorg2:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
rtc
omnibook ectype=14
ma risultati nessuno dove sbaglio ?
mi aiuti a cercare i vari "modprobe omnibook ectype" ?

ho  ubuntu 10.10 alpha 1 solo cosi' mi funziona quasi tutto

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 13:40

hai compilato il modulo dopo aver installato il pacchetto?

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 13:45

penso di no , :-[
ora riguardo sulla guida sul tuo blog

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 13:47

per quanto riguarda il kernel puoi anche usare lucid, i pacchetti per il kernel aggiornati li trovi qui :
http://kernel.ubuntu.com/~kernel-ppa/mainline/

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 13:56

ho provato ad usare il kernel 2.6.34 con lucid ma come anche altri utenti mi hanno confermato il wifi non funziona (bo)
mentre con il 10.10 funziona

-ritornando alla compilazione del modulo omnibok devo confessare che ci ho capito poco :
da gestine pacchetti trovo che
omnibook-source
Source for the omnibook driver.
e' istallato,ora per copilarlo cosa devo fare: ???
grazie passo passo cosi' siuamo sicuro che non faccio cappellate

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 14:06

da terminale :

Codice: Seleziona tutto

cd /usr/src/modules/omnibook

Codice: Seleziona tutto

make

Codice: Seleziona tutto

sudo make install

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 14:09

se
cd /usr/src/modules/omnibook
bash: cd: /usr/src/modules/omnibook: Nessun file o directory

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 14:12

controlla il contenuto della cartella, potrebbe essere solo /usr/src/modules , se  hai difficoltà posta il contenuto di /usr/src e /usr/src/modules

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 14:18

giorg2@giorg2-desktop:~$ cd /usr/src/modules
bash: cd: /usr/src/modules: Nessun file o directory
giorg2@giorg2-desktop:~$
se:
iorg2@giorg2-desktop:~$ gedit usr/usr
giorg2@giorg2-desktop:~$ gedit /usr/src/modules

sono vuoti ??? ??? ???

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 14:20

(rotfl)
sono cartelle.

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 14:28

capito dovrei aver trovato :-[

/usr/src/omnibook.tar.gz

che devo fare?

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 14:49

luigi sto andando avanti guarda se tutto bene? ::)
giorg2@giorg2-desktop:~$ tar -zxvf /usr/src/omnibook.tar.gz
modules/
modules/omnibook/
modules/omnibook/debian/
modules/omnibook/debian/compat
modules/omnibook/debian/rules
modules/omnibook/debian/changelog
modules/omnibook/debian/copyright
modules/omnibook/debian/control
modules/omnibook/debian/control.modules.in
modules/omnibook/debian/postinst.modules.in
modules/omnibook/debian/postrm.modules.in
modules/omnibook/Makefile
modules/omnibook/ac.c
modules/omnibook/apmemu.c
modules/omnibook/battery.c
modules/omnibook/blank.c
modules/omnibook/display.c
modules/omnibook/dmi.c
modules/omnibook/dock.c
modules/omnibook/ec.c
modules/omnibook/fan.c
modules/omnibook/fan_policy.c
modules/omnibook/init.c
modules/omnibook/lcd.c
modules/omnibook/onetouch.c
modules/omnibook/polling.c
modules/omnibook/temperature.c
modules/omnibook/touchpad.c
modules/omnibook/util.c
modules/omnibook/apmemu.h
modules/omnibook/dmi.h
modules/omnibook/ec.h
modules/omnibook/init.h
modules/omnibook/omnibook.h
modules/omnibook/util.h
giorg2@giorg2-desktop:~$ sudo aptitude install module-assistant
[sudo] password for giorg2:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
Inizializzazione dello stato dei pacchetti... Fatto
Scrittura delle informazioni sullo stato esteso... Fatto
I seguenti pacchetti NUOVI (NEW) saranno installati:
  module-assistant
I seguenti pacchetti parzialmente instalalti saranno configurati:
  fglrx fglrx-amdcccle
0 pacchetti aggiornati, 1 installati, 0 da rimuovere e 74 non aggiornati.
È necessario prelevare 111kB di archivi. Dopo l'estrazione, verranno occupati 578kB.
Scrittura delle informazioni sullo stato esteso... Fatto
Get:1 http://ua.archive.ubuntu.com/ubuntu/ maverick/universe module-assistant 0.11.2ubuntu1 [111kB]
Scaricato 111kB in 0s (170kB/s) 
Selezionato il pacchetto module-assistant.
(Lettura del database... 127040 file e directory attualmente installati.)
Estrazione di module-assistant (da .../module-assistant_0.11.2ubuntu1_all.deb)...
Elaborazione dei trigger per man-db...
Configurazione di fglrx (2:8.723.1-0ubuntu4)...
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.723.1 DKMS files...

------------------------------
Deleting module version: 8.723.1
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.723.1 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.34-5-generic
Building for architecture x86_64
Building initial module for 2.6.34-5-generic

Error! Bad return status for module build on kernel: 2.6.34-5-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 57, in
    report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/fglrx.0.crash'
dpkg: errore nell'elaborare fglrx (--configure):
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 10
dpkg: problemi con le dipendenze impediscono la configurazione di fglrx-amdcccle:
fglrx-amdcccle dipende da fglrx; comunque:
  Il pacchetto fglrx non è ancora configurato.
dpkg: errore nell'elaborare fglrx-amdcccle (--configure):
problemi con le dipendenze - lasciato non configurato
Configurazione di module-assistant (0.11.2ubuntu1)...
Non è stata scritta alcuna segnalazione apport poiché il messaggio di errore indica che è un errore da un fallimento precedente.
                                                Elaborazione dei trigger per python-gmenu...
Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per initramfs-tools...
update-initramfs: Generating /boot/initrd.img-2.6.34-5-generic
Elaborazione dei trigger per python-support...
Si sono verificati degli errori nell'elaborazione:
fglrx
fglrx-amdcccle
E: Sub-process /usr/bin/dpkg returned an error code (1)
Errore durante l'installazione di un pacchetto. Tentativo di ripristino:
Configurazione di fglrx (2:8.723.1-0ubuntu4)...
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.723.1 DKMS files...

------------------------------
Deleting module version: 8.723.1
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.723.1 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.34-5-generic
Building for architecture x86_64
Building initial module for 2.6.34-5-generic

Error! Bad return status for module build on kernel: 2.6.34-5-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 57, in
    report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/fglrx.0.crash'
dpkg: errore nell'elaborare fglrx (--configure):
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 10
dpkg: problemi con le dipendenze impediscono la configurazione di fglrx-amdcccle:
fglrx-amdcccle dipende da fglrx; comunque:
  Il pacchetto fglrx non è ancora configurato.
dpkg: errore nell'elaborare fglrx-amdcccle (--configure):
problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per python-gmenu...
Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per initramfs-tools...
update-initramfs: Generating /boot/initrd.img-2.6.34-5-generic
Elaborazione dei trigger per python-support...
Si sono verificati degli errori nell'elaborazione:
fglrx
fglrx-amdcccle
Lettura elenco dei pacchetti... Fatto                 
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
Lettura delle informazioni sullo stato esteso     
Inizializzazione dello stato dei pacchetti... Fatto
Scrittura delle informazioni sullo stato esteso... Fatto

giorg2@giorg2-desktop:~$ sudo m-a prepare
Getting source for kernel version: 2.6.34-5-generic
apt-get install linux-headers-2.6.34-5-generic
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno aggiornati:
  linux-headers-2.6.34-5-generic
1 aggiornati, 0 installati, 0 da rimuovere e 73 non aggiornati.
2 non completamente installati o rimossi.
È necessario scaricare 759kB di archivi.
Dopo quest'operazione, verranno occupati 0B di spazio su disco.
Scaricare:1 http://ua.archive.ubuntu.com/ubuntu/ maverick/main linux-headers-2.6.34-5-generic 2.6.34-5.14 [759kB]
Recuperati 759kB in 3s (195kB/s)                     
(Lettura del database... 127094 file e directory attualmente installati.)
Preparativi per sostituire linux-headers-2.6.34-5-generic v.2.6.34-5.13 (utilizzando .../linux-headers-2.6.34-5-generic_2.6.34-5.14_amd64.deb)...
Estrazione del sostituto di linux-headers-2.6.34-5-generic...
Configurazione di linux-headers-2.6.34-5-generic (2.6.34-5.14)...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.34-5-generic /boot/vmlinuz-2.6.34-5-generic
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.34-5-generic /boot/vmlinuz-2.6.34-5-generic
Configurazione di fglrx (2:8.723.1-0ubuntu4)...
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.723.1 DKMS files...

------------------------------
Deleting module version: 8.723.1
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.723.1 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.34-5-generic
Building for architecture x86_64
Building initial module for 2.6.34-5-generic

Error! Bad return status for module build on kernel: 2.6.34-5-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 57, in
    report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/fglrx.0.crash'
dpkg: errore nell'elaborare fglrx (--configure):
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 10
dpkg: problemi con le dipendenze impediscono la configurazione di fglrx-amdcccle:
fglrx-amdcccle dipende da fglrx; comunque:
  Il pacchetto fglrx non è ancora configurato.
dpkg: errore nell'elaborare fglrx-amdcccle (--configure):
problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per python-gmenu...
Non è stata scritta alcuna segnalazione apport poiché il messaggio di errore indica che è un errore da un fallimento precedente.
                                                Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per initramfs-tools...
update-initramfs: Generating /boot/initrd.img-2.6.34-5-generic
Elaborazione dei trigger per python-support...
Si sono verificati degli errori nell'elaborazione:
fglrx
fglrx-amdcccle
E: Sub-process /usr/bin/dpkg returned an error code (1)
Creating symlink...
apt-get install build-essential
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno inoltre installati:
  cpp-4.4 dpkg-dev g++ g++-4.4 gcc-4.4 gcc-4.4-base libalgorithm-diff-perl
  libalgorithm-merge-perl libdpkg-perl libstdc++6-4.4-dev
Pacchetti suggeriti:
  gcc-4.4-locales debian-keyring g++-multilib g++-4.4-multilib gcc-4.4-doc
  libstdc++6-4.4-dbg gcc-4.4-multilib libmudflap0-4.4-dev libgcc1-dbg
  libgomp1-dbg libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7
  libstdc++6-4.4-doc
I seguenti pacchetti NUOVI saranno installati:
  build-essential dpkg-dev g++ g++-4.4 libalgorithm-diff-perl
  libalgorithm-merge-perl libdpkg-perl libstdc++6-4.4-dev
I seguenti pacchetti saranno aggiornati:
  cpp-4.4 gcc-4.4 gcc-4.4-base
3 aggiornati, 8 installati, 0 da rimuovere e 70 non aggiornati.
2 non completamente installati o rimossi.
È necessario scaricare 15,3MB di archivi.
Dopo quest'operazione, verranno occupati 26,2MB di spazio su disco.
Continuare [S/n]? s
Scaricare:1 http://ua.archive.ubuntu.com/ubuntu/ maverick/main gcc-4.4 4.4.4-4ubuntu1 [2867kB]
Scaricare:2 http://ua.archive.ubuntu.com/ubuntu/ maverick/main cpp-4.4 4.4.4-4ubuntu1 [4112kB]
Scaricare:3 http://ua.archive.ubuntu.com/ubuntu/ maverick/main gcc-4.4-base 4.4.4-4ubuntu1 [120kB]
Scaricare:4 http://ua.archive.ubuntu.com/ubuntu/ maverick/main libstdc++6-4.4-dev 4.4.4-4ubuntu1 [1527kB]
Scaricare:5 http://ua.archive.ubuntu.com/ubuntu/ maverick/main g++-4.4 4.4.4-4ubuntu1 [5762kB]
Scaricare:6 http://ua.archive.ubuntu.com/ubuntu/ maverick/main g++ 4:4.4.4-1ubuntu2 [1448B]
Scaricare:7 http://ua.archive.ubuntu.com/ubuntu/ maverick/main libdpkg-perl 1.15.7.2ubuntu1 [467kB]
Scaricare:8 http://ua.archive.ubuntu.com/ubuntu/ maverick/main dpkg-dev 1.15.7.2ubuntu1 [416kB]
Scaricare:9 http://ua.archive.ubuntu.com/ubuntu/ maverick/main build-essential 11.5 [7228B]
Scaricare:10 http://ua.archive.ubuntu.com/ubuntu/ maverick/main libalgorithm-diff-perl 1.19.02-1 [51,3kB]
Scaricare:11 http://ua.archive.ubuntu.com/ubuntu/ maverick/main libalgorithm-merge-perl 0.08-1 [13,0kB]
Recuperati 15,3MB in 9s (1653kB/s)                                           
(Lettura del database... 127094 file e directory attualmente installati.)
Preparativi per sostituire gcc-4.4 v.4.4.4-3ubuntu3 (utilizzando .../gcc-4.4_4.4.4-4ubuntu1_amd64.deb)...
Estrazione del sostituto di gcc-4.4...
Preparativi per sostituire cpp-4.4 v.4.4.4-3ubuntu3 (utilizzando .../cpp-4.4_4.4.4-4ubuntu1_amd64.deb)...
Estrazione del sostituto di cpp-4.4...
Preparativi per sostituire gcc-4.4-base v.4.4.4-3ubuntu3 (utilizzando .../gcc-4.4-base_4.4.4-4ubuntu1_amd64.deb)...
Estrazione del sostituto di gcc-4.4-base...
Selezionato il pacchetto libstdc++6-4.4-dev.
Estrazione di libstdc++6-4.4-dev (da .../libstdc++6-4.4-dev_4.4.4-4ubuntu1_amd64.deb)...
Selezionato il pacchetto g++-4.4.
Estrazione di g++-4.4 (da .../g++-4.4_4.4.4-4ubuntu1_amd64.deb)...
Selezionato il pacchetto g++.
Estrazione di g++ (da .../g++_4%3a4.4.4-1ubuntu2_amd64.deb)...
Selezionato il pacchetto libdpkg-perl.
Estrazione di libdpkg-perl (da .../libdpkg-perl_1.15.7.2ubuntu1_all.deb)...
Selezionato il pacchetto dpkg-dev.
Estrazione di dpkg-dev (da .../dpkg-dev_1.15.7.2ubuntu1_all.deb)...
Selezionato il pacchetto build-essential.
Estrazione di build-essential (da .../build-essential_11.5_amd64.deb)...
Selezionato il pacchetto libalgorithm-diff-perl.
Estrazione di libalgorithm-diff-perl (da .../libalgorithm-diff-perl_1.19.02-1_all.deb)...
Selezionato il pacchetto libalgorithm-merge-perl.
Estrazione di libalgorithm-merge-perl (da .../libalgorithm-merge-perl_0.08-1_all.deb)...
Elaborazione dei trigger per man-db...
Configurazione di fglrx (2:8.723.1-0ubuntu4)...
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.723.1 DKMS files...

------------------------------
Deleting module version: 8.723.1
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.723.1 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.34-5-generic
Building for architecture x86_64
Building initial module for 2.6.34-5-generic

Error! Bad return status for module build on kernel: 2.6.34-5-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 57, in
    report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/fglrx.0.crash'
dpkg: errore nell'elaborare fglrx (--configure):
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 10
dpkg: problemi con le dipendenze impediscono la configurazione di fglrx-amdcccle:
fglrx-amdcccle dipende da fglrx; comunque:
  Il pacchetto fglrx non è ancora configurato.
dpkg: errore nell'elaborare fglrx-amdcccle (--configure):
problemi con le dipendenze - lasciato non configurato
Configurazione di gcc-4.4-base (4.4.4-4ubuntu1)...
Non è stata scritta alcuna segnalazione apport poiché il messaggio di errore indica che è un errore da un fallimento precedente.
                                                Configurazione di cpp-4.4 (4.4.4-4ubuntu1)...
Configurazione di gcc-4.4 (4.4.4-4ubuntu1)...
Configurazione di libdpkg-perl (1.15.7.2ubuntu1)...
Configurazione di dpkg-dev (1.15.7.2ubuntu1)...
Configurazione di libalgorithm-diff-perl (1.19.02-1)...
Configurazione di libalgorithm-merge-perl (0.08-1)...
Configurazione di libstdc++6-4.4-dev (4.4.4-4ubuntu1)...
Configurazione di g++-4.4 (4.4.4-4ubuntu1)...
Configurazione di g++ (4:4.4.4-1ubuntu2)...
update-alternatives: viene usato /usr/bin/g++ per fornire /usr/bin/c++ (c++) in modalità automatica.
Configurazione di build-essential (11.5)...
Elaborazione dei trigger per python-gmenu...
Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per initramfs-tools...
update-initramfs: Generating /boot/initrd.img-2.6.34-5-generic
Elaborazione dei trigger per python-support...
Si sono verificati degli errori nell'elaborazione:
fglrx
fglrx-amdcccle
E: Sub-process /usr/bin/dpkg returned an error code (1)

Done!
giorg2@giorg2-desktop:~$ cd modules/omnibook/
giorg2@giorg2-desktop:~/modules/omnibook$ sudo make install
PWD=/home/giorg2/modules/omnibook
make -C /lib/modules/2.6.34-5-generic/build SUBDIRS= modules
make[1]: ingresso nella directory «/usr/src/linux-headers-2.6.34-5-generic»
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/docproc
  HOSTCC  scripts/basic/hash
  HOSTCC  scripts/kconfig/conf.o
scripts/kconfig/conf.c: In function ‘conf_askvalue’:
scripts/kconfig/conf.c:105: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
scripts/kconfig/conf.c: In function ‘conf_choice’:
scripts/kconfig/conf.c:307: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
  HOSTCC  scripts/kconfig/kxgettext.o
  HOSTCC  scripts/kconfig/zconf.tab.o
  HOSTLD  scripts/kconfig/conf
scripts/kconfig/conf -s arch/x86/Kconfig
make[1]: uscita dalla directory «/usr/src/linux-headers-2.6.34-5-generic»
make[1]: ingresso nella directory «/usr/src/linux-headers-2.6.34-5-generic»
  CHK    include/linux/version.h
  CHK    include/generated/utsrelease.h
  UPD    include/generated/utsrelease.h
make[2]: *** Nessuna regola per creare l'obiettivo «kernel/bounds.c», necessario a «kernel/bounds.s».  Arresto.
make[1]: *** [prepare0] Errore 2
make[1]: uscita dalla directory «/usr/src/linux-headers-2.6.34-5-generic»
make: *** [omnibook.ko] Errore 2
giorg2@giorg2-desktop:~/modules/omnibook$ sudo depmod -a
giorg2@giorg2-desktop:~/modules/omnibook$ sudo modprobe omnibook
WARNING: All config files need .conf: /etc/modprobe.d/omnibook, it will be ignored in a future release.
giorg2@giorg2-desktop:~/modules/omnibook$ modinfo omnibook
filename:      /lib/modules/2.6.34-5-generic/kernel/ubuntu/omnibook/omnibook.ko
license:        GPL
description:    Kernel interface for HP OmniBook, HP Pavilion, Toshiba Satellite and Compal ACL00 laptops
version:        2.20090707-trunk
author:        Soós Péter, Mathieu Bérard
srcversion:    302E1ECA1E6B00F304E6876
depends:       
vermagic:      2.6.34-5-generic SMP mod_unload modversions
parm:          throttle:Use 0 to disable, 1 to enable CPU throttling control (int)
parm:          wifi:Use 0 to disable, 1 to enable Wifi adapter control (int)
parm:          touchpad:Use 0 to disable, 1 to enable touchpad handling (int)
parm:          temperature:Use 0 to disable, 1 to enable thermal status and policy support (int)
parm:          key_polling:Use 0 to disable, 1 to enable key polling (int)
parm:          muteled:Use 0 to disable, 1 to enable 'Audo Mute' LED control (int)
parm:          lcd:Use 0 to disable, 1 to enable to LCD brightness support (int)
parm:          dmi:Use 0 to disable, 1 to enable DMI informations display support (int)
parm:          hotkeys:Use 0 to disable, 1 to enable hotkeys handling (int)
parm:          fan_policy:Use 0 to disable, 1 to enable fan control policy support (int)
parm:          fan:Use 0 to disable, 1 to enable fan status monitor and control (int)
parm:          dump:Use 0 to disable, 1 to enable embedded controller register dump support (int)
parm:          dock:Use 0 to disable, 1 to enable docking station support (int)
parm:          display:Use 0 to disable, 1 to enable display status handling (int)
parm:          cooling:Use 0 to disable, 1 to enable CPU cooling method control (int)
parm:          bluetooth:Use 0 to disable, 1 to enable bluetooth adapter control (int)
parm:          blank:Use 0 to disable, 1 to enable lcd console blanking (int)
parm:          battery:Use 0 to disable, 1 to enable battery status monitoring (int)
parm:          ac:Use 0 to disable, 1 to enable AC adapter status monitoring (int)
parm:          ectype:Type of embedded controller firmware
parm:          userset:Use 0 to disable, 1 to enable users to set parameters (int)
giorg2@giorg2-desktop:~/modules/omnibook$

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 14:53

se:
cat /proc/omnibook/dmi
BIOS Vendor:  INSYDE
BIOS Version:  1.20
BIOS Release:  04/26/2010
System Vendor: TOSHIBA
Product Name:  Satellite L650
Version:      PSK1JE-00800HIT
Serial Number: 4A248558Q
Board Vendor:  TOSHIBA
Board Name:    Base Board Version

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 14:59

la versione del modulo omnibook che dovrei aver istallato:
giorg2@giorg2-desktop:~$ cat /proc/omnibook/version
2.20090707-trunk
ora cosa mi consigli di fare

lgsalvati
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2519
Iscrizione: mercoledì 4 ottobre 2006, 12:24
Località: SALERNO

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da lgsalvati » sabato 5 giugno 2010, 15:09

L'archivio andava estratto nella cartella /usr/src , poi per caricare il modulo il comando è :

Codice: Seleziona tutto

sudo modprobe omnibook ectype=13
o altri numeri, dipende dalla macchina, per provarlo correttamente scaricalo prima :

Codice: Seleziona tutto

sudo modprobe -r omnibook
assicurati che NON dia risultati questo comando :

Codice: Seleziona tutto

lsmod|grep omnibook
poi carichi il modulo come indicato.

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 15:13

mi sa che c'e' qualcosa che non va
giorg2@giorg2-desktop:~$ sudo modprobe omnibook ectype=13
[sudo] password for giorg2:
WARNING: All config files need .conf: /etc/modprobe.d/omnibook, it will be ignored in a future release.
giorg2@giorg2-desktop:~$ sudo modprobe -r omnibook
WARNING: All config files need .conf: /etc/modprobe.d/omnibook, it will be ignored in a future release.
giorg2@giorg2-desktop:~$

Avatar utente
giorgio.01
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 690
Iscrizione: domenica 23 dicembre 2007, 5:43

Re: ubuntu su toshiba L650-116 -richiesta di aiuto omnibook x luigi Salvati

Messaggio da giorgio.01 » sabato 5 giugno 2010, 15:15

giorg2@giorg2-desktop:~$ lsmod|grep omnibook
giorg2@giorg2-desktop:~$

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Majestic-12 [Bot] e 26 ospiti