[proftpd]niente FTP da esterno

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns e altro.
Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

[proftpd]niente FTP da esterno

Messaggio da kekko_94 » mercoledì 18 maggio 2011, 14:17

Ciao! Ancora alle prese con il mio serverino virtuale sto impazzendo perché se tento di entrare via FTP da rete locale (quindi digitando l'indirizzo 192.168 eccetera và, mentre se cerco di entrare passando per internet, mi dice errore di timeout:

Codice: Seleziona tutto

Stato:	Risoluzione dell'indirizzo IP  costafrancesco94.dyndns-server.com in corso
Stato:	Connessione a 79.45.182.118:21...
Stato:	Connessione stabilita, in attesa del messaggio di benvenuto...
Risposta:	220 ProFTPD 1.3.2e Server (Ubuntu-Kekko-Server) [::ffff:192.168.1.69]
Comando:	USER francesco
Risposta:	331 Password richiesta per francesco
Comando:	PASS *********
Risposta:	230 Utente francesco collegato
Comando:	OPTS UTF8 ON
Risposta:	200 UTF8 attivato
Stato:	Connesso
Stato:	Lettura elenco cartelle...
Comando:	PWD
Risposta:	257 "/" è la directory corrente
Comando:	TYPE I
Risposta:	200 Tipo impostato a I
Comando:	PASV
Risposta:	227 Entering Passive Mode (79,45,182,118,195,81)
Comando:	MLSD
Errore:	Tempo scaduto per la connessione
Errore:	Non è stato possibile leggere il contenuto della cartella
Avevo letto che era perchè avevo le porte del router chiuse, ma ora che le ho aperte non so cosa possa essere... Vi posto un paio di immagini:

Attivazione delle porte
Immagine

Inoltro delle porte
Immagine

Configurazione proftpd
Immagine
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

nydardosh
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 300
Iscrizione: domenica 25 marzo 2007, 19:06
Località: Cagliari

Re: [proftpd]niente FTP da esterno

Messaggio da nydardosh » mercoledì 18 maggio 2011, 18:02

entrando con l'ip locale funziona?
Lenovo Z500, Intel Core i7 2.2Ghz, 8Gb RAM, nVidia gm740 1Gb Windows 8.1 Ubuntu 14.04 - HP Proliant DL 380 G3 Debian (ormai parcheggiato) - RaspberryPi model B Raspbian

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » mercoledì 18 maggio 2011, 19:17

nydardosh ha scritto: entrando con l'ip locale funziona?
Hai voglia! Funziona anche troppo bene!
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

toma.luca95
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 750
Iscrizione: giovedì 25 febbraio 2010, 19:32

Re: [proftpd]niente FTP da esterno

Messaggio da toma.luca95 » mercoledì 18 maggio 2011, 20:03

Hai controllato se non ci sono impostazioni che contengono la tua rete?
Perché, per esempio, apache può limitare l'accesso alla cartella a una determinata subnet o a degli host specifici...

Avatar utente
ziomax66
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 682
Iscrizione: martedì 29 aprile 2008, 23:01

Re: [proftpd]niente FTP da esterno

Messaggio da ziomax66 » mercoledì 18 maggio 2011, 20:17

Ma se il servizio ftp è in tcp su porta 21 perchè su router hai aperto la 20 ?

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » giovedì 19 maggio 2011, 16:08

perchè mi ricordo che sulle configurazioni di vsftpd c'era anche l'impostazione "FTP data port 20=yes" e pensavo che fosse indispensabile... evidentemente no...

Non ho altre impostazioni, volete che posti il file di configurazione di apache o di proftpd?? Non saprei davvero come uscirne....
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

toma.luca95
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 750
Iscrizione: giovedì 25 febbraio 2010, 19:32

Re: [proftpd]niente FTP da esterno

Messaggio da toma.luca95 » giovedì 19 maggio 2011, 17:00

Prova a fare l'nmap del tuo ip pubblico e controlla che la porta sia aperta, poi prova a collegarti con nc indirizzo 21 e controlla che se si chiude subito vuol dire che la connessione non arriva altrimenti le porte sono giuste ed è tutto nel programma...

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » giovedì 19 maggio 2011, 18:21

Intendevi questo??
[img width=800 height=445]http://upload.centerzone.it/images/9305 ... 873892.png[/img]

Per l'altra cosa ecco qui:

Codice: Seleziona tutto

francesco@francesco-station:~$ nc *********.dyndns-server.com 21
220 ProFTPD 1.3.2e Server (Ubuntu-Kekko-Server) [::ffff:192.168.1.69]
421 Login Timeout (300 seconds): closing control connection
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

Avatar utente
ziomax66
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 682
Iscrizione: martedì 29 aprile 2008, 23:01

Re: [proftpd]niente FTP da esterno

Messaggio da ziomax66 » giovedì 19 maggio 2011, 18:26

kekko_94 ha scritto: perchè mi ricordo che sulle configurazioni di vsftpd c'era anche l'impostazione "FTP data port 20=yes" e pensavo che fosse indispensabile... evidentemente no...

Non ho altre impostazioni, volete che posti il file di configurazione di apache o di proftpd?? Non saprei davvero come uscirne....
Ok  per l'ftp servono sia la porta tcp 21 (command port) che la tcp 20 (data port) quindi aprile tutte e due nel firewall.

toma.luca95
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 750
Iscrizione: giovedì 25 febbraio 2010, 19:32

Re: [proftpd]niente FTP da esterno

Messaggio da toma.luca95 » giovedì 19 maggio 2011, 18:30

Il server risponde dall'esterno, e quindi il problema è a livello di configurazione del programma, prova a postare il file .conf

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » giovedì 19 maggio 2011, 18:35

Codice: Seleziona tutto

francesco@ubuntu-server-virt:~$ sudo cat /etc/proftpd/proftpd.conf 
[sudo] password for francesco: 
#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes reload proftpd after modifications.
# 

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6				on
# If set on you can experience a longer connection delay in many cases.
IdentLookups			off

ServerName			"Ubuntu-Kekko-Server"
ServerType			standalone
DeferWelcome			off

MultilineRFC2228		on
DefaultServer			on
ShowSymlinks			on

TimeoutNoTransfer		600
TimeoutStalled			600
TimeoutIdle			1200

DisplayLogin                    welcome.msg
DisplayChdir               	.message true
ListOptions                	"-l"

DenyFilter			\*.*/

# Use this to jail all users in their homes 
# DefaultRoot			~
DefaultRoot			/home/francesco/www	www-data
# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
# RequireValidShell		off

# Port 21 is the standard FTP port.
Port				21

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
PassivePorts                  49152 65534

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
# MasqueradeAddress		1.2.3.4

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
# DynMasqRefresh 28800
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances			30

# Set the user and group that the server normally runs at.
User				proftpd
Group				nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask				022  022
# Normally, we want files to be overwriteable.
AllowOverwrite			on

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
# PersistentPasswd		off

# This is required to use both PAM-based authentication and local passwords
# AuthOrder			mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile			off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
# It is on by default. 
<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.con

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User				ftp
#   Group				nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias			anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser	on ftp
#   DirFakeGroup on ftp
# 
#   RequireValidShell		off
# 
#   # Limit the maximum number of anonymous logins
#   MaxClients			10
# 
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin			welcome.msg
#   DisplayChdir		.message
# 
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
# 
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask				022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
# 
# </Anonymous>
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

toma.luca95
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 750
Iscrizione: giovedì 25 febbraio 2010, 19:32

Re: [proftpd]niente FTP da esterno

Messaggio da toma.luca95 » giovedì 19 maggio 2011, 18:41

Prova a mettere al posto di "UseIPv6 on" "UseIPv6 off", potrebbe essere l'ipv6 che rompe le scatole...

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » giovedì 19 maggio 2011, 18:55

toma.luca95 ha scritto: Prova a mettere al posto di "UseIPv6 on" "UseIPv6 off", potrebbe essere l'ipv6 che rompe le scatole...
Niente... ho provato ma non funziona neanche questo..... mi da lo stesso errore di prima...
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

toma.luca95
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 750
Iscrizione: giovedì 25 febbraio 2010, 19:32

Re: [proftpd]niente FTP da esterno

Messaggio da toma.luca95 » giovedì 19 maggio 2011, 19:00

Prova a dare un'occhiata alla lista moduli, non si sa ai che il problema sia in un qualche modulo per la sicurezza...

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » venerdì 20 maggio 2011, 15:43

Cioè dove dovrei guardare?? Non ho la più pallida idea di cosa debba fare??

Non è che la connessione è troppo poco potente?? Mi dice errore di timeout, e se provassi ad aumentarlo??
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

toma.luca95
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 750
Iscrizione: giovedì 25 febbraio 2010, 19:32

Re: [proftpd]niente FTP da esterno

Messaggio da toma.luca95 » venerdì 20 maggio 2011, 15:54

potrebbe essere dovuto alla velocità della linea ma non credo, ma provare sicuro non fa male, per i moduli dovrebbero essere nel file "/etc/proftpd/modules.conf"

paolo1951
Prode Principiante
Messaggi: 3
Iscrizione: martedì 12 gennaio 2010, 20:41

Re: [proftpd]niente FTP da esterno

Messaggio da paolo1951 » martedì 24 maggio 2011, 17:44

kekko_94 ha scritto: Ciao! Ancora alle prese con il mio serverino virtuale sto impazzendo perché se tento di entrare via FTP da rete locale (quindi digitando l'indirizzo 192.168 eccetera và, mentre se cerco di entrare passando per internet, mi dice errore di timeout:

Codice: Seleziona tutto

Stato:	Risoluzione dell'indirizzo IP  costafrancesco94.dyndns-server.com in corso
Stato:	Connessione a 79.45.182.118:21...
Stato:	Connessione stabilita, in attesa del messaggio di benvenuto...
Risposta:	220 ProFTPD 1.3.2e Server (Ubuntu-Kekko-Server) [::ffff:192.168.1.69]
Comando:	USER francesco
Risposta:	331 Password richiesta per francesco
Comando:	PASS *********
Risposta:	230 Utente francesco collegato
Comando:	OPTS UTF8 ON
Risposta:	200 UTF8 attivato
Stato:	Connesso
Stato:	Lettura elenco cartelle...
Comando:	PWD
Risposta:	257 "/" è la directory corrente
Comando:	TYPE I
Risposta:	200 Tipo impostato a I
Comando:	PASV
Risposta:	227 Entering Passive Mode (79,45,182,118,195,81)
Comando:	MLSD
Errore:	Tempo scaduto per la connessione
Errore:	Non è stato possibile leggere il contenuto della cartella
Avevo letto che era perchè avevo le porte del router chiuse, ma ora che le ho aperte non so cosa possa essere...

Dunque io ho avuto il tuo stesso problema ... il server FTP era nel mio caso una VM di ESXi con S.O. SME, però ho risolto la cosa aprendo sul firewall tutte le porte da è verso questa VM... non è una cosa che mi piaccia molto ma "funziona".
Ora sto cercando di capire quale/i porta/e viene/vengono effettivamente utilizzate (oltre logicamente alla 21)... per ora ho stabilito che la 20 non viene affatto utilizzata!

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » martedì 24 maggio 2011, 19:34

Il punto è che io non ho nessun firewall (o almeno credo...)

Dovrei aprire tutte le porte del router per riuscire a connettermi?? Non ha senso!!!
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » giovedì 26 maggio 2011, 8:18

EDIT: Scusate ho sbagliato topic in cui rispondere....  :-[
Ultima modifica di Anonymous il giovedì 26 maggio 2011, 8:22, modificato 1 volta in totale.
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

Avatar utente
kekko_94
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 815
Iscrizione: giovedì 11 giugno 2009, 15:01
Desktop: gnome-shell
Distribuzione: Ubuntu 11.10 x86_64
Località: Padova - Italy

Re: [proftpd]niente FTP da esterno

Messaggio da kekko_94 » martedì 24 gennaio 2012, 17:01

Ragazzi, sono nella stessa situazione, ma ora è abbastanza urgente... Qualcuno che sappia come risolvere?

L'unica cosa che è cambiata è che ora non ce l'ho più su una macchina virtuale ma su macchina reale... Ma è perfettamente uguale.

Ho visto che per le porte passive proftd erano dalla 4000 e qualcosa alla 6000 e qualcosa e le ho attivate nel router... Ma non so dove altro sbattere la testa!!!  >:( >:( >:(
AMD Phenom II X6 1100T 3.3GHz, 8GB Ram 1600MHz DDR3, 1,5TB HDD, nVidia GTS450 1GB DDR5
Toshiba Satellite A200 15X Intel Pentium D 1.73GHz 2Gb Ram, 110Gb HDD
OS: Ubuntu 10.10 Maverick Meerkat

Scrivi risposta

Ritorna a “Ubuntu su server”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 0 ospiti