Niente lettere accentate in kate

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
decola
Prode Principiante
Messaggi: 8
Iscrizione: lunedì 20 novembre 2006, 4:14

Niente lettere accentate in kate

Messaggio da decola »

Ciao a tutti!

Ho un grande problema. In kate, quando digito una lettera accentata, mi vengono fuori due rettangolini. In Openoffice e in Firefox tutto OK.

Tra l'altro quando installo o aggiorno dei pacchetti, mi viene fuori questo messaggi che credo sia in qualche modo collegato al problema:

perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:en_GB:en",
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


Cosa pensate possa essere? Ne ho provate tante ma nulla :-(
Divilinux

Re: Niente lettere accentate in kate

Messaggio da Divilinux »

hehe..non ti preoccupare e'' un errore da nulla
da un mio vecchio wiki
nulla di grave..alla fine non succede nulla come si puo'' vedere
Se la loro configurazione non è corretta in base all''impostazione del proprio sistema, Perl mostra una segnalazione di errore per ogni programma avviato, attraverso lo standard error di cui sopra..
Difatti come condizione LC_ALL=(unset) non esiste..
Per risolvere il problema, se non si trova la definizione giusta per la localizzazione, conviene eliminare la configurazione del variabili di localizzazione, oppure impostare LC_ALL al valore C.

# export LC_ALL=C

questo pero'' dura una sessione..per evitare di dgtare ogni volta export....basta editare il file

/home/user/.bashrc

ed inserire in fondo al file export LC_ALL=C o la vostra localizzazione
inoltre ti conviene esportare anche la tua lingua digitando questo da console

export LANG = "it_IT.UTF-8"
export LC_CTYPE = "it_IT.euro"

oppure inserirlo nel .bashrc (good)
Ultima modifica di Divilinux il martedì 21 novembre 2006, 14:51, modificato 1 volta in totale.
decola
Prode Principiante
Messaggi: 8
Iscrizione: lunedì 20 novembre 2006, 4:14

Re: Niente lettere accentate in kate

Messaggio da decola »

Grazie Divilinux della risposta ma mi viene lo stesso messaggio...solo che ora invece che con 'en', rompe con 'it'.

Il problema mi sa che è più a fondo ed è ciò che non mi permette l'uso delle accentate. Non ci capisco nulla :-(
Divilinux

Re: Niente lettere accentate in kate

Messaggio da Divilinux »

strano..ma hai inserito nel file di conf della shell di bash?
Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 4 ospiti