[RISOLTO] benq m310 wireless mouse problema

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

[RISOLTO] benq m310 wireless mouse problema

Messaggio da DrLo »

Ciao a tutti,

sto usando un mouse wireless BenQ M310.
Funziona in windows, ma in ubuntu non c'è verso... Quando inserisco il ricevitore, il mouse automaticamente viene spostato nell'angolo superiore destro o sinistro dello schermo. Ho provato a sintonizzarlo con l'apposito bottoncino e a provare questo fix in xorg.conf.d: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/325581. Niente.
Ultima modifica di DrLo il mercoledì 22 giugno 2011, 13:47, modificato 1 volta in totale.
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24946
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: benq m310 wireless mouse problema

Messaggio da magozurlinux »

Hai controllato che le batterie siano cariche?  ;D

Hai controllato la distanza tra il trasmettitore ed il ricevitore che non siano distanti (mt. 1.5)?

Il bottone va tenuto premuto per 2'' o 3'' in modo da associarsi (no pairing; questo è per i dispositivi bluetooth).

Da terminale postami questi comandi col mouse inserito:

Codice: Seleziona tutto

lsusb

Codice: Seleziona tutto

dmesg | grep Mouse
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

Re: benq m310 wireless mouse problema

Messaggio da DrLo »

magozurlinux ha scritto:...
Eheh, sì alla domanda 1  8)

Domanda 2: sì, lo uso a meno di 15 cm.

Domanda 3: provate tutte le possibili combinazioni.

Non è che non lo associa, è che non lo riconosce: infatti prende qualche click sinistro, ma il cursore tende sempre a lato dello schermo e non lo si può spostare. A volte è come se il click sinistro rimanesse premuto, a volte non si preme. Problema hardware?

Codice: Seleziona tutto

lo@lo-K52Je:~$ lsusb
Bus 002 Device 011: ID 0d62:1000 Darfon Electronics Corp. 
Bus 002 Device 003: ID 1307:0165 Transcend Information, Inc. 2GB/4GB Flash Drive
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 174f:1120 Syntek 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
lo@lo-K52Je:~$ dmesg | grep Mouse
[ 3433.799850] generic-usb 0003:0D62:1000.0001: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 3794.780691] generic-usb 0003:0D62:1000.0002: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 3845.892634] generic-usb 0003:0D62:1000.0003: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 4050.595074] generic-usb 0003:0D62:1000.0004: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10166.389793] generic-usb 0003:0D62:1000.0005: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10251.236365] generic-usb 0003:0D62:1000.0006: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10456.449538] generic-usb 0003:0D62:1000.0007: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10495.550644] generic-usb 0003:0D62:1000.0008: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
EDIT: refuso
Ultima modifica di DrLo il domenica 19 giugno 2011, 12:45, modificato 1 volta in totale.
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

Re: benq m310 wireless mouse problema

Messaggio da DrLo »

Potrebbe darsi che sia io a non avere aggiunto correttamente lo snippet in xorg.conf.d

Ho solo inserito il codice (fornito nel bugzilla, link postato sopra) in un "mouse.conf" all'interno di /usr/share/X11/xorg.conf.d

Codice: Seleziona tutto

Section "InputClass"
   Identifier "Benq m310"
   MatchProduct "HID 0d62:1000"
   Driver "evdev"
   Option "IgnoreAbsoluteAxes" "true"
EndSection
Giusto così?
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24946
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: benq m310 wireless mouse problema

Messaggio da magozurlinux »

Hai scritto:
Ho solo inserito il codice (fornito nel bugzilla, link postato sopra) in un "mouse.conf" all'interno di /usr/share/X11/xorg.conf.d
Sei sicuro di aver dato il percorso giusto dove mettere quelle istruzioni per il mouse?

Ho fatto questa prova per cercare quel percorso, non l'ho trovato; questo è corretto:
jupiter@jupiter:~$ locate xorg.conf.d
/usr/lib/X11/xorg.conf.d
/usr/lib/X11/xorg.conf.d/05-evdev.conf
/usr/lib/X11/xorg.conf.d/10-synaptics.conf
/usr/lib/X11/xorg.conf.d/10-vmmouse.conf
/usr/lib/X11/xorg.conf.d/10-wacom.conf
Se quei parametri li metti in /etc/X11/xorg.conf dove si configura anche la scheda video e la tastiera?
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

Re: benq m310 wireless mouse problema

Messaggio da DrLo »

Ho controllato sul mio ubuntu natty: il percorso "/usr/share/X11/xorg.conf.d" c'è e contiene i parametri di touchpad e altre cose (praticamente i .conf postati da te nel code).
Invece, xorg.conf.d non ce l'ho né sotto /etc/X11 né sotto /usr/lib/X11  ???
I do believe in magic!
Ultima modifica di DrLo il domenica 19 giugno 2011, 18:50, modificato 1 volta in totale.
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

Re: benq m310 wireless mouse problema

Messaggio da DrLo »

Okay, la via è questa. Ho provato ad inserire quell'InputClass all'interno di evdev.conf, evdev-quirks.conf, vmmouse.conf e, al riavvio di xorg, funge. Non completamente, però.

Posso selezionare, muovere il mouse liberamente e cliccare sul desktop. Non posso cliccare all'interno delle applicazioni né cliccare altre icone sul desktop dopo la prima che ho cliccato.

Consigli? A parte comperare per 5 euro un mouse no-brand...  :'(
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24946
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: benq m310 wireless mouse problema

Messaggio da magozurlinux »

Continua a darti questi errori:
lo@lo-K52Je:~$ dmesg | grep Mouse
[ 3433.799850] generic-usb 0003:0D62:1000.0001: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 3794.780691] generic-usb 0003:0D62:1000.0002: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 3845.892634] generic-usb 0003:0D62:1000.0003: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 4050.595074] generic-usb 0003:0D62:1000.0004: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10166.389793] generic-usb 0003:0D62:1000.0005: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10251.236365] generic-usb 0003:0D62:1000.0006: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10456.449538] generic-usb 0003:0D62:1000.0007: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[10495.550644] generic-usb 0003:0D62:1000.0008: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
ho un mouse come il tuo ma "taroccato", l'ho comprato 5 euro dai cinesi, funziona perfettamente anche con Linux, questi sono i mei outputs:

Codice: Seleziona tutto

Bus 006 Device 006: ID 062a:0000 Creative Labs Optical mouse
jupiter@jupiter:~$ dmesg | grep Mouse
[  28.278147] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input4
[  29.022262] generic-usb 0003:062A:0000.0001: input,hidraw0: USB HID v1.10 Mouse [HID 062a:0000] on usb-0000:00:0c.1-2.3/input0
quello evidenziato in rosso è il mouse usb wireless.
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

Re: benq m310 wireless mouse problema

Messaggio da DrLo »

Oggi sono stato via per tesi (proprio sulla cina), solo ora sono tornato.

Errori me ne dà ma meno:

Codice: Seleziona tutto

lo@lo-K52Je:~$ dmesg | grep Mouse
[    2.831249] generic-usb 0003:0D62:1000.0001: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 1038.300639] generic-usb 0003:0D62:1000.0002: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
[ 1115.902641] generic-usb 0003:0D62:1000.0003: input,hidraw0: USB HID v1.10 Mouse [HID 0d62:1000] on usb-0000:00:1d.0-1.3/input0
lo@lo-K52Je:~$ lsusb
Bus 002 Device 005: ID 0d62:1000 Darfon Electronics Corp. 
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 174f:1120 Syntek 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Potresti postarmi il tuo .conf?

EDIT: precisazione
Ultima modifica di DrLo il lunedì 20 giugno 2011, 21:11, modificato 1 volta in totale.
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24946
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: benq m310 wireless mouse problema

Messaggio da magozurlinux »

Il mio .conf è vuoto.

Fai questa prova:

da terminale dai questo comando per far funzionare il mouse usb:

Codice: Seleziona tutto

sudo gedit /etc/X11/xorg.conf
il file è vuoto, copia ed incolla queste righe:

Codice: Seleziona tutto

              Section "InputDevice"
                 Identifier "Generic Mouse"
                 Driver     "mouse"
                 Option     "SendCoreEvents" "true"
                 Option     "Device"   "/dev/input/mice"
                 Option     "Protocol" "IMPS/2"
                 Option     "Buttons" "5"
                 Option  "ZAxisMapping" "4 5"
               EndSection
salva ed esci dall'editor di testo.

Riavvia il pc.
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
DrLo
Prode Principiante
Messaggi: 38
Iscrizione: giovedì 8 aprile 2010, 16:12

Re: benq m310 wireless mouse problema

Messaggio da DrLo »

Ho fatto come hai detto tu e non registrava il mouse. Allora, ho provato ad inserire le Options in /usr/share/X11/xorg.conf.d/wmmouse.conf tranne Device e Protocol e... funge!
Non riscontro più i problemi di prima sul fatto di cliccare una volta ecc ecc  (good)

Allora, per la cronaca... La configurazione in /usr/share/X11/xorg.conf.d/wmmouse.conf è:

Codice: Seleziona tutto

Section "InputClass"
   Identifier "Benq m310"
   MatchProduct "HID 0d62:1000"
   Driver "evdev"
   Option "IgnoreAbsoluteAxes" "true"
   Option     "SendCoreEvents" "true"
   Option     "Buttons" "5"
   Option  "ZAxisMapping" "4 5"
EndSection
Per ora non riscontro problemi. Nel caso, in futuro si vedrà...

Un grande grazie a magozurlinux per l'assiduità e competenza!
Linux Ubuntu, a differenza di altri, risolve sempre i suoi problemi.
Ultima modifica di DrLo il martedì 21 giugno 2011, 19:47, modificato 1 volta in totale.
Ubuntu 10.10 maverick. Gnome.
www.lorenzoapps.com
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24946
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: benq m310 wireless mouse problema

Messaggio da magozurlinux »

Prego, di nulla.

Metti RISOLTO sul primo titolo della discussione.
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 15 ospiti