[Risolto] Driver mesa errori

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

[Risolto] Driver mesa errori

Messaggio da AlexDiste »

Dove aver cercato aggiornamenti oggi, ho ottenuto da terminale

Codice: Seleziona tutto

Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
2 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare [S/n]? s
Configurazione di libgl1-mesa-glx (7.10.2-0ubuntu2.1)...
update-alternatives: errore: il collegamento alternativo /usr/lib/xorg/extra-modules è già gestito da x86_64-linux-gnu_gl_conf.
dpkg: errore nell'elaborare libgl1-mesa-glx (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 2
dpkg: problemi con le dipendenze impediscono la configurazione di libglu1-mesa:
 libglu1-mesa dipende da libgl1-mesa-glx | libgl1, ma:
  Il pacchetto libgl1-mesa-glx non è ancora configurato.
  Il pacchetto libgl1 non è installato.
  Il pacchetto libgl1-mesa-glx che fornisce libgl1 non è ancora configurato.
dpkg: errore nell'elaborare libglu1-mesa (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                             Si sono verificati degli errori nell'elaborazione:
 libgl1-mesa-glx
 libglu1-mesa
E: Sub-process /usr/bin/dpkg returned an error code (1)
che vuol dire esattamente e come risolvo?
Tra l' altro sbaglio o i driver MESA sono per schede ATI, io ho una Nvidia e ho installato nvidia-current
Ultima modifica di AlexDiste il mercoledì 24 agosto 2011, 19:17, modificato 1 volta in totale.
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

Nessuno sa come mai mi ha aggiornato i driver mesa pur avendo scheda video Nvidia e processore intel? E come posso fare in modo non mi dia più questo errore?
Vallia
Prode Principiante
Messaggi: 27
Iscrizione: giovedì 23 dicembre 2010, 16:00

Re: Driver mesa errori

Messaggio da Vallia »

Ho il tuo medesimo problema, anche io ho scheda video Nvidia e ho installato Nvidia current e sinceramente neanche io so come risolvere.
Avatar utente
sin4psi77
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 356
Iscrizione: mercoledì 11 ottobre 2006, 12:39
Sesso: Maschile
Località: Sicily

Re: Driver mesa errori

Messaggio da sin4psi77 »

mi associo
Avatar utente
sin4psi77
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 356
Iscrizione: mercoledì 11 ottobre 2006, 12:39
Sesso: Maschile
Località: Sicily

Re: Driver mesa errori

Messaggio da sin4psi77 »

qui nessuno osa dire nulla...
ad un primo sguardo sembra che il principio di tutto sia questo
update-alternatives: errore: il collegamento alternativo /usr/lib/xorg/extra-modules è già gestito da x86_64-linux-gnu_gl_conf.
che vuol dire?
Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18217
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: Driver mesa errori

Messaggio da Janvitus »

I mesa sono anche per le nvidia, non ci sono solo i driver proprietari. Comunque, come si è verificato quell'errore e cosa hai aggiornato esattamente?
+Fedora 33 • +Xubuntu 20.10
jerico
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 19127
Iscrizione: lunedì 21 luglio 2008, 23:43
Desktop: Gnome
Distribuzione: Archlinux

Re: Driver mesa errori

Messaggio da jerico »

i mesa sono un implementazione open source per le librerie openGl. ci sono a prescindere dalla scheda video
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

Un semplice aggiornamento del sistema, da gestore aggiornamenti me li dava tra gli importanti (o raccomandati, non ricordo di preciso) e poi mi ha dato quel messaggio.

Non so se c' entra ma di recente ho installato il kernel 3.0.3, startup-manager (che si è portato dietro un altro pacchetto) e plymouth-manager, niente altro. Sistema a 64 bit
Ultima modifica di AlexDiste il mercoledì 24 agosto 2011, 17:27, modificato 1 volta in totale.
jerico
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 19127
Iscrizione: lunedì 21 luglio 2008, 23:43
Desktop: Gnome
Distribuzione: Archlinux

Re: Driver mesa errori

Messaggio da jerico »

usi natty? postami
sudo apt-get -f install
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

Codice: Seleziona tutto

alessandro@alessandro-ixtreme-M5800:~$ sudo apt-get -f install
[sudo] password for alessandro: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
2 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Configurazione di libgl1-mesa-glx (7.10.2-0ubuntu2.1)...
update-alternatives: errore: il collegamento alternativo /usr/lib/xorg/extra-modules è già gestito da x86_64-linux-gnu_gl_conf.
dpkg: errore nell'elaborare libgl1-mesa-glx (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 2
dpkg: problemi con le dipendenze impediscono la configurazione di libglu1-mesa:
 libglu1-mesa dipende da libgl1-mesa-glx | libgl1, ma:
  Il pacchetto libgl1-mesa-glx non è ancora configurato.
  Il pacchetto libgl1 non è installato.
  Il pacchetto libgl1-mesa-glx che fornisce libgl1 non è ancora configurato.
dpkg: errore nell'elaborare libglu1-mesa (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                             Si sono verificati degli errori nell'elaborazione:
 libgl1-mesa-glx
 libglu1-mesa
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ecco qua
Avatar utente
Diabolik62
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16046
Iscrizione: domenica 20 dicembre 2009, 16:29
Distribuzione: wind 10049 archfce4.12

Re: Driver mesa errori

Messaggio da Diabolik62 »

posta
sudo dpkg --configure -a
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

Codice: Seleziona tutto

alessandro@alessandro-ixtreme-M5800:~$ sudo dpkg --configure -a
[sudo] password for alessandro: 
Configurazione di libgl1-mesa-glx (7.10.2-0ubuntu2.1)...
update-alternatives: errore: il collegamento alternativo /usr/lib/xorg/extra-modules è già gestito da x86_64-linux-gnu_gl_conf.
dpkg: errore nell'elaborare libgl1-mesa-glx (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 2
dpkg: problemi con le dipendenze impediscono la configurazione di libglu1-mesa:
 libglu1-mesa dipende da libgl1-mesa-glx | libgl1, ma:
  Il pacchetto libgl1-mesa-glx non è ancora configurato.
  Il pacchetto libgl1 non è installato.
  Il pacchetto libgl1-mesa-glx che fornisce libgl1 non è ancora configurato.
dpkg: errore nell'elaborare libglu1-mesa (--configure):
 problemi con le dipendenze - lasciato non configurato
Si sono verificati degli errori nell'elaborazione:
 libgl1-mesa-glx
 libglu1-mesa
alessandro@alessandro-ixtreme-M5800:~$ 
Avatar utente
Diabolik62
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16046
Iscrizione: domenica 20 dicembre 2009, 16:29
Distribuzione: wind 10049 archfce4.12

Re: Driver mesa errori

Messaggio da Diabolik62 »

posta
sudo apt-get  --purge remove libgl1-mesa-glx
sudo apt-get  --purge remove libglu1-mesa
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

Siamo sicuri?

Codice: Seleziona tutto

alessandro@alessandro-ixtreme-M5800:~$ sudo apt-get  --purge remove libgl1-mesa-glx
[sudo] password for alessandro: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libxcb-xv0 libsdl-image1.2 vlc-plugin-notify libxcb-keysyms1 libtar
  libxcb-randr0
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno RIMOSSI:
  brasero* compiz* compiz-gnome* compiz-plugins* compiz-plugins-main* gdm*
  gdm-guest-session* gnome-applets* gnome-media* gnome-screensaver*
  gnome-session* gnome-session-bin* gvfs* gvfs-backends* gvfs-fuse*
  libclutter-1.0-0* libclutter-gtk-0.10-0* libgl1-mesa-glx* libglew1.5*
  libglewmx1.5* libglu1-mesa* libnux-0.9-0* libqt4-opengl*
  libunity-2d-private0* libvisual-0.4-plugins* nautilus* nautilus-share*
  nux-tools* ubuntu-tweak* unity* unity-2d* unity-2d-default-settings*
  unity-2d-launcher* unity-2d-panel* unity-2d-places* unity-2d-spread* vlc*
  x11-utils* xorg* xscreensaver-gl*
0 aggiornati, 0 installati, 40 da rimuovere e 0 non aggiornati.
2 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 55,0 MB di spazio su disco.
Continuare [S/n]? 
e

Codice: Seleziona tutto

alessandro@alessandro-ixtreme-M5800:~$ sudo apt-get  --purge remove libglu1-mesa[sudo] password for alessandro: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  compiz* compiz-gnome* compiz-plugins* compiz-plugins-main* libglu1-mesa*
  libnux-0.9-0* libvisual-0.4-plugins* ubuntu-tweak* unity* xorg*
  xscreensaver-gl*
0 aggiornati, 0 installati, 11 da rimuovere e 0 non aggiornati.
2 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 22,8 MB di spazio su disco.
Continuare [S/n]? 


mi rimuove troppe cose no?
Avatar utente
Diabolik62
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16046
Iscrizione: domenica 20 dicembre 2009, 16:29
Distribuzione: wind 10049 archfce4.12

Re: Driver mesa errori

Messaggio da Diabolik62 »

alt fermo li ,non dare si.
Avatar utente
Diabolik62
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16046
Iscrizione: domenica 20 dicembre 2009, 16:29
Distribuzione: wind 10049 archfce4.12

Re: Driver mesa errori

Messaggio da Diabolik62 »

ma hai abilitato i repo backports, perchè ora su lucid non ho quella versione installata 7.10.2-0ubuntu2.1 ma la 7.7.1
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

no niente backports, forse qualche ppa esterno, come posso essere certo della provenienza di quei pacchetti o dirgli di ignorare tutit i ppa esterni?
Avatar utente
Diabolik62
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16046
Iscrizione: domenica 20 dicembre 2009, 16:29
Distribuzione: wind 10049 archfce4.12

Re: Driver mesa errori

Messaggio da Diabolik62 »

il problema su che distro lo hai??per evitare gli aggiornamenti devi decommentare o spuntare i ppa esterni
AlexDiste
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2299
Iscrizione: martedì 18 agosto 2009, 9:25

Re: Driver mesa errori

Messaggio da AlexDiste »

Ubuntu 11.04 natty narwhal
Avatar utente
Diabolik62
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16046
Iscrizione: domenica 20 dicembre 2009, 16:29
Distribuzione: wind 10049 archfce4.12

Re: Driver mesa errori

Messaggio da Diabolik62 »

aspetta che ci vado e vedo se mi propone quell'aggiornamento
Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: corradoventu, leoleonardo e 4 ospiti