[RISOLTO] Disastro...non si avvia più nulla

Domande e richieste di un principiante alle prime armi con Ubuntu e il mondo GNU/Linux in generale. Per domande specifiche, utilizzare le altre sezioni.
Regole della sezione
In questa sezione possono inserire nuove discussioni solo coloro che fanno parte del livello "Prode Principiante", tutti gli altri possono comunque rispondere regolarmente. Se si fa parte di questo livello e si è registrati al forum prima del 24 aprile 2012, data del passaggio al nuovo forum, consultare questa discussione.

Immagine Come usare UbuntuPrimi passi su Ubuntu Immagine Amministrazione del sistemaComandi di baseInstallare programmiLog di sistemaRiga di comandoSudo
Scrivi risposta
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

[RISOLTO] Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

Ragazzi,
stò avendo grossissimi problema da quando ho installato Ubuntu 12.4 sul mio portatile (installato, non avanzato...l'avanzamento era andato male ed ho reinstallato tutto)

sostanzialmente mi è capitato questo: ha eseguito un aggiornamento di alcuni software presenti sul sistema (almeno credo che c'entri questo...è l'unica cosa che ha fatto prima di incasinarsi). Quando sono andato a spengere il computer si è impallato tirandomi fuori dei messaggi relativi ad Apache o Mysql (ora non ricordo bene) e si è bloccato là...

al riavvio del computer...schermata nera...niente...morto...

lo riavvio un altro paio di volte e niente...alla fine dopo tot riavii mi compare la possibilità di entrare nella shell (mi chiede username e password)...entro...e nella disperazione più totale provo a digitare: startx (nella speranza di far partire gnome? booo non sò neanche se abbia senso) e mi compare una serie di check che dice ok fino a questo:

apache2: Could not reaiabbly determinate the server's fully qualified domain name, using 127.0.0.1 for server name
*Starting web server apache2


Ed è rimasto bloccato così...

Sono veramente scoraggiato perchè stavo lavorando su un progetto web ed avrei bisogno di riaccedere al mio sistema

le uniche cose che avevo installato dopo l'installazione di Ubuntu 12.4 di fatto erano Apache2 e mySql ed i driver della scheda video ATI (che funzionavano benissimo fino a 15 minuti fà e non credo c'entrino nulla)

Pareri? vi prego aiutatemi, sono nel panico...

Grazie mille
Andrea
Ultima modifica di D4rkang3l il mercoledì 2 maggio 2012, 18:34, modificato 1 volta in totale.
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: Disastro...non si avvia più nulla

Messaggio da hellojoker »

http://russenreaktor.wordpress.com/2010 ... %E2%80%9D/

sostituisci nano a gedit per ottenere la console ctrl + alt + f2
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

hellojoker ha scritto:http://russenreaktor.wordpress.com/2010 ... %E2%80%9D/

sostituisci nano a gedit per ottenere la console ctrl + alt + f2
Ok,
ora stò scappando a lezione, appena torno al lavoro provo...ma secondo te è quello il problema? Non capisco che c'entri un problema di Apache con Gnome...parere?

ah altra cosa...domanda banalissima...per ottenere la console devo digitare quei tasti quando? mentre stà là bloccato dopo l'avvio?

Tnx
Andrea
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: Disastro...non si avvia più nulla

Messaggio da hellojoker »

si mentre è bloccato anche io non sono per niente convinto che dipenda da quello ma almeno apache lo sistemi
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

No a quanto pare non c'entrava nulla..cioè...si è risolto il problemam di Apache 2 ma permane il fatto che ora si apre solo in modalità testuale...

Ho visto che oggi quì sul forum varie persone hanno avuto e stanno avendo lo stesso problema ma non mi pare che nessuno abbia trovato soluzioni....

Qualche idea per cercare di capire cosa sia successo?
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: Disastro...non si avvia più nulla

Messaggio da hellojoker »

ma qualcuno ha risolto, dai

Codice: Seleziona tutto

sudo dpkg-reconfigure lightdm
scegli lightdm se te lo chiede
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

hellojoker ha scritto:ma qualcuno ha risolto, dai

Codice: Seleziona tutto

sudo dpkg-reconfigure lightdm
scegli lightdm se te lo chiede
Ho lanciato quel comando, lo ha eseguito (senza chiedermi nulla) ma quando riavvio continua a ripartire in modalità shell e non si apre Gnome 3... :-(

Sono abbastanza disoperato
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: Disastro...non si avvia più nulla

Messaggio da hellojoker »

ok ok, da console se digiti startx cosa ti dice?
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

hellojoker ha scritto:ok ok, da console se digiti startx cosa ti dice?
semplicemente schermo nero ma se una volta entrato nella shell otenuta entrando nella modalità di ripristino digito il comando gnome-shell mi dà un messaggio di queto tipo:


WARNING **: Riga di comando "dbus-launch --autolaunch="una serie di numeri" --bynary-syntax --close-stderr" uscita con stato di uscita 1 non-zero: Autolaunch error: X11 inizialization faluided.\n Errore del winmdows manager: Unable to open X display


Non sò se ci possa entrare qualcosa ma mi dà l'idea che si possa essere sminchiato X? non sò proprio come procedere però...
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: Disastro...non si avvia più nulla

Messaggio da hellojoker »

e no non puoi partire gnome-shell da li, niente a me sembra un problema di driver bello e buono, senza driver proprietari il sistema ti funziona ?
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

hellojoker ha scritto:e no non puoi partire gnome-shell da li, niente a me sembra un problema di driver bello e buono, senza driver proprietari il sistema ti funziona ?
Non lo sò, leggendo quà (la procedura usata per installarli la prima volta): http://www.chimerarevo.com/2012/03/29/u ... lyst-12-3/

leggo che per disinstallarli dovrei fare:


sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx


Provo così sperando di non fare ulteriori casini...la procedura di disintallazione dei driver è corretta vero?
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

RISOLTO !!! Tolto i driver della ATI scaricati ed installati manualmente ed ha ripreso ad andare...
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: [RISOLTO] Disastro...non si avvia più nulla

Messaggio da hellojoker »

ma li avevi installati manualmente ? magari insieme hai anche qualche rimasuglio di quelli dei repository, si va bene disinstalla tutto come dice li

poi riavvia se non parte proviamo ad installare quelli della distribuzione e vediamo che succede

ops come non detto, comunque non capirò mai perchè andate in giro ad installare cose quando ci sono i pacchetti belli e buoni mah se hai risolto metti risolto nel primo post (nel titolo)
D4rkang3l
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 422
Iscrizione: giovedì 3 novembre 2005, 22:17

Re: [RISOLTO] Disastro...non si avvia più nulla

Messaggio da D4rkang3l »

hellojoker ha scritto:ma li avevi installati manualmente ? magari insieme hai anche qualche rimasuglio di quelli dei repository, si va bene disinstalla tutto come dice li

poi riavvia se non parte proviamo ad installare quelli della distribuzione e vediamo che succede

ops come non detto, comunque non capirò mai perchè andate in giro ad installare cose quando ci sono i pacchetti belli e buoni mah se hai risolto metti risolto nel primo post (nel titolo)
ehehe ti spiego...li avevo installati manualmente diciamo per abitudine...nella versione precedente di Ubuntu con i driver open non funzionava Gnome 3 Shell e con i driver proprietari che faceva scaricare direttamente Ubuntu come software di terze parti andava in conflitto (non erano l'ultima versione) e si vedeva tutto impastrocchiato...unica soluzione era quella di scaricare ed installare i driver proprietari manualmente per far funzionare il tutto...quindi questa volta una volta installato Ubunu 12.4 ho disinstallato i driver, reinstallato manulmente i driver e poi installato Gnome 3 pensando che senza fare così gnome 3 non avrebbe funzionato...a quanto pare hanno aggiornato i repository
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: [RISOLTO] Disastro...non si avvia più nulla

Messaggio da hellojoker »

ho capito però una prova per scrupolo l'avrei fatta diamogli un po di fiducia a pangolin :D comunque tutto è bene quello che finisce bene

ciao
Scrivi risposta

Ritorna a “Dilemmi del principiante”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 3 ospiti