[Guida] Unity/Installazione

Richieste di nuove guide, traduzioni, offerte di collaborazione e comunicazioni da parte del gruppo agli utenti.

Moderatore: Gruppo Documentazione

[Guida] Unity/Installazione

Messaggioda peppe84 » giovedì 10 maggio 2012, 19:29

Avatar utente
peppe84
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2228
Iscrizione: marzo 2006
Località: La dotta
Desktop: unity-2d e gnome-fallback
Distribuzione: Ubuntu 12.04 LTS x86_64

Re: [Guida] Unity/Installazione

Messaggioda vaillant » giovedì 10 maggio 2012, 20:07

Eviterei di far installare il metapacchetto, si porta dietro programmi che non ci azzeccano con kubuntu (ad esempio). O l'intento è far coesistere le due interfacce nella loro completezza?
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8314
Iscrizione: marzo 2009
Località: Modica
Desktop: Pantheon
Distribuzione: Elementary Freya

Re: [Guida] Unity/Installazione

Messaggioda peppe84 » giovedì 10 maggio 2012, 20:22

L'obiettivo è, come fu in passato per Installazione/Gnome, installare l'ambiente predefinito di ubuntu sulle derivate.

Quindi se su kubuntu 10.04 e 10.10 si usava il meta-pacchetto ubuntu-desktop per installare Gnome2 (inteso come interfaccia di ubuntu con le sue customizzazioni) qui questo meta-pacchetto serve per installare l'interfaccia predefinita di Ubuntu (intesa come Unity).

Riporto per completezza l'output di apt-get install -s ubuntu-desktop su una ubuntu 11.10 versione server (si, sono tanti):

Codice: Seleziona tutto
I seguenti pacchetti NUOVI saranno installati:
  adium-theme-ubuntu alsa-base alsa-utils anacron app-install-data apport aptdaemon aptdaemon-data at-spi2-core bamfdaemon baobab bc checkbox
  checkbox-gtk compiz compiz-core compiz-gnome compiz-plugins-default compiz-plugins-main-default compizconfig-backend-gconf consolekit dc defoma
  dmz-cursor-theme doc-base docbook-xml eog evince evince-common file-roller foomatic-db-compressed-ppds foomatic-filters gcalctool gedit gedit-common  ghostscript ghostscript-x gir1.2-atk-1.0 gir1.2-dbusmenu-glib-0.4 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gmenu-3.0 gir1.2-gtk-3.0
  gir1.2-indicate-0.6 gir1.2-pango-1.0 gir1.2-peas-1.0 gir1.2-soup-2.4 gir1.2-vte-2.90 gir1.2-webkit-3.0 gksu gnome-control-center gnome-control-center-data gnome-desktop-data gnome-desktop3-data gnome-font-viewer gnome-keyring gnome-media gnome-menus gnome-nettool gnome-power-manager gnome-screenshot gnome-search-tool gnome-session   gnome-session-bin gnome-session-canberra gnome-session-common   gnome-settings-daemon gnome-system-log gnome-system-monitor gnome-terminal   gnome-terminal-data gnome-utils-common gs-cjk-resource gsfonts   gstreamer0.10-alsa gstreamer0.10-gconf gstreamer0.10-plugins-base   gstreamer0.10-plugins-base-apps gstreamer0.10-plugins-good   gstreamer0.10-pulseaudio gstreamer0.10-tools gtk2-engines-murrine   gtk3-engines-unico gucharmap gvfs gwibber gwibber-service inputattach   intel-gpu-tools language-selector-gnome lftp libaa1 libappindicator3-1   libasound2 libasound2-plugins libasyncns0 libatasmart4 libatk-adaptor   libatkmm-1.6-1 libatspi2.0-0 libaudio2 libavahi-glib1 libavc1394-0
  libbamf3-0 libboost-serialization1.46.1 libcaca0 libcairomm-1.0-1   libcanberra-gtk0 libcanberra-gtk3-0 libcanberra0 libcap2-bin libcdparanoia0
  libck-connector0 libcolord1 libcompizconfig0 libcupsimage2 libdbusmenu-glib4   libdbusmenu-gtk3-4 libdbusmenu-qt2 libdconf-dbus-1-0 libdconf-qt0 libdconf0   libdecoration0 libdee-1.0-1 libdevmapper-event1.02.1 libdjvulibre-text   libdjvulibre21 libdv4 libevince3-3 libexempi3 libexif12 libflac8 libfontenc1
  libfs6 libgail18 libgck-1-0 libgcr-3-1 libgdu0 libgee2 libgksu2-0   libgl1-mesa-dri libglew1.5 libglewmx1.5 libglib2.0-bin libglib2.0-data
  libglibmm-2.4-1c2a libglu1-mesa libgnome-control-center1   libgnome-desktop-3-2 libgnome-keyring0 libgnome-media-profiles-3.0-0
  libgnome-menu-3-0 libgnome2-common libgnomekbd-common libgnomekbd7   libgoa-1.0-0 libgpgme11 libgrip0 libgs9 libgs9-common libgtkmm-3.0-1
  libgtksourceview-3.0-0 libgtksourceview-3.0-common libgtkspell3-0 libgtop2-7 libgtop2-common libgucharmap-2-90-7 libgudev-1.0-0 libgwibber-gtk2
  libgwibber2 libiec61883-0 libijs-0.35 libimobiledevice2 libindicator3-6   libiw30 libjack-jackd2-0 libjbig2dec0 libjpeg8 libjson-glib-1.0-0 libjson0
  libkpathsea5 liblcms2-2 libllvm2.9 libltdl7 liblvm2app2.2   libmetacity-private0 libmng1 libmtdev1 libnautilus-extension1 libnl3
  libnm-glib4 libnm-gtk-common libnm-gtk0 libnm-util2 libnotify-bin libnotify4   libnss3 libnux-1.0-0 libnux-1.0-common libogg0 liborc-0.4-0 libp11-kit0
  libpam-ck-connector libpangomm-1.4-1 libpaper1 libpcsclite1 libpeas-1.0-0   libpeas-common libplist1 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpoppler-glib6 libpoppler13 libprotobuf7 libpth20 libpulse-mainloop-glib0   libpulse0 libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl
  libqt4-script libqt4-sql libqt4-svg libqt4-xml libqt4-xmlpatterns libqtbamf1   libqtcore4 libqtdee2 libqtgconf1 libqtgui4 librarian0 libraw1394-11
  librest-0.7-0 libsamplerate0 libsdl1.2debian libsdl1.2debian-pulseaudio   libsgutils2-2 libshout3 libsmbclient libsndfile1 libsoup-gnome2.4-1
  libspectre1 libspeex1 libspeexdsp1 libstartup-notification0 libtag1-vanilla   libtag1c2a libtalloc2 libtdb1 libtheora0 libunity-2d-private0
  libunity-core-4.0-4 libunity-misc4 libunity6 libupower-glib1 libusbmuxd1   libutempter0 libutouch-evemu1 libutouch-frame1 libutouch-geis1
  libutouch-grail1 libuuid-perl libv4l-0 libvisual-0.4-0 libvorbis0a   libvorbisenc2 libvorbisfile3 libvte-2.90-9 libvte-common libwavpack1
  libwbclient0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwnck-3-0   libwnck-3-common libwnck-common libwnck22 libx11-xcb1 libxaw7 libxcb-dri2-0
  libxcb-shape0 libxcb-util0 libxfont1 libxkbfile1 libxklavier16 libxmu6
  libxmuu1 libxp6 libxres1 libxtst6 libxv1 libxvmc1 libxxf86dga1
  libyaml-tiny-perl light-themes lightdm linux-sound-base metacity
  metacity-common nautilus nautilus-data nautilus-sendto notification-daemon
  notify-osd nux-tools nvidia-common oneconf openprinting-ppds pm-utils
  pnm2ppa policykit-1 policykit-1-gnome pulseaudio pulseaudio-utils
  python-apport python-aptdaemon python-aptdaemon.gtk3widgets python-cups
  python-cupshelpers python-debian python-defer python-gnomekeyring
  python-gobject-cairo python-notify python-piston-mini-client
  python-problem-report python-smbc python-twisted-bin python-twisted-core
  python-twisted-web python-webkit python-wnck qdbus rarian-compat rfkill
  seahorse software-center software-properties-common software-properties-gtk
  sound-theme-freedesktop ssh-askpass-gnome system-config-printer-common
  system-config-printer-gnome ttf-freefont ubuntu-artwork ubuntu-desktop
  ubuntu-extras-keyring ubuntu-sounds ubuntu-sso-client ubuntu-system-service
  ubuntu-wallpapers udisks unity unity-2d unity-2d-launcher unity-2d-panel
  unity-2d-places unity-2d-spread unity-asset-pool unity-services
  update-manager update-notifier update-notifier-common upower usbmuxd whois
  wireless-tools wpasupplicant x-ttcidfont-conf x11-apps x11-session-utils
  x11-utils x11-xfs-utils x11-xkb-utils x11-xserver-utils xauth xbitmaps
  xdg-user-dirs xdg-user-dirs-gtk xdiagnose xfonts-base xfonts-encodings
  xfonts-utils xinit xinput xorg xorg-docs-core xserver-common xserver-xorg
  xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-s3 xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware xterm zenity zenity-common
I seguenti pacchetti saranno aggiornati:
  update-manager-core
1 aggiornati, 422 installati, 0 da rimuovere e 11 non aggiornati.






Avatar utente
peppe84
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2228
Iscrizione: marzo 2006
Località: La dotta
Desktop: unity-2d e gnome-fallback
Distribuzione: Ubuntu 12.04 LTS x86_64

Re: [Guida] Unity/Installazione

Messaggioda Staffo » martedì 7 febbraio 2017, 10:13

Guida AmbienteGrafico/Unity/Installazione aggiornata ad Ubuntu 14.04 e 16.04.
Ho anche aggiunto la procedura di installazione minimale di Unity, in modo da unire la vecchia guida "Installazione/CdMinimale/Unity" con quella dell'installazione classica di Unity.

Se trovate degli errori, correggeteli senza timore :birra:
Staffo
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 846
Iscrizione: marzo 2012
Località: Palazzolo sull'Oglio
Desktop: Unity
Distribuzione: Ubuntu 16.04 LTS
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda xavier77 » mercoledì 4 ottobre 2017, 15:49

Per il rilascio della 17.10 con gnome ho effettuato alcune modifiche alla pagina. Date un'occhiata.
Inoltre nel portale AmbienteGrafico/Unity ho nascosto il link a http://unity.ubuntu.com/ attualmente non raggiungibile.
:ciao:
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 5131
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 18.04 (e altre)
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda xavier77 » sabato 7 ottobre 2017, 1:11

Provando Ubuntu 17.10 (però in live) ho visto con i comandi
Codice: Seleziona tutto
sudo apt install unity

(indicato nella guida attuale) e
Codice: Seleziona tutto
sudo apt install unity-session

si ottiene praticamente la stessa cosa (stesso numero di pacchetti e dipendenze).
Avete consigli o segnalazioni per modificare eventualmente la guida?
:ciao:
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 5131
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 18.04 (e altre)
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda Staffo » sabato 14 ottobre 2017, 15:59

Credo sia più corretto indicare l'installazione di "unity-session", il quale contiene tra le dipendenze anche zeitgeist e systemd: https://packages.ubuntu.com/artful/unity-session

Prima di fare qualunque modifica alla guida, comunque, sarà il caso che io faccia qualche test :P
A risentirci!
Staffo
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 846
Iscrizione: marzo 2012
Località: Palazzolo sull'Oglio
Desktop: Unity
Distribuzione: Ubuntu 16.04 LTS
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda xavier77 » sabato 14 ottobre 2017, 17:05

Staffo Immagine ha scritto:Credo sia più corretto indicare l'installazione di "unity-session", il quale contiene tra le dipendenze anche zeitgeist e systemd: https://packages.ubuntu.com/artful/unity-session

Prima di fare qualunque modifica alla guida, comunque, sarà il caso che io faccia qualche test :P
A risentirci!


Perfetto :ciao:
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 5131
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 18.04 (e altre)
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda Staffo » martedì 7 novembre 2017, 18:58

Staffo Immagine ha scritto:Credo sia più corretto indicare l'installazione di "unity-session", il quale contiene tra le dipendenze anche zeitgeist e systemd: https://packages.ubuntu.com/artful/unity-session

Prima di fare qualunque modifica alla guida, comunque, sarà il caso che io faccia qualche test :P
A risentirci!


Avevo iniziato a sistemate la guida wiki, poi mi sono accorto che qualcosa non tornava. Ora sto lavorando in una pagina di prova: vipri-alessandro/Prova06

Leggetela, correggetela e, se potete, verificate il contenuto. :)
Staffo
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 846
Iscrizione: marzo 2012
Località: Palazzolo sull'Oglio
Desktop: Unity
Distribuzione: Ubuntu 16.04 LTS
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda xavier77 » giovedì 2 agosto 2018, 10:34

Fra le cose da fare, ci sarebbe da aggiornare/verificare la pagina di unity.
Ricordo infatti che unity é ancora disponibile nei repo.
La pagina attuale fa ancora riferimento a Ubuntu 17.04 è 17.10 (come anche la pagina di prova sopra).
Le procedure per 18.04 dovrebbero essere grosso modo le stesse. Chi può verificare/confermare è benvenuto. :)
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 5131
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 18.04 (e altre)
Sesso: Maschile

Re: [Guida] Unity/Installazione

Messaggioda jeremie2 » venerdì 3 agosto 2018, 21:12

xavier77 Immagine ha scritto:Fra le cose da fare, ci sarebbe da aggiornare/verificare la pagina di unity.
Ricordo infatti che unity é ancora disponibile nei repo.
La pagina attuale fa ancora riferimento a Ubuntu 17.04 è 17.10 (come anche la pagina di prova sopra).
Le procedure per 18.04 dovrebbero essere grosso modo le stesse. Chi può verificare/confermare è benvenuto. :)

Ho verificato l'installazione completa https://wiki.ubuntu-it.org/AmbienteGraf ... e#completa
Il pacchetto utilizzato nella 18.04 si chiama ubuntu-unity-desktop.

Non ci ho speso un granché di tempo per verificare possibili problemi. Una sbavatura che balza all'occhio è la data in alto a destra, che mi segna "ven ago 3"...
Nel complesso l'ambiente sembrerebbe funzionare bene. Ho provato a installare Unity anche dal ppa:unity7maintainers/unity7-desktop ma a occhio non vedo differenze.

Non ho invece provato l'installazione da cd minimale.
Ho comunque tolto riferimenti alle versioni EOL.

Ciao!
Sai come funziona? ...scrivilo tu stesso nella Documentazione WiKi di Ubuntu-it
Avatar utente
jeremie2
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 3133
Iscrizione: giugno 2006
Località: Casciana Terme
Distribuzione: Ubuntu 14.04

Re: [Guida] Unity/Installazione

Messaggioda xavier77 » sabato 4 agosto 2018, 11:33

jeremie2 Immagine ha scritto:
xavier77 Immagine ha scritto:Fra le cose da fare, ci sarebbe da aggiornare/verificare la pagina di unity.
Ricordo infatti che unity é ancora disponibile nei repo.
La pagina attuale fa ancora riferimento a Ubuntu 17.04 è 17.10 (come anche la pagina di prova sopra).
Le procedure per 18.04 dovrebbero essere grosso modo le stesse. Chi può verificare/confermare è benvenuto. :)

Ho verificato l'installazione completa https://wiki.ubuntu-it.org/AmbienteGraf ... e#completa
Il pacchetto utilizzato nella 18.04 si chiama ubuntu-unity-desktop.

Non ci ho speso un granché di tempo per verificare possibili problemi. Una sbavatura che balza all'occhio è la data in alto a destra, che mi segna "ven ago 3"...
Nel complesso l'ambiente sembrerebbe funzionare bene. Ho provato a installare Unity anche dal ppa:unity7maintainers/unity7-desktop ma a occhio non vedo differenze.

Non ho invece provato l'installazione da cd minimale.
Ho comunque tolto riferimenti alle versioni EOL.

Ciao!

grazie jeremie! :)
Appena posso (penso fra qualche settimana essendoci agosto di mezzo) testo un'installazione minimale di bionic con unity.
:ciao:
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 5131
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 18.04 (e altre)
Sesso: Maschile


Torna a Gruppo Documentazione

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti